]> git.pld-linux.org Git - packages/icu.git/blob - icu.spec
fix timezone issue affecting thunderbird 115; rel 2
[packages/icu.git] / icu.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # don't build static libraries
4
5 %define         ver     %(echo %{version} | tr . _)
6 %define         basever %(echo %{version} | cut -d. -f1)
7 Summary:        International Components for Unicode
8 Summary(pl.UTF-8):      Międzynarodowe komponenty dla unikodu
9 Name:           icu
10 Version:        72.1
11 Release:        1
12 License:        MIT-like
13 Group:          Libraries
14 Source0:        https://github.com/unicode-org/icu/releases/download/release-72-1/icu4c-%{ver}-src.tgz
15 # Source0-md5:  4de6484a6c460d3d1468a6fe50369439
16 Patch0:         %{name}-cxx-pre11.patch
17 Patch1:         icudata-stdlibs.patch
18 URL:            http://site.icu-project.org/
19 BuildRequires:  autoconf >= 2.69
20 BuildRequires:  autoconf-archive
21 BuildRequires:  libstdc++-devel >= 6:4.8.1
22 Requires:       libicu = %{version}-%{release}
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %description
26 ICU is a set of C and C++ libraries that provides robust and
27 full-featured Unicode and locale support. The library provides
28 calendar support, conversions for many character sets, language
29 sensitive collation, date and time formatting, support for many
30 locales, message catalogs and resources, message formatting,
31 normalization, number and currency formatting, time zones support,
32 transliteration, word, line and sentence breaking, etc.
33
34 This package contains the Unicode character database and derived
35 properties, along with converters and time zones data.
36
37 %description -l pl.UTF-8
38 ICU jest grupą bibliotek C i C++, które dostarczają kompletną i pełną
39 obsługę Unikodu i lokalizacji. Biblioteka dostarcza obsługę
40 kalendarza, konwersje dla wielu zestawów znaków, sortowanie zależne od
41 języka, formatowanie daty i czasu, wsparcie dla wielu lokalizacji,
42 katalogów komunikatów i zasobów, formatowanie komunikatów,
43 normalizację, formatowanie liczb i walut, obsługę stref czasowych,
44 transliterację, łamanie słów, linii i zdań itp.
45
46 Ten pakiet zawiera bazę znaków unikodowych i pochodne własności wraz z
47 konwerterami i danymi stref czasowych.
48
49 %package -n libicu
50 Summary:        International Components for Unicode (libraries)
51 Summary(pl.UTF-8):      Międzynarodowe Komponenty dla Unikodu (biblioteki)
52 Group:          Libraries
53 Obsoletes:      libicu30
54
55 %description -n libicu
56 ICU is a set of C and C++ libraries that provides robust and
57 full-featured Unicode support. This package contains the runtime
58 libraries for ICU. It does not contain any of the data files needed at
59 runtime and present in the `icu' package.
60
61 %description -n libicu -l pl.UTF-8
62 ICU jest grupą bibliotek C i C++, które dostarczają kompletną i pełną
63 obsługę Unikodu i lokalizacji. Ten pakiet zawiera biblioteki
64 uruchomieniowe ICU. Nie zawiera żadnych plików z danymi potrzebnymi w
65 czasie działania i obecnymi w pakietach "icu".
66
67 %package -n libicu-devel
68 Summary:        International Components for Unicode (development files)
69 Summary(pl.UTF-8):      Międzynarodowe komponenty dla Unikodu (pliki dla programistów)
70 Group:          Development/Libraries
71 Requires:       libicu = %{version}-%{release}
72
73 %description -n libicu-devel
74 ICU is a set of C and C++ libraries that provides robust and
75 full-featured Unicode support. This package contains the development
76 files for ICU.
77
78 %description -n libicu-devel -l pl.UTF-8
79 ICU jest grupą bibliotek C i C++, które dostarczają kompletną i pełną
80 obsługę Unikodu i lokalizacji. Ten pakiet zawiera pliki
81 programistyczne ICU.
82
83 %package -n libicu-static
84 Summary:        International Components for Unicode (static libraries)
85 Summary(pl.UTF-8):      Międzynarodowe komponenty dla Unikodu (biblioteki statyczne)
86 Group:          Development/Libraries
87 Requires:       libicu-devel = %{version}-%{release}
88
89 %description -n libicu-static
90 ICU is a set of C and C++ libraries that provides robust and
91 full-featured Unicode support. This package contains the static 
92 libraries for ICU.
93
94 %description -n libicu-static -l pl.UTF-8
95 ICU jest grupą bibliotek C i C++, które dostarczają kompletną i pełną
96 obsługę Unikodu i lokalizacji. Ten pakiet zawiera statyczne
97 biblioteki programistyczne ICU.
98
99 %prep
100 %setup -q -n %{name}
101 %patch0 -p1
102 %patch1 -p1
103
104 %build
105 cd source
106 %{__autoconf}
107 %configure \
108         --sbindir=%{_bindir} \
109         --with-data-packaging=library \
110         %{?with_static_libs:--enable-static} \
111         --disable-samples
112
113 %{__make} \
114         VERBOSE=1
115
116 %install
117 rm -rf $RPM_BUILD_ROOT
118
119 %{__make} -C source install \
120         DESTDIR=$RPM_BUILD_ROOT
121
122 for f in icu-i18n icu-io icu-uc ; do
123 sed -i \
124         -e 's/\$(THREADSCXXFLAGS)//' \
125         -e 's/\$(THREADSCFLAGS)//' \
126         -e 's/\$(THREADSCPPFLAGS)/-D_REENTRANT/' $RPM_BUILD_ROOT%{_pkgconfigdir}/${f}.pc
127 done
128
129 # help rpm to generate deps
130 chmod +x $RPM_BUILD_ROOT%{_libdir}/lib*.so.*.*
131
132 # rpm is too stupid sometimes and fails on symlinks to symlinked resources
133 # (reporting unresolved dependency at install time)
134 for f in Makefile.inc pkgdata.inc ; do
135         ln -sf %{version}/${f} $RPM_BUILD_ROOT%{_libdir}/%{name}/${f}
136 done
137
138 %{__rm} $RPM_BUILD_ROOT%{_datadir}/icu/%{version}/LICENSE
139
140 %clean
141 rm -rf $RPM_BUILD_ROOT
142
143 %post   -n libicu -p /sbin/ldconfig
144 %postun -n libicu -p /sbin/ldconfig
145
146 %files
147 %defattr(644,root,root,755)
148 %doc license.html readme.html
149 %attr(755,root,root) %{_bindir}/derb
150 %attr(755,root,root) %{_bindir}/escapesrc
151 %attr(755,root,root) %{_bindir}/gen*
152 %attr(755,root,root) %{_bindir}/icuexportdata
153 %attr(755,root,root) %{_bindir}/icuinfo
154 %attr(755,root,root) %{_bindir}/icupkg
155 %attr(755,root,root) %{_bindir}/makeconv
156 %attr(755,root,root) %{_bindir}/pkgdata
157 %attr(755,root,root) %{_bindir}/uconv
158 %{_mandir}/man1/derb.1*
159 %{_mandir}/man1/gen*.1*
160 %{_mandir}/man1/icuexportdata.1*
161 %{_mandir}/man1/makeconv.1*
162 %{_mandir}/man1/pkgdata.1*
163 %{_mandir}/man1/uconv.1*
164 %{_mandir}/man8/gen*.8*
165 %{_mandir}/man8/icupkg.8*
166
167 %files -n libicu
168 %defattr(644,root,root,755)
169 %attr(755,root,root) %{_libdir}/libicu*.so.*.*
170 %attr(755,root,root) %ghost %{_libdir}/libicu*.so.%{basever}
171
172 %files -n libicu-devel
173 %defattr(644,root,root,755)
174 %attr(755,root,root) %{_bindir}/icu-config
175 %attr(755,root,root) %{_libdir}/libicu*.so
176 %{_pkgconfigdir}/icu-i18n.pc
177 %{_pkgconfigdir}/icu-io.pc
178 %{_pkgconfigdir}/icu-uc.pc
179 %{_includedir}/unicode
180 %dir %{_libdir}/%{name}
181 %{_libdir}/%{name}/*.inc
182 %{_libdir}/%{name}/current
183 %dir %{_libdir}/%{name}/%{version}
184 %{_libdir}/%{name}/%{version}/*.inc
185 %dir %{_datadir}/%{name}
186 %dir %{_datadir}/%{name}/%{version}
187 %{_datadir}/%{name}/%{version}/config
188 %attr(755,root,root) %{_datadir}/%{name}/%{version}/install-sh
189 %attr(755,root,root) %{_datadir}/%{name}/%{version}/mkinstalldirs
190 %{_mandir}/man1/icu-config.1*
191
192 %if %{with static_libs}
193 %files -n libicu-static
194 %defattr(644,root,root,755)
195 %{_libdir}/libicu*.a
196 %endif
This page took 0.111847 seconds and 3 git commands to generate.