]> git.pld-linux.org Git - packages/icu.git/commitdiff
fix timezone issue affecting thunderbird 115; rel 2 master auto/th/icu-73.2-2
authorJan Palus <atler@pld-linux.org>
Wed, 12 Jul 2023 17:10:23 +0000 (19:10 +0200)
committerJan Palus <atler@pld-linux.org>
Wed, 12 Jul 2023 17:10:23 +0000 (19:10 +0200)
fix from: https://unicode-org.atlassian.net/browse/ICU-22132

icu.spec
timezone.patch [new file with mode: 0644]

index 0f42c07cbfc012d0bf97876b40f33a13cea0b2db..10a1a9fdbd04e719634a61ccf374a85f5089283b 100644 (file)
--- a/icu.spec
+++ b/icu.spec
@@ -8,12 +8,13 @@ Summary:      International Components for Unicode
 Summary(pl.UTF-8):     MiÄ™dzynarodowe komponenty dla unikodu
 Name:          icu
 Version:       73.2
-Release:       1
+Release:       2
 License:       MIT-like
 Group:         Libraries
 Source0:       https://github.com/unicode-org/icu/releases/download/release-73-2/icu4c-%{ver}-src.tgz
 # Source0-md5: b8a4b8cf77f2e2f6e1341eac0aab2fc4
 Patch0:                icudata-stdlibs.patch
+Patch1:                timezone.patch
 URL:           http://site.icu-project.org/
 BuildRequires: autoconf >= 2.69
 BuildRequires: autoconf-archive
@@ -98,6 +99,7 @@ biblioteki programistyczne ICU.
 %prep
 %setup -q -n %{name}
 %patch0 -p1
+%patch1 -p2
 
 %build
 cd source
diff --git a/timezone.patch b/timezone.patch
new file mode 100644 (file)
index 0000000..65b9c4f
--- /dev/null
@@ -0,0 +1,26 @@
+diff --git a/icu4c/source/i18n/vtzone.cpp b/icu4c/source/i18n/vtzone.cpp
+index 3035106701..5e738e11fa 100644
+--- a/icu4c/source/i18n/vtzone.cpp
++++ b/icu4c/source/i18n/vtzone.cpp
+@@ -1735,14 +1735,14 @@ VTimeZone::write(VTZWriter& writer, UErrorCode& status) const {
+             }
+         }
+     } else {
+-        UnicodeString icutzprop;
+-        UVector customProps(nullptr, uhash_compareUnicodeString, status);
++        UVector customProps(uprv_deleteUObject, uhash_compareUnicodeString, status);
+         if (olsonzid.length() > 0 && icutzver.length() > 0) {
+-            icutzprop.append(olsonzid);
+-            icutzprop.append(u'[');
+-            icutzprop.append(icutzver);
+-            icutzprop.append(u']');
+-            customProps.addElement(&icutzprop, status);
++            LocalPointer<UnicodeString> icutzprop(new UnicodeString(ICU_TZINFO_PROP), status);
++            icutzprop->append(olsonzid);
++            icutzprop->append(u'[');
++            icutzprop->append(icutzver);
++            icutzprop->append(u']');
++            customProps.adoptElement(icutzprop.orphan(), status);
+         }
+         writeZone(writer, *tz, &customProps, status);
+     }
This page took 0.221803 seconds and 4 git commands to generate.