]> git.pld-linux.org Git - packages/gtk-webkit.git/blob - gtk-webkit.spec
- release 8
[packages/gtk-webkit.git] / gtk-webkit.spec
1 # TODO: optflags
2 #
3 # Conditional build:
4 %bcond_without  introspection   # disable introspection
5
6 Summary:        Port of WebKit embeddable web component to GTK+
7 Summary(pl.UTF-8):      Port osadzalnego komponentu WWW WebKit do GTK+
8 Name:           gtk-webkit
9 Version:        1.2.7
10 Release:        8
11 License:        BSD-like
12 Group:          X11/Libraries
13 Source0:        http://webkitgtk.org/webkit-%{version}.tar.gz
14 # Source0-md5:  25c7e548b65aeb6d83c0182c32ef0927
15 Patch0:         gobject-introspection.patch
16 URL:            http://webkitgtk.org/
17 BuildRequires:  autoconf >= 2.59
18 BuildRequires:  automake
19 BuildRequires:  bison
20 BuildRequires:  cairo-devel >= 1.6
21 BuildRequires:  cairo-gobject-devel >= 1.6
22 BuildRequires:  enchant-devel >= 0.22
23 BuildRequires:  flex >= 2.5.33
24 BuildRequires:  fontconfig-devel >= 2.4.0
25 BuildRequires:  freetype-devel >= 1:2.1.8
26 BuildRequires:  geoclue-devel
27 BuildRequires:  gettext-devel
28 BuildRequires:  glib2-devel >= 1:2.22.0
29 BuildRequires:  glibc-misc
30 %{?with_introspection:BuildRequires:    gobject-introspection-devel >= 0.9.5}
31 BuildRequires:  gperf
32 BuildRequires:  gstreamer-devel >= 0.10
33 BuildRequires:  gstreamer-plugins-base-devel >= 0.10.25
34 BuildRequires:  gtk+2-devel >= 2:2.20.0
35 BuildRequires:  gtk-doc >= 1.10
36 BuildRequires:  libicu-devel >= 4.2.1
37 BuildRequires:  libjpeg-devel
38 BuildRequires:  libpng-devel
39 BuildRequires:  libsoup-devel >= 2.30.2-4
40 BuildRequires:  libstdc++-devel
41 BuildRequires:  libtool >= 2:1.5
42 BuildRequires:  libxml2-devel >= 1:2.6.30
43 BuildRequires:  libxslt-devel >= 1.1.7
44 BuildRequires:  pango-devel >= 1:1.12
45 BuildRequires:  pkgconfig
46 BuildRequires:  sqlite3-devel
47 BuildRequires:  xorg-lib-libXt-devel
48 Requires:       cairo >= 1.6
49 Requires:       enchant >= 0.22
50 Requires:       gstreamer-plugins-base >= 0.10.25
51 Requires:       gtk+2 >= 2:2.20.0
52 Requires:       libsoup >= 2.30.0
53 Requires:       libxml2 >= 1:2.6.30
54 Requires:       libxslt >= 1.1.7
55 Requires:       pango >= 1:1.12
56 %{?with_introspection:Conflicts:        gir-repository < 0.6.5-7}
57 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
58
59 %description
60 webkit is a port of the WebKit embeddable web component to GTK+.
61
62 %description -l pl.UTF-8
63 webkit to port osadzalnego komponentu WWW WebKit do GTK+.
64
65 %package devel
66 Summary:        Development files for WebKit
67 Summary(pl.UTF-8):      Pliki programistyczne WebKit
68 Group:          X11/Development/Libraries
69 Requires:       %{name} = %{version}-%{release}
70 Requires:       cairo-devel >= 1.6
71 Requires:       enchant-devel >= 0.22
72 Requires:       fontconfig-devel >= 2.4.0
73 Requires:       freetype-devel >= 1:2.1.8
74 Requires:       geoclue-devel
75 Requires:       glib2-devel >= 1:2.22.0
76 Requires:       gstreamer-devel >= 0.10
77 Requires:       gstreamer-plugins-base-devel >= 0.10.25
78 Requires:       gtk+2-devel >= 2:2.20.0
79 Requires:       libicu-devel >= 4.2.1
80 Requires:       libjpeg-devel
81 Requires:       libpng-devel
82 Requires:       libsoup-devel >= 2.30.0
83 Requires:       libstdc++-devel
84 Requires:       libxml2-devel >= 1:2.6.30
85 Requires:       libxslt-devel >= 1.1.7
86 Requires:       pango-devel >= 1:1.12
87 Requires:       sqlite3-devel
88 Requires:       xorg-lib-libXt-devel
89
90 %description devel
91 Development files for WebKit.
92
93 %description devel -l pl.UTF-8
94 Pliki programistyczne WebKit.
95
96 %prep
97 %setup -q -n webkit-%{version}
98 %patch0 -p1
99
100 %build
101 %{__gtkdocize}
102 %{__libtoolize}
103 %{__aclocal} -I autotools
104 %{__autoconf}
105 %{__autoheader}
106 %{__automake}
107 %configure \
108         --disable-silent-rules \
109         --enable-3D-transforms \
110         --enable-dom-storage \
111         --enable-geolocation \
112         --enable-icon-database \
113         --%{!?with_introspection:dis}%{?with_introspection:en}able-introspection \
114         --enable-video \
115         --with-font-backend=freetype
116
117 %{__make} -j1
118
119 %install
120 rm -rf $RPM_BUILD_ROOT
121
122 %{__make} install \
123         DESTDIR=$RPM_BUILD_ROOT
124
125 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libwebkit-1.0.la
126
127 %find_lang webkit
128
129 %clean
130 rm -rf $RPM_BUILD_ROOT
131
132 %post   -p /sbin/ldconfig
133 %postun -p /sbin/ldconfig
134
135 %files -f webkit.lang
136 %defattr(644,root,root,755)
137 %doc ChangeLog
138 %attr(755,root,root) %{_bindir}/jsc
139 %attr(755,root,root) %{_libdir}/libwebkit-1.0.so.*.*.*
140 %attr(755,root,root) %ghost %{_libdir}/libwebkit-1.0.so.2
141 %if %{with introspection}
142 %{_libdir}/girepository-1.0/JSCore-1.0.typelib
143 %{_libdir}/girepository-1.0/WebKit-1.0.typelib
144 %endif
145 %dir %{_datadir}/webkit-1.0
146 %{_datadir}/webkit-1.0/images
147 %{_datadir}/webkit-1.0/resources
148 %{_datadir}/webkit-1.0/webinspector
149
150 %files devel
151 %defattr(644,root,root,755)
152 %attr(755,root,root) %{_libdir}/libwebkit-1.0.so
153 %if %{with introspection}
154 %{_datadir}/gir-1.0/JSCore-1.0.gir
155 %{_datadir}/gir-1.0/WebKit-1.0.gir
156 %endif
157 %{_includedir}/webkit-1.0
158 %{_pkgconfigdir}/webkit-1.0.pc
This page took 0.110952 seconds and 4 git commands to generate.