]> git.pld-linux.org Git - packages/gtk-webkit.git/blob - gtk-webkit.spec
icu rebuild
[packages/gtk-webkit.git] / gtk-webkit.spec
1 #
2 # Conditional build:
3 %bcond_without  introspection   # disable introspection
4 #
5 # it's not possible to build this with debuginfo on 32bit archs due to
6 # memory constraints during linking
7 %ifarch %{ix86} x32
8 %define         _enable_debug_packages          0
9 %endif
10 Summary:        Port of WebKit embeddable web component to GTK+ 2
11 Summary(pl.UTF-8):      Port osadzalnego komponentu WWW WebKit do GTK+ 2
12 Name:           gtk-webkit
13 # note: 2.4.x is the last series with webkitgtk-1 API and GTK+ 2.x support
14 Version:        2.4.11
15 Release:        14
16 License:        BSD-like
17 Group:          X11/Libraries
18 Source0:        http://webkitgtk.org/releases/webkitgtk-%{version}.tar.xz
19 # Source0-md5:  24a25ccc30a7914ae50922aedf24b7bc
20 Patch0:         x32.patch
21 Patch1:         abs.patch
22 Patch2:         %{name}-icu59.patch
23 Patch3:         %{name}-icu65.patch
24 Patch4:         glib2.68.patch
25 Patch5:         icu68.patch
26 Patch6:         grammar.patch
27 Patch7:         volatile.patch
28 URL:            http://webkitgtk.org/
29 BuildRequires:  /usr/bin/ld.gold
30 BuildRequires:  EGL-devel
31 BuildRequires:  OpenGL-GLX-devel
32 BuildRequires:  at-spi2-core-devel >= 2.6.0
33 BuildRequires:  autoconf >= 2.60
34 BuildRequires:  automake
35 BuildRequires:  bison >= 1.875
36 BuildRequires:  cairo-devel >= 1.10
37 BuildRequires:  enchant-devel >= 0.22
38 BuildRequires:  flex >= 2.5.33
39 BuildRequires:  fontconfig-devel >= 2.5.0
40 BuildRequires:  freetype-devel >= 1:2.1.8
41 BuildRequires:  gcc-c++ >= 6:4.7
42 BuildRequires:  geoclue2-devel >= 2.1.5
43 BuildRequires:  gettext-tools
44 BuildRequires:  glib2-devel >= 1:2.36.0
45 BuildRequires:  glibc-misc
46 %{?with_introspection:BuildRequires:    gobject-introspection-devel >= 1.32.0}
47 BuildRequires:  gperf
48 BuildRequires:  gstreamer-devel >= 1.0.3
49 BuildRequires:  gstreamer-plugins-base-devel >= 1.0.3
50 BuildRequires:  libstdc++-devel >= 6:4.7
51 BuildRequires:  gtk+2-devel >= 2:2.24.10
52 BuildRequires:  gtk-doc >= 1.10
53 BuildRequires:  harfbuzz-devel >= 0.9.7
54 BuildRequires:  harfbuzz-icu-devel >= 0.9.7
55 BuildRequires:  libicu-devel >= 59
56 BuildRequires:  libjpeg-devel
57 BuildRequires:  libpng-devel
58 BuildRequires:  libsecret-devel
59 BuildRequires:  libsoup-devel >= 2.42.0
60 BuildRequires:  libstdc++-devel
61 # libtool with -fuse-ld= gcc option support
62 BuildRequires:  libtool >= 2:2.4.2-13
63 BuildRequires:  libwebp-devel
64 BuildRequires:  libxml2-devel >= 1:2.6.30
65 BuildRequires:  libxslt-devel >= 1.1.7
66 BuildRequires:  pango-devel >= 1:1.32.0
67 BuildRequires:  perl-base
68 BuildRequires:  pkgconfig
69 BuildRequires:  python
70 BuildRequires:  rpmbuild(macros) >= 1.592
71 BuildRequires:  ruby
72 BuildRequires:  sqlite3-devel >= 3
73 BuildRequires:  tar >= 1:1.22
74 BuildRequires:  udev-glib-devel
75 BuildRequires:  xorg-lib-libXcomposite-devel
76 BuildRequires:  xorg-lib-libXdamage-devel
77 BuildRequires:  xorg-lib-libXrender-devel
78 BuildRequires:  xorg-lib-libXt-devel
79 BuildRequires:  xz
80 BuildRequires:  zlib-devel
81 Requires:       cairo >= 1.10
82 Requires:       enchant >= 0.22
83 Requires:       fontconfig-libs >= 2.5.0
84 Requires:       freetype >= 1:2.1.8
85 Requires:       glib2 >= 1:2.36.0
86 Requires:       gstreamer >= 1.0.3
87 Requires:       gstreamer-plugins-base >= 1.0.3
88 Requires:       gtk+2 >= 2:2.24.10
89 Requires:       harfbuzz >= 0.9.7
90 Requires:       libsoup >= 2.42.0
91 Requires:       libxml2 >= 1:2.6.30
92 Requires:       libxslt >= 1.1.7
93 Requires:       pango >= 1:1.32.0
94 %{?with_introspection:Conflicts:        gir-repository < 0.6.5-7}
95 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
96
97 # __once_call, __once_called non-function symbols from libstdc++
98 %define         skip_post_check_so      lib.*gtk-1.0.*
99
100 # JSStringRef uses "!this" comparisons (UB)
101 %define         specflags       -fno-delete-null-pointer-checks
102
103 %description
104 gtk-webkit is a port of the WebKit embeddable web component to GTK+ 2.
105
106 %description -l pl.UTF-8
107 gtk-webkit to port osadzalnego komponentu WWW WebKit do GTK+ 2.
108
109 %package devel
110 Summary:        Development files for WebKit for GTK+ 2
111 Summary(pl.UTF-8):      Pliki programistyczne komponentu WebKit dla GTK+ 2
112 Group:          X11/Development/Libraries
113 Requires:       %{name} = %{version}-%{release}
114 Requires:       glib2-devel >= 1:2.36.0
115 Requires:       gtk+2-devel >= 2:2.24.10
116 Requires:       libsoup-devel >= 2.42.0
117 Requires:       libstdc++-devel
118
119 %description devel
120 Development files for WebKit for GTK+ 2.
121
122 %description devel -l pl.UTF-8
123 Pliki programistyczne komponentu WebKit dla GTK+ 2.
124
125 %prep
126 %setup -q -n webkitgtk-%{version}
127 %patch0 -p1
128 %patch1 -p1
129 %patch2 -p1
130 %patch3 -p1
131 %patch4 -p1
132 %patch5 -p1
133 %patch6 -p1
134 %patch7 -p1
135
136 %build
137 %{__libtoolize}
138 %{__aclocal} -I Source/autotools
139 %{__autoconf}
140 %{__autoheader}
141 %{__automake}
142 %if "%{cxx_version}" >= "4.9"
143 CXXFLAGS="%{rpmcxxflags} -fno-delete-null-pointer-checks"
144 %endif
145 %configure \
146 %ifarch %{x8664}
147         LDFLAGS="%{rpmldflags} -fuse-ld=gold" \
148 %else
149         LDFLAGS="%{rpmldflags} -fuse-ld=bfd -Wl,--no-keep-memory" \
150 %endif
151         --disable-gtk-doc \
152         --disable-silent-rules \
153         --disable-webkit2 \
154         --enable-geolocation \
155         --enable-glx \
156         %{__enable_disable introspection} \
157         --enable-webgl \
158         --with-gtk=2.0 \
159         --with-html-dir=%{_gtkdocdir}
160
161 %{__make} -j1
162
163 %install
164 rm -rf $RPM_BUILD_ROOT
165
166 %{__make} install \
167         DESTDIR=$RPM_BUILD_ROOT
168
169 # obsoleted by pkg-config
170 %{__rm} $RPM_BUILD_ROOT%{_libdir}/lib*-1.0.la
171 # packaged in gtk-webkit3
172 %{__rm} -r $RPM_BUILD_ROOT%{_gtkdocdir}/{webkitgtk,webkitdomgtk}
173
174 %find_lang WebKitGTK-2.0
175
176 %clean
177 rm -rf $RPM_BUILD_ROOT
178
179 %post   -p /sbin/ldconfig
180 %postun -p /sbin/ldconfig
181
182 %files -f WebKitGTK-2.0.lang
183 %defattr(644,root,root,755)
184 %doc ChangeLog NEWS
185 %attr(755,root,root) %{_bindir}/jsc-1
186 %attr(755,root,root) %{_libdir}/libwebkitgtk-1.0.so.*.*.*
187 %attr(755,root,root) %ghost %{_libdir}/libwebkitgtk-1.0.so.0
188 %attr(755,root,root) %{_libdir}/libjavascriptcoregtk-1.0.so.*.*.*
189 %attr(755,root,root) %ghost %{_libdir}/libjavascriptcoregtk-1.0.so.0
190 %if %{with introspection}
191 %{_libdir}/girepository-1.0/JavaScriptCore-1.0.typelib
192 %{_libdir}/girepository-1.0/WebKit-1.0.typelib
193 %endif
194 %dir %{_datadir}/webkitgtk-1.0
195 %{_datadir}/webkitgtk-1.0/images
196 %{_datadir}/webkitgtk-1.0/resources
197
198 %files devel
199 %defattr(644,root,root,755)
200 %attr(755,root,root) %{_libdir}/libjavascriptcoregtk-1.0.so
201 %attr(755,root,root) %{_libdir}/libwebkitgtk-1.0.so
202 %if %{with introspection}
203 %{_datadir}/gir-1.0/JavaScriptCore-1.0.gir
204 %{_datadir}/gir-1.0/WebKit-1.0.gir
205 %endif
206 %{_includedir}/webkitgtk-1.0
207 %{_pkgconfigdir}/javascriptcoregtk-1.0.pc
208 %{_pkgconfigdir}/webkit-1.0.pc
This page took 0.09844 seconds and 4 git commands to generate.