]> git.pld-linux.org Git - packages/gtk-webkit.git/blob - gtk-webkit.spec
- updated to 1.8.1 built for gtk+2 (note: new sonames);
[packages/gtk-webkit.git] / gtk-webkit.spec
1 # TODO: optflags
2 #
3 # Conditional build:
4 %bcond_without  introspection   # disable introspection
5 #
6 Summary:        Port of WebKit embeddable web component to GTK+
7 Summary(pl.UTF-8):      Port osadzalnego komponentu WWW WebKit do GTK+
8 Name:           gtk-webkit
9 Version:        1.8.1
10 Release:        1
11 License:        BSD-like
12 Group:          X11/Libraries
13 Source0:        http://webkitgtk.org/releases/webkit-%{version}.tar.xz
14 # Source0-md5:  f2f01b1fdc7262a2eede81ebed0970b2
15 Patch0:         %{name}-am.patch
16 URL:            http://webkitgtk.org/
17 BuildRequires:  OpenGL-devel
18 BuildRequires:  OpenGL-GLX-devel
19 BuildRequires:  autoconf >= 2.59
20 BuildRequires:  automake
21 BuildRequires:  bison
22 BuildRequires:  cairo-devel >= 1.10
23 BuildRequires:  cairo-gobject-devel >= 1.10
24 BuildRequires:  enchant-devel >= 0.22
25 BuildRequires:  flex >= 2.5.33
26 BuildRequires:  fontconfig-devel >= 2.4.0
27 BuildRequires:  freetype-devel >= 1:2.1.8
28 BuildRequires:  geoclue-devel
29 BuildRequires:  gettext-devel
30 BuildRequires:  glib2-devel >= 1:2.32.0
31 BuildRequires:  glibc-misc
32 %{?with_introspection:BuildRequires:    gobject-introspection-devel >= 0.9.5}
33 BuildRequires:  gperf
34 BuildRequires:  gstreamer-devel >= 0.10
35 BuildRequires:  gstreamer-plugins-base-devel >= 0.10.30
36 BuildRequires:  gtk+2-devel >= 2:2.20.0
37 BuildRequires:  gtk-doc >= 1.10
38 BuildRequires:  libicu-devel >= 4.2.1
39 BuildRequires:  libjpeg-devel
40 BuildRequires:  libpng-devel
41 BuildRequires:  libsoup-devel >= 2.38
42 BuildRequires:  libstdc++-devel
43 BuildRequires:  libtool >= 2:1.5
44 BuildRequires:  libxml2-devel >= 1:2.6.30
45 BuildRequires:  libxslt-devel >= 1.1.7
46 BuildRequires:  pango-devel >= 1:1.21
47 BuildRequires:  pkgconfig
48 BuildRequires:  sqlite3-devel >= 3
49 BuildRequires:  tar >= 1:1.22
50 BuildRequires:  xorg-lib-libXrender-devel
51 BuildRequires:  xorg-lib-libXt-devel
52 BuildRequires:  xz
53 BuildRequires:  zlib-devel
54 Requires:       cairo >= 1.10
55 Requires:       enchant >= 0.22
56 Requires:       gstreamer-plugins-base >= 0.10.30
57 Requires:       gtk+2 >= 2:2.20.0
58 Requires:       libsoup >= 2.38
59 Requires:       libxml2 >= 1:2.6.30
60 Requires:       libxslt >= 1.1.7
61 Requires:       pango >= 1:1.21
62 %{?with_introspection:Conflicts:        gir-repository < 0.6.5-7}
63 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
64
65 %description
66 webkit is a port of the WebKit embeddable web component to GTK+.
67
68 %description -l pl.UTF-8
69 webkit to port osadzalnego komponentu WWW WebKit do GTK+.
70
71 %package devel
72 Summary:        Development files for WebKit
73 Summary(pl.UTF-8):      Pliki programistyczne WebKit
74 Group:          X11/Development/Libraries
75 Requires:       %{name} = %{version}-%{release}
76 Requires:       cairo-devel >= 1.10
77 Requires:       enchant-devel >= 0.22
78 Requires:       fontconfig-devel >= 2.4.0
79 Requires:       freetype-devel >= 1:2.1.8
80 Requires:       geoclue-devel
81 Requires:       glib2-devel >= 1:2.32.0
82 Requires:       gstreamer-devel >= 0.10
83 Requires:       gstreamer-plugins-base-devel >= 0.10.30
84 Requires:       gtk+2-devel >= 2:2.20.0
85 Requires:       libicu-devel >= 4.2.1
86 Requires:       libjpeg-devel
87 Requires:       libpng-devel
88 Requires:       libsoup-devel >= 2.38
89 Requires:       libstdc++-devel
90 Requires:       libxml2-devel >= 1:2.6.30
91 Requires:       libxslt-devel >= 1.1.7
92 Requires:       pango-devel >= 1:1.21
93 Requires:       sqlite3-devel >= 3
94 Requires:       xorg-lib-libXt-devel
95
96 %description devel
97 Development files for WebKit.
98
99 %description devel -l pl.UTF-8
100 Pliki programistyczne WebKit.
101
102 %prep
103 %setup -q -n webkit-%{version}
104 %patch0 -p1
105
106 %build
107 %{__gtkdocize}
108 %{__libtoolize}
109 %{__aclocal} -I Source/autotools
110 %{__autoconf}
111 %{__autoheader}
112 %{__automake}
113 %configure \
114         --disable-silent-rules \
115         --enable-geolocation \
116         --enable-gtk-doc \
117         --enable-icon-database \
118         --enable-introspection%{!?with_introspection:=no} \
119         --enable-video \
120         --with-font-backend=freetype \
121         --with-gtk=2.0 \
122         --with-html-dir=%{_gtkdocdir}
123
124 %{__make} -j1
125
126 %install
127 rm -rf $RPM_BUILD_ROOT
128
129 %{__make} install \
130         DESTDIR=$RPM_BUILD_ROOT
131
132 # obsoleted by pkg-config
133 %{__rm} $RPM_BUILD_ROOT%{_libdir}/lib*-1.0.la
134 # packaged in gtk-webkit3
135 %{__rm} -r $RPM_BUILD_ROOT%{_gtkdocdir}/webkitgtk
136
137 %find_lang webkit-2.0
138
139 %clean
140 rm -rf $RPM_BUILD_ROOT
141
142 %post   -p /sbin/ldconfig
143 %postun -p /sbin/ldconfig
144
145 %files -f webkit-2.0.lang
146 %defattr(644,root,root,755)
147 %doc ChangeLog NEWS 
148 %attr(755,root,root) %{_bindir}/jsc-1
149 %attr(755,root,root) %{_libdir}/libwebkitgtk-1.0.so.*.*.*
150 %attr(755,root,root) %ghost %{_libdir}/libwebkitgtk-1.0.so.0
151 %attr(755,root,root) %{_libdir}/libjavascriptcoregtk-1.0.so.*.*.*
152 %attr(755,root,root) %ghost %{_libdir}/libjavascriptcoregtk-1.0.so.0
153 %if %{with introspection}
154 %{_libdir}/girepository-1.0/JSCore-1.0.typelib
155 %{_libdir}/girepository-1.0/WebKit-1.0.typelib
156 %endif
157 %dir %{_datadir}/webkitgtk-1.0
158 %{_datadir}/webkitgtk-1.0/images
159 %{_datadir}/webkitgtk-1.0/resources
160 %{_datadir}/webkitgtk-1.0/webinspector
161
162 %files devel
163 %defattr(644,root,root,755)
164 %attr(755,root,root) %{_libdir}/libjavascriptcoregtk-1.0.so
165 %attr(755,root,root) %{_libdir}/libwebkitgtk-1.0.so
166 %if %{with introspection}
167 %{_datadir}/gir-1.0/JSCore-1.0.gir
168 %{_datadir}/gir-1.0/WebKit-1.0.gir
169 %endif
170 %{_includedir}/webkitgtk-1.0
171 %{_pkgconfigdir}/javascriptcoregtk-1.0.pc
172 %{_pkgconfigdir}/webkit-1.0.pc
This page took 0.052595 seconds and 4 git commands to generate.