]> git.pld-linux.org Git - packages/gtk-webkit.git/blob - gtk-webkit.spec
- build with new gir format
[packages/gtk-webkit.git] / gtk-webkit.spec
1 # TODO: optflags
2 #
3 # Conditional build:
4 %bcond_without  introspection   # disable introspection
5
6 Summary:        Port of WebKit embeddable web component to GTK+
7 Summary(pl.UTF-8):      Port osadzalnego komponentu WWW WebKit do GTK+
8 Name:           gtk-webkit
9 Version:        1.2.4
10 Release:        2
11 License:        BSD-like
12 Group:          X11/Libraries
13 Source0:        http://webkitgtk.org/webkit-%{version}.tar.gz
14 # Source0-md5:  dc3a92dd0e8c2e70263fbfdf809b51a5
15 Patch0:         gobject-introspection.patch
16 URL:            http://webkitgtk.org/
17 BuildRequires:  autoconf >= 2.59
18 BuildRequires:  automake
19 BuildRequires:  bison
20 BuildRequires:  enchant-devel >= 0.22
21 BuildRequires:  flex >= 2.5.33
22 BuildRequires:  fontconfig-devel >= 2.4.0
23 BuildRequires:  geoclue-devel
24 BuildRequires:  gettext-devel
25 BuildRequires:  glib2-devel >= 1:2.22.0
26 BuildRequires:  glibc-misc
27 %{?with_introspection:BuildRequires:    gobject-introspection-devel >= 0.9.5}
28 BuildRequires:  gperf
29 BuildRequires:  gstreamer-devel >= 0.10
30 BuildRequires:  gstreamer-plugins-base-devel >= 0.10.25
31 BuildRequires:  gtk+2-devel >= 2:2.20.0
32 BuildRequires:  gtk-doc >= 1.10
33 BuildRequires:  libicu-devel >= 4.2.1
34 BuildRequires:  libjpeg-devel
35 BuildRequires:  libpng-devel
36 BuildRequires:  libsoup-devel >= 2.30.2-4
37 BuildRequires:  libstdc++-devel
38 BuildRequires:  libtool >= 2:1.5
39 BuildRequires:  libxml2-devel >= 1:2.6.30
40 BuildRequires:  libxslt-devel
41 BuildRequires:  pkgconfig
42 BuildRequires:  sqlite3-devel
43 BuildRequires:  xorg-lib-libXft-devel >= 2.0.0
44 BuildRequires:  xorg-lib-libXt-devel
45 Requires:       gtk+2 >= 2:2.20.0
46 Requires:       libsoup >= 2.30.0
47 %{?with_introspection:Conflicts:        gir-repository < 0.6.5-7}
48 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
49
50 %description
51 webkit is a port of the WebKit embeddable web component to GTK+.
52
53 %description -l pl.UTF-8
54 webkit to port osadzalnego komponentu WWW WebKit do GTK+.
55
56 %package devel
57 Summary:        Development files for WebKit
58 Summary(pl.UTF-8):      Pliki programistyczne WebKit
59 Group:          X11/Development/Libraries
60 Requires:       %{name} = %{version}-%{release}
61 Requires:       fontconfig-devel >= 1.0.0
62 Requires:       glib2-devel >= 1:2.22.0
63 Requires:       gtk+2-devel >= 2:2.20.0
64 Requires:       libicu-devel
65 Requires:       libsoup-devel >= 2.30.0
66 Requires:       libstdc++-devel
67 Requires:       xorg-lib-libXft-devel >= 2.0.0
68
69 %description devel
70 Development files for WebKit.
71
72 %description devel -l pl.UTF-8
73 Pliki programistyczne WebKit.
74
75 %prep
76 %setup -q -n webkit-%{version}
77 %patch0 -p1
78
79 %build
80 %{__gtkdocize}
81 %{__aclocal} -I autotools
82 %{__libtoolize}
83 %{__autoheader}
84 %{__automake}
85 %{__autoconf}
86 %configure \
87         --disable-silent-rules \
88         --enable-3D-transforms \
89         --enable-dom-storage \
90         --enable-geolocation \
91         --enable-icon-database \
92         --%{!?with_introspection:dis}%{?with_introspection:en}able-introspection \
93         --enable-video
94
95 %{__make}
96
97 %install
98 rm -rf $RPM_BUILD_ROOT
99
100 %{__make} install \
101         DESTDIR=$RPM_BUILD_ROOT
102
103 %find_lang webkit
104
105 %clean
106 rm -rf $RPM_BUILD_ROOT
107
108 %post   -p /sbin/ldconfig
109 %postun -p /sbin/ldconfig
110
111 %files -f webkit.lang
112 %defattr(644,root,root,755)
113 %attr(755,root,root) %{_bindir}/jsc
114 %attr(755,root,root) %{_libdir}/libwebkit-1.0.so.*.*.*
115 %attr(755,root,root) %ghost %{_libdir}/libwebkit-1.0.so.2
116 %if %{with introspection}
117 %{_libdir}/girepository-1.0/JSCore-1.0.typelib
118 %{_libdir}/girepository-1.0/WebKit-1.0.typelib
119 %endif
120 %dir %{_datadir}/webkit-1.0
121 %{_datadir}/webkit-1.0/images
122 %{_datadir}/webkit-1.0/resources
123 %{_datadir}/webkit-1.0/webinspector
124
125 %files devel
126 %defattr(644,root,root,755)
127 %attr(755,root,root) %{_libdir}/libwebkit-1.0.so
128 %{_libdir}/libwebkit-1.0.la
129 %if %{with introspection}
130 %{_datadir}/gir-1.0/JSCore-1.0.gir
131 %{_datadir}/gir-1.0/WebKit-1.0.gir
132 %endif
133 %{_includedir}/webkit-1.0
134 %{_pkgconfigdir}/webkit-1.0.pc
This page took 0.088575 seconds and 4 git commands to generate.