]> git.pld-linux.org Git - packages/gpac.git/commitdiff
- added ffmpeg patch, build with system ffmpeg (0.6.2 build-tested)
authorJakub Bogusz <qboosh@pld-linux.org>
Wed, 30 Mar 2011 18:13:05 +0000 (18:13 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    gpac-ffmpeg.patch -> 1.1
    gpac.spec -> 1.31

gpac-ffmpeg.patch [new file with mode: 0644]
gpac.spec

diff --git a/gpac-ffmpeg.patch b/gpac-ffmpeg.patch
new file mode 100644 (file)
index 0000000..b06b273
--- /dev/null
@@ -0,0 +1,50 @@
+--- gpac/modules/ffmpeg_in/ffmpeg_in.h.orig    2008-10-20 13:04:40.000000000 +0200
++++ gpac/modules/ffmpeg_in/ffmpeg_in.h 2011-03-28 19:44:02.765729730 +0200
+@@ -56,14 +56,14 @@
+ /*include FFMPEG APIs*/
+-#include <ffmpeg/avformat.h>
++#include <libavformat/avformat.h>
+ void gf_av_vlog(void* avcl, int level, const char *fmt, va_list vl);
+ #if LIBAVCODEC_VERSION_INT > ((52<<16)+(0<<8)+0)
+ #define FFMPEG_SWSCALE
+-#include <ffmpeg/swscale.h>
++#include <libswscale/swscale.h>
+ #endif
+ /*FFMPEG decoder module */
+--- gpac/configure.orig        2011-03-27 21:38:49.493737273 +0200
++++ gpac/configure     2011-03-28 19:44:22.401729730 +0200
+@@ -732,7 +732,7 @@ fi
+ #look for FFMPEG support
+ cat > $TMPC << EOF
+ #include <stddef.h>
+-#include <ffmpeg/avcodec.h>
++#include <libavcodec/avcodec.h>
+ int main( void ) { return 0; }
+ EOF
+--- gpac/modules/ffmpeg_in/ffmpeg_decode.c.orig        2008-11-28 18:26:06.000000000 +0100
++++ gpac/modules/ffmpeg_in/ffmpeg_decode.c     2011-03-28 20:33:19.441729730 +0200
+@@ -241,7 +241,7 @@
+       /*setup audio streams*/
+       if (ffd->st==GF_STREAM_AUDIO) {
+-              if ((ffd->codec->type == CODEC_ID_MP3LAME) || (ffd->codec->type == CODEC_ID_MP2)) {
++              if ((ffd->codec->type == CODEC_ID_MP3) || (ffd->codec->type == CODEC_ID_MP2)) {
+                       ffd->ctx->frame_size = (ffd->ctx->sample_rate > 24000) ? 1152 : 576;
+               }
+               /*may be 0 (cfg not known yet)*/
+@@ -643,7 +643,7 @@
+                               NULL, NULL, NULL);
+                       
+                       if (ffd->sws_ctx)
+-                              sws_scale(ffd->sws_ctx, ffd->frame->data, ffd->frame->linesize, 0, ffd->ctx->height->codec->height, pict.data, pict.linesize);
++                              sws_scale(ffd->sws_ctx, ffd->frame->data, ffd->frame->linesize, 0, ffd->ctx->height, pict.data, pict.linesize);
+ #endif
index b40238cb442243786954d7bf53326fa2d40ac539..3ac0eb80d0fcc38764c2ba88e58ab09703152dd1 100644 (file)
--- a/gpac.spec
+++ b/gpac.spec
@@ -1,5 +1,3 @@
-# TODO
-# - FFMPEG: local
 #
 # Conditional build:
 %bcond_with    amr             # AMR-NB and AMR-WB (floating-point) support
@@ -17,7 +15,7 @@ Summary:      GPAC - an implementation of the MPEG-4 Systems standard (ISO/IEC 14496-
 Summary(pl.UTF-8):     GPAC - implementacja standardu MPEG-4 Systems (ISO/IEC 14496-1)
 Name:          gpac
 Version:       0.4.5
-Release:       0.2
+Release:       0.3
 License:       LGPL v2+
 Group:         Applications/Multimedia
 Source0:       http://downloads.sourceforge.net/gpac/%{name}-%{version}.tar.gz
@@ -27,6 +25,7 @@ Patch1:               %{name}-libpng.patch
 Patch2:                %{name}-pic.patch
 Patch3:                %{name}-xulrunner.patch
 Patch4:                %{name}-amr.patch
+Patch5:                %{name}-ffmpeg.patch
 URL:           http://gpac.sourceforge.net/
 BuildRequires: SDL-devel
 BuildRequires: a52dec-libs-devel
@@ -34,7 +33,7 @@ BuildRequires:        alsa-lib-devel >= 0.9
 %{?with_amr:BuildRequires:     amrnb-devel}
 %{?with_amr:BuildRequires:     amrwb-devel}
 %{?with_faad:BuildRequires:    faad2-devel}
-%{?with_ffmpeg:BuildRequires:  ffmpeg-devel}
+%{?with_ffmpeg:BuildRequires:  ffmpeg-devel >= 0.6}
 %{?with_freetype:BuildRequires:        freetype-devel}
 BuildRequires: jack-audio-connection-kit-devel
 %{?with_js:BuildRequires:      js-devel}
@@ -122,6 +121,7 @@ Wtyczka GPAC dla przeglÄ…darek WWW zgodnych z Netscape.
 %patch2 -p1
 %patch3 -p1
 %patch4 -p1
+%patch5 -p1
 
 %if %{with amr}
 sed -i -e 's/amr_\([nw]b\)_ft/amr\1/' modules/amr_float_dec/amr_float_dec.c
This page took 0.632302 seconds and 4 git commands to generate.