]> git.pld-linux.org Git - packages/gpac.git/commitdiff
- dropped outdated wxWidgets patch, use sed call to set wx-config path;
authorJakub Bogusz <qboosh@pld-linux.org>
Mon, 28 Mar 2011 17:39:49 +0000 (17:39 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
  enabled by default, packaged in -gui
- updated amr: use floating-point implementation in system amrnb/amrwb libraries;
  added amr patch

Changed files:
    gpac-amr.patch -> 1.1
    gpac-wxWidgets.patch -> 1.3
    gpac.spec -> 1.30

gpac-amr.patch [new file with mode: 0644]
gpac-wxWidgets.patch [deleted file]
gpac.spec

diff --git a/gpac-amr.patch b/gpac-amr.patch
new file mode 100644 (file)
index 0000000..e6e97ce
--- /dev/null
@@ -0,0 +1,35 @@
+--- gpac/modules/amr_float_dec/Makefile.orig   2007-08-28 14:51:20.000000000 +0200
++++ gpac/modules/amr_float_dec/Makefile        2011-03-27 21:37:20.585733920 +0200
+@@ -18,19 +18,19 @@
+ #common obj
+ OBJS=../amr_dec/amr_in.o amr_float_dec.o
++AMR_LIBS=
++
+ #AMR NB obj
+ CFLAGS+=-DGPAC_HAS_AMR_FT
+ ifeq ($(CONFIG_AMR_NB_FT), yes)
+-OBJS+=./amr_nb_ft/interf_dec.o ./amr_nb_ft/interf_enc.o ./amr_nb_ft/sp_dec.o ./amr_nb_ft/sp_enc.o
++AMR_LIBS=-lamrnb
+ endif
+ #AMR WB obj
+ CFLAGS+=-DGPAC_HAS_AMR_FT_WB
+ ifeq ($(CONFIG_AMR_WB_FT), yes)
+-OBJS+=./amr_wb_ft/dec_acelp.o ./amr_wb_ft/dec_dtx.o ./amr_wb_ft/dec_gain.o ./amr_wb_ft/dec_if.o ./amr_wb_ft/dec_lpc.o ./amr_wb_ft/dec_main.o \
+-      ./amr_wb_ft/dec_rom.o ./amr_wb_ft/dec_util.o ./amr_wb_ft/enc_acelp.o ./amr_wb_ft/enc_dtx.o ./amr_wb_ft/enc_gain.o ./amr_wb_ft/enc_if.o \
+-      ./amr_wb_ft/enc_lpc.o ./amr_wb_ft/enc_main.o ./amr_wb_ft/enc_rom.o ./amr_wb_ft/enc_util.o ./amr_wb_ft/if_rom.o 
++AMR_LIBS=-lamrwb
+ endif
+@@ -51,7 +51,7 @@
+ $(LIB): $(OBJSPIC)
+-      $(CC) $(SHFLAGS) $(LDFLAGS) -o ../../bin/gcc/$@ $(OBJSPIC) $(EXTRALIBS) -L../../bin/gcc -lgpac
++      $(CC) $(SHFLAGS) $(LDFLAGS) -o ../../bin/gcc/$@ $(OBJSPIC) $(EXTRALIBS) -L../../bin/gcc -lgpac $(AMR_LIBS)
+ %.o: %.c
diff --git a/gpac-wxWidgets.patch b/gpac-wxWidgets.patch
deleted file mode 100644 (file)
index fdc2242..0000000
+++ /dev/null
@@ -1,22 +0,0 @@
---- gpac/configure.orig        2005-07-23 19:59:27.000000000 +0200
-+++ gpac/configure     2006-03-19 12:18:44.000000000 +0100
-@@ -689,8 +689,8 @@
- #look for wxWidgets support
- has_wx="no"
- wx_too_old="no"
--wx_cflags=`wx-config --cppflags`
--wx_lflags=`wx-config --libs`
-+wx_cflags=`wx-gtk2-ansi-config --cppflags`
-+wx_lflags=`wx-gtk2-ansi-config --libs`
- cat > $TMPCPP << EOF
- #include <wx/wx.h>
-@@ -698,7 +698,7 @@
- EOF
- if $cc $wx_cflags -o $TMPO $TMPCPP $wx_lflags > /dev/null 2>&1 ; then
--wx_version=`wx-config --version | sed 's/[^0-9]//g'`
-+wx_version=`wx-gtk2-ansi-config --version | sed 's/[^0-9]//g'`
- if test "$wx_version" -lt 254 ; then
- wx_too_old="yes"
- else
index abbb0f31c2e65a88ff663ef8c267fa49816d7602..b40238cb442243786954d7bf53326fa2d40ac539 100644 (file)
--- a/gpac.spec
+++ b/gpac.spec
@@ -1,10 +1,8 @@
 # TODO
-# - amr-nb/amr-wb/amr-nb-fixed ?
 # - FFMPEG: local
-# - which: no wx-config in ...
 #
 # Conditional build:
-%bcond_with    amr             # AMR-NB support
+%bcond_with    amr             # AMR-NB and AMR-WB (floating-point) support
 %bcond_without faad            # AAC decoding support
 %bcond_without ffmpeg          # ffmpeg support
 %bcond_without freetype        # freetype support
 %bcond_without mad             # MP3 support
 %bcond_without png             # PNG support
 %bcond_without xvid            # xvid support
-%bcond_with    wx              # wxWidgets support
+%bcond_without wx              # wxWidgets support
 #
 Summary:       GPAC - an implementation of the MPEG-4 Systems standard (ISO/IEC 14496-1)
 Summary(pl.UTF-8):     GPAC - implementacja standardu MPEG-4 Systems (ISO/IEC 14496-1)
 Name:          gpac
 Version:       0.4.5
-Release:       0.1
+Release:       0.2
 License:       LGPL v2+
 Group:         Applications/Multimedia
 Source0:       http://downloads.sourceforge.net/gpac/%{name}-%{version}.tar.gz
 # Source0-md5: 755e8c438a48ebdb13525dd491f5b0d1
-Source1:       http://www.3gpp.org/ftp/Specs/archive/26_series/26.073/26073-530.zip
-# Source1-md5: 705f6993fbf890e92eb7a331e7c716d1
 Patch0:                %{name}-install.patch
-Patch1:                %{name}-wxWidgets.patch
-Patch2:                %{name}-libpng.patch
-Patch3:                %{name}-pic.patch
-Patch4:                %{name}-xulrunner.patch
+Patch1:                %{name}-libpng.patch
+Patch2:                %{name}-pic.patch
+Patch3:                %{name}-xulrunner.patch
+Patch4:                %{name}-amr.patch
 URL:           http://gpac.sourceforge.net/
 BuildRequires: SDL-devel
 BuildRequires: a52dec-libs-devel
 BuildRequires: alsa-lib-devel >= 0.9
+%{?with_amr:BuildRequires:     amrnb-devel}
+%{?with_amr:BuildRequires:     amrwb-devel}
 %{?with_faad:BuildRequires:    faad2-devel}
 %{?with_ffmpeg:BuildRequires:  ffmpeg-devel}
 %{?with_freetype:BuildRequires:        freetype-devel}
@@ -50,8 +48,9 @@ BuildRequires:        libxml2-devel
 BuildRequires: openjpeg-devel
 BuildRequires: pulseaudio-devel
 BuildRequires: rpmbuild(macros) >= 1.357
+BuildRequires: sed >= 4.0
 BuildRequires: unzip
-%{?with_wx:BuildRequires:      wxGTK2-devel >= 2.5.4}
+%{?with_wx:BuildRequires:      wxGTK2-devel >= 2.6.0}
 # -server
 BuildRequires: xmlrpc-c-devel
 BuildRequires: xorg-lib-libXext-devel
@@ -90,6 +89,18 @@ DSP) z prostym celem: wymagać tak mało pamięci, jak to tylko możliwe.
 Projekt docelowo dostarczy odtwarzacz(e), kodery systemowe i narzędzia
 do publikacji w celu dystrybucji materiałów.
 
+%package gui
+Summary:       wxWidgets-based GUI for GPAC
+Summary(pl.UTF-8):     Oparty na wxWidgets graficzny interfejs do GPAC
+Group:         X11/Applications/Multimedia
+Requires:      %{name} = %{version}-%{release}
+
+%description gui
+Osmo4 - wxWidgets-based GUI for GPAC.
+
+%description gui -l pl.UTF-8
+Osmo4 - oparty na wxWidgets graficzny interfejs do GPAC.
+
 %package -n browser-plugin-%{name}
 Summary:       GPAC browser plugin
 Summary(pl.UTF-8):     Wtyczka GPAC do przegląderek WWW
@@ -107,18 +118,15 @@ Wtyczka GPAC dla przeglądarek WWW zgodnych z Netscape.
 %prep
 %setup -q -n %{name}
 %patch0 -p1
-%{?with_wx:%patch1 -p1}
+%patch1 -p1
 %patch2 -p1
 %patch3 -p1
 %patch4 -p1
 
 %if %{with amr}
-mkdir -p Plugins/amr_dec/AMR_NB
-cd Plugins/amr_dec/AMR_NB
-unzip -j %{SOURCE1}
-unzip -j 26073-530_ANSI_C_source_code.zip
-cd ../../..
+sed -i -e 's/amr_\([nw]b\)_ft/amr\1/' modules/amr_float_dec/amr_float_dec.c
 %endif
+sed -i -e 's/wx-config/wx-gtk2-unicode-config/' configure
 chmod a+x configure
 
 %build
@@ -131,7 +139,8 @@ cd ../..
        --X11-path=/usr \
        --cc="%{__cc}" \
        --disable-opt \
-       %{?with_amr:--enable-amr-nb} \
+       %{!?with_wx:--disable-wx} \
+       %{?with_amr:--enable-amr} \
        --enable-joystick \
        --enable-pic \
        --extra-cflags="%{rpmcflags}" \
@@ -186,6 +195,10 @@ fi
 %{_mandir}/man1/mp4box.1*
 %{_mandir}/man1/mp4client.1*
 
+%files gui
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_bindir}/Osmo4
+
 %files -n browser-plugin-%{name}
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_browserpluginsdir}/nposmozilla.so
This page took 0.062441 seconds and 4 git commands to generate.