]> git.pld-linux.org Git - packages/gpac.git/blob - gpac.spec
- dropped outdated wxWidgets patch, use sed call to set wx-config path;
[packages/gpac.git] / gpac.spec
1 # TODO
2 # - FFMPEG: local
3 #
4 # Conditional build:
5 %bcond_with     amr             # AMR-NB and AMR-WB (floating-point) support
6 %bcond_without  faad            # AAC decoding support
7 %bcond_without  ffmpeg          # ffmpeg support
8 %bcond_without  freetype        # freetype support
9 %bcond_without  jpeg            # JPEG support
10 %bcond_without  js              # JavaScript support
11 %bcond_without  mad             # MP3 support
12 %bcond_without  png             # PNG support
13 %bcond_without  xvid            # xvid support
14 %bcond_without  wx              # wxWidgets support
15 #
16 Summary:        GPAC - an implementation of the MPEG-4 Systems standard (ISO/IEC 14496-1)
17 Summary(pl.UTF-8):      GPAC - implementacja standardu MPEG-4 Systems (ISO/IEC 14496-1)
18 Name:           gpac
19 Version:        0.4.5
20 Release:        0.2
21 License:        LGPL v2+
22 Group:          Applications/Multimedia
23 Source0:        http://downloads.sourceforge.net/gpac/%{name}-%{version}.tar.gz
24 # Source0-md5:  755e8c438a48ebdb13525dd491f5b0d1
25 Patch0:         %{name}-install.patch
26 Patch1:         %{name}-libpng.patch
27 Patch2:         %{name}-pic.patch
28 Patch3:         %{name}-xulrunner.patch
29 Patch4:         %{name}-amr.patch
30 URL:            http://gpac.sourceforge.net/
31 BuildRequires:  SDL-devel
32 BuildRequires:  a52dec-libs-devel
33 BuildRequires:  alsa-lib-devel >= 0.9
34 %{?with_amr:BuildRequires:      amrnb-devel}
35 %{?with_amr:BuildRequires:      amrwb-devel}
36 %{?with_faad:BuildRequires:     faad2-devel}
37 %{?with_ffmpeg:BuildRequires:   ffmpeg-devel}
38 %{?with_freetype:BuildRequires: freetype-devel}
39 BuildRequires:  jack-audio-connection-kit-devel
40 %{?with_js:BuildRequires:       js-devel}
41 %{?with_jpeg:BuildRequires:     libjpeg-devel}
42 %{?with_mad:BuildRequires:      libmad-devel}
43 BuildRequires:  libogg-devel
44 %{?with_png:BuildRequires:      libpng-devel}
45 BuildRequires:  libtheora-devel
46 BuildRequires:  libvorbis-devel
47 BuildRequires:  libxml2-devel
48 BuildRequires:  openjpeg-devel
49 BuildRequires:  pulseaudio-devel
50 BuildRequires:  rpmbuild(macros) >= 1.357
51 BuildRequires:  sed >= 4.0
52 BuildRequires:  unzip
53 %{?with_wx:BuildRequires:       wxGTK2-devel >= 2.6.0}
54 # -server
55 BuildRequires:  xmlrpc-c-devel
56 BuildRequires:  xorg-lib-libXext-devel
57 BuildRequires:  xorg-lib-libXv-devel
58 BuildRequires:  xulrunner-devel >= 1.9.1
59 %{?with_xvid:BuildRequires:     xvid-devel}
60 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
61
62 %description
63 GPAC is an implementation of the MPEG-4 Systems standard (ISO/IEC
64 14496-1) developed from scratch in ANSI C.
65
66 The main development goal is to provide a clean (a.k.a. readable by as
67 many people as possible), small and flexible alternative to the MPEG-4
68 Systems reference software (known as IM1 and distributed in ISO/IEC
69 14496-5). The MPEG-4 Reference software is indeed a very large piece
70 of software, designed to verify the standard rather than provide a
71 small, production-stable software. GPAC is written in ANSI C for
72 portability reasons (embedded platforms and DSPs) with a simple goal:
73 keep the memory footprint as low as possible. The project will at term
74 provide player(s), systems encoders and publishing tools for content
75 distribution.
76
77 %description -l pl.UTF-8
78 GPAC to implementacja standardu MPEG-4 Systems (ISO/IEC 14496-1)
79 stworzona od zera w ANSI C.
80
81 Głównym celem tworzenia jej jest dostarczenie czystej (tzn. czytelnej
82 dla jak największej liczby ludzi), małej i elastycznej alternatywy dla
83 wzorcowego oprogramowania MPEG-4 Systems (znanego jako IM1 i
84 rozprowadzanego w ISO/IEC 14496-5). Wzorcowe oprogramowanie MPEG-4
85 jest bardzo dużą porcją kodu, zaprojektowaną raczej do zweryfikowania
86 standardu niż dostarczenia małej, stabilnej wersji produkcyjnej. GPAC
87 jest pisany w ANSI C ze względu na przenośność (platformy wbudowane i
88 DSP) z prostym celem: wymagać tak mało pamięci, jak to tylko możliwe.
89 Projekt docelowo dostarczy odtwarzacz(e), kodery systemowe i narzędzia
90 do publikacji w celu dystrybucji materiałów.
91
92 %package gui
93 Summary:        wxWidgets-based GUI for GPAC
94 Summary(pl.UTF-8):      Oparty na wxWidgets graficzny interfejs do GPAC
95 Group:          X11/Applications/Multimedia
96 Requires:       %{name} = %{version}-%{release}
97
98 %description gui
99 Osmo4 - wxWidgets-based GUI for GPAC.
100
101 %description gui -l pl.UTF-8
102 Osmo4 - oparty na wxWidgets graficzny interfejs do GPAC.
103
104 %package -n browser-plugin-%{name}
105 Summary:        GPAC browser plugin
106 Summary(pl.UTF-8):      Wtyczka GPAC do przegląderek WWW
107 Group:          X11/Libraries
108 Requires:       %{name} = %{version}-%{release}
109 Requires:       browser-plugins >= 2.0
110 Requires:       browser-plugins(%{_target_base_arch})
111
112 %description -n browser-plugin-%{name}
113 GPAC plugin for Netscape-compatible WWW browsers.
114
115 %description -n browser-plugin-%{name} -l pl.UTF-8
116 Wtyczka GPAC dla przeglądarek WWW zgodnych z Netscape.
117
118 %prep
119 %setup -q -n %{name}
120 %patch0 -p1
121 %patch1 -p1
122 %patch2 -p1
123 %patch3 -p1
124 %patch4 -p1
125
126 %if %{with amr}
127 sed -i -e 's/amr_\([nw]b\)_ft/amr\1/' modules/amr_float_dec/amr_float_dec.c
128 %endif
129 sed -i -e 's/wx-config/wx-gtk2-unicode-config/' configure
130 chmod a+x configure
131
132 %build
133 cd applications/osmozilla
134 xpidl -m header -I /usr/share/idl/xulrunner nsIOsmozilla.idl
135 xpidl -m typelib -I /usr/share/idl/xulrunner nsIOsmozilla.idl
136 cp -f nsIOsmozilla.xpt nsIOsmozilla.xpt_linux
137 cd ../..
138 %configure \
139         --X11-path=/usr \
140         --cc="%{__cc}" \
141         --disable-opt \
142         %{!?with_wx:--disable-wx} \
143         %{?with_amr:--enable-amr} \
144         --enable-joystick \
145         --enable-pic \
146         --extra-cflags="%{rpmcflags}" \
147         --extra-ldflags="%{rpmldflags}" \
148         --mozdir=%{_browserpluginsdir} \
149         %{!?with_faad:--use-faad=no} \
150         %{!?with_ffmpeg:--use-ffmpeg=no} \
151         %{!?with_freetype:--use-ft=no} \
152         %{!?with_jpeg:--use-jpeg=no} \
153         %{!?with_js:--use-js=no} \
154         %{!?with_mad:--use-mad=no} \
155         %{!?with_png:--use-png=no} \
156         %{!?with_xvid:--use-xvid=no} \
157         --xulsdk-path="/usr/include/xulrunner -I/usr/include/nspr"
158
159 %{__make} -j1 \
160         libdir=%{_lib}
161
162 %install
163 rm -rf $RPM_BUILD_ROOT
164
165 %{__make} install \
166         DESTDIR=$RPM_BUILD_ROOT \
167         libdir=%{_lib} \
168         MOZILLA_DIR=$RPM_BUILD_ROOT%{_browserpluginsdir}
169
170 %clean
171 rm -rf $RPM_BUILD_ROOT
172
173 %post   -p /sbin/ldconfig
174 %postun -p /sbin/ldconfig
175
176 %post -n browser-plugin-%{name}
177 %update_browser_plugins
178
179 %postun -n browser-plugin-%{name}
180 if [ "$1" = 0 ]; then
181         %update_browser_plugins
182 fi
183
184 %files
185 %defattr(644,root,root,755)
186 %doc AUTHORS BUGS Changelog README TODO
187 %attr(755,root,root) %{_bindir}/MP4Box
188 %attr(755,root,root) %{_bindir}/MP4Client
189 %attr(755,root,root) %{_libdir}/libgpac-%{version}.so
190 %attr(755,root,root) %{_libdir}/libgpac.so
191 %dir %{_libdir}/gpac
192 %attr(755,root,root) %{_libdir}/gpac/gm_*.so
193 %{_datadir}/gpac
194 %{_mandir}/man1/gpac.1*
195 %{_mandir}/man1/mp4box.1*
196 %{_mandir}/man1/mp4client.1*
197
198 %files gui
199 %defattr(644,root,root,755)
200 %attr(755,root,root) %{_bindir}/Osmo4
201
202 %files -n browser-plugin-%{name}
203 %defattr(644,root,root,755)
204 %attr(755,root,root) %{_browserpluginsdir}/nposmozilla.so
205 %{_browserpluginsdir}/nposmozilla.xpt
This page took 0.057301 seconds and 3 git commands to generate.