]> git.pld-linux.org Git - packages/gnustep-gui.git/blob - gnustep-gui.spec
icu rebuild
[packages/gnustep-gui.git] / gnustep-gui.spec
1 #
2 # Conditional build:
3 %bcond_without  cups            # GSCUPS bundle
4 %bcond_without  magick          # ImageMagick support
5 %bcond_without  portaudio       # gsnd tool
6 #
7 Summary:        GNUstep GUI library package
8 Summary(pl.UTF-8):      Biblioteka GNUstep GUI
9 Name:           gnustep-gui
10 %define ver     0.24
11 Version:        %{ver}.0
12 Release:        26
13 License:        LGPL v2+ (library), GPL v3+ (applications)
14 Group:          Libraries
15 Source0:        ftp://ftp.gnustep.org/pub/gnustep/core/%{name}-%{version}.tar.gz
16 # Source0-md5:  bd289f0c7b2626d093ad92364069b9a7
17 Patch0:         %{name}-nocompressdocs.patch
18 Patch1:         %{name}-doc.patch
19 Patch2:         %{name}-giflib.patch
20 Patch3:         imagemagick7.patch
21 Patch4:         icu68.patch
22 URL:            http://www.gnustep.org/
23 %{?with_magick:BuildRequires:   ImageMagick-devel}
24 BuildRequires:  aspell-devel
25 %{?with_cups:BuildRequires:     cups-devel}
26 BuildRequires:  flite-devel
27 BuildRequires:  gcc-objc
28 BuildRequires:  giflib-devel
29 BuildRequires:  gnustep-base-devel >= 1.13.0
30 BuildRequires:  gnustep-make-devel
31 BuildRequires:  libao-devel
32 BuildRequires:  libicns-devel
33 BuildRequires:  libicu-devel >= 4.0
34 BuildRequires:  libjpeg-devel
35 BuildRequires:  libpng-devel
36 BuildRequires:  libsndfile-devel
37 BuildRequires:  libtiff-devel
38 BuildRequires:  pkgconfig
39 %{?with_portaudio:BuildRequires:        portaudio-devel >= 19}
40 BuildRequires:  zlib-devel
41 Requires:       gnustep-base >= 1.13.0
42 Conflicts:      gnustep-core
43 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
44
45 %description
46 It is a library of graphical user interface classes written completely
47 in the Objective-C language; the classes are based upon the OpenStep
48 specification as release by NeXT Software, Inc. The library does not
49 completely conform to the specification and has been enhanced in a
50 number of ways to take advantage of the GNU system. These classes
51 include graphical objects such as buttons, text fields, popup lists,
52 browser lists, and windows; there are also many associated classes for
53 handling events, colors, fonts, pasteboards and images.
54
55 %description -l pl.UTF-8
56 To jest biblioteka klas graficznego interfejsu użytkownika napisana w
57 Objective-C. Klasy bazują na specyfikacji OpenStep wypuszczonej przez
58 NeXT Software. Biblioteka nie jest całkowicie zgodna ze specyfikacją i
59 została rozszerzona, aby wykorzystać możliwości systemu GNU. Klasy
60 zawierają graficzne obiekty takie jak przyciski, pola tekstowe, listy
61 rozwijane, listy przewijane i okienka; jest także wiele klas do
62 obsługi zdarzeń, kolorów, fontów i obrazków.
63
64 %package devel
65 Summary:        GNUstep GUI headers and libs
66 Summary(pl.UTF-8):      Pliki nagłówkowe GNUstep GUI
67 Group:          Development/Libraries
68 Requires:       %{name} = %{version}-%{release}
69 Requires:       gnustep-base-devel >= 1.13.0
70 Conflicts:      gnustep-core
71
72 %description devel
73 Header files required to build applications against the GNUstep GUI
74 library.
75
76 %description devel -l pl.UTF-8
77 Pliki nagłówkowe potrzebne do budowania aplikacji korzystających z
78 biblioteki GNUstep GUI.
79
80 %prep
81 %setup -q
82 %patch0 -p1
83 %patch1 -p1
84 %patch2 -p1
85 %patch3 -p1
86 %patch4 -p1
87
88 %build
89 export GNUSTEP_MAKEFILES=%{_datadir}/GNUstep/Makefiles
90 export GNUSTEP_FLATTENED=yes
91 # disable gsnd - not ready for current portaudio
92 %configure \
93         %{!?with_cups:--disable-cups} \
94         %{!?with_portaudio:--disable-gsnd} \
95         %{?with_magick:--enable-imagemagick} \
96         --enable-libgif \
97         --disable-ungif
98
99 # with __make -jN we can got non-deterministic errors
100 %{__make} -j1 \
101         messages=yes
102
103 %install
104 rm -rf $RPM_BUILD_ROOT
105 export GNUSTEP_MAKEFILES=%{_datadir}/GNUstep/Makefiles
106 export GNUSTEP_INSTALLATION_DOMAIN=SYSTEM
107 export GNUSTEP_FLATTENED=yes
108
109 %{__make} install \
110         DESTDIR=$RPM_BUILD_ROOT
111
112 %{__make} install -C Documentation \
113         DESTDIR=$RPM_BUILD_ROOT
114
115 find $RPM_BUILD_ROOT%{_datadir}/GNUstep/Documentation \
116         -type f -name .cvsignore | xargs rm -f
117
118 # not (yet?) supported by rpm-compress-doc
119 find $RPM_BUILD_ROOT%{_datadir}/GNUstep/Documentation \
120         -type f -a ! -name '*.html' -a ! -name '*.gz' -a ! -name '*.jpg' -a ! -name '*.css' | xargs gzip -9nf
121
122 %clean
123 rm -rf $RPM_BUILD_ROOT
124
125 %post   -p /sbin/ldconfig
126 %postun -p /sbin/ldconfig
127
128 %files
129 %defattr(644,root,root,755)
130 %doc ChangeLog
131 %docdir %{_datadir}/GNUstep/Documentation
132 %dir %{_datadir}/GNUstep/Documentation/Developer
133 %dir %{_datadir}/GNUstep/Documentation/Developer/Gui
134 %{_datadir}/GNUstep/Documentation/Developer/Gui/ReleaseNotes
135 %{_datadir}/GNUstep/Documentation/User
136
137 %{_mandir}/man1/gclose.1*
138 %{_mandir}/man1/gcloseall.1*
139 %{_mandir}/man1/gopen.1*
140 %{_mandir}/man1/make_services.1*
141 %{_mandir}/man1/set_show_service.1*
142
143 %attr(755,root,root) %{_bindir}/GSSpeechServer
144 %attr(755,root,root) %{_bindir}/gclose
145 %attr(755,root,root) %{_bindir}/gcloseall
146 %attr(755,root,root) %{_bindir}/gopen
147 %attr(755,root,root) %{_bindir}/make_services
148 %attr(755,root,root) %{_bindir}/say
149 %attr(755,root,root) %{_bindir}/set_show_service
150 %attr(755,root,root) %{_libdir}/libgnustep-gui.so.*.*.*
151 %attr(755,root,root) %ghost %{_libdir}/libgnustep-gui.so.%{ver}
152
153 # XXX: shared with WindowMaker - move to gnustep-dirs?
154 %dir %{_libdir}/GNUstep/Applications
155
156 %dir %{_libdir}/GNUstep/Applications/GSSpeechServer.app
157 %attr(755,root,root) %{_libdir}/GNUstep/Applications/GSSpeechServer.app/GSSpeechServer
158 %{_libdir}/GNUstep/Applications/GSSpeechServer.app/Resources
159 %{_libdir}/GNUstep/Applications/GSSpeechServer.app/stamp.make
160
161 %dir %{_libdir}/GNUstep/Bundles
162
163 %dir %{_libdir}/GNUstep/Bundles/AudioOutput.nssound
164 %attr(755,root,root) %{_libdir}/GNUstep/Bundles/AudioOutput.nssound/AudioOutput
165 %{_libdir}/GNUstep/Bundles/AudioOutput.nssound/Resources
166 %{_libdir}/GNUstep/Bundles/AudioOutput.nssound/stamp.make
167
168 %dir %{_libdir}/GNUstep/Bundles/GSPrinting
169 %dir %{_libdir}/GNUstep/Bundles/GSPrinting/GSLPR.bundle
170 %attr(755,root,root) %{_libdir}/GNUstep/Bundles/GSPrinting/GSLPR.bundle/GSLPR
171 %{_libdir}/GNUstep/Bundles/GSPrinting/GSLPR.bundle/Resources
172 %{_libdir}/GNUstep/Bundles/GSPrinting/GSLPR.bundle/stamp.make
173 %if %{with cups}
174 # R: cups-lib - separate?
175 %dir %{_libdir}/GNUstep/Bundles/GSPrinting/GSCUPS.bundle
176 %attr(755,root,root) %{_libdir}/GNUstep/Bundles/GSPrinting/GSCUPS.bundle/GSCUPS
177 %{_libdir}/GNUstep/Bundles/GSPrinting/GSCUPS.bundle/Resources
178 %{_libdir}/GNUstep/Bundles/GSPrinting/GSCUPS.bundle/stamp.make
179 %endif
180
181 %dir %{_libdir}/GNUstep/Bundles/Sndfile.nssound
182 %attr(755,root,root) %{_libdir}/GNUstep/Bundles/Sndfile.nssound/Sndfile
183 %{_libdir}/GNUstep/Bundles/Sndfile.nssound/Resources
184 %{_libdir}/GNUstep/Bundles/Sndfile.nssound/stamp.make
185
186 %dir %{_libdir}/GNUstep/Bundles/TextConverters
187 %dir %{_libdir}/GNUstep/Bundles/TextConverters/RTFConverter.bundle
188 %attr(755,root,root) %{_libdir}/GNUstep/Bundles/TextConverters/RTFConverter.bundle/RTFConverter
189 %{_libdir}/GNUstep/Bundles/TextConverters/RTFConverter.bundle/Resources
190 %{_libdir}/GNUstep/Bundles/TextConverters/RTFConverter.bundle/stamp.make
191
192 %dir %{_libdir}/GNUstep/Bundles/libgmodel.bundle
193 %attr(755,root,root) %{_libdir}/GNUstep/Bundles/libgmodel.bundle/libgmodel
194 %{_libdir}/GNUstep/Bundles/libgmodel.bundle/Resources
195 %{_libdir}/GNUstep/Bundles/libgmodel.bundle/stamp.make
196
197 %dir %{_libdir}/GNUstep/ColorPickers
198
199 %dir %{_libdir}/GNUstep/ColorPickers/NamedPicker.bundle
200 %attr(755,root,root) %{_libdir}/GNUstep/ColorPickers/NamedPicker.bundle/NamedPicker
201 %{_libdir}/GNUstep/ColorPickers/NamedPicker.bundle/Resources
202 %{_libdir}/GNUstep/ColorPickers/NamedPicker.bundle/stamp.make
203
204 %dir %{_libdir}/GNUstep/ColorPickers/StandardPicker.bundle
205 %attr(755,root,root) %{_libdir}/GNUstep/ColorPickers/StandardPicker.bundle/StandardPicker
206 %dir %{_libdir}/GNUstep/ColorPickers/StandardPicker.bundle/Resources
207 %{_libdir}/GNUstep/ColorPickers/StandardPicker.bundle/Resources/*.tiff
208 %{_libdir}/GNUstep/ColorPickers/StandardPicker.bundle/Resources/*.plist
209 %{_libdir}/GNUstep/ColorPickers/StandardPicker.bundle/Resources/English.lproj
210 %lang(fr) %{_libdir}/GNUstep/ColorPickers/StandardPicker.bundle/Resources/French.lproj
211 %lang(es) %{_libdir}/GNUstep/ColorPickers/StandardPicker.bundle/Resources/Spanish.lproj
212 %lang(sv) %{_libdir}/GNUstep/ColorPickers/StandardPicker.bundle/Resources/Swedish.lproj
213 %{_libdir}/GNUstep/ColorPickers/StandardPicker.bundle/stamp.make
214
215 %dir %{_libdir}/GNUstep/ColorPickers/WheelPicker.bundle
216 %attr(755,root,root) %{_libdir}/GNUstep/ColorPickers/WheelPicker.bundle/WheelPicker
217 %{_libdir}/GNUstep/ColorPickers/WheelPicker.bundle/Resources
218 %{_libdir}/GNUstep/ColorPickers/WheelPicker.bundle/stamp.make
219
220 %{_libdir}/GNUstep/Images
221 %{_libdir}/GNUstep/KeyBindings
222
223 %dir %{_libdir}/GNUstep/Libraries/gnustep-gui
224 %dir %{_libdir}/GNUstep/Libraries/gnustep-gui/Versions
225 %dir %{_libdir}/GNUstep/Libraries/gnustep-gui/Versions/%{ver}
226 %dir %{_libdir}/GNUstep/Libraries/gnustep-gui/Versions/%{ver}/Resources
227 %{_libdir}/GNUstep/Libraries/gnustep-gui/Versions/%{ver}/Resources/*.plist
228 %{_libdir}/GNUstep/Libraries/gnustep-gui/Versions/%{ver}/Resources/English.lproj
229 %lang(eo) %{_libdir}/GNUstep/Libraries/gnustep-gui/Versions/%{ver}/Resources/Esperanto.lproj
230 %lang(fr) %{_libdir}/GNUstep/Libraries/gnustep-gui/Versions/%{ver}/Resources/French.lproj
231 %lang(de) %{_libdir}/GNUstep/Libraries/gnustep-gui/Versions/%{ver}/Resources/German.lproj
232 %lang(it) %{_libdir}/GNUstep/Libraries/gnustep-gui/Versions/%{ver}/Resources/Italian.lproj
233 %lang(jbo) %{_libdir}/GNUstep/Libraries/gnustep-gui/Versions/%{ver}/Resources/Lojban.lproj
234 %lang(es) %{_libdir}/GNUstep/Libraries/gnustep-gui/Versions/%{ver}/Resources/Spanish.lproj
235
236 %dir %{_libdir}/GNUstep/PostScript
237 %{_libdir}/GNUstep/PostScript/GSProlog.ps
238 %dir %{_libdir}/GNUstep/PostScript/PPD
239 %{_libdir}/GNUstep/PostScript/PPD/English.lproj
240
241 %dir %{_libdir}/GNUstep/Services
242
243 %dir %{_libdir}/GNUstep/Services/GSspell.service
244 %attr(755,root,root) %{_libdir}/GNUstep/Services/GSspell.service/GSspell
245 %{_libdir}/GNUstep/Services/GSspell.service/Resources
246
247 %{_libdir}/GNUstep/Sounds
248
249 %files devel
250 %defattr(644,root,root,755)
251 %attr(755,root,root) %{_libdir}/libgnustep-gui.so
252 %{_includedir}/AppKit
253 %{_includedir}/Cocoa
254 %{_includedir}/GNUstepGUI
255 %{_includedir}/gnustep/gui
256
257 %docdir %{_datadir}/GNUstep/Documentation
258 %{_datadir}/GNUstep/Documentation/Developer/Gui/Additions
259 %{_datadir}/GNUstep/Documentation/Developer/Gui/General
260 %{_datadir}/GNUstep/Documentation/Developer/Gui/ProgrammingManual
261 %{_datadir}/GNUstep/Documentation/Developer/Gui/Reference
262 %{_infodir}/AppKit.info*
263
264 %{_datadir}/GNUstep/Makefiles/Additional/gui.make
This page took 0.100486 seconds and 3 git commands to generate.