]> git.pld-linux.org Git - packages/gnustep-gui.git/blame - gnustep-gui.spec
icu rebuild
[packages/gnustep-gui.git] / gnustep-gui.spec
CommitLineData
5717de99
JB
1#
2# Conditional build:
3%bcond_without cups # GSCUPS bundle
58075a32 4%bcond_without magick # ImageMagick support
5717de99
JB
5%bcond_without portaudio # gsnd tool
6#
829d10ca 7Summary: GNUstep GUI library package
fb1f7b25 8Summary(pl.UTF-8): Biblioteka GNUstep GUI
829d10ca 9Name: gnustep-gui
b4d1c253
JB
10%define ver 0.24
11Version: %{ver}.0
a0f8f7c7 12Release: 26
58075a32 13License: LGPL v2+ (library), GPL v3+ (applications)
4b35d086 14Group: Libraries
829d10ca 15Source0: ftp://ftp.gnustep.org/pub/gnustep/core/%{name}-%{version}.tar.gz
b4d1c253 16# Source0-md5: bd289f0c7b2626d093ad92364069b9a7
58075a32
JB
17Patch0: %{name}-nocompressdocs.patch
18Patch1: %{name}-doc.patch
b4d1c253 19Patch2: %{name}-giflib.patch
319a56d2 20Patch3: imagemagick7.patch
cf168368 21Patch4: icu68.patch
aa92dd8e 22URL: http://www.gnustep.org/
58075a32 23%{?with_magick:BuildRequires: ImageMagick-devel}
c3847b61 24BuildRequires: aspell-devel
5717de99 25%{?with_cups:BuildRequires: cups-devel}
58075a32 26BuildRequires: flite-devel
f6967d0c 27BuildRequires: gcc-objc
5717de99
JB
28BuildRequires: giflib-devel
29BuildRequires: gnustep-base-devel >= 1.13.0
58075a32
JB
30BuildRequires: gnustep-make-devel
31BuildRequires: libao-devel
b4d1c253 32BuildRequires: libicns-devel
58075a32 33BuildRequires: libicu-devel >= 4.0
f6967d0c 34BuildRequires: libjpeg-devel
5717de99 35BuildRequires: libpng-devel
58075a32 36BuildRequires: libsndfile-devel
f6967d0c 37BuildRequires: libtiff-devel
58075a32 38BuildRequires: pkgconfig
5717de99 39%{?with_portaudio:BuildRequires: portaudio-devel >= 19}
f6967d0c 40BuildRequires: zlib-devel
5717de99 41Requires: gnustep-base >= 1.13.0
f6967d0c
JB
42Conflicts: gnustep-core
43BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
44
aa92dd8e 45%description
829d10ca 46It is a library of graphical user interface classes written completely
47in the Objective-C language; the classes are based upon the OpenStep
48specification as release by NeXT Software, Inc. The library does not
49completely conform to the specification and has been enhanced in a
50number of ways to take advantage of the GNU system. These classes
aa92dd8e 51include graphical objects such as buttons, text fields, popup lists,
52browser lists, and windows; there are also many associated classes for
53handling events, colors, fonts, pasteboards and images.
54
c261d120
JR
55%description -l pl.UTF-8
56To jest biblioteka klas graficznego interfejsu użytkownika napisana w
57Objective-C. Klasy bazują na specyfikacji OpenStep wypuszczonej przez
58NeXT Software. Biblioteka nie jest całkowicie zgodna ze specyfikacją i
59została rozszerzona, aby wykorzystać możliwości systemu GNU. Klasy
60zawierają graficzne obiekty takie jak przyciski, pola tekstowe, listy
61rozwijane, listy przewijane i okienka; jest także wiele klas do
62obsługi zdarzeń, kolorów, fontów i obrazków.
e0359688 63
aa92dd8e 64%package devel
e0359688 65Summary: GNUstep GUI headers and libs
fb1f7b25 66Summary(pl.UTF-8): Pliki nagłówkowe GNUstep GUI
829d10ca 67Group: Development/Libraries
40ce32db 68Requires: %{name} = %{version}-%{release}
5717de99 69Requires: gnustep-base-devel >= 1.13.0
829d10ca 70Conflicts: gnustep-core
aa92dd8e 71
72%description devel
829d10ca 73Header files required to build applications against the GNUstep GUI
f6967d0c 74library.
aa92dd8e 75
c261d120
JR
76%description devel -l pl.UTF-8
77Pliki nagłówkowe potrzebne do budowania aplikacji korzystających z
e0359688
JB
78biblioteki GNUstep GUI.
79
aa92dd8e 80%prep
f6967d0c 81%setup -q
41dc2ea6 82%patch0 -p1
0f8149d4 83%patch1 -p1
b4d1c253 84%patch2 -p1
319a56d2 85%patch3 -p1
cf168368 86%patch4 -p1
aa92dd8e 87
88%build
f669a675 89export GNUSTEP_MAKEFILES=%{_datadir}/GNUstep/Makefiles
5717de99 90export GNUSTEP_FLATTENED=yes
120e1cac
JB
91# disable gsnd - not ready for current portaudio
92%configure \
5717de99 93 %{!?with_cups:--disable-cups} \
58075a32
JB
94 %{!?with_portaudio:--disable-gsnd} \
95 %{?with_magick:--enable-imagemagick} \
96 --enable-libgif \
97 --disable-ungif
aa92dd8e 98
d4d24605
SS
99# with __make -jN we can got non-deterministic errors
100%{__make} -j1 \
f6967d0c 101 messages=yes
aa92dd8e 102
f6967d0c
JB
103%install
104rm -rf $RPM_BUILD_ROOT
f669a675 105export GNUSTEP_MAKEFILES=%{_datadir}/GNUstep/Makefiles
8bc301c9 106export GNUSTEP_INSTALLATION_DOMAIN=SYSTEM
5717de99 107export GNUSTEP_FLATTENED=yes
aa92dd8e 108
f6967d0c 109%{__make} install \
f669a675
JR
110 DESTDIR=$RPM_BUILD_ROOT
111
0bd255f5 112%{__make} install -C Documentation \
f669a675 113 DESTDIR=$RPM_BUILD_ROOT
aa92dd8e 114
f669a675 115find $RPM_BUILD_ROOT%{_datadir}/GNUstep/Documentation \
3e8a68a7 116 -type f -name .cvsignore | xargs rm -f
aa92dd8e 117
f669a675
JR
118# not (yet?) supported by rpm-compress-doc
119find $RPM_BUILD_ROOT%{_datadir}/GNUstep/Documentation \
120 -type f -a ! -name '*.html' -a ! -name '*.gz' -a ! -name '*.jpg' -a ! -name '*.css' | xargs gzip -9nf
c387a5cc 121
aa92dd8e 122%clean
123rm -rf $RPM_BUILD_ROOT
124
e0359688
JB
125%post -p /sbin/ldconfig
126%postun -p /sbin/ldconfig
127
f6967d0c 128%files
829d10ca 129%defattr(644,root,root,755)
f6967d0c 130%doc ChangeLog
f669a675
JR
131%docdir %{_datadir}/GNUstep/Documentation
132%dir %{_datadir}/GNUstep/Documentation/Developer
133%dir %{_datadir}/GNUstep/Documentation/Developer/Gui
134%{_datadir}/GNUstep/Documentation/Developer/Gui/ReleaseNotes
135%{_datadir}/GNUstep/Documentation/User
136
58075a32
JB
137%{_mandir}/man1/gclose.1*
138%{_mandir}/man1/gcloseall.1*
139%{_mandir}/man1/gopen.1*
140%{_mandir}/man1/make_services.1*
141%{_mandir}/man1/set_show_service.1*
f6967d0c 142
58075a32
JB
143%attr(755,root,root) %{_bindir}/GSSpeechServer
144%attr(755,root,root) %{_bindir}/gclose
145%attr(755,root,root) %{_bindir}/gcloseall
146%attr(755,root,root) %{_bindir}/gopen
147%attr(755,root,root) %{_bindir}/make_services
148%attr(755,root,root) %{_bindir}/say
149%attr(755,root,root) %{_bindir}/set_show_service
150%attr(755,root,root) %{_libdir}/libgnustep-gui.so.*.*.*
151%attr(755,root,root) %ghost %{_libdir}/libgnustep-gui.so.%{ver}
152
c83d61ad 153# XXX: shared with WindowMaker - move to gnustep-dirs?
58075a32 154%dir %{_libdir}/GNUstep/Applications
c83d61ad 155
58075a32
JB
156%dir %{_libdir}/GNUstep/Applications/GSSpeechServer.app
157%attr(755,root,root) %{_libdir}/GNUstep/Applications/GSSpeechServer.app/GSSpeechServer
158%{_libdir}/GNUstep/Applications/GSSpeechServer.app/Resources
159%{_libdir}/GNUstep/Applications/GSSpeechServer.app/stamp.make
f6967d0c 160
b10e018b 161%dir %{_libdir}/GNUstep/Bundles
58075a32
JB
162
163%dir %{_libdir}/GNUstep/Bundles/AudioOutput.nssound
164%attr(755,root,root) %{_libdir}/GNUstep/Bundles/AudioOutput.nssound/AudioOutput
165%{_libdir}/GNUstep/Bundles/AudioOutput.nssound/Resources
166%{_libdir}/GNUstep/Bundles/AudioOutput.nssound/stamp.make
167
f669a675
JR
168%dir %{_libdir}/GNUstep/Bundles/GSPrinting
169%dir %{_libdir}/GNUstep/Bundles/GSPrinting/GSLPR.bundle
58075a32 170%attr(755,root,root) %{_libdir}/GNUstep/Bundles/GSPrinting/GSLPR.bundle/GSLPR
f669a675 171%{_libdir}/GNUstep/Bundles/GSPrinting/GSLPR.bundle/Resources
58075a32 172%{_libdir}/GNUstep/Bundles/GSPrinting/GSLPR.bundle/stamp.make
5717de99
JB
173%if %{with cups}
174# R: cups-lib - separate?
f669a675 175%dir %{_libdir}/GNUstep/Bundles/GSPrinting/GSCUPS.bundle
58075a32 176%attr(755,root,root) %{_libdir}/GNUstep/Bundles/GSPrinting/GSCUPS.bundle/GSCUPS
f669a675 177%{_libdir}/GNUstep/Bundles/GSPrinting/GSCUPS.bundle/Resources
58075a32 178%{_libdir}/GNUstep/Bundles/GSPrinting/GSCUPS.bundle/stamp.make
5717de99 179%endif
f669a675 180
58075a32
JB
181%dir %{_libdir}/GNUstep/Bundles/Sndfile.nssound
182%attr(755,root,root) %{_libdir}/GNUstep/Bundles/Sndfile.nssound/Sndfile
183%{_libdir}/GNUstep/Bundles/Sndfile.nssound/Resources
184%{_libdir}/GNUstep/Bundles/Sndfile.nssound/stamp.make
185
f669a675
JR
186%dir %{_libdir}/GNUstep/Bundles/TextConverters
187%dir %{_libdir}/GNUstep/Bundles/TextConverters/RTFConverter.bundle
f669a675 188%attr(755,root,root) %{_libdir}/GNUstep/Bundles/TextConverters/RTFConverter.bundle/RTFConverter
58075a32
JB
189%{_libdir}/GNUstep/Bundles/TextConverters/RTFConverter.bundle/Resources
190%{_libdir}/GNUstep/Bundles/TextConverters/RTFConverter.bundle/stamp.make
191
f669a675 192%dir %{_libdir}/GNUstep/Bundles/libgmodel.bundle
f669a675 193%attr(755,root,root) %{_libdir}/GNUstep/Bundles/libgmodel.bundle/libgmodel
58075a32
JB
194%{_libdir}/GNUstep/Bundles/libgmodel.bundle/Resources
195%{_libdir}/GNUstep/Bundles/libgmodel.bundle/stamp.make
f669a675
JR
196
197%dir %{_libdir}/GNUstep/ColorPickers
58075a32 198
f669a675 199%dir %{_libdir}/GNUstep/ColorPickers/NamedPicker.bundle
f669a675 200%attr(755,root,root) %{_libdir}/GNUstep/ColorPickers/NamedPicker.bundle/NamedPicker
58075a32
JB
201%{_libdir}/GNUstep/ColorPickers/NamedPicker.bundle/Resources
202%{_libdir}/GNUstep/ColorPickers/NamedPicker.bundle/stamp.make
203
f669a675 204%dir %{_libdir}/GNUstep/ColorPickers/StandardPicker.bundle
58075a32 205%attr(755,root,root) %{_libdir}/GNUstep/ColorPickers/StandardPicker.bundle/StandardPicker
f669a675
JR
206%dir %{_libdir}/GNUstep/ColorPickers/StandardPicker.bundle/Resources
207%{_libdir}/GNUstep/ColorPickers/StandardPicker.bundle/Resources/*.tiff
208%{_libdir}/GNUstep/ColorPickers/StandardPicker.bundle/Resources/*.plist
209%{_libdir}/GNUstep/ColorPickers/StandardPicker.bundle/Resources/English.lproj
210%lang(fr) %{_libdir}/GNUstep/ColorPickers/StandardPicker.bundle/Resources/French.lproj
58075a32 211%lang(es) %{_libdir}/GNUstep/ColorPickers/StandardPicker.bundle/Resources/Spanish.lproj
f669a675 212%lang(sv) %{_libdir}/GNUstep/ColorPickers/StandardPicker.bundle/Resources/Swedish.lproj
58075a32
JB
213%{_libdir}/GNUstep/ColorPickers/StandardPicker.bundle/stamp.make
214
f669a675 215%dir %{_libdir}/GNUstep/ColorPickers/WheelPicker.bundle
f669a675 216%attr(755,root,root) %{_libdir}/GNUstep/ColorPickers/WheelPicker.bundle/WheelPicker
58075a32
JB
217%{_libdir}/GNUstep/ColorPickers/WheelPicker.bundle/Resources
218%{_libdir}/GNUstep/ColorPickers/WheelPicker.bundle/stamp.make
f669a675 219
b10e018b
JR
220%{_libdir}/GNUstep/Images
221%{_libdir}/GNUstep/KeyBindings
f669a675
JR
222
223%dir %{_libdir}/GNUstep/Libraries/gnustep-gui
224%dir %{_libdir}/GNUstep/Libraries/gnustep-gui/Versions
225%dir %{_libdir}/GNUstep/Libraries/gnustep-gui/Versions/%{ver}
226%dir %{_libdir}/GNUstep/Libraries/gnustep-gui/Versions/%{ver}/Resources
227%{_libdir}/GNUstep/Libraries/gnustep-gui/Versions/%{ver}/Resources/*.plist
228%{_libdir}/GNUstep/Libraries/gnustep-gui/Versions/%{ver}/Resources/English.lproj
229%lang(eo) %{_libdir}/GNUstep/Libraries/gnustep-gui/Versions/%{ver}/Resources/Esperanto.lproj
58075a32 230%lang(fr) %{_libdir}/GNUstep/Libraries/gnustep-gui/Versions/%{ver}/Resources/French.lproj
f669a675
JR
231%lang(de) %{_libdir}/GNUstep/Libraries/gnustep-gui/Versions/%{ver}/Resources/German.lproj
232%lang(it) %{_libdir}/GNUstep/Libraries/gnustep-gui/Versions/%{ver}/Resources/Italian.lproj
233%lang(jbo) %{_libdir}/GNUstep/Libraries/gnustep-gui/Versions/%{ver}/Resources/Lojban.lproj
58075a32 234%lang(es) %{_libdir}/GNUstep/Libraries/gnustep-gui/Versions/%{ver}/Resources/Spanish.lproj
f669a675
JR
235
236%dir %{_libdir}/GNUstep/PostScript
237%{_libdir}/GNUstep/PostScript/GSProlog.ps
238%dir %{_libdir}/GNUstep/PostScript/PPD
239%{_libdir}/GNUstep/PostScript/PPD/English.lproj
58075a32 240
b10e018b 241%dir %{_libdir}/GNUstep/Services
58075a32 242
f669a675 243%dir %{_libdir}/GNUstep/Services/GSspell.service
f669a675 244%attr(755,root,root) %{_libdir}/GNUstep/Services/GSspell.service/GSspell
58075a32
JB
245%{_libdir}/GNUstep/Services/GSspell.service/Resources
246
247%{_libdir}/GNUstep/Sounds
f6967d0c
JB
248
249%files devel
829d10ca 250%defattr(644,root,root,755)
58075a32
JB
251%attr(755,root,root) %{_libdir}/libgnustep-gui.so
252%{_includedir}/AppKit
253%{_includedir}/Cocoa
254%{_includedir}/GNUstepGUI
255%{_includedir}/gnustep/gui
256
f669a675
JR
257%docdir %{_datadir}/GNUstep/Documentation
258%{_datadir}/GNUstep/Documentation/Developer/Gui/Additions
259%{_datadir}/GNUstep/Documentation/Developer/Gui/General
260%{_datadir}/GNUstep/Documentation/Developer/Gui/ProgrammingManual
261%{_datadir}/GNUstep/Documentation/Developer/Gui/Reference
58075a32 262%{_infodir}/AppKit.info*
f669a675 263
f669a675 264%{_datadir}/GNUstep/Makefiles/Additional/gui.make
This page took 0.272986 seconds and 4 git commands to generate.