]> git.pld-linux.org Git - packages/gnustep-gui.git/blame - gnustep-gui.spec
- adapt to 0.14
[packages/gnustep-gui.git] / gnustep-gui.spec
CommitLineData
5717de99
JB
1#
2# Conditional build:
3%bcond_without cups # GSCUPS bundle
4%bcond_without portaudio # gsnd tool
5#
829d10ca 6Summary: GNUstep GUI library package
fb1f7b25 7Summary(pl.UTF-8): Biblioteka GNUstep GUI
829d10ca 8Name: gnustep-gui
472da72b 9%define ver 0.14
10Version: %{ver}.0
d53e8b57 11Release: 1
f6967d0c 12License: LGPL/GPL
4b35d086 13Group: Libraries
829d10ca 14Source0: ftp://ftp.gnustep.org/pub/gnustep/core/%{name}-%{version}.tar.gz
472da72b 15# Source0-md5: c2b65eb22bba4db053c17b20f12dfb4a
b63fcf5e 16Patch0: %{name}-themes.patch
0f8149d4
JB
17Patch1: %{name}-nocompressdocs.patch
18Patch2: %{name}-segv.patch
19Patch3: %{name}-doc.patch
aa92dd8e 20URL: http://www.gnustep.org/
c3847b61 21BuildRequires: aspell-devel
f6967d0c 22BuildRequires: audiofile-devel
5717de99 23%{?with_cups:BuildRequires: cups-devel}
f6967d0c 24BuildRequires: gcc-objc
5717de99
JB
25BuildRequires: giflib-devel
26BuildRequires: gnustep-base-devel >= 1.13.0
f6967d0c 27BuildRequires: libjpeg-devel
5717de99 28BuildRequires: libpng-devel
f6967d0c 29BuildRequires: libtiff-devel
5717de99 30%{?with_portaudio:BuildRequires: portaudio-devel >= 19}
f6967d0c 31BuildRequires: zlib-devel
5717de99 32Requires: gnustep-base >= 1.13.0
f6967d0c
JB
33Conflicts: gnustep-core
34BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
35
aa92dd8e 36%description
829d10ca 37It is a library of graphical user interface classes written completely
38in the Objective-C language; the classes are based upon the OpenStep
39specification as release by NeXT Software, Inc. The library does not
40completely conform to the specification and has been enhanced in a
41number of ways to take advantage of the GNU system. These classes
aa92dd8e 42include graphical objects such as buttons, text fields, popup lists,
43browser lists, and windows; there are also many associated classes for
44handling events, colors, fonts, pasteboards and images.
45
c261d120
JR
46%description -l pl.UTF-8
47To jest biblioteka klas graficznego interfejsu użytkownika napisana w
48Objective-C. Klasy bazują na specyfikacji OpenStep wypuszczonej przez
49NeXT Software. Biblioteka nie jest całkowicie zgodna ze specyfikacją i
50została rozszerzona, aby wykorzystać możliwości systemu GNU. Klasy
51zawierają graficzne obiekty takie jak przyciski, pola tekstowe, listy
52rozwijane, listy przewijane i okienka; jest także wiele klas do
53obsługi zdarzeń, kolorów, fontów i obrazków.
e0359688 54
aa92dd8e 55%package devel
e0359688 56Summary: GNUstep GUI headers and libs
fb1f7b25 57Summary(pl.UTF-8): Pliki nagłówkowe GNUstep GUI
829d10ca 58Group: Development/Libraries
40ce32db 59Requires: %{name} = %{version}-%{release}
f6967d0c 60Requires: audiofile-devel
5717de99 61Requires: gnustep-base-devel >= 1.13.0
f6967d0c
JB
62Requires: libjpeg-devel
63Requires: libtiff-devel
829d10ca 64Conflicts: gnustep-core
aa92dd8e 65
66%description devel
829d10ca 67Header files required to build applications against the GNUstep GUI
f6967d0c 68library.
aa92dd8e 69
c261d120
JR
70%description devel -l pl.UTF-8
71Pliki nagłówkowe potrzebne do budowania aplikacji korzystających z
e0359688
JB
72biblioteki GNUstep GUI.
73
aa92dd8e 74%prep
f6967d0c 75%setup -q
41dc2ea6 76%patch0 -p1
0f8149d4 77%patch1 -p1
7c623ec7 78%patch2 -p1
2ee3e930 79%patch3 -p1
aa92dd8e 80
81%build
f669a675 82export GNUSTEP_MAKEFILES=%{_datadir}/GNUstep/Makefiles
5717de99 83export GNUSTEP_FLATTENED=yes
120e1cac
JB
84# disable gsnd - not ready for current portaudio
85%configure \
5717de99
JB
86 %{!?with_cups:--disable-cups} \
87 %{!?with_portaudio:--disable-gsnd}
aa92dd8e 88
d4d24605
SS
89# with __make -jN we can got non-deterministic errors
90%{__make} -j1 \
f6967d0c 91 messages=yes
aa92dd8e 92
f6967d0c
JB
93%install
94rm -rf $RPM_BUILD_ROOT
f669a675 95export GNUSTEP_MAKEFILES=%{_datadir}/GNUstep/Makefiles
5717de99 96export GNUSTEP_FLATTENED=yes
aa92dd8e 97
f6967d0c 98%{__make} install \
f669a675
JR
99 DESTDIR=$RPM_BUILD_ROOT
100
0bd255f5 101%{__make} install -C Documentation \
f669a675 102 DESTDIR=$RPM_BUILD_ROOT
aa92dd8e 103
f669a675 104find $RPM_BUILD_ROOT%{_datadir}/GNUstep/Documentation \
3e8a68a7 105 -type f -name .cvsignore | xargs rm -f
aa92dd8e 106
f669a675
JR
107# not (yet?) supported by rpm-compress-doc
108find $RPM_BUILD_ROOT%{_datadir}/GNUstep/Documentation \
109 -type f -a ! -name '*.html' -a ! -name '*.gz' -a ! -name '*.jpg' -a ! -name '*.css' | xargs gzip -9nf
c387a5cc 110
aa92dd8e 111%clean
112rm -rf $RPM_BUILD_ROOT
113
e0359688
JB
114%post -p /sbin/ldconfig
115%postun -p /sbin/ldconfig
116
f6967d0c 117%files
829d10ca 118%defattr(644,root,root,755)
f6967d0c 119%doc ChangeLog
f669a675
JR
120%docdir %{_datadir}/GNUstep/Documentation
121%dir %{_datadir}/GNUstep/Documentation/Developer
122%dir %{_datadir}/GNUstep/Documentation/Developer/Gui
123%{_datadir}/GNUstep/Documentation/Developer/Gui/ReleaseNotes
124%{_datadir}/GNUstep/Documentation/User
125
126%{_mandir}/man1/*
f6967d0c 127
f669a675
JR
128%attr(755,root,root) %{_bindir}/*
129%attr(755,root,root) %{_libdir}/libgnustep-gui.so.*
f6967d0c 130
b10e018b 131%dir %{_libdir}/GNUstep/Bundles
f669a675
JR
132%dir %{_libdir}/GNUstep/Bundles/GSPrinting
133%dir %{_libdir}/GNUstep/Bundles/GSPrinting/GSLPR.bundle
134%{_libdir}/GNUstep/Bundles/GSPrinting/GSLPR.bundle/Resources
135%{_libdir}/GNUstep/Bundles/GSPrinting/GSLPR.bundle/GSLPR
5717de99
JB
136%if %{with cups}
137# R: cups-lib - separate?
f669a675
JR
138%dir %{_libdir}/GNUstep/Bundles/GSPrinting/GSCUPS.bundle
139%{_libdir}/GNUstep/Bundles/GSPrinting/GSCUPS.bundle/Resources
140%{_libdir}/GNUstep/Bundles/GSPrinting/GSCUPS.bundle/GSCUPS
5717de99 141%endif
f669a675
JR
142
143%dir %{_libdir}/GNUstep/Bundles/TextConverters
144%dir %{_libdir}/GNUstep/Bundles/TextConverters/RTFConverter.bundle
145%{_libdir}/GNUstep/Bundles/TextConverters/RTFConverter.bundle/Resources
146%attr(755,root,root) %{_libdir}/GNUstep/Bundles/TextConverters/RTFConverter.bundle/RTFConverter
147%dir %{_libdir}/GNUstep/Bundles/libgmodel.bundle
148%{_libdir}/GNUstep/Bundles/libgmodel.bundle/Resources
149%attr(755,root,root) %{_libdir}/GNUstep/Bundles/libgmodel.bundle/libgmodel
150
151%dir %{_libdir}/GNUstep/ColorPickers
152%dir %{_libdir}/GNUstep/ColorPickers/NamedPicker.bundle
153%{_libdir}/GNUstep/ColorPickers/NamedPicker.bundle/Resources
154%attr(755,root,root) %{_libdir}/GNUstep/ColorPickers/NamedPicker.bundle/NamedPicker
155%dir %{_libdir}/GNUstep/ColorPickers/StandardPicker.bundle
156%dir %{_libdir}/GNUstep/ColorPickers/StandardPicker.bundle/Resources
157%{_libdir}/GNUstep/ColorPickers/StandardPicker.bundle/Resources/*.tiff
158%{_libdir}/GNUstep/ColorPickers/StandardPicker.bundle/Resources/*.plist
159%{_libdir}/GNUstep/ColorPickers/StandardPicker.bundle/Resources/English.lproj
160%lang(fr) %{_libdir}/GNUstep/ColorPickers/StandardPicker.bundle/Resources/French.lproj
161%lang(sv) %{_libdir}/GNUstep/ColorPickers/StandardPicker.bundle/Resources/Swedish.lproj
162%attr(755,root,root) %{_libdir}/GNUstep/ColorPickers/StandardPicker.bundle/StandardPicker
163%dir %{_libdir}/GNUstep/ColorPickers/WheelPicker.bundle
164%{_libdir}/GNUstep/ColorPickers/WheelPicker.bundle/Resources
165%attr(755,root,root) %{_libdir}/GNUstep/ColorPickers/WheelPicker.bundle/WheelPicker
166
b10e018b
JR
167%{_libdir}/GNUstep/Images
168%{_libdir}/GNUstep/KeyBindings
f669a675
JR
169
170%dir %{_libdir}/GNUstep/Libraries/gnustep-gui
171%dir %{_libdir}/GNUstep/Libraries/gnustep-gui/Versions
172%dir %{_libdir}/GNUstep/Libraries/gnustep-gui/Versions/%{ver}
173%dir %{_libdir}/GNUstep/Libraries/gnustep-gui/Versions/%{ver}/Resources
174%{_libdir}/GNUstep/Libraries/gnustep-gui/Versions/%{ver}/Resources/*.plist
175%{_libdir}/GNUstep/Libraries/gnustep-gui/Versions/%{ver}/Resources/English.lproj
176%lang(eo) %{_libdir}/GNUstep/Libraries/gnustep-gui/Versions/%{ver}/Resources/Esperanto.lproj
177%lang(de) %{_libdir}/GNUstep/Libraries/gnustep-gui/Versions/%{ver}/Resources/German.lproj
178%lang(it) %{_libdir}/GNUstep/Libraries/gnustep-gui/Versions/%{ver}/Resources/Italian.lproj
179%lang(jbo) %{_libdir}/GNUstep/Libraries/gnustep-gui/Versions/%{ver}/Resources/Lojban.lproj
180
181%dir %{_libdir}/GNUstep/PostScript
182%{_libdir}/GNUstep/PostScript/GSProlog.ps
183%dir %{_libdir}/GNUstep/PostScript/PPD
184%{_libdir}/GNUstep/PostScript/PPD/English.lproj
b10e018b 185%dir %{_libdir}/GNUstep/Services
f669a675
JR
186%dir %{_libdir}/GNUstep/Services/GSspell.service
187%{_libdir}/GNUstep/Services/GSspell.service/Resources
188%attr(755,root,root) %{_libdir}/GNUstep/Services/GSspell.service/GSspell
f6967d0c
JB
189
190%files devel
829d10ca 191%defattr(644,root,root,755)
f669a675
JR
192%docdir %{_datadir}/GNUstep/Documentation
193%{_datadir}/GNUstep/Documentation/Developer/Gui/Additions
194%{_datadir}/GNUstep/Documentation/Developer/Gui/General
195%{_datadir}/GNUstep/Documentation/Developer/Gui/ProgrammingManual
196%{_datadir}/GNUstep/Documentation/Developer/Gui/Reference
197%{_infodir}/*.info*
198
199%{_includedir}/AppKit
200%{_includedir}/Cocoa
201%{_includedir}/GNUstepGUI
202%{_includedir}/gnustep/gui
203
204%attr(755,root,root) %{_libdir}/libgnustep-gui.so
205%{_datadir}/GNUstep/Makefiles/Additional/gui.make
This page took 0.849444 seconds and 4 git commands to generate.