]> git.pld-linux.org Git - packages/gnustep-back.git/blob - gnustep-back.spec
- up to 0.8.7, removed obsolete art-freetype213 patch
[packages/gnustep-back.git] / gnustep-back.spec
1 Summary:        The GNUstep backend bundle
2 Summary(pl):    Pakiet backendowy GNUstep
3 Name:           gnustep-back
4 Version:        0.8.7
5 Release:        1
6 License:        LGPL/GPL
7 Vendor:         The GNUstep Project
8 Group:          X11/Libraries
9 Source0:        ftp://ftp.gnustep.org/pub/gnustep/core/%{name}-%{version}.tar.gz
10 # Source0-md5:  1b9e0eae52bce69a979d07a3cbe4019d
11 Patch0:         %{name}-xdps-fix.patch
12 URL:            http://www.gnustep.org/
13 BuildRequires:  OpenGL-devel
14 BuildRequires:  WindowMaker-devel
15 BuildRequires:  XFree86-devel
16 BuildRequires:  XFree86-DPS-devel
17 BuildRequires:  freetype-devel >= 2.1.4
18 BuildRequires:  gnustep-gui-devel >= 0.8.7
19 BuildRequires:  libart_lgpl-devel
20 BuildRequires:  xft-devel
21 Requires:       OpenGL
22 Requires:       gnustep-gui
23 Obsoletes:      gnustep-xgps
24 Conflicts:      gnustep-core
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %define         _prefix         /usr/lib/GNUstep
28
29 %define         _noautoreqdep   libGL.so.1 libGLU.so.1
30
31 %define         libcombo        gnu-gnu-gnu
32 %define         gsos            linux-gnu
33 %ifarch %{ix86}
34 %define         gscpu           ix86
35 %else
36 # also s/alpha.*/alpha/, but we use only "alpha" arch for now
37 %define         gscpu           %{_target_cpu}
38 %endif
39
40 %description
41 This is a backend for the GNUstep gui Library which allows you to use
42 the GNUstep gui Library on an X Windows System (other backends will
43 be added later to allow you to use the GNUstep gui Library in other
44 windowing environments).
45
46 This package contains common part and xlib graphics backend.
47
48 %description -l pl
49 To jest backend dla biblioteki GNUstep GUI, pozwalaj±cy na u¿ywanie
50 biblioteki graficznego interfejsu u¿ytkownika GNUstep pod systemem X
51 Window (inne backendy, pozwalaj±ce na u¿ywanie biblioteki GNUstep GUI
52 w innych ¶rodowiskach okienkowych, zostan± dodane pó¼niej).
53
54 Ten pakiet zawiera czê¶æ wspóln± i backend graficzny xlib.
55
56 %package art
57 Summary:        GNUstep graphics backend - art
58 Summary(pl):    Graficzny backend GNUstep - art
59 Group:          X11/Libraries
60 Requires:       %{name} = %{version}
61 Requires:       freetype >= 2.1.4
62 Conflicts:      gnustep-core
63
64 %description art
65 GNUstep graphics backend - art.
66
67 %description art -l pl
68 Graficzny backend GNUstep - art.
69
70 %package xdps
71 Summary:        GNUstep graphics backend - xdps
72 Summary(pl):    Graficzny backend GNUstep - xdps
73 Group:          X11/Libraries
74 Requires:       %{name} = %{version}
75 Obsoletes:      gnustep-xdps
76 Conflicts:      gnustep-core
77
78 %description xdps
79 GNUstep graphics backend - xdps.
80
81 %description xdps -l pl
82 Graficzny backend GNUstep - xdps.
83
84 %package devel
85 Summary:        Headers for GNUstep backends
86 Summary(pl):    Pliki nag³ówkowe backendów GNUstep
87 Group:          X11/Development/Libraries
88 Requires:       %{name} = %{version}
89 Requires:       XFree86-devel
90 Requires:       gnustep-gui-devel >= 0.8.7
91 Requires:       xft-devel
92 Obsoletes:      gnustep-xdps-devel
93 Obsoletes:      gnustep-xgps-devel
94 Conflicts:      gnustep-core
95
96 %description devel
97 This package contains development headers for GNUstep backends. It
98 includes also files specific for all x11 graphic backends (xlib,
99 art, xdps).
100
101 %description devel -l pl
102 Ten pakiet zawiera pliki nag³ówkowe dla backendów GNUstep, w tym pliki
103 specyficzne dla wszystkich backendów graficznych dla x11 (xlib, art,
104 xdps).
105
106 %prep
107 %setup -q
108 %patch0 -p1
109
110 %build
111 . %{_prefix}/System/Library/Makefiles/GNUstep.sh
112 for g in art xdps xlib ; do
113 if [ "$g" = "xlib" ]; then
114         INC='--with-include-flags=-I/usr/include/freetype2'
115         NAME="back"
116 else
117         INC=
118         NAME="back-$g"
119 fi
120 %configure \
121         --enable-graphics=$g \
122         --with-name=$NAME \
123         $INC
124
125 %{__make} \
126         messages=yes
127 cp -f back.make back-$g.make
128 # preserve timestamp of config.h
129 cp -pf config.h config-$g.h
130 done
131
132 %{__make} -C Documentation
133
134 %install
135 rm -rf $RPM_BUILD_ROOT
136 . %{_prefix}/System/Library/Makefiles/GNUstep.sh
137
138 for g in art xdps xlib ; do
139 if [ "$g" = "xlib" ]; then
140         NAME="back"
141 else
142         NAME="back-$g"
143 fi
144 # hack - restore timestamps to prevent rebuilding
145 cp -pf config-$g.h config.h
146 cp -pf config.h Source/%{gscpu}/%{gsos}/config.h
147 touch config.status -r config.h
148 %{__make} install \
149         GNUSTEP_INSTALLATION_DIR=$RPM_BUILD_ROOT%{_prefix}/System \
150         BUILD_GRAPHICS="$g" \
151         BACKEND_NAME="$NAME"
152 done
153
154 %{__make} install -C Documentation \
155         GNUSTEP_INSTALLATION_DIR=$RPM_BUILD_ROOT%{_prefix}/System \
156 # not (yet?) supported by rpm-compress-doc
157 find $RPM_BUILD_ROOT%{_prefix}/System/Library/Documentation -type f | xargs gzip -9nf
158
159 %clean
160 rm -rf $RPM_BUILD_ROOT
161
162 %post   -p /sbin/ldconfig
163 %postun -p /sbin/ldconfig
164
165 %files
166 %defattr(644,root,root,755)
167 %doc ChangeLog
168 %docdir %{_prefix}/System/Library/Documentation
169 %{_prefix}/System/Library/Documentation/Developer/Back
170
171 %dir %{_prefix}/System/Library/Bundles/libgnustep-back.bundle
172 %{_prefix}/System/Library/Bundles/libgnustep-back.bundle/Resources
173 %attr(755,root,root) %{_prefix}/System/Library/Bundles/libgnustep-back.bundle/%{gscpu}
174
175 %attr(755,root,root) %{_prefix}/System/Tools/%{gscpu}/%{gsos}/%{libcombo}/*
176
177 %files art
178 %defattr(644,root,root,755)
179 %dir %{_prefix}/System/Library/Bundles/libgnustep-back-art.bundle
180 %{_prefix}/System/Library/Bundles/libgnustep-back-art.bundle/Resources
181 %attr(755,root,root) %{_prefix}/System/Library/Bundles/libgnustep-back-art.bundle/%{gscpu}
182
183 %files xdps
184 %defattr(644,root,root,755)
185 %dir %{_prefix}/System/Library/Bundles/libgnustep-back-xdps.bundle
186 %{_prefix}/System/Library/Bundles/libgnustep-back-xdps.bundle/Resources
187 %attr(755,root,root) %{_prefix}/System/Library/Bundles/libgnustep-back-xdps.bundle/%{gscpu}
188
189 %files devel
190 %defattr(644,root,root,755)
191 %{_prefix}/System/Library/Headers/gnustep/gsc
192 %{_prefix}/System/Library/Headers/gnustep/x11
193
194 %{_prefix}/System/Library/Headers/gnustep/xlib
195 %{_prefix}/System/Library/Headers/gnustep/art
196 %{_prefix}/System/Library/Headers/gnustep/xdps
This page took 0.097797 seconds and 4 git commands to generate.