]> git.pld-linux.org Git - packages/gnustep-back.git/commitdiff
- up to 0.8.7, removed obsolete art-freetype213 patch
authorJakub Bogusz <qboosh@pld-linux.org>
Sat, 19 Jul 2003 23:50:15 +0000 (23:50 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    gnustep-back-art-freetype213.patch -> 1.3
    gnustep-back.spec -> 1.6

gnustep-back-art-freetype213.patch [deleted file]
gnustep-back.spec

diff --git a/gnustep-back-art-freetype213.patch b/gnustep-back-art-freetype213.patch
deleted file mode 100644 (file)
index d3cb96a..0000000
+++ /dev/null
@@ -1,181 +0,0 @@
---- gnustep-back-0.8.5/Source/art/ftfont.m.orig        2003-02-10 18:46:06.000000000 +0100
-+++ gnustep-back-0.8.5/Source/art/ftfont.m     2003-05-14 21:46:52.000000000 +0200
-@@ -79,9 +79,9 @@
- @interface FTFontInfo : GSFontInfo <FTFontInfo>
- {
- @public
--  FTC_ImageDesc imgd;
-+  FTC_ImageTypeRec imgd;
--  FTC_ImageDesc fallback;
-+  FTC_ImageTypeRec fallback;
-   FTFaceInfo *face_info;
-@@ -743,7 +743,7 @@
-   int use_sbit;
-   FTC_SBit sbit;
--  FTC_ImageDesc cur;
-+  FTC_ImageTypeRec cur;
-   FT_Matrix ftmatrix;
-   FT_Vector ftdelta;
-@@ -793,23 +793,23 @@
-           int rh = face_info->render_hints_hack;
-           if (rh & 0x10000)
-             {
--              cur.type = ftc_image_grays;
-+              cur.flags = FT_LOAD_DEFAULT;
-               rh = (rh >> 8) & 0xff;
-             }
-           else
-             {
--              cur.type = ftc_image_mono;
-+              cur.flags = FT_LOAD_MONOCHROME;
-               rh = rh & 0xff;
-             }
-           if (rh & 1)
--            cur.type |= ftc_image_flag_autohinted;
-+            cur.flags |= FT_LOAD_FORCE_AUTOHINT;
-           if (!(rh & 2))
--            cur.type |= ftc_image_flag_unhinted;
-+            cur.flags |= FT_LOAD_NO_HINTING;
-         }
-       else if (xx < 8)
--        cur.type = ftc_image_grays | ftc_image_flag_unhinted;
-+        cur.flags = FT_LOAD_DEFAULT | FT_LOAD_NO_HINTING;
-       else
--        cur.type = ftc_image_grays;
-+        cur.flags = FT_LOAD_DEFAULT;
-       }
-     else
-       {
-@@ -1135,7 +1135,7 @@
-   int use_sbit;
-   FTC_SBit sbit;
--  FTC_ImageDesc cur;
-+  FTC_ImageTypeRec cur;
-   FT_Matrix ftmatrix;
-   FT_Vector ftdelta;
-@@ -1185,23 +1185,23 @@
-           int rh = face_info->render_hints_hack;
-           if (rh & 0x10000)
-             {
--              cur.type = ftc_image_grays;
-+              cur.flags = FT_LOAD_DEFAULT;
-               rh = (rh >> 8) & 0xff;
-             }
-           else
-             {
--              cur.type = ftc_image_mono;
-+              cur.flags = FT_LOAD_MONOCHROME;
-               rh = rh & 0xff;
-             }
-           if (rh & 1)
--            cur.type |= ftc_image_flag_autohinted;
-+            cur.flags |= FT_LOAD_FORCE_AUTOHINT;
-           if (!(rh & 2))
--            cur.type |= ftc_image_flag_unhinted;
-+            cur.flags |= FT_LOAD_NO_HINTING;
-         }
-       else if (xx < 8)
--        cur.type = ftc_image_grays | ftc_image_flag_unhinted;
-+        cur.flags = FT_LOAD_DEFAULT | FT_LOAD_NO_HINTING;
-       else
--        cur.type = ftc_image_grays;
-+        cur.flags = FT_LOAD_DEFAULT;
-       }
-     else
-       {
-@@ -1466,7 +1466,7 @@
-       /* TODO: try to more efficiently? */
-       /* TODO: set up all this stuff in -init... for the raw metric case */
-       float xx, yy;
--      FTC_ImageDesc cur;
-+      FTC_ImageTypeRec cur;
-       FTC_SBit sbit;
-       cur = imgd;
-@@ -1479,23 +1479,23 @@
-           int rh = face_info->render_hints_hack;
-           if (rh & 0x10000)
-             {
--              cur.type = ftc_image_grays;
-+              cur.flags = FT_LOAD_DEFAULT;
-               rh = (rh >> 8) & 0xff;
-             }
-           else
-             {
--              cur.type = ftc_image_mono;
-+              cur.flags = FT_LOAD_MONOCHROME;
-               rh = rh & 0xff;
-             }
-           if (rh & 1)
--            cur.type |= ftc_image_flag_autohinted;
-+            cur.flags |= FT_LOAD_FORCE_AUTOHINT;
-           if (!(rh & 2))
--            cur.type |= ftc_image_flag_unhinted;
-+            cur.flags |= FT_LOAD_NO_HINTING;
-         }
-       else if (xx < 8)
--        cur.type = ftc_image_grays | ftc_image_flag_unhinted;
-+        cur.flags = FT_LOAD_DEFAULT | FT_LOAD_NO_HINTING;
-       else
--        cur.type = ftc_image_grays;
-+        cur.flags = FT_LOAD_DEFAULT;
-       if (FTC_SBitCache_Lookup(ftc_sbitcache, &cur, glyph, &sbit, NULL))
-       return NSZeroSize;
-@@ -1547,7 +1547,7 @@
- - (NSRect) boundingRectForGlyph: (NSGlyph)glyph
- {
--  FTC_ImageDesc *cur;
-+  FTC_ImageTypeRec *cur;
-   FT_BBox bbox;
-   FT_Glyph g;
-@@ -1618,7 +1618,7 @@
-   FTC_SBit sbit;
--  FTC_ImageDesc *cur;
-+  FTC_ImageTypeRec *cur;
-   cmap.face_id = imgd.font.face_id;
-@@ -1831,7 +1831,7 @@
-   unichar *uch;
-   int ulen;
--  FTC_ImageDesc cur;
-+  FTC_ImageTypeRec cur;
-   FT_Matrix ftmatrix;
-@@ -2003,7 +2003,7 @@
-   int use_sbit;
-   FTC_SBit sbit;
--  FTC_ImageDesc cur;
-+  FTC_ImageTypeRec cur;
-   FT_Matrix ftmatrix;
-   FT_Vector ftdelta;
-@@ -2050,10 +2050,10 @@
- /*    if (cur.font.pix_width < 16 && cur.font.pix_height < 16 &&
-           cur.font.pix_width > 6 && cur.font.pix_height > 6)
--        cur.type = ftc_image_mono;
-+        cur.flags = FT_LOAD_MONOCHROME;
-       else*/
--        cur.type = ftc_image_grays, subpixel = YES, cur.font.pix_width *= 3, x *= 3;
--//                    imgd.type|=|ftc_image_flag_unhinted; /* TODO? when? */
-+        cur.flags = FT_LOAD_DEFAULT, subpixel = YES, cur.font.pix_width *= 3, x *= 3;
-+//                    imgd.flags|=|FT_LOAD_NO_HINTING; /* TODO? when? */
-       }
-     else
-       {
index d4ec254a67c927483de2d7514735c03bcbb12df4..7a250cb4abda0a48c890efddd30bc929a619a637 100644 (file)
@@ -1,22 +1,21 @@
 Summary:       The GNUstep backend bundle
 Summary(pl):   Pakiet backendowy GNUstep
 Name:          gnustep-back
-Version:       0.8.5
+Version:       0.8.7
 Release:       1
 License:       LGPL/GPL
 Vendor:                The GNUstep Project
 Group:         X11/Libraries
 Source0:       ftp://ftp.gnustep.org/pub/gnustep/core/%{name}-%{version}.tar.gz
-# Source0-md5: 9020f254f584ed176221321218857b55
-Patch0:                %{name}-art-freetype213.patch
-Patch1:                %{name}-xdps-fix.patch
+# Source0-md5: 1b9e0eae52bce69a979d07a3cbe4019d
+Patch0:                %{name}-xdps-fix.patch
 URL:           http://www.gnustep.org/
 BuildRequires: OpenGL-devel
 BuildRequires: WindowMaker-devel
 BuildRequires: XFree86-devel
 BuildRequires: XFree86-DPS-devel
-BuildRequires: freetype-devel >= 2.1.3
-BuildRequires: gnustep-gui-devel
+BuildRequires: freetype-devel >= 2.1.4
+BuildRequires: gnustep-gui-devel >= 0.8.7
 BuildRequires: libart_lgpl-devel
 BuildRequires: xft-devel
 Requires:      OpenGL
@@ -59,6 +58,7 @@ Summary:      GNUstep graphics backend - art
 Summary(pl):   Graficzny backend GNUstep - art
 Group:         X11/Libraries
 Requires:      %{name} = %{version}
+Requires:      freetype >= 2.1.4
 Conflicts:     gnustep-core
 
 %description art
@@ -87,7 +87,7 @@ Summary(pl):  Pliki nag
 Group:         X11/Development/Libraries
 Requires:      %{name} = %{version}
 Requires:      XFree86-devel
-Requires:      gnustep-gui-devel
+Requires:      gnustep-gui-devel >= 0.8.7
 Requires:      xft-devel
 Obsoletes:     gnustep-xdps-devel
 Obsoletes:     gnustep-xgps-devel
@@ -106,10 +106,9 @@ xdps).
 %prep
 %setup -q
 %patch0 -p1
-%patch1 -p1
 
 %build
-. %{_prefix}/System/Makefiles/GNUstep.sh
+. %{_prefix}/System/Library/Makefiles/GNUstep.sh
 for g in art xdps xlib ; do
 if [ "$g" = "xlib" ]; then
        INC='--with-include-flags=-I/usr/include/freetype2'
@@ -134,7 +133,7 @@ done
 
 %install
 rm -rf $RPM_BUILD_ROOT
-. %{_prefix}/System/Makefiles/GNUstep.sh
+. %{_prefix}/System/Library/Makefiles/GNUstep.sh
 
 for g in art xdps xlib ; do
 if [ "$g" = "xlib" ]; then
@@ -155,7 +154,7 @@ done
 %{__make} install -C Documentation \
        GNUSTEP_INSTALLATION_DIR=$RPM_BUILD_ROOT%{_prefix}/System \
 # not (yet?) supported by rpm-compress-doc
-find $RPM_BUILD_ROOT%{_prefix}/System/Documentation -type f | xargs gzip -9nf
+find $RPM_BUILD_ROOT%{_prefix}/System/Library/Documentation -type f | xargs gzip -9nf
 
 %clean
 rm -rf $RPM_BUILD_ROOT
@@ -166,7 +165,8 @@ rm -rf $RPM_BUILD_ROOT
 %files
 %defattr(644,root,root,755)
 %doc ChangeLog
-%{_prefix}/System/Documentation/Developer/Back
+%docdir %{_prefix}/System/Library/Documentation
+%{_prefix}/System/Library/Documentation/Developer/Back
 
 %dir %{_prefix}/System/Library/Bundles/libgnustep-back.bundle
 %{_prefix}/System/Library/Bundles/libgnustep-back.bundle/Resources
@@ -188,9 +188,9 @@ rm -rf $RPM_BUILD_ROOT
 
 %files devel
 %defattr(644,root,root,755)
-%{_prefix}/System/Headers/gnustep/gsc
-%{_prefix}/System/Headers/gnustep/x11
+%{_prefix}/System/Library/Headers/gnustep/gsc
+%{_prefix}/System/Library/Headers/gnustep/x11
 
-%{_prefix}/System/Headers/gnustep/xlib
-%{_prefix}/System/Headers/gnustep/art
-%{_prefix}/System/Headers/gnustep/xdps
+%{_prefix}/System/Library/Headers/gnustep/xlib
+%{_prefix}/System/Library/Headers/gnustep/art
+%{_prefix}/System/Library/Headers/gnustep/xdps
This page took 0.104656 seconds and 4 git commands to generate.