]> git.pld-linux.org Git - packages/gnustep-back.git/blob - gnustep-back.spec
- new, based on gnustep-x[dg]ps.spec
[packages/gnustep-back.git] / gnustep-back.spec
1 Summary:        The GNUstep backend bundle
2 Summary(pl):    Pakiet backendowy GNUstep
3 Name:           gnustep-back
4 Version:        0.8.3
5 Release:        1
6 License:        LGPL/GPL
7 Vendor:         The GNUstep Project
8 Group:          X11/Libraries
9 Source0:        ftp://ftp.gnustep.org/pub/gnustep/core/%{name}-%{version}.tar.gz
10 Patch0:         %{name}-Xft2.patch
11 Patch1:         %{name}-art-freetype213.patch
12 Patch2:         %{name}-xdps-fix.patch
13 URL:            http://www.gnustep.org/
14 BuildRequires:  OpenGL-devel
15 BuildRequires:  WindowMaker-devel
16 BuildRequires:  XFree86-devel
17 BuildRequires:  XFree86-DPS-devel
18 BuildRequires:  Xft-devel
19 BuildRequires:  freetype-devel >= 2.1.3
20 BuildRequires:  gnustep-gui-devel
21 BuildRequires:  libart_lgpl-devel
22 Requires:       OpenGL
23 Requires:       gnustep-gui
24 Obsoletes:      gnustep-xgps
25 Conflicts:      gnustep-core
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %define         _prefix         /usr/lib/GNUstep
29
30 %define         libcombo        gnu-gnu-gnu
31 %define         gsos            linux-gnu
32 %ifarch %{ix86}
33 %define         gscpu           ix86
34 %else
35 # also s/alpha.*/alpha/, but we use only "alpha" arch for now
36 %define         gscpu           %{_target_cpu}
37 %endif
38
39 %description
40 This is a backend for the GNUstep gui Library which allows you to use
41 the GNUstep gui Library on an X Windows System (other backends will
42 be added later to allow you to use the GNUstep gui Library in other
43 windowing environments).
44
45 This package contains common part and xlib graphics backend.
46
47 %description -l pl
48 To jest backend dla biblioteki GNUstep GUI, pozwalaj±cy na u¿ywanie
49 biblioteki graficznego interfejsu u¿ytkownika GNUstep pod systemem X
50 Window (inne backendy, pozwalaj±ce na u¿ywanie biblioteki GNUstep GUI
51 w innych ¶rodowiskach okienkowych, zostan± dodane pó¼niej).
52
53 Ten pakiet zawiera czê¶æ wspóln± i backend graficzny xlib.
54
55 %package art
56 Summary:        GNUstep graphics backend - art
57 Summary(pl):    Graficzny backend GNUstep - art
58 Group:          X11/Libraries
59 Requires:       %{name} = %{version}
60 Conflicts:      gnustep-core
61
62 %description art
63 GNUstep graphics backend - art.
64
65 %description art -l pl
66 Graficzny backend GNUstep - art.
67
68 %package xdps
69 Summary:        GNUstep graphics backend - xdps
70 Summary(pl):    Graficzny backend GNUstep - xdps
71 Group:          X11/Libraries
72 Requires:       %{name} = %{version}
73 Obsoletes:      gnustep-xdps
74 Conflicts:      gnustep-core
75
76 %description xdps
77 GNUstep graphics backend - xdps.
78
79 %description xdps -l pl
80 Graficzny backend GNUstep - xdps.
81
82 %package devel
83 Summary:        Headers for GNUstep backends
84 Summary(pl):    Pliki nag³ówkowe backendów GNUstep
85 Group:          X11/Development/Libraries
86 Requires:       %{name} = %{version}
87 Requires:       XFree86-devel
88 Requires:       Xft-devel
89 Requires:       gnustep-gui-devel
90 Obsoletes:      gnustep-xdps-devel
91 Obsoletes:      gnustep-xgps-devel
92 Conflicts:      gnustep-core
93
94 %description devel
95 This package contains development headers for GNUstep backends. It
96 includes also files specific for all x11 graphic backends (xlib,
97 art, xdps).
98
99 %description devel -l pl
100 Ten pakiet zawiera pliki nag³ówkowe dla backendów GNUstep, w tym pliki
101 specyficzne dla wszystkich backendów graficznych dla x11 (xlib, art,
102 xdps).
103
104 %prep
105 %setup -q
106 %patch0 -p1
107 %patch1 -p1
108 %patch2 -p1
109
110 %build
111 . %{_prefix}/System/Makefiles/GNUstep.sh
112 for g in art xdps xlib ; do
113 if [ "$g" = "xlib" ]; then
114         INC='--with-include-flags=-I/usr/include/freetype2'
115         NAME="back"
116 else
117         INC=
118         NAME="back-$g"
119 fi
120 %configure \
121         --enable-graphics=$g \
122         --with-name=$NAME \
123         $INC
124
125 %{__make} \
126         messages=yes
127 cp -f back.make back-$g.make
128 done
129
130 %{__make} -C Documentation
131
132 %install
133 rm -rf $RPM_BUILD_ROOT
134 . %{_prefix}/System/Makefiles/GNUstep.sh
135
136 for g in art xdps xlib ; do
137 if [ "$g" = "xlib" ]; then
138         NAME="back"
139 else
140         NAME="back-$g"
141 fi
142 %{__make} install \
143         GNUSTEP_INSTALLATION_DIR=$RPM_BUILD_ROOT%{_prefix}/System \
144         BUILD_GRAPHICS="$g" \
145         BACKEND_NAME="$NAME"
146 done
147
148 %{__make} install -C Documentation \
149         GNUSTEP_INSTALLATION_DIR=$RPM_BUILD_ROOT%{_prefix}/System \
150 # not (yet?) supported by rpm-compress-doc
151 find $RPM_BUILD_ROOT%{_prefix}/System/Documentation -type f | xargs gzip -9nf
152
153 %clean
154 rm -rf $RPM_BUILD_ROOT
155
156 %post   -p /sbin/ldconfig
157 %postun -p /sbin/ldconfig
158
159 %files
160 %defattr(644,root,root,755)
161 %doc ChangeLog
162 %{_prefix}/System/Documentation/Developer/Back
163
164 %dir %{_prefix}/System/Library/Bundles/libgnustep-back.bundle
165 %{_prefix}/System/Library/Bundles/libgnustep-back.bundle/Resources
166 %attr(755,root,root) %{_prefix}/System/Library/Bundles/libgnustep-back.bundle/%{gscpu}
167
168 %attr(755,root,root) %{_prefix}/System/Tools/%{gscpu}/%{gsos}/%{libcombo}/*
169
170 %files art
171 %defattr(644,root,root,755)
172 %dir %{_prefix}/System/Library/Bundles/libgnustep-back-art.bundle
173 %{_prefix}/System/Library/Bundles/libgnustep-back-art.bundle/Resources
174 %attr(755,root,root) %{_prefix}/System/Library/Bundles/libgnustep-back-art.bundle/%{gscpu}
175
176 %files xdps
177 %defattr(644,root,root,755)
178 %dir %{_prefix}/System/Library/Bundles/libgnustep-back-xdps.bundle
179 %{_prefix}/System/Library/Bundles/libgnustep-back-xdps.bundle/Resources
180 %attr(755,root,root) %{_prefix}/System/Library/Bundles/libgnustep-back-xdps.bundle/%{gscpu}
181
182 %files devel
183 %defattr(644,root,root,755)
184 %{_prefix}/System/Headers/gnustep/gsc
185 %{_prefix}/System/Headers/gnustep/x11
186
187 %{_prefix}/System/Headers/gnustep/xlib
188 %{_prefix}/System/Headers/gnustep/art
189 %{_prefix}/System/Headers/gnustep/xdps
This page took 0.069146 seconds and 4 git commands to generate.