]> git.pld-linux.org Git - packages/gnustep-back.git/commitdiff
- new, based on gnustep-x[dg]ps.spec
authorJakub Bogusz <qboosh@pld-linux.org>
Sun, 29 Dec 2002 13:47:10 +0000 (13:47 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    gnustep-back-Xft2.patch -> 1.1
    gnustep-back-art-freetype213.patch -> 1.1
    gnustep-back-xdps-fix.patch -> 1.1
    gnustep-back.spec -> 1.1

gnustep-back-Xft2.patch [new file with mode: 0644]
gnustep-back-art-freetype213.patch [new file with mode: 0644]
gnustep-back-xdps-fix.patch [new file with mode: 0644]
gnustep-back.spec [new file with mode: 0644]

diff --git a/gnustep-back-Xft2.patch b/gnustep-back-Xft2.patch
new file mode 100644 (file)
index 0000000..66a0c10
--- /dev/null
@@ -0,0 +1,50 @@
+--- gnustep-back-0.8.3/Headers/xlib/XftFontInfo.h.orig Thu Mar 28 00:45:33 2002
++++ gnustep-back-0.8.3/Headers/xlib/XftFontInfo.h      Sun Dec 29 12:28:04 2002
+@@ -34,7 +34,7 @@
+ #include <AppKit/GSFontInfo.h>
+-@interface XftFontInfo : GSFontInfo
++@interface GSXftFontInfo : GSFontInfo
+ {
+   XftFont *font_info;
+ }
+--- gnustep-back-0.8.3/Source/xlib/XGContext.m.orig    Tue Jun  4 04:21:35 2002
++++ gnustep-back-0.8.3/Source/xlib/XGContext.m Sun Dec 29 12:30:06 2002
+@@ -78,7 +78,7 @@
+ #ifdef HAVE_XFT
+   if ([[NSUserDefaults standardUserDefaults] boolForKey: @"GSFontAntiAlias"])
+     {
+-      fontClass = [XftFontInfo class];
++      fontClass = [GSXftFontInfo class];
+     }
+ #endif
+   if (fontClass == Nil)
+--- gnustep-back-0.8.3/Source/xlib/XftFontInfo.m.orig  Tue Oct 22 05:47:15 2002
++++ gnustep-back-0.8.3/Source/xlib/XftFontInfo.m       Sun Dec 29 12:30:21 2002
+@@ -44,14 +44,14 @@
+  */
+ static NSMutableDictionary    *_globalFontDictionary = nil;
+-@interface XftFontInfo (Private)
++@interface GSXftFontInfo (Private)
+ - (BOOL) setupAttributes;
+ - (XGlyphInfo *)xGlyphInfo: (NSGlyph) glyph;
+ @end
+-@implementation XftFontInfo
++@implementation GSXftFontInfo
+ - initWithFontName: (NSString*)name matrix: (const float *)fmatrix
+ {
+@@ -305,7 +305,7 @@
+ @end
+-@implementation XftFontInfo (Private)
++@implementation GSXftFontInfo (Private)
+ - (BOOL) setupAttributes
+ {
diff --git a/gnustep-back-art-freetype213.patch b/gnustep-back-art-freetype213.patch
new file mode 100644 (file)
index 0000000..7380f93
--- /dev/null
@@ -0,0 +1,112 @@
+--- gnustep-back-0.8.3/Source/art/ftfont.m.orig        Sun Sep 29 12:25:42 2002
++++ gnustep-back-0.8.3/Source/art/ftfont.m     Sun Dec 29 13:49:33 2002
+@@ -76,9 +76,9 @@
+ @interface FTFontInfo : GSFontInfo <FTFontInfo>
+ {
+   const char *filename;
+-  FTC_ImageDesc imgd;
++  FTC_ImageTypeRec imgd;
+-  FTC_ImageDesc fallback;
++  FTC_ImageTypeRec fallback;
+   FTFaceInfo *face_info;
+ }
+@@ -707,7 +707,7 @@
+   int use_sbit;
+   FTC_SBit sbit;
+-  FTC_ImageDesc cur;
++  FTC_ImageTypeRec cur;
+   FT_Matrix ftmatrix;
+   FT_Vector ftdelta;
+@@ -756,23 +756,23 @@
+           int rh = face_info->render_hints_hack;
+           if (rh & 0x10000)
+             {
+-              cur.type = ftc_image_grays;
++              cur.flags = FT_LOAD_DEFAULT;
+               rh = (rh >> 8) & 0xff;
+             }
+           else
+             {
+-              cur.type = ftc_image_mono;
++              cur.flags = FT_LOAD_MONOCHROME;
+               rh = rh & 0xff;
+             }
+           if (rh & 1)
+-            cur.type |= ftc_image_flag_autohinted;
++            cur.flags |= FT_LOAD_FORCE_AUTOHINT;
+           if (!(rh & 2))
+-            cur.type |= ftc_image_flag_unhinted;
++            cur.flags |= FT_LOAD_NO_HINTING;
+         }
+       else if (xx < 8)
+-        cur.type = ftc_image_grays | ftc_image_flag_unhinted;
++        cur.flags = FT_LOAD_DEFAULT | FT_LOAD_NO_HINTING;
+       else
+-        cur.type = ftc_image_grays;
++        cur.flags = FT_LOAD_DEFAULT;
+       }
+     else
+       {
+@@ -1091,7 +1091,7 @@
+   FT_Glyph g;
+-  FTC_ImageDesc *cur;
++  FTC_ImageTypeRec *cur;
+   cmap.face_id = imgd.font.face_id;
+   cmap.u.encoding = ft_encoding_unicode;
+@@ -1122,7 +1122,7 @@
+ - (NSRect) boundingRectForGlyph: (NSGlyph)aGlyph
+ {
+   FTC_CMapDescRec cmap;
+-  FTC_ImageDesc *cur;
++  FTC_ImageTypeRec *cur;
+   unsigned int glyph;
+   FT_BBox bbox;
+@@ -1168,7 +1168,7 @@
+   FTC_SBit sbit;
+-  FTC_ImageDesc *cur;
++  FTC_ImageTypeRec *cur;
+   cmap.face_id = imgd.font.face_id;
+@@ -1381,7 +1381,7 @@
+   unichar *uch;
+   int ulen;
+-  FTC_ImageDesc cur;
++  FTC_ImageTypeRec cur;
+   FT_Matrix ftmatrix;
+@@ -1552,7 +1552,7 @@
+   int use_sbit;
+   FTC_SBit sbit;
+-  FTC_ImageDesc cur;
++  FTC_ImageTypeRec cur;
+   FT_Matrix ftmatrix;
+   FT_Vector ftdelta;
+@@ -1599,10 +1599,10 @@
+ /*    if (cur.font.pix_width < 16 && cur.font.pix_height < 16 &&
+           cur.font.pix_width > 6 && cur.font.pix_height > 6)
+-        cur.type = ftc_image_mono;
++        cur.flags = FT_LOAD_MONOCHROME;
+       else*/
+-        cur.type = ftc_image_grays, subpixel = YES, cur.font.pix_width *= 3, x *= 3;
+-//                    imgd.type|=|ftc_image_flag_unhinted; /* TODO? when? */
++        cur.flags = FT_LOAD_DEFAULT, subpixel = YES, cur.font.pix_width *= 3, x *= 3;
++//                    imgd.flags|=|FT_LOAD_NO_HINTING; /* TODO? when? */
+       }
+     else
+       {
diff --git a/gnustep-back-xdps-fix.patch b/gnustep-back-xdps-fix.patch
new file mode 100644 (file)
index 0000000..b2e0301
--- /dev/null
@@ -0,0 +1,11 @@
+--- gnustep-back-0.8.3/Source/xdps/GNUmakefile.orig    Thu Mar 28 00:45:31 2002
++++ gnustep-back-0.8.3/Source/xdps/GNUmakefile Sun Dec 29 14:06:48 2002
+@@ -32,6 +32,8 @@
+ GNUSTEP_LOCAL_ADDITIONAL_MAKEFILES=../../back.make
+ include $(GNUSTEP_MAKEFILES)/common.make
++include ../../config.make
++
+ SUBPROJECT_NAME=xdps
+ # The pswrap source files to be compiled
diff --git a/gnustep-back.spec b/gnustep-back.spec
new file mode 100644 (file)
index 0000000..d6491a3
--- /dev/null
@@ -0,0 +1,189 @@
+Summary:       The GNUstep backend bundle
+Summary(pl):   Pakiet backendowy GNUstep
+Name:          gnustep-back
+Version:       0.8.3
+Release:       1
+License:       LGPL/GPL
+Vendor:                The GNUstep Project
+Group:         X11/Libraries
+Source0:       ftp://ftp.gnustep.org/pub/gnustep/core/%{name}-%{version}.tar.gz
+Patch0:                %{name}-Xft2.patch
+Patch1:                %{name}-art-freetype213.patch
+Patch2:                %{name}-xdps-fix.patch
+URL:           http://www.gnustep.org/
+BuildRequires: OpenGL-devel
+BuildRequires: WindowMaker-devel
+BuildRequires: XFree86-devel
+BuildRequires: XFree86-DPS-devel
+BuildRequires: Xft-devel
+BuildRequires: freetype-devel >= 2.1.3
+BuildRequires: gnustep-gui-devel
+BuildRequires: libart_lgpl-devel
+Requires:      OpenGL
+Requires:      gnustep-gui
+Obsoletes:     gnustep-xgps
+Conflicts:     gnustep-core
+BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
+
+%define         _prefix         /usr/lib/GNUstep
+
+%define                libcombo        gnu-gnu-gnu
+%define                gsos            linux-gnu
+%ifarch %{ix86}
+%define                gscpu           ix86
+%else
+# also s/alpha.*/alpha/, but we use only "alpha" arch for now
+%define                gscpu           %{_target_cpu}
+%endif
+
+%description
+This is a backend for the GNUstep gui Library which allows you to use
+the GNUstep gui Library on an X Windows System (other backends will
+be added later to allow you to use the GNUstep gui Library in other
+windowing environments).
+
+This package contains common part and xlib graphics backend.
+
+%description -l pl
+To jest backend dla biblioteki GNUstep GUI, pozwalaj±cy na u¿ywanie
+biblioteki graficznego interfejsu u¿ytkownika GNUstep pod systemem X
+Window (inne backendy, pozwalaj±ce na u¿ywanie biblioteki GNUstep GUI
+w innych ¶rodowiskach okienkowych, zostan± dodane pó¼niej).
+
+Ten pakiet zawiera czê¶æ wspóln± i backend graficzny xlib.
+
+%package art
+Summary:       GNUstep graphics backend - art
+Summary(pl):   Graficzny backend GNUstep - art
+Group:         X11/Libraries
+Requires:      %{name} = %{version}
+Conflicts:     gnustep-core
+
+%description art
+GNUstep graphics backend - art.
+
+%description art -l pl
+Graficzny backend GNUstep - art.
+
+%package xdps
+Summary:       GNUstep graphics backend - xdps
+Summary(pl):   Graficzny backend GNUstep - xdps
+Group:         X11/Libraries
+Requires:      %{name} = %{version}
+Obsoletes:     gnustep-xdps
+Conflicts:     gnustep-core
+
+%description xdps
+GNUstep graphics backend - xdps.
+
+%description xdps -l pl
+Graficzny backend GNUstep - xdps.
+
+%package devel
+Summary:       Headers for GNUstep backends
+Summary(pl):   Pliki nag³ówkowe backendów GNUstep
+Group:         X11/Development/Libraries
+Requires:      %{name} = %{version}
+Requires:      XFree86-devel
+Requires:      Xft-devel
+Requires:      gnustep-gui-devel
+Obsoletes:     gnustep-xdps-devel
+Obsoletes:     gnustep-xgps-devel
+Conflicts:     gnustep-core
+
+%description devel
+This package contains development headers for GNUstep backends. It
+includes also files specific for all x11 graphic backends (xlib,
+art, xdps).
+
+%description devel -l pl
+Ten pakiet zawiera pliki nag³ówkowe dla backendów GNUstep, w tym pliki
+specyficzne dla wszystkich backendów graficznych dla x11 (xlib, art,
+xdps).
+
+%prep
+%setup -q
+%patch0 -p1
+%patch1 -p1
+%patch2 -p1
+
+%build
+. %{_prefix}/System/Makefiles/GNUstep.sh
+for g in art xdps xlib ; do
+if [ "$g" = "xlib" ]; then
+       INC='--with-include-flags=-I/usr/include/freetype2'
+       NAME="back"
+else
+       INC=
+       NAME="back-$g"
+fi
+%configure \
+       --enable-graphics=$g \
+       --with-name=$NAME \
+       $INC
+
+%{__make} \
+       messages=yes
+cp -f back.make back-$g.make
+done
+
+%{__make} -C Documentation
+
+%install
+rm -rf $RPM_BUILD_ROOT
+. %{_prefix}/System/Makefiles/GNUstep.sh
+
+for g in art xdps xlib ; do
+if [ "$g" = "xlib" ]; then
+       NAME="back"
+else
+       NAME="back-$g"
+fi
+%{__make} install \
+       GNUSTEP_INSTALLATION_DIR=$RPM_BUILD_ROOT%{_prefix}/System \
+       BUILD_GRAPHICS="$g" \
+       BACKEND_NAME="$NAME"
+done
+
+%{__make} install -C Documentation \
+       GNUSTEP_INSTALLATION_DIR=$RPM_BUILD_ROOT%{_prefix}/System \
+# not (yet?) supported by rpm-compress-doc
+find $RPM_BUILD_ROOT%{_prefix}/System/Documentation -type f | xargs gzip -9nf
+
+%clean
+rm -rf $RPM_BUILD_ROOT
+
+%post  -p /sbin/ldconfig
+%postun        -p /sbin/ldconfig
+
+%files
+%defattr(644,root,root,755)
+%doc ChangeLog
+%{_prefix}/System/Documentation/Developer/Back
+
+%dir %{_prefix}/System/Library/Bundles/libgnustep-back.bundle
+%{_prefix}/System/Library/Bundles/libgnustep-back.bundle/Resources
+%attr(755,root,root) %{_prefix}/System/Library/Bundles/libgnustep-back.bundle/%{gscpu}
+
+%attr(755,root,root) %{_prefix}/System/Tools/%{gscpu}/%{gsos}/%{libcombo}/*
+
+%files art
+%defattr(644,root,root,755)
+%dir %{_prefix}/System/Library/Bundles/libgnustep-back-art.bundle
+%{_prefix}/System/Library/Bundles/libgnustep-back-art.bundle/Resources
+%attr(755,root,root) %{_prefix}/System/Library/Bundles/libgnustep-back-art.bundle/%{gscpu}
+
+%files xdps
+%defattr(644,root,root,755)
+%dir %{_prefix}/System/Library/Bundles/libgnustep-back-xdps.bundle
+%{_prefix}/System/Library/Bundles/libgnustep-back-xdps.bundle/Resources
+%attr(755,root,root) %{_prefix}/System/Library/Bundles/libgnustep-back-xdps.bundle/%{gscpu}
+
+%files devel
+%defattr(644,root,root,755)
+%{_prefix}/System/Headers/gnustep/gsc
+%{_prefix}/System/Headers/gnustep/x11
+
+%{_prefix}/System/Headers/gnustep/xlib
+%{_prefix}/System/Headers/gnustep/art
+%{_prefix}/System/Headers/gnustep/xdps
This page took 0.061256 seconds and 4 git commands to generate.