]> git.pld-linux.org Git - packages/gnustep-back.git/blob - gnustep-back.spec
- updated to 0.8.5
[packages/gnustep-back.git] / gnustep-back.spec
1 Summary:        The GNUstep backend bundle
2 Summary(pl):    Pakiet backendowy GNUstep
3 Name:           gnustep-back
4 Version:        0.8.5
5 Release:        1
6 License:        LGPL/GPL
7 Vendor:         The GNUstep Project
8 Group:          X11/Libraries
9 Source0:        ftp://ftp.gnustep.org/pub/gnustep/core/%{name}-%{version}.tar.gz
10 Patch0:         %{name}-art-freetype213.patch
11 Patch1:         %{name}-xdps-fix.patch
12 URL:            http://www.gnustep.org/
13 BuildRequires:  OpenGL-devel
14 BuildRequires:  WindowMaker-devel
15 BuildRequires:  XFree86-devel
16 BuildRequires:  XFree86-DPS-devel
17 BuildRequires:  freetype-devel >= 2.1.3
18 BuildRequires:  gnustep-gui-devel
19 BuildRequires:  libart_lgpl-devel
20 BuildRequires:  xft-devel
21 Requires:       OpenGL
22 Requires:       gnustep-gui
23 Obsoletes:      gnustep-xgps
24 Conflicts:      gnustep-core
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %define         _prefix         /usr/lib/GNUstep
28
29 %define         _noautoreqdep   libGL.so.1 libGLU.so.1
30
31 %define         libcombo        gnu-gnu-gnu
32 %define         gsos            linux-gnu
33 %ifarch %{ix86}
34 %define         gscpu           ix86
35 %else
36 # also s/alpha.*/alpha/, but we use only "alpha" arch for now
37 %define         gscpu           %{_target_cpu}
38 %endif
39
40 %description
41 This is a backend for the GNUstep gui Library which allows you to use
42 the GNUstep gui Library on an X Windows System (other backends will
43 be added later to allow you to use the GNUstep gui Library in other
44 windowing environments).
45
46 This package contains common part and xlib graphics backend.
47
48 %description -l pl
49 To jest backend dla biblioteki GNUstep GUI, pozwalaj±cy na u¿ywanie
50 biblioteki graficznego interfejsu u¿ytkownika GNUstep pod systemem X
51 Window (inne backendy, pozwalaj±ce na u¿ywanie biblioteki GNUstep GUI
52 w innych ¶rodowiskach okienkowych, zostan± dodane pó¼niej).
53
54 Ten pakiet zawiera czê¶æ wspóln± i backend graficzny xlib.
55
56 %package art
57 Summary:        GNUstep graphics backend - art
58 Summary(pl):    Graficzny backend GNUstep - art
59 Group:          X11/Libraries
60 Requires:       %{name} = %{version}
61 Conflicts:      gnustep-core
62
63 %description art
64 GNUstep graphics backend - art.
65
66 %description art -l pl
67 Graficzny backend GNUstep - art.
68
69 %package xdps
70 Summary:        GNUstep graphics backend - xdps
71 Summary(pl):    Graficzny backend GNUstep - xdps
72 Group:          X11/Libraries
73 Requires:       %{name} = %{version}
74 Obsoletes:      gnustep-xdps
75 Conflicts:      gnustep-core
76
77 %description xdps
78 GNUstep graphics backend - xdps.
79
80 %description xdps -l pl
81 Graficzny backend GNUstep - xdps.
82
83 %package devel
84 Summary:        Headers for GNUstep backends
85 Summary(pl):    Pliki nag³ówkowe backendów GNUstep
86 Group:          X11/Development/Libraries
87 Requires:       %{name} = %{version}
88 Requires:       XFree86-devel
89 Requires:       gnustep-gui-devel
90 Requires:       xft-devel
91 Obsoletes:      gnustep-xdps-devel
92 Obsoletes:      gnustep-xgps-devel
93 Conflicts:      gnustep-core
94
95 %description devel
96 This package contains development headers for GNUstep backends. It
97 includes also files specific for all x11 graphic backends (xlib,
98 art, xdps).
99
100 %description devel -l pl
101 Ten pakiet zawiera pliki nag³ówkowe dla backendów GNUstep, w tym pliki
102 specyficzne dla wszystkich backendów graficznych dla x11 (xlib, art,
103 xdps).
104
105 %prep
106 %setup -q
107 %patch0 -p1
108 %patch1 -p1
109
110 %build
111 . %{_prefix}/System/Makefiles/GNUstep.sh
112 for g in art xdps xlib ; do
113 if [ "$g" = "xlib" ]; then
114         INC='--with-include-flags=-I/usr/include/freetype2'
115         NAME="back"
116 else
117         INC=
118         NAME="back-$g"
119 fi
120 %configure \
121         --enable-graphics=$g \
122         --with-name=$NAME \
123         $INC
124
125 %{__make} \
126         messages=yes
127 cp -f back.make back-$g.make
128 # preserve timestamp of config.h
129 cp -pf config.h config-$g.h
130 done
131
132 %{__make} -C Documentation
133
134 %install
135 rm -rf $RPM_BUILD_ROOT
136 . %{_prefix}/System/Makefiles/GNUstep.sh
137
138 for g in art xdps xlib ; do
139 if [ "$g" = "xlib" ]; then
140         NAME="back"
141 else
142         NAME="back-$g"
143 fi
144 # hack - restore timestamps to prevent rebuilding
145 cp -pf config-$g.h config.h
146 cp -pf config.h Source/%{gscpu}/%{gsos}/config.h
147 touch config.status -r config.h
148 %{__make} install \
149         GNUSTEP_INSTALLATION_DIR=$RPM_BUILD_ROOT%{_prefix}/System \
150         BUILD_GRAPHICS="$g" \
151         BACKEND_NAME="$NAME"
152 done
153
154 %{__make} install -C Documentation \
155         GNUSTEP_INSTALLATION_DIR=$RPM_BUILD_ROOT%{_prefix}/System \
156 # not (yet?) supported by rpm-compress-doc
157 find $RPM_BUILD_ROOT%{_prefix}/System/Documentation -type f | xargs gzip -9nf
158
159 %clean
160 rm -rf $RPM_BUILD_ROOT
161
162 %post   -p /sbin/ldconfig
163 %postun -p /sbin/ldconfig
164
165 %files
166 %defattr(644,root,root,755)
167 %doc ChangeLog
168 %{_prefix}/System/Documentation/Developer/Back
169
170 %dir %{_prefix}/System/Library/Bundles/libgnustep-back.bundle
171 %{_prefix}/System/Library/Bundles/libgnustep-back.bundle/Resources
172 %attr(755,root,root) %{_prefix}/System/Library/Bundles/libgnustep-back.bundle/%{gscpu}
173
174 %attr(755,root,root) %{_prefix}/System/Tools/%{gscpu}/%{gsos}/%{libcombo}/*
175
176 %files art
177 %defattr(644,root,root,755)
178 %dir %{_prefix}/System/Library/Bundles/libgnustep-back-art.bundle
179 %{_prefix}/System/Library/Bundles/libgnustep-back-art.bundle/Resources
180 %attr(755,root,root) %{_prefix}/System/Library/Bundles/libgnustep-back-art.bundle/%{gscpu}
181
182 %files xdps
183 %defattr(644,root,root,755)
184 %dir %{_prefix}/System/Library/Bundles/libgnustep-back-xdps.bundle
185 %{_prefix}/System/Library/Bundles/libgnustep-back-xdps.bundle/Resources
186 %attr(755,root,root) %{_prefix}/System/Library/Bundles/libgnustep-back-xdps.bundle/%{gscpu}
187
188 %files devel
189 %defattr(644,root,root,755)
190 %{_prefix}/System/Headers/gnustep/gsc
191 %{_prefix}/System/Headers/gnustep/x11
192
193 %{_prefix}/System/Headers/gnustep/xlib
194 %{_prefix}/System/Headers/gnustep/art
195 %{_prefix}/System/Headers/gnustep/xdps
This page took 0.037006 seconds and 4 git commands to generate.