]> git.pld-linux.org Git - packages/gnustep-back.git/commitdiff
- updated to 0.8.5
authorJakub Bogusz <qboosh@pld-linux.org>
Wed, 14 May 2003 20:39:27 +0000 (20:39 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
- removed obsolete Xft2 patch, updated art-freetype213 patch
- s/Xft-devel/xft-devel/
- added hack to avoid rebuilding on make install

Changed files:
    gnustep-back-Xft2.patch -> 1.2
    gnustep-back-art-freetype213.patch -> 1.2
    gnustep-back.spec -> 1.3

gnustep-back-Xft2.patch [deleted file]
gnustep-back-art-freetype213.patch
gnustep-back.spec

diff --git a/gnustep-back-Xft2.patch b/gnustep-back-Xft2.patch
deleted file mode 100644 (file)
index 66a0c10..0000000
+++ /dev/null
@@ -1,50 +0,0 @@
---- gnustep-back-0.8.3/Headers/xlib/XftFontInfo.h.orig Thu Mar 28 00:45:33 2002
-+++ gnustep-back-0.8.3/Headers/xlib/XftFontInfo.h      Sun Dec 29 12:28:04 2002
-@@ -34,7 +34,7 @@
- #include <AppKit/GSFontInfo.h>
--@interface XftFontInfo : GSFontInfo
-+@interface GSXftFontInfo : GSFontInfo
- {
-   XftFont *font_info;
- }
---- gnustep-back-0.8.3/Source/xlib/XGContext.m.orig    Tue Jun  4 04:21:35 2002
-+++ gnustep-back-0.8.3/Source/xlib/XGContext.m Sun Dec 29 12:30:06 2002
-@@ -78,7 +78,7 @@
- #ifdef HAVE_XFT
-   if ([[NSUserDefaults standardUserDefaults] boolForKey: @"GSFontAntiAlias"])
-     {
--      fontClass = [XftFontInfo class];
-+      fontClass = [GSXftFontInfo class];
-     }
- #endif
-   if (fontClass == Nil)
---- gnustep-back-0.8.3/Source/xlib/XftFontInfo.m.orig  Tue Oct 22 05:47:15 2002
-+++ gnustep-back-0.8.3/Source/xlib/XftFontInfo.m       Sun Dec 29 12:30:21 2002
-@@ -44,14 +44,14 @@
-  */
- static NSMutableDictionary    *_globalFontDictionary = nil;
--@interface XftFontInfo (Private)
-+@interface GSXftFontInfo (Private)
- - (BOOL) setupAttributes;
- - (XGlyphInfo *)xGlyphInfo: (NSGlyph) glyph;
- @end
--@implementation XftFontInfo
-+@implementation GSXftFontInfo
- - initWithFontName: (NSString*)name matrix: (const float *)fmatrix
- {
-@@ -305,7 +305,7 @@
- @end
--@implementation XftFontInfo (Private)
-+@implementation GSXftFontInfo (Private)
- - (BOOL) setupAttributes
- {
index 7380f93a66a54e2d222b60d8f9e6b7de32563fd5..d3cb96a7af64a52373faf331addd2943352fd296 100644 (file)
@@ -1,9 +1,9 @@
---- gnustep-back-0.8.3/Source/art/ftfont.m.orig        Sun Sep 29 12:25:42 2002
-+++ gnustep-back-0.8.3/Source/art/ftfont.m     Sun Dec 29 13:49:33 2002
-@@ -76,9 +76,9 @@
+--- gnustep-back-0.8.5/Source/art/ftfont.m.orig        2003-02-10 18:46:06.000000000 +0100
++++ gnustep-back-0.8.5/Source/art/ftfont.m     2003-05-14 21:46:52.000000000 +0200
+@@ -79,9 +79,9 @@
  @interface FTFontInfo : GSFontInfo <FTFontInfo>
  {
-   const char *filename;
+ @public
 -  FTC_ImageDesc imgd;
 +  FTC_ImageTypeRec imgd;
  
@@ -11,8 +11,8 @@
 +  FTC_ImageTypeRec fallback;
  
    FTFaceInfo *face_info;
- }
-@@ -707,7 +707,7 @@
+@@ -743,7 +743,7 @@
    int use_sbit;
  
    FTC_SBit sbit;
@@ -21,7 +21,7 @@
  
    FT_Matrix ftmatrix;
    FT_Vector ftdelta;
-@@ -756,23 +756,23 @@
+@@ -793,23 +793,23 @@
            int rh = face_info->render_hints_hack;
            if (rh & 0x10000)
              {
        }
      else
        {
-@@ -1091,7 +1091,7 @@
+@@ -1135,7 +1135,7 @@
+   int use_sbit;
  
-   FT_Glyph g;
+   FTC_SBit sbit;
+-  FTC_ImageDesc cur;
++  FTC_ImageTypeRec cur;
  
--  FTC_ImageDesc *cur;
-+  FTC_ImageTypeRec *cur;
+   FT_Matrix ftmatrix;
+   FT_Vector ftdelta;
+@@ -1185,23 +1185,23 @@
+           int rh = face_info->render_hints_hack;
+           if (rh & 0x10000)
+             {
+-              cur.type = ftc_image_grays;
++              cur.flags = FT_LOAD_DEFAULT;
+               rh = (rh >> 8) & 0xff;
+             }
+           else
+             {
+-              cur.type = ftc_image_mono;
++              cur.flags = FT_LOAD_MONOCHROME;
+               rh = rh & 0xff;
+             }
+           if (rh & 1)
+-            cur.type |= ftc_image_flag_autohinted;
++            cur.flags |= FT_LOAD_FORCE_AUTOHINT;
+           if (!(rh & 2))
+-            cur.type |= ftc_image_flag_unhinted;
++            cur.flags |= FT_LOAD_NO_HINTING;
+         }
+       else if (xx < 8)
+-        cur.type = ftc_image_grays | ftc_image_flag_unhinted;
++        cur.flags = FT_LOAD_DEFAULT | FT_LOAD_NO_HINTING;
+       else
+-        cur.type = ftc_image_grays;
++        cur.flags = FT_LOAD_DEFAULT;
+       }
+     else
+       {
+@@ -1466,7 +1466,7 @@
+       /* TODO: try to more efficiently? */
+       /* TODO: set up all this stuff in -init... for the raw metric case */
+       float xx, yy;
+-      FTC_ImageDesc cur;
++      FTC_ImageTypeRec cur;
+       FTC_SBit sbit;
+       cur = imgd;
+@@ -1479,23 +1479,23 @@
+           int rh = face_info->render_hints_hack;
+           if (rh & 0x10000)
+             {
+-              cur.type = ftc_image_grays;
++              cur.flags = FT_LOAD_DEFAULT;
+               rh = (rh >> 8) & 0xff;
+             }
+           else
+             {
+-              cur.type = ftc_image_mono;
++              cur.flags = FT_LOAD_MONOCHROME;
+               rh = rh & 0xff;
+             }
+           if (rh & 1)
+-            cur.type |= ftc_image_flag_autohinted;
++            cur.flags |= FT_LOAD_FORCE_AUTOHINT;
+           if (!(rh & 2))
+-            cur.type |= ftc_image_flag_unhinted;
++            cur.flags |= FT_LOAD_NO_HINTING;
+         }
+       else if (xx < 8)
+-        cur.type = ftc_image_grays | ftc_image_flag_unhinted;
++        cur.flags = FT_LOAD_DEFAULT | FT_LOAD_NO_HINTING;
+       else
+-        cur.type = ftc_image_grays;
++        cur.flags = FT_LOAD_DEFAULT;
  
-   cmap.face_id = imgd.font.face_id;
-   cmap.u.encoding = ft_encoding_unicode;
-@@ -1122,7 +1122,7 @@
- - (NSRect) boundingRectForGlyph: (NSGlyph)aGlyph
+       if (FTC_SBitCache_Lookup(ftc_sbitcache, &cur, glyph, &sbit, NULL))
+       return NSZeroSize;
+@@ -1547,7 +1547,7 @@
+ - (NSRect) boundingRectForGlyph: (NSGlyph)glyph
  {
-   FTC_CMapDescRec cmap;
 -  FTC_ImageDesc *cur;
 +  FTC_ImageTypeRec *cur;
-   unsigned int glyph;
    FT_BBox bbox;
+   FT_Glyph g;
  
-@@ -1168,7 +1168,7 @@
+@@ -1618,7 +1618,7 @@
  
    FTC_SBit sbit;
  
  
  
    cmap.face_id = imgd.font.face_id;
-@@ -1381,7 +1381,7 @@
+@@ -1831,7 +1831,7 @@
    unichar *uch;
    int ulen;
  
  
  
    FT_Matrix ftmatrix;
-@@ -1552,7 +1552,7 @@
+@@ -2003,7 +2003,7 @@
    int use_sbit;
  
    FTC_SBit sbit;
  
    FT_Matrix ftmatrix;
    FT_Vector ftdelta;
-@@ -1599,10 +1599,10 @@
+@@ -2050,10 +2050,10 @@
  
  /*    if (cur.font.pix_width < 16 && cur.font.pix_height < 16 &&
            cur.font.pix_width > 6 && cur.font.pix_height > 6)
index c5fb9dc9be48a85c764d3a8d23c4e01dccf6976d..9e595a080c593d82c5c55f2c9e23645105ba6def 100644 (file)
@@ -1,24 +1,23 @@
 Summary:       The GNUstep backend bundle
 Summary(pl):   Pakiet backendowy GNUstep
 Name:          gnustep-back
-Version:       0.8.3
+Version:       0.8.5
 Release:       1
 License:       LGPL/GPL
 Vendor:                The GNUstep Project
 Group:         X11/Libraries
 Source0:       ftp://ftp.gnustep.org/pub/gnustep/core/%{name}-%{version}.tar.gz
-Patch0:                %{name}-Xft2.patch
-Patch1:                %{name}-art-freetype213.patch
-Patch2:                %{name}-xdps-fix.patch
+Patch0:                %{name}-art-freetype213.patch
+Patch1:                %{name}-xdps-fix.patch
 URL:           http://www.gnustep.org/
 BuildRequires: OpenGL-devel
 BuildRequires: WindowMaker-devel
 BuildRequires: XFree86-devel
 BuildRequires: XFree86-DPS-devel
-BuildRequires: Xft-devel
 BuildRequires: freetype-devel >= 2.1.3
 BuildRequires: gnustep-gui-devel
 BuildRequires: libart_lgpl-devel
+BuildRequires: xft-devel
 Requires:      OpenGL
 Requires:      gnustep-gui
 Obsoletes:     gnustep-xgps
@@ -87,8 +86,8 @@ Summary(pl):  Pliki nag
 Group:         X11/Development/Libraries
 Requires:      %{name} = %{version}
 Requires:      XFree86-devel
-Requires:      Xft-devel
 Requires:      gnustep-gui-devel
+Requires:      xft-devel
 Obsoletes:     gnustep-xdps-devel
 Obsoletes:     gnustep-xgps-devel
 Conflicts:     gnustep-core
@@ -107,7 +106,6 @@ xdps).
 %setup -q
 %patch0 -p1
 %patch1 -p1
-%patch2 -p1
 
 %build
 . %{_prefix}/System/Makefiles/GNUstep.sh
@@ -127,6 +125,8 @@ fi
 %{__make} \
        messages=yes
 cp -f back.make back-$g.make
+# preserve timestamp of config.h
+cp -pf config.h config-$g.h
 done
 
 %{__make} -C Documentation
@@ -141,6 +141,10 @@ if [ "$g" = "xlib" ]; then
 else
        NAME="back-$g"
 fi
+# hack - restore timestamps to prevent rebuilding
+cp -pf config-$g.h config.h
+cp -pf config.h Source/%{gscpu}/%{gsos}/config.h
+touch config.status -r config.h
 %{__make} install \
        GNUSTEP_INSTALLATION_DIR=$RPM_BUILD_ROOT%{_prefix}/System \
        BUILD_GRAPHICS="$g" \
This page took 0.044157 seconds and 4 git commands to generate.