]> git.pld-linux.org Git - packages/gnome-shell.git/blob - gnome-shell.spec
- patch the extension delete as well
[packages/gnome-shell.git] / gnome-shell.spec
1 Summary:        Window manager and application launcher for GNOME
2 Name:           gnome-shell
3 Version:        3.2.1
4 Release:        4
5 License:        GPL v2+
6 Group:          X11/Window Managers
7 Source0:        http://ftp.gnome.org/pub/GNOME/sources/gnome-shell/3.2/%{name}-%{version}.tar.xz
8 # Source0-md5:  9519921d31d8c43d054dbc11e1f0733b
9 Patch0:         browser-plugin-webkit.patch
10 Patch1:         extension-delete.patch
11 URL:            http://live.gnome.org/GnomeShell
12 BuildRequires:  GConf2-devel
13 BuildRequires:  NetworkManager-devel >= 0.8.999
14 BuildRequires:  autoconf >= 2.63
15 BuildRequires:  automake >= 1:1.11
16 BuildRequires:  clutter-devel >= 1.7.5
17 BuildRequires:  dbus-glib-devel
18 BuildRequires:  evolution-data-server-devel >= 3.1.90
19 BuildRequires:  folks-devel >= 0.6.1
20 BuildRequires:  gettext-devel >= 0.17
21 BuildRequires:  gjs-devel >= 1.29.18
22 BuildRequires:  glib2-devel >= 1:2.29.10
23 BuildRequires:  gnome-bluetooth-devel >= 3.1.0
24 BuildRequires:  gnome-desktop-devel >= 3.1.90
25 BuildRequires:  gnome-menus-devel >= 3.1.90
26 BuildRequires:  gobject-introspection-devel >= 0.10.1
27 BuildRequires:  gsettings-desktop-schemas-devel >= 3.1.90
28 BuildRequires:  gstreamer-devel >= 0.10.21
29 BuildRequires:  gstreamer-plugins-base-devel >= 0.10.21
30 BuildRequires:  gtk+3-devel >= 3.0.0
31 BuildRequires:  intltool >= 0.40
32 BuildRequires:  json-glib-devel >= 0.13.90
33 BuildRequires:  libcanberra-devel
34 BuildRequires:  libcroco-devel >= 0.6.2
35 BuildRequires:  libgnome-keyring-devel
36 BuildRequires:  libsoup-devel
37 BuildRequires:  libtool >= 2:2.2.6
38 BuildRequires:  libxml2-devel
39 BuildRequires:  mutter-devel >= 3.2.1
40 BuildRequires:  pkgconfig >= 1:0.22
41 BuildRequires:  polkit-devel >= 0.100
42 BuildRequires:  pulseaudio-devel
43 BuildRequires:  rpm-pythonprov
44 BuildRequires:  rpmbuild(macros) >= 1.601
45 BuildRequires:  startup-notification-devel >= 0.11
46 BuildRequires:  tar >= 1:1.22
47 BuildRequires:  telepathy-glib-devel >= 0.15.5
48 BuildRequires:  telepathy-logger-devel >= 0.2.4
49 BuildRequires:  xorg-lib-libXfixes-devel
50 # for libmozjs.so
51 BuildRequires:  xulrunner-libs
52 BuildRequires:  xz
53 Requires(post,postun):  glib2 >= 1:2.26.0
54 Requires(post,preun):   GConf2
55 Requires:       caribou >= 0.3.5
56 Requires:       evolution-data-server >= 3.1.90
57 Requires:       gnome-bluetooth-libs >= 3.1.0
58 Requires:       gnome-menus >= 3.1.90
59 Requires:       gnome-settings-daemon >= 3.1.90
60 Requires:       gsettings-desktop-schemas >= 3.1.90
61 Requires:       mutter >= 3.2.1
62 Requires:       nautilus >= 3.2.0
63 Requires:       telepathy-logger >= 0.2.4
64 %requires_eq    xulrunner-libs
65 Suggests:       gnome-contacts >= 3.2.0
66 Suggests:       gnome-icon-theme-symbolic >= 3.0.0
67 Provides:       gdm-wm = 3.2.1-1
68 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
69
70 %description
71 GNOME Shell is the defining technology of the GNOME 3 desktop user
72 experience. It provides core interface functions like switching to
73 windows and launching applications. GNOME Shell takes advantage of the
74 capabilities of modern graphics hardware and introduces innovative
75 user interface concepts to provide a delightful and easy to use
76 experience.
77
78 %package -n browser-plugin-%{name}
79 Summary:        gnome-shell plugin for WWW browsers
80 Summary(pl.UTF-8):      Wtyczka gnome-shell do przeglÄ…darek WWW
81 Group:          X11/Libraries
82 Requires:       %{name} = %{version}-%{release}
83 Requires:       browser-plugins >= 2.0
84 Requires:       browser-plugins(%{_target_base_arch})
85 Provides:       mozilla-firefox-plugin-gnome-shell = %{version}-%{release}
86 Provides:       mozilla-plugin-gnome-shell = %{version}-%{release}
87 Obsoletes:      mozilla-firefox-plugin-gnome-shell < %{version}-%{release}
88 Obsoletes:      mozilla-plugin-gnome-shell < %{version}-%{release}
89
90 %description -n browser-plugin-%{name}
91 gnome-shell plugin for WWW browsers.
92
93 %description -n browser-plugin-%{name} -l pl.UTF-8
94 Wtyczka gnome-shell do przeglÄ…darek WWW.
95
96 %prep
97 %setup -q
98 %patch0 -p1
99 %patch1 -p1
100
101 %build
102 %{__intltoolize}
103 %{__libtoolize}
104 %{__aclocal} -I m4
105 %{__autoconf}
106 %{__autoheader}
107 %{__automake}
108 export LD_LIBRARY_PATH=%{_libdir}/xulrunner
109 %configure \
110         --with-ca-certificates=/etc/certs/ca-certificates.crt \
111         --disable-schemas-install \
112         --disable-silent-rules \
113         --disable-static
114 %{__make} -j1
115
116 %install
117 rm -rf $RPM_BUILD_ROOT
118 install -d $RPM_BUILD_ROOT%{_datadir}/gnome-shell/extensions
119
120 %{__make} install \
121         INSTALL="install -p" \
122         install_sh="install -p" \
123         DESTDIR=$RPM_BUILD_ROOT \
124         mozillalibdir=%{_browserpluginsdir}
125
126 # TODO use rpath at link time instead of this hack
127 mv $RPM_BUILD_ROOT%{_bindir}/gnome-shell{,.bin}
128 cat > $RPM_BUILD_ROOT%{_bindir}/gnome-shell <<'EOF'
129 #!/bin/sh
130 LD_LIBRARY_PATH=%{_libdir}/xulrunner
131 export LD_LIBRARY_PATH
132 exec %{_bindir}/gnome-shell.bin "$@"
133 EOF
134 chmod a+rx $RPM_BUILD_ROOT%{_bindir}/gnome-shell
135
136 %{__rm} $RPM_BUILD_ROOT%{_libdir}/gnome-shell/libgnome-shell.la \
137         $RPM_BUILD_ROOT%{_browserpluginsdir}/*.la
138
139 %find_lang %{name}
140
141 %clean
142 rm -rf $RPM_BUILD_ROOT
143
144 %post
145 %gconf_schema_install gnome-shell.schemas
146 %glib_compile_schemas
147
148 %preun
149 %gconf_schema_uninstall gnome-shell.schemas
150
151 %postun
152 if [ "$1" = "0" ]; then
153         %glib_compile_schemas
154 fi
155
156 %post -n browser-plugin-%{name}
157 %update_browser_plugins
158
159 %postun -n browser-plugin-%{name}
160 if [ "$1" = 0 ]; then
161         %update_browser_plugins
162 fi
163
164 %files -f %{name}.lang
165 %defattr(644,root,root,755)
166 %attr(755,root,root) %{_bindir}/gnome-shell
167 %attr(755,root,root) %{_bindir}/gnome-shell.bin
168 %attr(755,root,root) %{_bindir}/gnome-shell-extension-tool
169 %attr(755,root,root) %{_libexecdir}/gnome-shell-calendar-server
170 %attr(755,root,root) %{_libexecdir}/gnome-shell-hotplug-sniffer
171 %attr(755,root,root) %{_libexecdir}/gnome-shell-perf-helper
172 %{_sysconfdir}/gconf/schemas/gnome-shell.schemas
173 %dir %{_libdir}/gnome-shell
174 %attr(755,root,root) %{_libdir}/gnome-shell/libgnome-shell.so
175 %{_libdir}/gnome-shell/Gvc-1.0.typelib
176 %{_libdir}/gnome-shell/Shell-0.1.typelib
177 %{_libdir}/gnome-shell/St-1.0.typelib
178 %{_datadir}/dbus-1/services/org.gnome.Shell.CalendarServer.service
179 %{_datadir}/dbus-1/services/org.gnome.Shell.HotplugSniffer.service
180 %{_datadir}/glib-2.0/schemas/org.gnome.shell.gschema.xml
181 %{_datadir}/gnome-shell
182 %{_desktopdir}/gnome-shell.desktop
183 %{_mandir}/man1/gnome-shell.1*
184
185 %files -n browser-plugin-%{name}
186 %defattr(644,root,root,755)
187 %attr(755,root,root) %{_browserpluginsdir}/libgnome-shell-browser-plugin.so
This page took 0.065543 seconds and 4 git commands to generate.