]> git.pld-linux.org Git - packages/gnome-shell.git/commitdiff
- patch the extension delete as well auto/th/gnome-shell-3_2_1-4
authorElan Ruusamäe <glen@pld-linux.org>
Thu, 15 Dec 2011 16:43:35 +0000 (16:43 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    extension-delete.patch -> 1.1
    gnome-shell.spec -> 1.33

extension-delete.patch [new file with mode: 0644]
gnome-shell.spec

diff --git a/extension-delete.patch b/extension-delete.patch
new file mode 100644 (file)
index 0000000..faf81f2
--- /dev/null
@@ -0,0 +1,46 @@
+From ef49670ae491993cbfcfe666d389485c3a7c8adb Mon Sep 17 00:00:00 2001
+From: Jasper St. Pierre <jstpierre@mecheye.net>
+Date: Thu, 01 Dec 2011 02:46:52 +0000
+Subject: fileUtils: Fix recursivelyDeleteDir
+
+---
+diff --git a/js/misc/fileUtils.js b/js/misc/fileUtils.js
+index cd7339c..7466be8 100644
+--- a/js/misc/fileUtils.js
++++ b/js/misc/fileUtils.js
+@@ -38,7 +38,7 @@ function recursivelyDeleteDir(dir) {
+         let child = dir.get_child(info.get_name());
+         if (type == Gio.FileType.REGULAR)
+             deleteGFile(child);
+-        else if (type == Gio.TypeType.DIRECTORY)
++        else if (type == Gio.FileType.DIRECTORY)
+             recursivelyDeleteDir(child);
+     }
+--
+cgit v0.9.0.2
+From bbb83656bf83c9740fe68db7e35e05ea4f129b01 Mon Sep 17 00:00:00 2001
+From: Jasper St. Pierre <jstpierre@mecheye.net>
+Date: Thu, 01 Dec 2011 03:02:09 +0000
+Subject: extensionSystem: Set the proper 'enabled' and 'type' parameters
+
+When installing an extension at runtime, we accidentally swapped the 'type'
+and 'enabled' parameters. While this doesn't directly affect anything right
+now, as everything works coincidentally, future patches that look at the
+'type' parameter to decide what to do would get the wrong answer.
+---
+diff --git a/js/ui/extensionSystem.js b/js/ui/extensionSystem.js
+index a0302fe..9aadb3a 100644
+--- a/js/ui/extensionSystem.js
++++ b/js/ui/extensionSystem.js
+@@ -202,7 +202,7 @@ function gotExtensionZipFile(session, message, uuid) {
+             global.settings.set_strv(ENABLED_EXTENSIONS_KEY, enabledExtensions);
+         }
+-        loadExtension(dir, true, ExtensionType.PER_USER);
++        loadExtension(dir, ExtensionType.PER_USER, true);
+     });
+ }
+--
+cgit v0.9.0.2
index 19ca23e1ec13a9b6033b9a9dbddd311941c5f194..4972da519d2db185745885837e9b84c44841b8ae 100644 (file)
@@ -7,6 +7,7 @@ Group:          X11/Window Managers
 Source0:       http://ftp.gnome.org/pub/GNOME/sources/gnome-shell/3.2/%{name}-%{version}.tar.xz
 # Source0-md5: 9519921d31d8c43d054dbc11e1f0733b
 Patch0:                browser-plugin-webkit.patch
+Patch1:                extension-delete.patch
 URL:           http://live.gnome.org/GnomeShell
 BuildRequires: GConf2-devel
 BuildRequires: NetworkManager-devel >= 0.8.999
@@ -95,6 +96,7 @@ Wtyczka gnome-shell do przeglądarek WWW.
 %prep
 %setup -q
 %patch0 -p1
+%patch1 -p1
 
 %build
 %{__intltoolize}
This page took 0.048388 seconds and 4 git commands to generate.