]> git.pld-linux.org Git - packages/gdb.git/blob - gdb.spec
- up to 9.1
[packages/gdb.git] / gdb.spec
1 # NOTE: -lib package is used by fpc.spec
2
3 # TODO
4 # - rpm5 librpm support (gdb/configure.ac checks for 4.x or so)
5 # - change install msg to poldek in buildid-locate-rpm-pld.patch when poldek allows it. LP#493922
6 # - reenable guile after https://sourceware.org/bugzilla/show_bug.cgi?id=21104 is fixed
7 #
8 # Conditional build:
9 %bcond_with     guile           # Guile embedded scripting
10 %bcond_without  python          # build without python support
11
12 Summary:        A GNU source-level debugger for C, C++ and Fortran
13 Summary(de.UTF-8):      Symbolischer Debugger für C und andere Sprachen
14 Summary(es.UTF-8):      Depurador de programas C y otras lenguajes
15 Summary(fr.UTF-8):      Débugger symbolique pour C et d'autres langages
16 Summary(pl.UTF-8):      Symboliczny odpluskwiacz dla C i innych języków
17 Summary(pt_BR.UTF-8):   Depurador de programas C e outras linguagens
18 Summary(ru.UTF-8):      Символический отладчик для C и других языков
19 Summary(tr.UTF-8):      C ve diğer diller için sembolik hata ayıklayıcı
20 Summary(uk.UTF-8):      Символьний відладчик для С та інших мов
21 Summary(zh_CN.UTF-8):   [开发]C和其他语言的调试器
22 Summary(zh_TW.UTF-8):   [.-A開發]C和.$)B其.-A他語.$)B言的調試器
23 Name:           gdb
24 Version:        9.1
25 Release:        1
26 License:        GPL v3+
27 Group:          Development/Debuggers
28 Source0:        http://ftp.gnu.org/gnu/gdb/%{name}-%{version}.tar.xz
29 # Source0-md5:  f7e9f6236c425097d9e5f18a6ac40655
30 Source1:        http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-non-english-man-pages.tar.bz2
31 # Source1-md5:  2e8a48939ae282c12bbacdd54e398247
32 Source3:        %{name}-gstack.man
33 Patch100:       gdb-6.6-buildid-locate.patch
34 Patch101:       gdb-6.6-buildid-locate-solib-missing-ids.patch
35 Patch102:       gdb-6.6-buildid-locate-rpm.patch
36 Patch103:       gdb-6.6-buildid-locate-core-as-arg.patch
37 Patch104:       gdb-6.6-buildid-locate-rpm-librpm-workaround.patch
38 Patch105:       gdb-6.6-buildid-locate-misleading-warning-missing-debuginfo-rhbz981154.patch
39 Patch106:       gdb-6.6-buildid-locate-rpm-scl.patch
40 Patch110:       gdb-6.3-gstack-20050411.patch
41
42 Patch112:       gdb-archer-vla-tests.patch
43 Patch113:       gdb-vla-intel-fortran-strides.patch
44 Patch114:       gdb-vla-intel-stringbt-fix.patch
45 Patch115:       gdb-vla-intel-fortran-vla-strings.patch
46 Patch116:       gdb-vla-intel-tests.patch
47 Patch1000:      %{name}-readline.patch
48 Patch1001:      %{name}-info.patch
49 Patch1002:      %{name}-passflags.patch
50 Patch1005:      %{name}-pretty-print-by-default.patch
51 Patch1006:      buildid-locate-rpm-pld.patch
52 URL:            http://www.gnu.org/software/gdb/
53 BuildRequires:  autoconf >= 2.69
54 BuildRequires:  automake
55 BuildRequires:  bison
56 BuildRequires:  babeltrace-devel >= 1.1.0
57 BuildRequires:  expat-devel
58 BuildRequires:  flex >= 2.6.4
59 BuildRequires:  gettext-tools >= 0.12.1
60 %{?with_guile:BuildRequires:    guile-devel >= 2.0}
61 %ifarch %{ix86} %{x8664}
62 BuildRequires:  libipt-devel
63 %endif
64 BuildRequires:  libselinux-devel
65 BuildRequires:  libstdc++-devel >= 6:4.8
66 BuildRequires:  libtool
67 BuildRequires:  make >= 3.81
68 BuildRequires:  mpfr-devel
69 BuildRequires:  ncurses-devel >= 5.2
70 BuildRequires:  pkgconfig
71 BuildRequires:  readline-devel
72 BuildRequires:  rpmbuild(macros) >= 1.219
73 BuildRequires:  tar >= 1:1.22
74 BuildRequires:  texinfo >= 4.4
75 BuildRequires:  xz
76 BuildRequires:  xz-devel
77 BuildRequires:  zlib-devel
78 %if %{with python}
79 BuildRequires:  python-devel
80 BuildRequires:  rpm-pythonprov
81 Obsoletes:      python-gdb
82 # for traceback module
83 Requires:       python-modules
84 %endif
85 %{?with_guile:Requires: guile >= 2.0.12}
86 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
87
88 %description
89 Gdb is a full featured, command driven debugger. Gdb allows you to
90 trace the execution of programs and examine their internal state at
91 any time. Gdb works for C and C++ compiled with the GNU C compiler
92 gcc.
93
94 %description -l de.UTF-8
95 dem Sie die Ausführung von Programmen verfolgen und jederzeit den
96 inneren Zustand überprüfen können. Er funktioniert für C und mit GNU C
97 kompiliertes C++.
98
99 %description -l es.UTF-8
100 Este es un debugger orientado a comandos repleto de características.
101 Te permite rastrear la ejecución de programas y examinar su estado
102 interno a cualquier momento. Funciona para C y C++ compilado con el
103 compilador GNU C.
104
105 %description -l fr.UTF-8
106 Débugger complet, piloté par commandes. Permet de tracer l'exécution
107 des programmes et d'examiner à tout moment leur état interne.
108 Fonctionne avec les binaires C et C++ compilés avec le compilateur C
109 de GNU, gcc.
110
111 %description -l pl.UTF-8
112 Gdb jest rozbudowanym odpluskwiaczem (debuggerem), pozwalającym
113 śledzić wykonywanie programu i badać jego stan wewnętrzny. Gdb
114 umożliwia odpluskwianie programów napisanych w C/C++ i skompilowanych
115 przy pomocy kompilatora GNU (gcc).
116
117 %description -l pt_BR.UTF-8
118 Este é um debugger orientado a comandos repleto de características.
119 Ele permite à você rastrear a execução de programas e examinar o seu
120 estado interno a qualquer momento. Ele funciona para para C e C++
121 compilado com o compilador GNU C.
122
123 %description -l ru.UTF-8
124 Это полноценный отладчик, управляемый командами. Он позволяет
125 трассировать исполнение программ и изучать их внутреннее состояние в
126 любой момент времени. Работает с программами на C и C++,
127 скомпилированными GNU компилятором C (gcc, egcs, pgcc).
128
129 %description -l tr.UTF-8
130 Bir komut arayüzü üzerinden programcıya programını adım adım izleme
131 (trace) ve herhangi bir anda programın durumunu inceleme olanağı
132 verir.
133
134 %description -l uk.UTF-8
135 Це повноцінний відладчик, що керується командами. Він дозволяє
136 трасувати виконання програм та вивчати їх внутрішній стан в довільний
137 момент часу. Працює з програмами на C та C++, зкомпільованими
138 компіляторами GNU C (gcc, egcs, pgcc).
139
140 %package gdbserver
141 Summary:        A standalone server for GDB (the GNU source-level debugger)
142 Summary(pl.UTF-8):      Samodzielny serwer GDB (debuggera GNU)
143 Group:          Development/Debuggers
144
145 %description gdbserver
146 GDB, the GNU debugger, allows you to debug programs written in C, C++,
147 Java, and other languages, by executing them in a controlled fashion
148 and printing their data.
149
150 This package provides a program that allows you to run GDB on a
151 different machine than the one which is running the program being
152 debugged.
153
154 %description gdbserver -l pl.UTF-8
155 GDB (GNU debugger) pozwala śledzić programy napisane w C, C++, Javie i
156 innych językach programowania poprzez wykonywanie ich w sposób
157 kontrolowany oraz wypisywanie ich danych.
158
159 Ten pakiet zawiera program pozwalający uruchamiać GDB na innej
160 maszynie niż ta, na której działa śledzony program.
161
162 %package lib
163 Summary:        GDB in the form of a static library
164 Summary(pl.UTF-8):      GDB w postaci biblioteki statycznej
165 Group:          Development/Debuggers
166 # libraries that needs to be linked to fulfill libgdb.a symbol requirements
167 Requires:       binutils-devel >= 2.17.50
168 Requires:       expat-devel
169 Requires:       libselinux-devel
170 Requires:       libsepol-devel
171 Requires:       ncurses-devel
172 Requires:       python-devel
173 Requires:       readline-devel
174 Requires:       xz-devel
175 Requires:       zlib-devel
176
177 %description lib
178 GDB in the form of a static library.
179
180 %description lib -l pl.UTF-8
181 GDB w postaci biblioteki statycznej.
182
183 %prep
184 %setup -q
185
186 # Files have `# <number> <file>' statements breaking VPATH / find-debuginfo.sh .
187 %{__rm} gdb/ada-exp.c gdb/ada-lex.c gdb/c-exp.c gdb/cp-name-parser.c gdb/f-exp.c
188 %{__rm} gdb/m2-exp.c gdb/p-exp.c
189
190 %patch100 -p1
191 %patch101 -p1
192 %patch102 -p1
193 %patch103 -p1
194 %patch104 -p1
195 %patch105 -p1
196 %patch106 -p1
197 %patch110 -p1
198
199 %patch112 -p1
200 %patch113 -p1
201 %patch114 -p1
202 %patch115 -p1
203 %patch116 -p1
204
205 %patch1000 -p1
206 %patch1001 -p1
207 %patch1002 -p1
208 %patch1005 -p1
209 %patch1006 -p1
210
211 # Change the version that gets printed at GDB startup, so it is PLD Linux specific.
212 cat > gdb/version.in << EOF
213 %{version}-%{release} (PLD Linux)
214 EOF
215
216 sed -E -i -e '1s,#!\s*/usr/bin/env\s+python2(\s|$),#!%{__python}\1,' -e '1s,#!\s*/usr/bin/env\s+python(\s|$),#!%{__python}\1,' -e '1s,#!\s*/usr/bin/python(\s|$),#!%{__python}\1,' \
217       contrib/dg-extract-results.py \
218       gdb/contrib/test_pubnames_and_indexes.py \
219       gdb/testsuite/analyze-racy-logs.py \
220       gdb/testsuite/print-ts.py
221
222 sed -E -i -e '1s,#!\s*/usr/bin/env\s+python3(\s|$),#!%{__python3}\1,' \
223       gdb/copyright.py
224
225 sed -E -i -e '1s,#!\s*/usr/bin/env\s+(.*),#!%{__bindir}\1,' \
226       gdb/contrib/cc-with-tweaks.sh \
227       gdb/gcore \
228       gdb/gcore.in \
229       src-release.sh
230
231 %build
232 # omit hand-written gdb/testsuite aclocal.m4
233 for dir in gdb gdb/gdbserver ; do
234         olddir=$(pwd)
235         cd $dir
236         %{__rm} aclocal.m4
237         %{__aclocal} $(grep '^ACLOCAL_AMFLAGS' Makefile.in | sed -e 's/.*=//')
238         cd $olddir
239 done
240 for dir in $(find gdb -name 'configure.in' -o -name 'configure.ac'); do
241         dir=$(dirname "$dir")
242         olddir=$(pwd)
243         cd $dir
244         %{__autoconf}
245         grep -q AC_CONFIG_HEADER configure.* && %{__autoheader}
246         cd $olddir
247 done
248 cp -f /usr/share/automake/config.* .
249 install -d build && cd build
250 # don't --enable-shared here, there would be libs version mismatch with binutils
251 ../%configure \
252         --disable-gdbtk \
253         --disable-shared \
254         --disable-silent-rules \
255         --enable-gdbcli \
256         --enable-gdbmi \
257         --enable-multi-ice \
258         --enable-netrom \
259         --enable-nls \
260         --enable-tui \
261         --with-cpu=%{_target_cpu} \
262         --with-gdb-datadir=%{_datadir}/gdb \
263         --with-guile%{!?with_guile:=no} \
264 %ifnarch alpha
265         --with-mmalloc \
266 %endif
267 %if %{with python}
268         --with-python \
269         --with-pythondir=%{py_sitescriptdir} \
270 %else
271         --without-python \
272 %endif
273         --with-separate-debug-dir=/usr/lib/debug \
274         --with-system-readline \
275         --without-included-gettext \
276         --without-included-regex \
277         --without-x
278
279 # V=1 because only some subdirs honour --enable-silent-rules
280 %{__make} \
281         V=1
282
283 %{__make} -j1 info
284
285 # gdb/ChangeLog: Build gdb directly from *.o files not using libgdb.a.
286 %{__make} -C gdb libgdb.a \
287         V=1
288
289 %install
290 rm -rf $RPM_BUILD_ROOT
291 install -d $RPM_BUILD_ROOT%{_infodir}
292
293 %{__make} -C build -j1 install install-info \
294         DESTDIR=$RPM_BUILD_ROOT
295
296 cp -a build/gdb/libgdb.a $RPM_BUILD_ROOT%{_libdir}
297
298 # gdbtui seems all identical to gdb except when invoked as gdbtui, ncurses
299 # window is created too.
300 echo ".so gdb.1" > $RPM_BUILD_ROOT%{_mandir}/man1/gdbtui.1
301 ln -f $RPM_BUILD_ROOT%{_bindir}/{gdb,gdbtui}
302
303 bzip2 -dc %{SOURCE1} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
304 %{__rm} $RPM_BUILD_ROOT%{_mandir}/README.gdb-non-english-man-pages
305
306 rm -f $RPM_BUILD_ROOT%{_infodir}/dir
307
308 %if %{with python}
309 # Temporarily now:
310 for LIB in lib lib64 libx32; do
311         LIBPATH="$RPM_BUILD_ROOT%{_datadir}/gdb/auto-load%{_prefix}/$LIB"
312         install -d $LIBPATH
313 done
314
315 %py_ocomp $RPM_BUILD_ROOT%{py_sitescriptdir}
316 %py_comp $RPM_BUILD_ROOT%{py_sitescriptdir}
317 %py_postclean
318 %endif
319
320 cp -a %{SOURCE3} $RPM_BUILD_ROOT%{_mandir}/man1/gstack.1
321
322 cp -p build/libdecnumber/libdecnumber.a $RPM_BUILD_ROOT%{_libdir}
323
324 # Remove the files that are part of a gdb build but that are owned and provided by other packages.
325 # These are part of binutils:
326 %{__rm} $RPM_BUILD_ROOT%{_localedir}/*/LC_MESSAGES/{bfd,opcodes}.mo
327 %{__rm} $RPM_BUILD_ROOT%{_infodir}/bfd.info*
328 %{__rm} $RPM_BUILD_ROOT%{_includedir}/{ansidecl,bfd,bfd_stdint,bfdlink,diagnostics,dis-asm,symcat,plugin-api}.h
329 %{__rm} $RPM_BUILD_ROOT%{_libdir}/lib{bfd,opcodes}.la
330 %{__rm} $RPM_BUILD_ROOT%{_libdir}/lib{bfd,opcodes}.a
331
332 %clean
333 rm -rf $RPM_BUILD_ROOT
334
335 %post   -p /sbin/postshell
336 -/usr/sbin/fix-info-dir -c %{_infodir}
337
338 %postun -p /sbin/postshell
339 -/usr/sbin/fix-info-dir -c %{_infodir}
340
341 %files
342 %defattr(644,root,root,755)
343 %doc gdb/{ChangeLog,NEWS,PROBLEMS,README}
344 %attr(755,root,root) %{_bindir}/gdb
345 %attr(755,root,root) %{_bindir}/gdbtui
346 %attr(755,root,root) %{_bindir}/gdb-add-index
347 %attr(755,root,root) %{_bindir}/gstack
348 %attr(755,root,root) %{_bindir}/gcore
349 %dir %{_datadir}/gdb
350 %dir %{_datadir}/gdb/auto-load
351 %dir %{_datadir}/gdb/auto-load%{_prefix}
352 %dir %{_datadir}/gdb/auto-load%{_prefix}/lib
353 %ifarch %{x8664} x32
354 %dir %{_datadir}/gdb/auto-load%{_prefix}/lib64
355 %dir %{_datadir}/gdb/auto-load%{_prefix}/libx32
356 %endif
357 %{?with_guile:%{_datadir}/gdb/guile}
358 %{_datadir}/gdb/syscalls
359 %{_datadir}/gdb/system-gdbinit
360 %{_datadir}/gdb/python
361 %{_mandir}/man1/gdb.1*
362 %{_mandir}/man1/gdbtui.1*
363 %{_mandir}/man1/gdb-add-index.1*
364 %{_mandir}/man1/gstack.1*
365 %{_mandir}/man1/gcore.1*
366 %{_mandir}/man5/gdbinit.5*
367 %lang(es) %{_mandir}/es/man1/*
368 %lang(fr) %{_mandir}/fr/man1/*
369 %lang(hu) %{_mandir}/hu/man1/*
370 %lang(ja) %{_mandir}/ja/man1/*
371 %lang(pl) %{_mandir}/pl/man1/*
372 %{_infodir}/annotate.info*
373 %{_infodir}/gdb.info*
374 %{_infodir}/stabs.info*
375
376 %files gdbserver
377 %defattr(644,root,root,755)
378 %attr(755,root,root) %{_bindir}/gdbserver
379 %{_mandir}/man1/gdbserver.1*
380 %attr(755,root,root) %{_libdir}/libinproctrace.so
381
382 %files lib
383 %defattr(644,root,root,755)
384 %{_libdir}/libdecnumber.a
385 %{_libdir}/libgdb.a
386 %{_includedir}/gdb
This page took 0.583544 seconds and 4 git commands to generate.