]> git.pld-linux.org Git - packages/gdb.git/blob - gdb.spec
- updated to 14.1 + rebased Fedora buildid patches set
[packages/gdb.git] / gdb.spec
1 # NOTE: -lib package is used by fpc.spec
2
3 # TODO
4 # - debuginfod (BR: elfutils-debuginfod-devel >= 0.179)
5 # - amd-dbgapi (BR: pkgconfig(amd-dbgapi) >= 0.68.0) <https://github.com/ROCm/ROCdbgapi>
6 # - change install msg to poldek in buildid-locate-rpm-pld.patch when poldek allows it. LP#493922
7 #
8 # Conditional build:
9 %bcond_without  guile           # Guile embedded scripting
10 %bcond_without  python          # build without python support
11
12 Summary:        A GNU source-level debugger for C, C++ and Fortran
13 Summary(de.UTF-8):      Symbolischer Debugger für C und andere Sprachen
14 Summary(es.UTF-8):      Depurador de programas C y otras lenguajes
15 Summary(fr.UTF-8):      Débugger symbolique pour C et d'autres langages
16 Summary(pl.UTF-8):      Symboliczny odpluskwiacz dla C i innych języków
17 Summary(pt_BR.UTF-8):   Depurador de programas C e outras linguagens
18 Summary(ru.UTF-8):      Символический отладчик для C и других языков
19 Summary(tr.UTF-8):      C ve diğer diller için sembolik hata ayıklayıcı
20 Summary(uk.UTF-8):      Символьний відладчик для С та інших мов
21 Summary(zh_CN.UTF-8):   [开发]C和其他语言的调试器
22 Summary(zh_TW.UTF-8):   [.-A開發]C和.$)B其.-A他語.$)B言的調試器
23 Name:           gdb
24 Version:        14.1
25 Release:        1
26 License:        GPL v3+
27 Group:          Development/Debuggers
28 Source0:        https://ftp.gnu.org/gnu/gdb/%{name}-%{version}.tar.xz
29 # Source0-md5:  4a084d03915b271f67e9b8ea2ab24972
30 Source1:        http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-non-english-man-pages.tar.bz2
31 # Source1-md5:  2e8a48939ae282c12bbacdd54e398247
32 Source3:        %{name}-gstack.man
33 Patch100:       gdb-6.6-buildid-locate.patch
34 Patch101:       gdb-6.6-buildid-locate-solib-missing-ids.patch
35 Patch102:       gdb-6.6-buildid-locate-rpm.patch
36 Patch104:       gdb-6.6-buildid-locate-rpm-librpm-workaround.patch
37 Patch105:       gdb-6.6-buildid-locate-misleading-warning-missing-debuginfo-rhbz981154.patch
38 Patch110:       gdb-6.3-gstack-20050411.patch
39 Patch1000:      %{name}-readline.patch
40 Patch1001:      %{name}-info.patch
41 Patch1002:      %{name}-passflags.patch
42 Patch1005:      %{name}-pretty-print-by-default.patch
43 Patch1006:      buildid-locate-rpm-pld.patch
44 URL:            http://www.gnu.org/software/gdb/
45 BuildRequires:  autoconf >= 2.69
46 BuildRequires:  automake
47 BuildRequires:  babeltrace-devel >= 1.1.0
48 BuildRequires:  bison
49 BuildRequires:  expat-devel
50 BuildRequires:  flex >= 2.6.4
51 BuildRequires:  gettext-tools >= 0.12.1
52 BuildRequires:  gmp-devel >= 4.3.2
53 %if %{with guile}
54 BuildRequires:  guile-devel >= 5:2.0
55 BuildRequires:  guile-devel < 5:3.2
56 %endif
57 %ifarch %{ix86} %{x8664}
58 BuildRequires:  libipt-devel
59 %endif
60 BuildRequires:  libmpc-devel >= 0.8.1
61 BuildRequires:  libselinux-devel
62 BuildRequires:  libstdc++-devel >= 6:4.8
63 BuildRequires:  libtool >= 2:2
64 BuildRequires:  make >= 3.81
65 BuildRequires:  mpfr-devel >= 3.1.6
66 BuildRequires:  ncurses-devel >= 5.2
67 BuildRequires:  pkgconfig
68 BuildRequires:  readline-devel
69 BuildRequires:  rpm-devel >= 1:4.6
70 BuildRequires:  rpmbuild(macros) >= 1.219
71 BuildRequires:  source-highlight-devel >= 3.0
72 BuildRequires:  tar >= 1:1.22
73 BuildRequires:  texinfo >= 4.4
74 BuildRequires:  xxHash-devel
75 BuildRequires:  xz
76 BuildRequires:  xz-devel
77 BuildRequires:  zlib-devel
78 %if %{with python}
79 BuildRequires:  python3-devel >= 1:3.2
80 BuildRequires:  rpm-pythonprov
81 Obsoletes:      python-gdb < 7.3
82 # for traceback module
83 Requires:       python3-modules >= 1:3.2
84 %endif
85 %{?with_guile:Requires: guile >= 2.0.12}
86 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
87
88 %define         autoconf_ver    %(rpm -q --qf='%%{VERSION}' autoconf)
89
90 %define         _noautostrip    .*%{_datadir}/gdb/guile/.*\.go
91
92 %description
93 Gdb is a full featured, command driven debugger. Gdb allows you to
94 trace the execution of programs and examine their internal state at
95 any time. Gdb works for C and C++ compiled with the GNU C compiler
96 gcc.
97
98 %description -l de.UTF-8
99 dem Sie die Ausführung von Programmen verfolgen und jederzeit den
100 inneren Zustand überprüfen können. Er funktioniert für C und mit GNU C
101 kompiliertes C++.
102
103 %description -l es.UTF-8
104 Este es un debugger orientado a comandos repleto de características.
105 Te permite rastrear la ejecución de programas y examinar su estado
106 interno a cualquier momento. Funciona para C y C++ compilado con el
107 compilador GNU C.
108
109 %description -l fr.UTF-8
110 Débugger complet, piloté par commandes. Permet de tracer l'exécution
111 des programmes et d'examiner à tout moment leur état interne.
112 Fonctionne avec les binaires C et C++ compilés avec le compilateur C
113 de GNU, gcc.
114
115 %description -l pl.UTF-8
116 Gdb jest rozbudowanym odpluskwiaczem (debuggerem), pozwalającym
117 śledzić wykonywanie programu i badać jego stan wewnętrzny. Gdb
118 umożliwia odpluskwianie programów napisanych w C/C++ i skompilowanych
119 przy pomocy kompilatora GNU (gcc).
120
121 %description -l pt_BR.UTF-8
122 Este é um debugger orientado a comandos repleto de características.
123 Ele permite à você rastrear a execução de programas e examinar o seu
124 estado interno a qualquer momento. Ele funciona para para C e C++
125 compilado com o compilador GNU C.
126
127 %description -l ru.UTF-8
128 Это полноценный отладчик, управляемый командами. Он позволяет
129 трассировать исполнение программ и изучать их внутреннее состояние в
130 любой момент времени. Работает с программами на C и C++,
131 скомпилированными GNU компилятором C (gcc, egcs, pgcc).
132
133 %description -l tr.UTF-8
134 Bir komut arayüzü üzerinden programcıya programını adım adım izleme
135 (trace) ve herhangi bir anda programın durumunu inceleme olanağı
136 verir.
137
138 %description -l uk.UTF-8
139 Це повноцінний відладчик, що керується командами. Він дозволяє
140 трасувати виконання програм та вивчати їх внутрішній стан в довільний
141 момент часу. Працює з програмами на C та C++, зкомпільованими
142 компіляторами GNU C (gcc, egcs, pgcc).
143
144 %package gdbserver
145 Summary:        A standalone server for GDB (the GNU source-level debugger)
146 Summary(pl.UTF-8):      Samodzielny serwer GDB (debuggera GNU)
147 Group:          Development/Debuggers
148
149 %description gdbserver
150 GDB, the GNU debugger, allows you to debug programs written in C, C++,
151 Java, and other languages, by executing them in a controlled fashion
152 and printing their data.
153
154 This package provides a program that allows you to run GDB on a
155 different machine than the one which is running the program being
156 debugged.
157
158 %description gdbserver -l pl.UTF-8
159 GDB (GNU debugger) pozwala śledzić programy napisane w C, C++, Javie i
160 innych językach programowania poprzez wykonywanie ich w sposób
161 kontrolowany oraz wypisywanie ich danych.
162
163 Ten pakiet zawiera program pozwalający uruchamiać GDB na innej
164 maszynie niż ta, na której działa śledzony program.
165
166 %package lib
167 Summary:        GDB in the form of a static library
168 Summary(pl.UTF-8):      GDB w postaci biblioteki statycznej
169 Group:          Development/Debuggers
170 # libraries that needs to be linked to fulfill libgdb.a symbol requirements
171 Requires:       binutils-devel >= 2.17.50
172 Requires:       expat-devel
173 Requires:       libselinux-devel
174 Requires:       libsepol-devel
175 Requires:       ncurses-devel
176 Requires:       python3-devel
177 Requires:       readline-devel
178 Requires:       xz-devel
179 Requires:       zlib-devel
180
181 %description lib
182 GDB in the form of a static library.
183
184 %description lib -l pl.UTF-8
185 GDB w postaci biblioteki statycznej.
186
187 %prep
188 %setup -q
189
190 # Files have `# <number> <file>' statements breaking VPATH / find-debuginfo.sh .
191 %{__rm} gdb/ada-exp.c gdb/ada-lex.c gdb/c-exp.c gdb/cp-name-parser.c gdb/f-exp.c
192 %{__rm} gdb/m2-exp.c gdb/p-exp.c
193
194 %patch100 -p1
195 %patch101 -p1
196 %patch102 -p1
197 %patch104 -p1
198 %patch105 -p1
199 %patch110 -p1
200
201 %patch1000 -p1
202 %patch1001 -p1
203 %patch1002 -p1
204 %patch1005 -p1
205 %patch1006 -p1
206
207 # Change the version that gets printed at GDB startup, so it is PLD Linux specific.
208 cat > gdb/version.in << EOF
209 %{version}-%{release} (PLD Linux)
210 EOF
211
212 %{__sed} -i -e '1s,/usr/bin/python$,%{__python},' \
213       contrib/dg-extract-results.py \
214
215 %{__sed} -i -e '1s,/usr/bin/env python$,%{__python},' \
216       gdb/contrib/test_pubnames_and_indexes.py \
217       gdb/testsuite/print-ts.py
218
219 %{__sed} -i -e '1s,/usr/bin/env python3,%{__python3},' \
220       gdb/testsuite/analyze-racy-logs.py \
221       gdb/copyright.py
222
223 %{__sed} -i -e '1s,/usr/bin/env bash,/bin/bash,' \
224       gdb/contrib/cc-with-tweaks.sh \
225       gdb/gcore.in \
226       src-release.sh
227
228 sed -i -e 's/\[2\.69\]/[%{autoconf_ver}]/' config/override.m4
229
230 %build
231 # omit hand-written gdb/testsuite aclocal.m4
232 for dir in gdb gdbserver ; do
233         olddir=$(pwd)
234         cd $dir
235         %{__rm} aclocal.m4
236         %{__aclocal} $(grep '^ACLOCAL_AMFLAGS' Makefile.in | sed -e 's/.*=//')
237         cd $olddir
238 done
239 for dir in $(find gdb -name 'configure.in' -o -name 'configure.ac'); do
240         dir=$(dirname "$dir")
241         olddir=$(pwd)
242         cd $dir
243         %{__autoconf}
244         grep -q AC_CONFIG_HEADER configure.* && %{__autoheader}
245         cd $olddir
246 done
247 cp -f /usr/share/automake/config.* .
248 install -d build && cd build
249 # don't --enable-shared here, there would be libs version mismatch with binutils
250 ../%configure \
251         --disable-gdbtk \
252         --disable-shared \
253         --disable-silent-rules \
254         --enable-gdbcli \
255         --enable-gdbmi \
256         --enable-multi-ice \
257         --enable-netrom \
258         --enable-nls \
259         --enable-tui \
260         --with-cpu=%{_target_cpu} \
261         --with-gdb-datadir=%{_datadir}/gdb \
262         --with-guile%{!?with_guile:=no} \
263 %ifnarch alpha
264         --with-mmalloc \
265 %endif
266 %if %{with python}
267         --with-python="%{__python3}" \
268         --with-pythondir=%{py3_sitescriptdir} \
269 %else
270         --without-python \
271 %endif
272         --with-separate-debug-dir=/usr/lib/debug \
273         --with-system-readline \
274         --without-included-gettext \
275         --without-included-regex \
276         --without-x
277
278 # V=1 because only some subdirs honour --enable-silent-rules
279 %{__make} \
280         V=1
281
282 %{__make} -j1 info
283
284 # gdb/ChangeLog: Build gdb directly from *.o files not using libgdb.a.
285 %{__make} -C gdb libgdb.a \
286         V=1
287
288 %install
289 rm -rf $RPM_BUILD_ROOT
290 install -d $RPM_BUILD_ROOT%{_infodir}
291
292 %{__make} -C build -j1 install install-info \
293         DESTDIR=$RPM_BUILD_ROOT
294
295 cp -a build/gdb/libgdb.a $RPM_BUILD_ROOT%{_libdir}
296
297 # gdbtui seems all identical to gdb except when invoked as gdbtui, ncurses
298 # window is created too.
299 echo ".so gdb.1" > $RPM_BUILD_ROOT%{_mandir}/man1/gdbtui.1
300 ln -f $RPM_BUILD_ROOT%{_bindir}/{gdb,gdbtui}
301
302 bzip2 -dc %{SOURCE1} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
303 %{__rm} $RPM_BUILD_ROOT%{_mandir}/README.gdb-non-english-man-pages
304
305 rm -f $RPM_BUILD_ROOT%{_infodir}/dir
306
307 %if %{with python}
308 # Temporarily now:
309 for LIB in lib lib64 libx32; do
310         LIBPATH="$RPM_BUILD_ROOT%{_datadir}/gdb/auto-load%{_prefix}/$LIB"
311         install -d $LIBPATH
312 done
313
314 %py3_ocomp $RPM_BUILD_ROOT%{py3_sitescriptdir}
315 %py3_comp $RPM_BUILD_ROOT%{py3_sitescriptdir}
316 %endif
317
318 cp -a %{SOURCE3} $RPM_BUILD_ROOT%{_mandir}/man1/gstack.1
319
320 cp -p build/libdecnumber/libdecnumber.a $RPM_BUILD_ROOT%{_libdir}
321
322 # Remove the files that are part of a gdb build but that are owned and provided by other packages.
323 # These are part of binutils:
324 %{__rm} $RPM_BUILD_ROOT%{_localedir}/*/LC_MESSAGES/{bfd,opcodes}.mo
325 %{__rm} $RPM_BUILD_ROOT%{_infodir}/{bfd,ctf-spec,sframe-spec}.info*
326 %{__rm} $RPM_BUILD_ROOT%{_includedir}/{ansidecl,bfd,bfdlink,ctf,ctf-api,diagnostics,dis-asm,symcat,plugin-api}.h
327 %{__rm} $RPM_BUILD_ROOT%{_libdir}/lib{bfd,ctf,ctf-nobfd,opcodes}.la
328 %{__rm} $RPM_BUILD_ROOT%{_libdir}/lib{bfd,ctf,ctf-nobfd,opcodes}.a
329
330 %clean
331 rm -rf $RPM_BUILD_ROOT
332
333 %post   -p /sbin/postshell
334 -/usr/sbin/fix-info-dir -c %{_infodir}
335
336 %postun -p /sbin/postshell
337 -/usr/sbin/fix-info-dir -c %{_infodir}
338
339 %files
340 %defattr(644,root,root,755)
341 %doc gdb/{NEWS,PROBLEMS,README}
342 %attr(755,root,root) %{_bindir}/gdb
343 %attr(755,root,root) %{_bindir}/gdbtui
344 %attr(755,root,root) %{_bindir}/gdb-add-index
345 %attr(755,root,root) %{_bindir}/gstack
346 %attr(755,root,root) %{_bindir}/gcore
347 %dir %{_datadir}/gdb
348 %dir %{_datadir}/gdb/auto-load
349 %dir %{_datadir}/gdb/auto-load%{_prefix}
350 %dir %{_datadir}/gdb/auto-load%{_prefix}/lib
351 %ifarch %{x8664} x32
352 %dir %{_datadir}/gdb/auto-load%{_prefix}/lib64
353 %dir %{_datadir}/gdb/auto-load%{_prefix}/libx32
354 %endif
355 %ifarch aarch64
356 %dir %{_datadir}/gdb/auto-load%{_prefix}/lib64
357 %endif
358 %{?with_guile:%{_datadir}/gdb/guile}
359 %{_datadir}/gdb/syscalls
360 %{_datadir}/gdb/system-gdbinit
361 %{_datadir}/gdb/python
362 %{_mandir}/man1/gdb.1*
363 %{_mandir}/man1/gdbtui.1*
364 %{_mandir}/man1/gdb-add-index.1*
365 %{_mandir}/man1/gstack.1*
366 %{_mandir}/man1/gcore.1*
367 %{_mandir}/man5/gdbinit.5*
368 %lang(es) %{_mandir}/es/man1/*
369 %lang(fr) %{_mandir}/fr/man1/*
370 %lang(hu) %{_mandir}/hu/man1/*
371 %lang(ja) %{_mandir}/ja/man1/*
372 %lang(pl) %{_mandir}/pl/man1/*
373 %{_infodir}/annotate.info*
374 %{_infodir}/gdb.info*
375 %{_infodir}/stabs.info*
376
377 %files gdbserver
378 %defattr(644,root,root,755)
379 %attr(755,root,root) %{_bindir}/gdbserver
380 %{_mandir}/man1/gdbserver.1*
381 %ifnarch %{arm}
382 %attr(755,root,root) %{_libdir}/libinproctrace.so
383 %endif
384
385 %files lib
386 %defattr(644,root,root,755)
387 %{_libdir}/libdecnumber.a
388 %{_libdir}/libgdb.a
389 %{_includedir}/gdb
This page took 0.098033 seconds and 4 git commands to generate.