]> git.pld-linux.org Git - packages/gdb.git/blob - gdb.spec
- use bzipped source
[packages/gdb.git] / gdb.spec
1 Summary:        A GNU source-level debugger for C, C++ and Fortran
2 Summary(de):    Symbolischer Debugger für C und andere Sprachen 
3 Summary(fr):    Débugger symbolique pour C et d'autres langages
4 Summary(pl):    Symboliczny odpluskwiacz dla C i innych jêzyków
5 Summary(tr):    C ve diðer diller için sembolik hata ayýklayýcý
6 Name:           gdb
7 Version:        5.0
8 Release:        1
9 License:        GPL
10 Group:          Development/Debuggers
11 Group(pl):      Programowanie/Odpluskwiacze
12 Source0:        ftp://ftp.gnu.org/pub/gnu/gdb/%{name}-%{version}.tar.bz2
13 #Patch0:        gdb-shared-readline.patch
14 BuildRequires:  ncurses-devel >= 5.0
15 BuildRequires:  readline-devel >= 4.1
16 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
17
18 %description
19 Gdb is a full featured, command driven debugger. Gdb allows you to
20 trace the execution of programs and examine their internal state at
21 any time. Gdb works for C and C++ compiled with the GNU C compiler
22 gcc.
23
24 %description -l de
25 dem Sie die Ausführung von Programmen verfolgen und jederzeit den
26 inneren Zustand überprüfen können. Er funktioniert für C und mit GNU C
27 kompiliertes C++.
28
29 %description -l fr
30 Débugger complet, piloté par commandes. Permet de tracer l'exécution
31 des programmes et d'examiner à tout moment leur état interne.
32 Fonctionne avec les binaires C et C++ compilés avec le compilateur C
33 de GNU, gcc.
34
35 %description -l pl
36 Gdb jest rozbudowanym odpluskwiaczem (debuggerem), pozwalaj±cym
37 ¶ledziæ wykonywanie programu i badaæ jego stan wewnêtrzny. Gdb
38 umo¿liwia odpluskwianie programów napisanych w C/C++ i skompilowanych
39 przy pomocy kompilatora GNU (gcc).
40
41 %description -l tr
42 Bir komut arayüzü üzerinden programcýya programýný adým adým izleme
43 (trace) ve herhangi bir anda programýn durumunu inceleme olanaðý
44 verir.
45
46 %prep
47 %setup -q
48 #%patch0 -p1
49
50 %build
51 CFLAGS="$RPM_OPT_FLAGS" LDFLAGS="-s" \
52 ./configure %{_target_platform} \
53         --prefix=%{_prefix} \
54         --infodir=%{_infodir} \
55         --mandir=%{_mandir} \
56         --enable-shared
57
58 %{__make}
59 %{__make} info
60
61 %install
62 rm -rf $RPM_BUILD_ROOT
63 install -d $RPM_BUILD_ROOT%{_infodir}
64
65 %{__make} install \
66         prefix=$RPM_BUILD_ROOT%{_prefix} \
67         infodir=$RPM_BUILD_ROOT%{_infodir} \
68         mandir=$RPM_BUILD_ROOT%{_mandir}
69
70 # install by hand
71 install gdb/doc/*.info* $RPM_BUILD_ROOT%{_infodir}
72
73 strip $RPM_BUILD_ROOT%{_bindir}/*
74
75 gzip -9nf $RPM_BUILD_ROOT{%{_infodir}/*info*,%{_mandir}/man?/*}
76
77 %post
78 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
79
80 %postun
81 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
82
83 %clean
84 rm -rf $RPM_BUILD_ROOT
85
86 %files
87 %defattr(644,root,root,755)
88 %attr(755,root,root) %{_bindir}/*
89
90 %{_mandir}/man1/*
91 %{_infodir}/gdb*.info*
92 %{_infodir}/stabs*.info*
This page took 0.032937 seconds and 4 git commands to generate.