]> git.pld-linux.org Git - packages/gdb.git/blob - gdb.spec
- release 3 (by relup.sh)
[packages/gdb.git] / gdb.spec
1 # NOTE: -lib package is used by fpc.spec
2
3 # TODO
4 # - rpm5 librpm support (gdb/configure.ac checks for 4.x or so)
5 # - change install msg to poldek in buildid-locate-rpm-pld.patch when poldek allows it. LP#493922
6 #
7 # Conditional build:
8 %bcond_without  guile           # Guile embedded scripting
9 %bcond_without  python          # build without python support
10
11 Summary:        A GNU source-level debugger for C, C++ and Fortran
12 Summary(de.UTF-8):      Symbolischer Debugger für C und andere Sprachen
13 Summary(es.UTF-8):      Depurador de programas C y otras lenguajes
14 Summary(fr.UTF-8):      Débugger symbolique pour C et d'autres langages
15 Summary(pl.UTF-8):      Symboliczny odpluskwiacz dla C i innych języków
16 Summary(pt_BR.UTF-8):   Depurador de programas C e outras linguagens
17 Summary(ru.UTF-8):      Символический отладчик для C и других языков
18 Summary(tr.UTF-8):      C ve diğer diller için sembolik hata ayıklayıcı
19 Summary(uk.UTF-8):      Символьний відладчик для С та інших мов
20 Summary(zh_CN.UTF-8):   [开发]C和其他语言的调试器
21 Summary(zh_TW.UTF-8):   [.-A開發]C和.$)B其.-A他語.$)B言的調試器
22 Name:           gdb
23 Version:        8.2
24 Release:        3
25 License:        GPL v3+
26 Group:          Development/Debuggers
27 Source0:        http://ftp.gnu.org/gnu/gdb/%{name}-%{version}.tar.xz
28 # Source0-md5:  b5a49dbff00d9a87fbe114d14b3101c0
29 Source1:        http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-non-english-man-pages.tar.bz2
30 # Source1-md5:  2e8a48939ae282c12bbacdd54e398247
31 Source3:        %{name}-gstack.man
32 Patch100:       gdb-6.6-buildid-locate.patch
33 Patch101:       gdb-6.6-buildid-locate-solib-missing-ids.patch
34 Patch102:       gdb-6.6-buildid-locate-rpm.patch
35 Patch103:       gdb-6.6-buildid-locate-core-as-arg.patch
36 Patch104:       gdb-6.6-buildid-locate-rpm-librpm-workaround.patch
37 Patch105:       gdb-6.6-buildid-locate-misleading-warning-missing-debuginfo-rhbz981154.patch
38 Patch106:       gdb-6.6-buildid-locate-rpm-scl.patch
39 Patch110:       gdb-6.3-gstack-20050411.patch
40
41 Patch112:       gdb-archer-vla-tests.patch
42 Patch113:       gdb-vla-intel-fortran-strides.patch
43 Patch114:       gdb-vla-intel-stringbt-fix.patch
44 Patch115:       gdb-vla-intel-fortran-vla-strings.patch
45 Patch116:       gdb-vla-intel-tests.patch
46 Patch1000:      %{name}-readline.patch
47 Patch1001:      %{name}-info.patch
48 Patch1002:      %{name}-passflags.patch
49 Patch1005:      %{name}-pretty-print-by-default.patch
50 Patch1006:      buildid-locate-rpm-pld.patch
51 URL:            http://www.gnu.org/software/gdb/
52 BuildRequires:  autoconf >= 2.69
53 BuildRequires:  automake
54 BuildRequires:  bison
55 BuildRequires:  babeltrace-devel >= 1.1.0
56 BuildRequires:  expat-devel
57 BuildRequires:  flex >= 2.6.4
58 BuildRequires:  gettext-tools >= 0.12.1
59 %{?with_guile:BuildRequires:    guile-devel >= 2.0}
60 %ifarch %{ix86} %{x8664}
61 BuildRequires:  libipt-devel
62 %endif
63 BuildRequires:  libselinux-devel
64 BuildRequires:  libstdc++-devel >= 6:4.8
65 BuildRequires:  libtool
66 BuildRequires:  make >= 3.81
67 BuildRequires:  mpfr-devel
68 BuildRequires:  ncurses-devel >= 5.2
69 BuildRequires:  pkgconfig
70 BuildRequires:  readline-devel
71 BuildRequires:  rpmbuild(macros) >= 1.219
72 BuildRequires:  tar >= 1:1.22
73 BuildRequires:  texinfo >= 4.4
74 BuildRequires:  xz
75 BuildRequires:  xz-devel
76 BuildRequires:  zlib-devel
77 %if %{with python}
78 BuildRequires:  python-devel
79 BuildRequires:  rpm-pythonprov
80 Obsoletes:      python-gdb
81 # for traceback module
82 Requires:       python-modules
83 %endif
84 %{?with_guile:Requires: guile >= 2.0.12}
85 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
86
87 %description
88 Gdb is a full featured, command driven debugger. Gdb allows you to
89 trace the execution of programs and examine their internal state at
90 any time. Gdb works for C and C++ compiled with the GNU C compiler
91 gcc.
92
93 %description -l de.UTF-8
94 dem Sie die Ausführung von Programmen verfolgen und jederzeit den
95 inneren Zustand überprüfen können. Er funktioniert für C und mit GNU C
96 kompiliertes C++.
97
98 %description -l es.UTF-8
99 Este es un debugger orientado a comandos repleto de características.
100 Te permite rastrear la ejecución de programas y examinar su estado
101 interno a cualquier momento. Funciona para C y C++ compilado con el
102 compilador GNU C.
103
104 %description -l fr.UTF-8
105 Débugger complet, piloté par commandes. Permet de tracer l'exécution
106 des programmes et d'examiner à tout moment leur état interne.
107 Fonctionne avec les binaires C et C++ compilés avec le compilateur C
108 de GNU, gcc.
109
110 %description -l pl.UTF-8
111 Gdb jest rozbudowanym odpluskwiaczem (debuggerem), pozwalającym
112 śledzić wykonywanie programu i badać jego stan wewnętrzny. Gdb
113 umożliwia odpluskwianie programów napisanych w C/C++ i skompilowanych
114 przy pomocy kompilatora GNU (gcc).
115
116 %description -l pt_BR.UTF-8
117 Este é um debugger orientado a comandos repleto de características.
118 Ele permite à você rastrear a execução de programas e examinar o seu
119 estado interno a qualquer momento. Ele funciona para para C e C++
120 compilado com o compilador GNU C.
121
122 %description -l ru.UTF-8
123 Это полноценный отладчик, управляемый командами. Он позволяет
124 трассировать исполнение программ и изучать их внутреннее состояние в
125 любой момент времени. Работает с программами на C и C++,
126 скомпилированными GNU компилятором C (gcc, egcs, pgcc).
127
128 %description -l tr.UTF-8
129 Bir komut arayüzü üzerinden programcıya programını adım adım izleme
130 (trace) ve herhangi bir anda programın durumunu inceleme olanağı
131 verir.
132
133 %description -l uk.UTF-8
134 Це повноцінний відладчик, що керується командами. Він дозволяє
135 трасувати виконання програм та вивчати їх внутрішній стан в довільний
136 момент часу. Працює з програмами на C та C++, зкомпільованими
137 компіляторами GNU C (gcc, egcs, pgcc).
138
139 %package gdbserver
140 Summary:        A standalone server for GDB (the GNU source-level debugger)
141 Summary(pl.UTF-8):      Samodzielny serwer GDB (debuggera GNU)
142 Group:          Development/Debuggers
143
144 %description gdbserver
145 GDB, the GNU debugger, allows you to debug programs written in C, C++,
146 Java, and other languages, by executing them in a controlled fashion
147 and printing their data.
148
149 This package provides a program that allows you to run GDB on a
150 different machine than the one which is running the program being
151 debugged.
152
153 %description gdbserver -l pl.UTF-8
154 GDB (GNU debugger) pozwala śledzić programy napisane w C, C++, Javie i
155 innych językach programowania poprzez wykonywanie ich w sposób
156 kontrolowany oraz wypisywanie ich danych.
157
158 Ten pakiet zawiera program pozwalający uruchamiać GDB na innej
159 maszynie niż ta, na której działa śledzony program.
160
161 %package lib
162 Summary:        GDB in the form of a static library
163 Summary(pl.UTF-8):      GDB w postaci biblioteki statycznej
164 Group:          Development/Debuggers
165 # libraries that needs to be linked to fulfill libgdb.a symbol requirements
166 Requires:       binutils-devel >= 2.17.50
167 Requires:       expat-devel
168 Requires:       libselinux-devel
169 Requires:       libsepol-devel
170 Requires:       ncurses-devel
171 Requires:       python-devel
172 Requires:       readline-devel
173 Requires:       xz-devel
174 Requires:       zlib-devel
175
176 %description lib
177 GDB in the form of a static library.
178
179 %description lib -l pl.UTF-8
180 GDB w postaci biblioteki statycznej.
181
182 %prep
183 %setup -q
184
185 # Files have `# <number> <file>' statements breaking VPATH / find-debuginfo.sh .
186 %{__rm} gdb/ada-exp.c gdb/ada-lex.c gdb/c-exp.c gdb/cp-name-parser.c gdb/f-exp.c
187 %{__rm} gdb/m2-exp.c gdb/p-exp.c
188
189 %patch100 -p1
190 %patch101 -p1
191 %patch102 -p1
192 %patch103 -p1
193 %patch104 -p1
194 %patch105 -p1
195 %patch106 -p1
196 %patch110 -p1
197
198 %patch112 -p1
199 %patch113 -p1
200 %patch114 -p1
201 %patch115 -p1
202 %patch116 -p1
203
204 %patch1000 -p1
205 %patch1001 -p1
206 %patch1002 -p1
207 %patch1005 -p1
208 %patch1006 -p1
209
210 # Change the version that gets printed at GDB startup, so it is PLD Linux specific.
211 cat > gdb/version.in << EOF
212 %{version}-%{release} (PLD Linux)
213 EOF
214
215 sed -i -e 's#_GCC_AUTOCONF_VERSION\], \[2\.64\]#_GCC_AUTOCONF_VERSION], [2.69]#g' config/override.m4
216
217 %build
218 # omit hand-written gdb/testsuite aclocal.m4
219 for dir in gdb gdb/gdbserver ; do
220         olddir=$(pwd)
221         cd $dir
222         %{__rm} aclocal.m4
223         %{__aclocal} $(grep '^ACLOCAL_AMFLAGS' Makefile.in | sed -e 's/.*=//')
224         cd $olddir
225 done
226 for dir in $(find gdb -name 'configure.in' -o -name 'configure.ac'); do
227         dir=$(dirname "$dir")
228         olddir=$(pwd)
229         cd $dir
230         %{__autoconf}
231         grep -q AC_CONFIG_HEADER configure.* && %{__autoheader}
232         cd $olddir
233 done
234 cp -f /usr/share/automake/config.* .
235 # don't --enable-shared here, there would be libs version mismatch with binutils
236 %configure \
237         --with-gdb-datadir=%{_datadir}/gdb \
238         --with-separate-debug-dir=/usr/lib/debug \
239 %if %{with python}
240         --with-python=yes \
241         --with-pythondir=%{py_sitescriptdir} \
242 %else
243         --without-python \
244 %endif
245 %if %{with guile}
246         --with-guile \
247 %else
248         --without-guile \
249 %endif
250         --disable-gdbtk \
251         --disable-shared \
252         --enable-gdbcli \
253         --enable-gdbmi \
254         --enable-multi-ice \
255         --enable-netrom \
256         --enable-nls \
257         --enable-tui \
258         --with-system-readline \
259         --with-cpu=%{_target_cpu} \
260 %ifnarch alpha
261         --with-mmalloc \
262 %endif
263         --without-included-gettext \
264         --without-included-regex \
265         --without-x
266
267 %{__make}
268 %{__make} -j1 info
269
270 # gdb/ChangeLog: Build gdb directly from *.o files not using libgdb.a.
271 %{__make} -C gdb libgdb.a
272
273 %install
274 rm -rf $RPM_BUILD_ROOT
275 install -d $RPM_BUILD_ROOT%{_infodir}
276
277 %{__make} -j1 install install-info \
278         DESTDIR=$RPM_BUILD_ROOT
279
280 cp -a gdb/libgdb.a $RPM_BUILD_ROOT%{_libdir}
281
282 # gdbtui seems all identical to gdb except when invoked as gdbtui, ncurses
283 # window is created too.
284 echo ".so gdb.1" > $RPM_BUILD_ROOT%{_mandir}/man1/gdbtui.1
285 ln -f $RPM_BUILD_ROOT%{_bindir}/{gdb,gdbtui}
286
287 bzip2 -dc %{SOURCE1} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
288 %{__rm} $RPM_BUILD_ROOT%{_mandir}/README.gdb-non-english-man-pages
289
290 rm -f $RPM_BUILD_ROOT%{_infodir}/dir
291
292 %if %{with python}
293 # Temporarily now:
294 for LIB in lib lib64 libx32; do
295         LIBPATH="$RPM_BUILD_ROOT%{_datadir}/gdb/auto-load%{_prefix}/$LIB"
296         install -d $LIBPATH
297 done
298
299 %py_ocomp $RPM_BUILD_ROOT%{py_sitescriptdir}
300 %py_comp $RPM_BUILD_ROOT%{py_sitescriptdir}
301 %py_postclean
302 %endif
303
304 cp -a %{SOURCE3} $RPM_BUILD_ROOT%{_mandir}/man1/gstack.1
305
306 install libdecnumber/libdecnumber.a $RPM_BUILD_ROOT%{_libdir}
307
308 # Remove the files that are part of a gdb build but that are owned and provided by other packages.
309 # These are part of binutils:
310 %{__rm} $RPM_BUILD_ROOT%{_localedir}/*/LC_MESSAGES/{bfd,opcodes}.mo
311 %{__rm} $RPM_BUILD_ROOT%{_infodir}/bfd.info*
312 %{__rm} $RPM_BUILD_ROOT%{_includedir}/{ansidecl,bfd,bfdlink,dis-asm,symcat,plugin-api}.h
313 %{__rm} $RPM_BUILD_ROOT%{_libdir}/lib{bfd,opcodes}.la
314 %{__rm} $RPM_BUILD_ROOT%{_libdir}/lib{bfd,opcodes}.a
315
316 %clean
317 rm -rf $RPM_BUILD_ROOT
318
319 %post   -p /sbin/postshell
320 -/usr/sbin/fix-info-dir -c %{_infodir}
321
322 %postun -p /sbin/postshell
323 -/usr/sbin/fix-info-dir -c %{_infodir}
324
325 %files
326 %defattr(644,root,root,755)
327 %doc gdb/{ChangeLog,NEWS,PROBLEMS,README}
328 %attr(755,root,root) %{_bindir}/gdb
329 %attr(755,root,root) %{_bindir}/gdbtui
330 %attr(755,root,root) %{_bindir}/gdb-add-index
331 %attr(755,root,root) %{_bindir}/gstack
332 %attr(755,root,root) %{_bindir}/gcore
333 %dir %{_datadir}/gdb
334 %dir %{_datadir}/gdb/auto-load
335 %dir %{_datadir}/gdb/auto-load%{_prefix}
336 %dir %{_datadir}/gdb/auto-load%{_prefix}/lib
337 %ifarch %{x8664} x32
338 %dir %{_datadir}/gdb/auto-load%{_prefix}/lib64
339 %dir %{_datadir}/gdb/auto-load%{_prefix}/libx32
340 %endif
341 %{?with_guile:%{_datadir}/gdb/guile}
342 %{_datadir}/gdb/syscalls
343 %{_datadir}/gdb/system-gdbinit
344 %{_datadir}/gdb/python
345 %{_mandir}/man1/gdb.1*
346 %{_mandir}/man1/gdbtui.1*
347 %{_mandir}/man1/gdb-add-index.1*
348 %{_mandir}/man1/gstack.1*
349 %{_mandir}/man1/gcore.1*
350 %{_mandir}/man5/gdbinit.5*
351 %lang(es) %{_mandir}/es/man1/*
352 %lang(fr) %{_mandir}/fr/man1/*
353 %lang(hu) %{_mandir}/hu/man1/*
354 %lang(ja) %{_mandir}/ja/man1/*
355 %lang(pl) %{_mandir}/pl/man1/*
356 %{_infodir}/annotate.info*
357 %{_infodir}/gdb.info*
358 %{_infodir}/stabs.info*
359
360 %files gdbserver
361 %defattr(644,root,root,755)
362 %attr(755,root,root) %{_bindir}/gdbserver
363 %{_mandir}/man1/gdbserver.1*
364 %attr(755,root,root) %{_libdir}/libinproctrace.so
365
366 %files lib
367 %defattr(644,root,root,755)
368 %{_libdir}/libdecnumber.a
369 %{_libdir}/libgdb.a
370 %{_includedir}/gdb
This page took 0.078528 seconds and 4 git commands to generate.