]> git.pld-linux.org Git - packages/gdb.git/blob - gdb.spec
- add support for Fortran dynamics arrays; copied from Fedora (263b580)
[packages/gdb.git] / gdb.spec
1 # NOTE: -lib package is used by fpc.spec
2
3 # TODO
4 # - change install msg to poldek in buildid-locate-rpm-pld.patch when poldek allows it. LP#493922
5 #
6 # Conditional build:
7 %bcond_without  python          # build without python support
8
9 Summary:        A GNU source-level debugger for C, C++ and Fortran
10 Summary(de.UTF-8):      Symbolischer Debugger für C und andere Sprachen
11 Summary(es.UTF-8):      Depurador de programas C y otras lenguajes
12 Summary(fr.UTF-8):      Débugger symbolique pour C et d'autres langages
13 Summary(pl.UTF-8):      Symboliczny odpluskwiacz dla C i innych języków
14 Summary(pt_BR.UTF-8):   Depurador de programas C e outras linguagens
15 Summary(ru.UTF-8):      Символический отладчик для C и других языков
16 Summary(tr.UTF-8):      C ve diğer diller için sembolik hata ayıklayıcı
17 Summary(uk.UTF-8):      Символьний відладчик для С та інших мов
18 Summary(zh_CN.UTF-8):   [开发]C和其他语言的调试器
19 Summary(zh_TW.UTF-8):   [.-A開發]C和.$)B其.-A他語.$)B言的調試器
20 %define         snap    20120926
21 Name:           gdb
22 Version:        7.8
23 Release:        1
24 License:        GPL v3+
25 Group:          Development/Debuggers
26 Source0:        http://ftp.gnu.org/gnu/gdb/%{name}-%{version}.tar.xz
27 # Source0-md5:  bd958fe9019d7c7896f29f6724a764ed
28 Source1:        http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-non-english-man-pages.tar.bz2
29 # Source1-md5:  2e8a48939ae282c12bbacdd54e398247
30 Source3:        %{name}-gstack.man
31 Patch100:       gdb-6.6-buildid-locate.patch
32 Patch101:       gdb-6.6-buildid-locate-solib-missing-ids.patch
33 Patch102:       gdb-6.6-buildid-locate-rpm.patch
34 Patch103:       gdb-6.6-buildid-locate-core-as-arg.patch
35 Patch104:       gdb-6.6-buildid-locate-rpm-librpm-workaround.patch
36 Patch105:       gdb-6.6-buildid-locate-misleading-warning-missing-debuginfo-rhbz981154.patch
37 Patch110:       gdb-6.3-gstack-20050411.patch
38 Patch111:       gdb-gdb-add-index-script.patch
39 Patch112:       gdb-archer-vla-tests.patch
40 Patch113:       gdb-vla-intel.patch
41 Patch114:       gdb-vla-intel-04of23-fix.patch
42 Patch115:       gdb-vla-intel-stringbt-fix.patch
43 Patch1000:      %{name}-readline.patch
44 Patch1001:      %{name}-info.patch
45 Patch1002:      %{name}-passflags.patch
46 Patch1005:      %{name}-pretty-print-by-default.patch
47 Patch1006:      buildid-locate-rpm-pld.patch
48 URL:            http://www.gnu.org/software/gdb/
49 BuildRequires:  autoconf >= 2.69
50 BuildRequires:  automake
51 BuildRequires:  bison
52 BuildRequires:  expat-devel
53 BuildRequires:  flex
54 BuildRequires:  gettext-devel
55 BuildRequires:  libselinux-devel
56 BuildRequires:  libtool
57 BuildRequires:  libunwind-devel >= 0.97
58 BuildRequires:  ncurses-devel >= 5.2
59 BuildRequires:  pkgconfig
60 BuildRequires:  readline-devel
61 BuildRequires:  rpmbuild(macros) >= 1.219
62 BuildRequires:  texinfo >= 4.4
63 BuildRequires:  zlib-devel
64 %if %{with python}
65 BuildRequires:  python-devel
66 BuildRequires:  rpm-pythonprov
67 Obsoletes:      python-gdb
68 # for traceback module
69 Requires:       python-modules
70 %endif
71 Requires:       libunwind >= 0.97
72 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
73
74 %description
75 Gdb is a full featured, command driven debugger. Gdb allows you to
76 trace the execution of programs and examine their internal state at
77 any time. Gdb works for C and C++ compiled with the GNU C compiler
78 gcc.
79
80 %description -l de.UTF-8
81 dem Sie die Ausführung von Programmen verfolgen und jederzeit den
82 inneren Zustand überprüfen können. Er funktioniert für C und mit GNU C
83 kompiliertes C++.
84
85 %description -l es.UTF-8
86 Este es un debugger orientado a comandos repleto de características.
87 Te permite rastrear la ejecución de programas y examinar su estado
88 interno a cualquier momento. Funciona para C y C++ compilado con el
89 compilador GNU C.
90
91 %description -l fr.UTF-8
92 Débugger complet, piloté par commandes. Permet de tracer l'exécution
93 des programmes et d'examiner à tout moment leur état interne.
94 Fonctionne avec les binaires C et C++ compilés avec le compilateur C
95 de GNU, gcc.
96
97 %description -l pl.UTF-8
98 Gdb jest rozbudowanym odpluskwiaczem (debuggerem), pozwalającym
99 śledzić wykonywanie programu i badać jego stan wewnętrzny. Gdb
100 umożliwia odpluskwianie programów napisanych w C/C++ i skompilowanych
101 przy pomocy kompilatora GNU (gcc).
102
103 %description -l pt_BR.UTF-8
104 Este é um debugger orientado a comandos repleto de características.
105 Ele permite à você rastrear a execução de programas e examinar o seu
106 estado interno a qualquer momento. Ele funciona para para C e C++
107 compilado com o compilador GNU C.
108
109 %description -l ru.UTF-8
110 Это полноценный отладчик, управляемый командами. Он позволяет
111 трассировать исполнение программ и изучать их внутреннее состояние в
112 любой момент времени. Работает с программами на C и C++,
113 скомпилированными GNU компилятором C (gcc, egcs, pgcc).
114
115 %description -l tr.UTF-8
116 Bir komut arayüzü üzerinden programcıya programını adım adım izleme
117 (trace) ve herhangi bir anda programın durumunu inceleme olanağı
118 verir.
119
120 %description -l uk.UTF-8
121 Це повноцінний відладчик, що керується командами. Він дозволяє
122 трасувати виконання програм та вивчати їх внутрішній стан в довільний
123 момент часу. Працює з програмами на C та C++, зкомпільованими
124 компіляторами GNU C (gcc, egcs, pgcc).
125
126 %package gdbserver
127 Summary:        A standalone server for GDB (the GNU source-level debugger)
128 Summary(pl.UTF-8):      Samodzielny serwer GDB (debuggera GNU)
129 Group:          Development/Debuggers
130
131 %description gdbserver
132 GDB, the GNU debugger, allows you to debug programs written in C, C++,
133 Java, and other languages, by executing them in a controlled fashion
134 and printing their data.
135
136 This package provides a program that allows you to run GDB on a
137 different machine than the one which is running the program being
138 debugged.
139
140 %description gdbserver -l pl.UTF-8
141 GDB (GNU debugger) pozwala śledzić programy napisane w C, C++, Javie i
142 innych językach programowania poprzez wykonywanie ich w sposób
143 kontrolowany oraz wypisywanie ich danych.
144
145 Ten pakiet zawiera program pozwalający uruchamiać GDB na innej
146 maszynie niż ta, na której działa śledzony program.
147
148 %package lib
149 Summary:        GDB in the form of a static library
150 Summary(pl.UTF-8):      GDB w postaci biblioteki statycznej
151 Group:          Development/Debuggers
152 # libraries that needs to be linked to fulfill libgdb.a symbol requirements
153 Requires:       binutils-devel >= 2.17.50
154 Requires:       expat-devel
155 Requires:       libselinux-devel
156 Requires:       libsepol-devel
157 Requires:       ncurses-devel
158 Requires:       python-devel
159 Requires:       readline-devel
160 Requires:       xz-devel
161 Requires:       zlib-devel
162
163 %description lib
164 GDB in the form of a static library.
165
166 %description lib -l pl.UTF-8
167 GDB w postaci biblioteki statycznej.
168
169 %prep
170 %setup -q
171
172 # Files have `# <number> <file>' statements breaking VPATH / find-debuginfo.sh .
173 rm -f gdb/ada-exp.c gdb/ada-lex.c gdb/c-exp.c gdb/cp-name-parser.c gdb/f-exp.c
174 rm -f gdb/jv-exp.c gdb/m2-exp.c gdb/objc-exp.c gdb/p-exp.c
175
176 %patch100 -p1
177 %patch101 -p1
178 %patch102 -p1
179 %patch103 -p1
180 %patch104 -p1
181 %patch105 -p1
182 %patch110 -p1
183 %patch111 -p1
184 %patch112 -p1
185 %patch113 -p1
186 %patch114 -p1
187 %patch115 -p1
188
189 %patch1000 -p1
190 %patch1001 -p1
191 %patch1002 -p1
192 %patch1005 -p1
193 %patch1006 -p1
194
195 # Change the version that gets printed at GDB startup, so it is PLD Linux specific.
196 cat > gdb/version.in << EOF
197 %{version}-%{release} (PLD Linux)
198 EOF
199
200 sed -i -e 's#_GCC_AUTOCONF_VERSION\], \[2\.64\]#_GCC_AUTOCONF_VERSION], [2.69]#g' config/override.m4
201
202 %build
203 # omit hand-written gdb/testsuite aclocal.m4
204 for dir in gdb gdb/gdbserver ; do
205         olddir=$(pwd)
206         cd $dir
207         %{__rm} aclocal.m4
208         %{__aclocal} $(grep '^ACLOCAL_AMFLAGS' Makefile.in | sed -e 's/.*=//')
209         cd $olddir
210 done
211 for dir in $(find gdb -name 'configure.in' -o -name 'configure.ac'); do
212         dir=$(dirname "$dir")
213         olddir=$(pwd)
214         cd $dir
215         %{__autoconf}
216         grep -q AC_CONFIG_HEADER configure.* && %{__autoheader}
217         cd $olddir
218 done
219 cp -f /usr/share/automake/config.* .
220 # don't --enable-shared here, there would be libs version mismatch with binutils
221 %configure \
222         --with-gdb-datadir=%{_datadir}/gdb \
223         --with-separate-debug-dir=/usr/lib/debug \
224 %if %{with python}
225         --with-python=yes \
226         --with-pythondir=%{py_sitescriptdir} \
227 %else
228         --without-python \
229 %endif
230         --disable-gdbtk \
231         --disable-shared \
232         --enable-gdbcli \
233         --enable-gdbmi \
234         --enable-multi-ice \
235         --enable-netrom \
236         --enable-nls \
237         --enable-tui \
238         --with-system-readline \
239         --with-cpu=%{_target_cpu} \
240 %ifnarch alpha
241         --with-mmalloc \
242 %endif
243         --without-included-gettext \
244         --without-included-regex \
245         --without-x
246
247 %{__make}
248 %{__make} -j1 info
249
250 # gdb/ChangeLog: Build gdb directly from *.o files not using libgdb.a.
251 %{__make} -C gdb libgdb.a
252
253 %install
254 rm -rf $RPM_BUILD_ROOT
255 install -d $RPM_BUILD_ROOT%{_infodir}
256
257 %{__make} -j1 install install-info \
258         DESTDIR=$RPM_BUILD_ROOT
259
260 # gdbtui seems all identical to gdb except when invoked as gdbtio, ncurses
261 # window is created too.
262 echo ".so gdb.1" > $RPM_BUILD_ROOT%{_mandir}/man1/gdbtui.1
263 ln -f $RPM_BUILD_ROOT%{_bindir}/{gdb,gdbtui}
264
265 bzip2 -dc %{SOURCE1} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
266 cp -a gdb/libgdb.a $RPM_BUILD_ROOT%{_libdir}
267
268 rm -f $RPM_BUILD_ROOT%{_infodir}/dir
269 rm -f $RPM_BUILD_ROOT%{_mandir}/README.gdb-non-english-man-pages
270
271 %if %{with python}
272 # Temporarily now:
273 for LIB in lib lib64; do
274         LIBPATH="$RPM_BUILD_ROOT%{_datadir}/gdb/auto-load%{_prefix}/$LIB"
275         install -d $LIBPATH
276 done
277
278 %py_ocomp $RPM_BUILD_ROOT%{py_sitescriptdir}
279 %py_comp $RPM_BUILD_ROOT%{py_sitescriptdir}
280 %py_postclean
281 %endif
282
283 cp -a %{SOURCE3} $RPM_BUILD_ROOT%{_mandir}/man1/gstack.1
284
285 install libdecnumber/libdecnumber.a $RPM_BUILD_ROOT%{_libdir}
286
287 # Remove the files that are part of a gdb build but that are owned and provided by other packages.
288 # These are part of binutils:
289 %{__rm} $RPM_BUILD_ROOT%{_localedir}/*/LC_MESSAGES/{bfd,opcodes}.mo
290 %{__rm} $RPM_BUILD_ROOT%{_infodir}/{bfd,configure,standards}.info*
291 %{__rm} $RPM_BUILD_ROOT%{_includedir}/{ansidecl,bfd,bfdlink,dis-asm,symcat}.h
292 %{__rm} $RPM_BUILD_ROOT%{_libdir}/lib{bfd,opcodes}.la
293 %{__rm} $RPM_BUILD_ROOT%{_libdir}/lib{bfd,opcodes}.a
294
295 %clean
296 rm -rf $RPM_BUILD_ROOT
297
298 %post   -p /sbin/postshell
299 -/usr/sbin/fix-info-dir -c %{_infodir}
300
301 %postun -p /sbin/postshell
302 -/usr/sbin/fix-info-dir -c %{_infodir}
303
304 %files
305 %defattr(644,root,root,755)
306 %doc gdb/{ChangeLog,NEWS,PROBLEMS,README}
307 %attr(755,root,root) %{_bindir}/gdb
308 %attr(755,root,root) %{_bindir}/gdbtui
309 %attr(755,root,root) %{_bindir}/gdb-add-index
310 %attr(755,root,root) %{_bindir}/gstack
311 %attr(755,root,root) %{_bindir}/gcore
312 %dir %{_datadir}/gdb
313 %dir %{_datadir}/gdb/auto-load
314 %dir %{_datadir}/gdb/auto-load%{_prefix}
315 %dir %{_datadir}/gdb/auto-load%{_prefix}/lib
316 %ifarch %{x8664}
317 %dir %{_datadir}/gdb/auto-load%{_prefix}/lib64
318 %endif
319 %{_datadir}/gdb/syscalls
320 %{_datadir}/gdb/system-gdbinit
321 %{_datadir}/gdb/python
322 %{_mandir}/man1/gdb.1*
323 %{_mandir}/man1/gdbtui.1*
324 %{_mandir}/man1/gdb-add-index.1*
325 %{_mandir}/man1/gstack.1*
326 %{_mandir}/man1/gcore.1*
327 %{_mandir}/man5/gdbinit.5*
328 %lang(es) %{_mandir}/es/man1/*
329 %lang(fr) %{_mandir}/fr/man1/*
330 %lang(hu) %{_mandir}/hu/man1/*
331 %lang(ja) %{_mandir}/ja/man1/*
332 %lang(pl) %{_mandir}/pl/man1/*
333 %{_infodir}/annotate.info*
334 %{_infodir}/gdb.info*
335 %{_infodir}/stabs.info*
336
337 %files gdbserver
338 %defattr(644,root,root,755)
339 %attr(755,root,root) %{_bindir}/gdbserver
340 %{_mandir}/man1/gdbserver.1*
341 %attr(755,root,root) %{_libdir}/libinproctrace.so
342
343 %files lib
344 %defattr(644,root,root,755)
345 %{_libdir}/libdecnumber.a
346 %{_libdir}/libgdb.a
347 %{_includedir}/gdb
This page took 0.07105 seconds and 4 git commands to generate.