]> git.pld-linux.org Git - packages/gdb.git/blob - gdb.spec
- updated to 7.8.1
[packages/gdb.git] / gdb.spec
1 # NOTE: -lib package is used by fpc.spec
2
3 # TODO
4 # - change install msg to poldek in buildid-locate-rpm-pld.patch when poldek allows it. LP#493922
5 #
6 # Conditional build:
7 %bcond_without  guile           # Guile embedded scripting
8 %bcond_without  python          # build without python support
9
10 Summary:        A GNU source-level debugger for C, C++ and Fortran
11 Summary(de.UTF-8):      Symbolischer Debugger für C und andere Sprachen
12 Summary(es.UTF-8):      Depurador de programas C y otras lenguajes
13 Summary(fr.UTF-8):      Débugger symbolique pour C et d'autres langages
14 Summary(pl.UTF-8):      Symboliczny odpluskwiacz dla C i innych języków
15 Summary(pt_BR.UTF-8):   Depurador de programas C e outras linguagens
16 Summary(ru.UTF-8):      Символический отладчик для C и других языков
17 Summary(tr.UTF-8):      C ve diğer diller için sembolik hata ayıklayıcı
18 Summary(uk.UTF-8):      Символьний відладчик для С та інших мов
19 Summary(zh_CN.UTF-8):   [开发]C和其他语言的调试器
20 Summary(zh_TW.UTF-8):   [.-A開發]C和.$)B其.-A他語.$)B言的調試器
21 %define         snap    20120926
22 Name:           gdb
23 Version:        7.8.1
24 Release:        1
25 License:        GPL v3+
26 Group:          Development/Debuggers
27 Source0:        http://ftp.gnu.org/gnu/gdb/%{name}-%{version}.tar.xz
28 # Source0-md5:  8072be87a94be0936bc3b4b6941b0862
29 Source1:        http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-non-english-man-pages.tar.bz2
30 # Source1-md5:  2e8a48939ae282c12bbacdd54e398247
31 Source3:        %{name}-gstack.man
32 Patch100:       gdb-6.6-buildid-locate.patch
33 Patch101:       gdb-6.6-buildid-locate-solib-missing-ids.patch
34 Patch102:       gdb-6.6-buildid-locate-rpm.patch
35 Patch103:       gdb-6.6-buildid-locate-core-as-arg.patch
36 Patch104:       gdb-6.6-buildid-locate-rpm-librpm-workaround.patch
37 Patch105:       gdb-6.6-buildid-locate-misleading-warning-missing-debuginfo-rhbz981154.patch
38 Patch110:       gdb-6.3-gstack-20050411.patch
39 Patch111:       gdb-gdb-add-index-script.patch
40 Patch112:       gdb-archer-vla-tests.patch
41 Patch113:       gdb-vla-intel.patch
42 Patch114:       gdb-vla-intel-04of23-fix.patch
43 Patch115:       gdb-vla-intel-stringbt-fix.patch
44 Patch1000:      %{name}-readline.patch
45 Patch1001:      %{name}-info.patch
46 Patch1002:      %{name}-passflags.patch
47 Patch1005:      %{name}-pretty-print-by-default.patch
48 Patch1006:      buildid-locate-rpm-pld.patch
49 URL:            http://www.gnu.org/software/gdb/
50 BuildRequires:  autoconf >= 2.69
51 BuildRequires:  automake
52 BuildRequires:  bison
53 BuildRequires:  babeltrace-devel
54 BuildRequires:  expat-devel
55 BuildRequires:  flex
56 BuildRequires:  gettext-devel
57 %{?with_guile:BuildRequires:    guile-devel >= 2.0}
58 BuildRequires:  libselinux-devel
59 BuildRequires:  libtool
60 BuildRequires:  libunwind-devel >= 0.97
61 BuildRequires:  ncurses-devel >= 5.2
62 BuildRequires:  pkgconfig
63 BuildRequires:  readline-devel
64 BuildRequires:  rpmbuild(macros) >= 1.219
65 BuildRequires:  texinfo >= 4.4
66 BuildRequires:  zlib-devel
67 %if %{with python}
68 BuildRequires:  python-devel
69 BuildRequires:  rpm-pythonprov
70 Obsoletes:      python-gdb
71 # for traceback module
72 Requires:       python-modules
73 %endif
74 Requires:       libunwind >= 0.97
75 %{?with_guile:Requires: guile >= 2.0}
76 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
77
78 %description
79 Gdb is a full featured, command driven debugger. Gdb allows you to
80 trace the execution of programs and examine their internal state at
81 any time. Gdb works for C and C++ compiled with the GNU C compiler
82 gcc.
83
84 %description -l de.UTF-8
85 dem Sie die Ausführung von Programmen verfolgen und jederzeit den
86 inneren Zustand überprüfen können. Er funktioniert für C und mit GNU C
87 kompiliertes C++.
88
89 %description -l es.UTF-8
90 Este es un debugger orientado a comandos repleto de características.
91 Te permite rastrear la ejecución de programas y examinar su estado
92 interno a cualquier momento. Funciona para C y C++ compilado con el
93 compilador GNU C.
94
95 %description -l fr.UTF-8
96 Débugger complet, piloté par commandes. Permet de tracer l'exécution
97 des programmes et d'examiner à tout moment leur état interne.
98 Fonctionne avec les binaires C et C++ compilés avec le compilateur C
99 de GNU, gcc.
100
101 %description -l pl.UTF-8
102 Gdb jest rozbudowanym odpluskwiaczem (debuggerem), pozwalającym
103 śledzić wykonywanie programu i badać jego stan wewnętrzny. Gdb
104 umożliwia odpluskwianie programów napisanych w C/C++ i skompilowanych
105 przy pomocy kompilatora GNU (gcc).
106
107 %description -l pt_BR.UTF-8
108 Este é um debugger orientado a comandos repleto de características.
109 Ele permite à você rastrear a execução de programas e examinar o seu
110 estado interno a qualquer momento. Ele funciona para para C e C++
111 compilado com o compilador GNU C.
112
113 %description -l ru.UTF-8
114 Это полноценный отладчик, управляемый командами. Он позволяет
115 трассировать исполнение программ и изучать их внутреннее состояние в
116 любой момент времени. Работает с программами на C и C++,
117 скомпилированными GNU компилятором C (gcc, egcs, pgcc).
118
119 %description -l tr.UTF-8
120 Bir komut arayüzü üzerinden programcıya programını adım adım izleme
121 (trace) ve herhangi bir anda programın durumunu inceleme olanağı
122 verir.
123
124 %description -l uk.UTF-8
125 Це повноцінний відладчик, що керується командами. Він дозволяє
126 трасувати виконання програм та вивчати їх внутрішній стан в довільний
127 момент часу. Працює з програмами на C та C++, зкомпільованими
128 компіляторами GNU C (gcc, egcs, pgcc).
129
130 %package gdbserver
131 Summary:        A standalone server for GDB (the GNU source-level debugger)
132 Summary(pl.UTF-8):      Samodzielny serwer GDB (debuggera GNU)
133 Group:          Development/Debuggers
134
135 %description gdbserver
136 GDB, the GNU debugger, allows you to debug programs written in C, C++,
137 Java, and other languages, by executing them in a controlled fashion
138 and printing their data.
139
140 This package provides a program that allows you to run GDB on a
141 different machine than the one which is running the program being
142 debugged.
143
144 %description gdbserver -l pl.UTF-8
145 GDB (GNU debugger) pozwala śledzić programy napisane w C, C++, Javie i
146 innych językach programowania poprzez wykonywanie ich w sposób
147 kontrolowany oraz wypisywanie ich danych.
148
149 Ten pakiet zawiera program pozwalający uruchamiać GDB na innej
150 maszynie niż ta, na której działa śledzony program.
151
152 %package lib
153 Summary:        GDB in the form of a static library
154 Summary(pl.UTF-8):      GDB w postaci biblioteki statycznej
155 Group:          Development/Debuggers
156 # libraries that needs to be linked to fulfill libgdb.a symbol requirements
157 Requires:       binutils-devel >= 2.17.50
158 Requires:       expat-devel
159 Requires:       libselinux-devel
160 Requires:       libsepol-devel
161 Requires:       ncurses-devel
162 Requires:       python-devel
163 Requires:       readline-devel
164 Requires:       xz-devel
165 Requires:       zlib-devel
166
167 %description lib
168 GDB in the form of a static library.
169
170 %description lib -l pl.UTF-8
171 GDB w postaci biblioteki statycznej.
172
173 %prep
174 %setup -q
175
176 # Files have `# <number> <file>' statements breaking VPATH / find-debuginfo.sh .
177 rm -f gdb/ada-exp.c gdb/ada-lex.c gdb/c-exp.c gdb/cp-name-parser.c gdb/f-exp.c
178 rm -f gdb/jv-exp.c gdb/m2-exp.c gdb/objc-exp.c gdb/p-exp.c
179
180 %patch100 -p1
181 %patch101 -p1
182 %patch102 -p1
183 %patch103 -p1
184 %patch104 -p1
185 %patch105 -p1
186 %patch110 -p1
187 %patch111 -p1
188 %patch112 -p1
189 %patch113 -p1
190 %patch114 -p1
191 %patch115 -p1
192
193 %patch1000 -p1
194 %patch1001 -p1
195 %patch1002 -p1
196 %patch1005 -p1
197 %patch1006 -p1
198
199 # Change the version that gets printed at GDB startup, so it is PLD Linux specific.
200 cat > gdb/version.in << EOF
201 %{version}-%{release} (PLD Linux)
202 EOF
203
204 sed -i -e 's#_GCC_AUTOCONF_VERSION\], \[2\.64\]#_GCC_AUTOCONF_VERSION], [2.69]#g' config/override.m4
205
206 %build
207 # omit hand-written gdb/testsuite aclocal.m4
208 for dir in gdb gdb/gdbserver ; do
209         olddir=$(pwd)
210         cd $dir
211         %{__rm} aclocal.m4
212         %{__aclocal} $(grep '^ACLOCAL_AMFLAGS' Makefile.in | sed -e 's/.*=//')
213         cd $olddir
214 done
215 for dir in $(find gdb -name 'configure.in' -o -name 'configure.ac'); do
216         dir=$(dirname "$dir")
217         olddir=$(pwd)
218         cd $dir
219         %{__autoconf}
220         grep -q AC_CONFIG_HEADER configure.* && %{__autoheader}
221         cd $olddir
222 done
223 cp -f /usr/share/automake/config.* .
224 # don't --enable-shared here, there would be libs version mismatch with binutils
225 %configure \
226         --with-gdb-datadir=%{_datadir}/gdb \
227         --with-separate-debug-dir=/usr/lib/debug \
228 %if %{with python}
229         --with-python=yes \
230         --with-pythondir=%{py_sitescriptdir} \
231 %else
232         --without-python \
233 %endif
234 %if %{with guile}
235         --with-guile \
236 %else
237         --without-guile \
238 %endif
239         --disable-gdbtk \
240         --disable-shared \
241         --enable-gdbcli \
242         --enable-gdbmi \
243         --enable-multi-ice \
244         --enable-netrom \
245         --enable-nls \
246         --enable-tui \
247         --with-system-readline \
248         --with-cpu=%{_target_cpu} \
249 %ifnarch alpha
250         --with-mmalloc \
251 %endif
252         --without-included-gettext \
253         --without-included-regex \
254         --without-x
255
256 %{__make}
257 %{__make} -j1 info
258
259 # gdb/ChangeLog: Build gdb directly from *.o files not using libgdb.a.
260 %{__make} -C gdb libgdb.a
261
262 %install
263 rm -rf $RPM_BUILD_ROOT
264 install -d $RPM_BUILD_ROOT%{_infodir}
265
266 %{__make} -j1 install install-info \
267         DESTDIR=$RPM_BUILD_ROOT
268
269 # gdbtui seems all identical to gdb except when invoked as gdbtio, ncurses
270 # window is created too.
271 echo ".so gdb.1" > $RPM_BUILD_ROOT%{_mandir}/man1/gdbtui.1
272 ln -f $RPM_BUILD_ROOT%{_bindir}/{gdb,gdbtui}
273
274 bzip2 -dc %{SOURCE1} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
275 cp -a gdb/libgdb.a $RPM_BUILD_ROOT%{_libdir}
276
277 rm -f $RPM_BUILD_ROOT%{_infodir}/dir
278 rm -f $RPM_BUILD_ROOT%{_mandir}/README.gdb-non-english-man-pages
279
280 %if %{with python}
281 # Temporarily now:
282 for LIB in lib lib64; do
283         LIBPATH="$RPM_BUILD_ROOT%{_datadir}/gdb/auto-load%{_prefix}/$LIB"
284         install -d $LIBPATH
285 done
286
287 %py_ocomp $RPM_BUILD_ROOT%{py_sitescriptdir}
288 %py_comp $RPM_BUILD_ROOT%{py_sitescriptdir}
289 %py_postclean
290 %endif
291
292 cp -a %{SOURCE3} $RPM_BUILD_ROOT%{_mandir}/man1/gstack.1
293
294 install libdecnumber/libdecnumber.a $RPM_BUILD_ROOT%{_libdir}
295
296 # Remove the files that are part of a gdb build but that are owned and provided by other packages.
297 # These are part of binutils:
298 %{__rm} $RPM_BUILD_ROOT%{_localedir}/*/LC_MESSAGES/{bfd,opcodes}.mo
299 %{__rm} $RPM_BUILD_ROOT%{_infodir}/{bfd,configure,standards}.info*
300 %{__rm} $RPM_BUILD_ROOT%{_includedir}/{ansidecl,bfd,bfdlink,dis-asm,symcat}.h
301 %{__rm} $RPM_BUILD_ROOT%{_libdir}/lib{bfd,opcodes}.la
302 %{__rm} $RPM_BUILD_ROOT%{_libdir}/lib{bfd,opcodes}.a
303
304 %clean
305 rm -rf $RPM_BUILD_ROOT
306
307 %post   -p /sbin/postshell
308 -/usr/sbin/fix-info-dir -c %{_infodir}
309
310 %postun -p /sbin/postshell
311 -/usr/sbin/fix-info-dir -c %{_infodir}
312
313 %files
314 %defattr(644,root,root,755)
315 %doc gdb/{ChangeLog,NEWS,PROBLEMS,README}
316 %attr(755,root,root) %{_bindir}/gdb
317 %attr(755,root,root) %{_bindir}/gdbtui
318 %attr(755,root,root) %{_bindir}/gdb-add-index
319 %attr(755,root,root) %{_bindir}/gstack
320 %attr(755,root,root) %{_bindir}/gcore
321 %dir %{_datadir}/gdb
322 %dir %{_datadir}/gdb/auto-load
323 %dir %{_datadir}/gdb/auto-load%{_prefix}
324 %dir %{_datadir}/gdb/auto-load%{_prefix}/lib
325 %ifarch %{x8664}
326 %dir %{_datadir}/gdb/auto-load%{_prefix}/lib64
327 %endif
328 %{?with_guile:%{_datadir}/gdb/guile}
329 %{_datadir}/gdb/syscalls
330 %{_datadir}/gdb/system-gdbinit
331 %{_datadir}/gdb/python
332 %{_mandir}/man1/gdb.1*
333 %{_mandir}/man1/gdbtui.1*
334 %{_mandir}/man1/gdb-add-index.1*
335 %{_mandir}/man1/gstack.1*
336 %{_mandir}/man1/gcore.1*
337 %{_mandir}/man5/gdbinit.5*
338 %lang(es) %{_mandir}/es/man1/*
339 %lang(fr) %{_mandir}/fr/man1/*
340 %lang(hu) %{_mandir}/hu/man1/*
341 %lang(ja) %{_mandir}/ja/man1/*
342 %lang(pl) %{_mandir}/pl/man1/*
343 %{_infodir}/annotate.info*
344 %{_infodir}/gdb.info*
345 %{_infodir}/stabs.info*
346
347 %files gdbserver
348 %defattr(644,root,root,755)
349 %attr(755,root,root) %{_bindir}/gdbserver
350 %{_mandir}/man1/gdbserver.1*
351 %attr(755,root,root) %{_libdir}/libinproctrace.so
352
353 %files lib
354 %defattr(644,root,root,755)
355 %{_libdir}/libdecnumber.a
356 %{_libdir}/libgdb.a
357 %{_includedir}/gdb
This page took 0.069751 seconds and 4 git commands to generate.