]> git.pld-linux.org Git - packages/gdb.git/blob - gdb.spec
- guile has been fixed in 10.x
[packages/gdb.git] / gdb.spec
1 # NOTE: -lib package is used by fpc.spec
2
3 # TODO
4 # - debuginfod (BR: elfutils-debuginfod-devel >= 0.179)
5 # - rpm5 librpm support (gdb/configure.ac checks for 4.x or so)
6 # - change install msg to poldek in buildid-locate-rpm-pld.patch when poldek allows it. LP#493922
7 #
8 # Conditional build:
9 %bcond_without  guile           # Guile embedded scripting
10 %bcond_without  python          # build without python support
11
12 Summary:        A GNU source-level debugger for C, C++ and Fortran
13 Summary(de.UTF-8):      Symbolischer Debugger für C und andere Sprachen
14 Summary(es.UTF-8):      Depurador de programas C y otras lenguajes
15 Summary(fr.UTF-8):      Débugger symbolique pour C et d'autres langages
16 Summary(pl.UTF-8):      Symboliczny odpluskwiacz dla C i innych języków
17 Summary(pt_BR.UTF-8):   Depurador de programas C e outras linguagens
18 Summary(ru.UTF-8):      Символический отладчик для C и других языков
19 Summary(tr.UTF-8):      C ve diğer diller için sembolik hata ayıklayıcı
20 Summary(uk.UTF-8):      Символьний відладчик для С та інших мов
21 Summary(zh_CN.UTF-8):   [开发]C和其他语言的调试器
22 Summary(zh_TW.UTF-8):   [.-A開發]C和.$)B其.-A他語.$)B言的調試器
23 Name:           gdb
24 Version:        12.1
25 Release:        1
26 License:        GPL v3+
27 Group:          Development/Debuggers
28 Source0:        https://ftp.gnu.org/gnu/gdb/%{name}-%{version}.tar.xz
29 # Source0-md5:  759a1b8d2b4d403367dd0e14fa04643d
30 Source1:        http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-non-english-man-pages.tar.bz2
31 # Source1-md5:  2e8a48939ae282c12bbacdd54e398247
32 Source3:        %{name}-gstack.man
33 Patch100:       gdb-6.6-buildid-locate.patch
34 Patch101:       gdb-6.6-buildid-locate-solib-missing-ids.patch
35 Patch102:       gdb-6.6-buildid-locate-rpm.patch
36 Patch104:       gdb-6.6-buildid-locate-rpm-librpm-workaround.patch
37 Patch105:       gdb-6.6-buildid-locate-misleading-warning-missing-debuginfo-rhbz981154.patch
38 Patch106:       gdb-6.6-buildid-locate-rpm-scl.patch
39 Patch110:       gdb-6.3-gstack-20050411.patch
40 Patch1000:      %{name}-readline.patch
41 Patch1001:      %{name}-info.patch
42 Patch1002:      %{name}-passflags.patch
43 Patch1003:      %{name}-readline8.2.patch
44 Patch1005:      %{name}-pretty-print-by-default.patch
45 Patch1006:      buildid-locate-rpm-pld.patch
46 URL:            http://www.gnu.org/software/gdb/
47 BuildRequires:  autoconf >= 2.69
48 BuildRequires:  automake
49 BuildRequires:  babeltrace-devel >= 1.1.0
50 BuildRequires:  bison
51 BuildRequires:  expat-devel
52 BuildRequires:  flex >= 2.6.4
53 BuildRequires:  gettext-tools >= 0.12.1
54 BuildRequires:  gmp-devel
55 %if %{with guile}
56 BuildRequires:  guile-devel >= 5:2.0
57 BuildRequires:  guile-devel < 5:3.2
58 %endif
59 %ifarch %{ix86} %{x8664}
60 BuildRequires:  libipt-devel
61 %endif
62 BuildRequires:  libmpc-devel
63 BuildRequires:  libselinux-devel
64 BuildRequires:  libstdc++-devel >= 6:4.8
65 BuildRequires:  libtool >= 2:2
66 BuildRequires:  make >= 3.81
67 BuildRequires:  mpfr-devel
68 BuildRequires:  ncurses-devel >= 5.2
69 BuildRequires:  pkgconfig
70 BuildRequires:  readline-devel
71 BuildRequires:  rpm-devel >= 4.6
72 BuildRequires:  rpmbuild(macros) >= 1.219
73 BuildRequires:  source-highlight-devel >= 3.0
74 BuildRequires:  tar >= 1:1.22
75 BuildRequires:  texinfo >= 4.4
76 BuildRequires:  xxHash-devel
77 BuildRequires:  xz
78 BuildRequires:  xz-devel
79 BuildRequires:  zlib-devel
80 %if %{with python}
81 BuildRequires:  python3-devel >= 1:3.2
82 BuildRequires:  rpm-pythonprov
83 Obsoletes:      python-gdb < 7.3
84 # for traceback module
85 Requires:       python3-modules >= 1:3.2
86 %endif
87 %{?with_guile:Requires: guile >= 2.0.12}
88 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
89
90 %define         autoconf_ver    %(rpm -q --qf='%%{VERSION}' autoconf)
91
92 %define         _noautostrip    .*%{_datadir}/gdb/guile/.*\.go
93
94 %description
95 Gdb is a full featured, command driven debugger. Gdb allows you to
96 trace the execution of programs and examine their internal state at
97 any time. Gdb works for C and C++ compiled with the GNU C compiler
98 gcc.
99
100 %description -l de.UTF-8
101 dem Sie die Ausführung von Programmen verfolgen und jederzeit den
102 inneren Zustand überprüfen können. Er funktioniert für C und mit GNU C
103 kompiliertes C++.
104
105 %description -l es.UTF-8
106 Este es un debugger orientado a comandos repleto de características.
107 Te permite rastrear la ejecución de programas y examinar su estado
108 interno a cualquier momento. Funciona para C y C++ compilado con el
109 compilador GNU C.
110
111 %description -l fr.UTF-8
112 Débugger complet, piloté par commandes. Permet de tracer l'exécution
113 des programmes et d'examiner à tout moment leur état interne.
114 Fonctionne avec les binaires C et C++ compilés avec le compilateur C
115 de GNU, gcc.
116
117 %description -l pl.UTF-8
118 Gdb jest rozbudowanym odpluskwiaczem (debuggerem), pozwalającym
119 śledzić wykonywanie programu i badać jego stan wewnętrzny. Gdb
120 umożliwia odpluskwianie programów napisanych w C/C++ i skompilowanych
121 przy pomocy kompilatora GNU (gcc).
122
123 %description -l pt_BR.UTF-8
124 Este é um debugger orientado a comandos repleto de características.
125 Ele permite à você rastrear a execução de programas e examinar o seu
126 estado interno a qualquer momento. Ele funciona para para C e C++
127 compilado com o compilador GNU C.
128
129 %description -l ru.UTF-8
130 Это полноценный отладчик, управляемый командами. Он позволяет
131 трассировать исполнение программ и изучать их внутреннее состояние в
132 любой момент времени. Работает с программами на C и C++,
133 скомпилированными GNU компилятором C (gcc, egcs, pgcc).
134
135 %description -l tr.UTF-8
136 Bir komut arayüzü üzerinden programcıya programını adım adım izleme
137 (trace) ve herhangi bir anda programın durumunu inceleme olanağı
138 verir.
139
140 %description -l uk.UTF-8
141 Це повноцінний відладчик, що керується командами. Він дозволяє
142 трасувати виконання програм та вивчати їх внутрішній стан в довільний
143 момент часу. Працює з програмами на C та C++, зкомпільованими
144 компіляторами GNU C (gcc, egcs, pgcc).
145
146 %package gdbserver
147 Summary:        A standalone server for GDB (the GNU source-level debugger)
148 Summary(pl.UTF-8):      Samodzielny serwer GDB (debuggera GNU)
149 Group:          Development/Debuggers
150
151 %description gdbserver
152 GDB, the GNU debugger, allows you to debug programs written in C, C++,
153 Java, and other languages, by executing them in a controlled fashion
154 and printing their data.
155
156 This package provides a program that allows you to run GDB on a
157 different machine than the one which is running the program being
158 debugged.
159
160 %description gdbserver -l pl.UTF-8
161 GDB (GNU debugger) pozwala śledzić programy napisane w C, C++, Javie i
162 innych językach programowania poprzez wykonywanie ich w sposób
163 kontrolowany oraz wypisywanie ich danych.
164
165 Ten pakiet zawiera program pozwalający uruchamiać GDB na innej
166 maszynie niż ta, na której działa śledzony program.
167
168 %package lib
169 Summary:        GDB in the form of a static library
170 Summary(pl.UTF-8):      GDB w postaci biblioteki statycznej
171 Group:          Development/Debuggers
172 # libraries that needs to be linked to fulfill libgdb.a symbol requirements
173 Requires:       binutils-devel >= 2.17.50
174 Requires:       expat-devel
175 Requires:       libselinux-devel
176 Requires:       libsepol-devel
177 Requires:       ncurses-devel
178 Requires:       python3-devel
179 Requires:       readline-devel
180 Requires:       xz-devel
181 Requires:       zlib-devel
182
183 %description lib
184 GDB in the form of a static library.
185
186 %description lib -l pl.UTF-8
187 GDB w postaci biblioteki statycznej.
188
189 %prep
190 %setup -q
191
192 # Files have `# <number> <file>' statements breaking VPATH / find-debuginfo.sh .
193 %{__rm} gdb/ada-exp.c gdb/ada-lex.c gdb/c-exp.c gdb/cp-name-parser.c gdb/f-exp.c
194 %{__rm} gdb/m2-exp.c gdb/p-exp.c
195
196 %patch100 -p1
197 %patch101 -p1
198 %patch102 -p1
199 %patch104 -p1
200 %patch105 -p1
201 %patch106 -p1
202 %patch110 -p1
203
204 %patch1000 -p1
205 %patch1001 -p1
206 %patch1002 -p1
207 %patch1003 -p1
208 %patch1005 -p1
209 %patch1006 -p1
210
211 # Change the version that gets printed at GDB startup, so it is PLD Linux specific.
212 cat > gdb/version.in << EOF
213 %{version}-%{release} (PLD Linux)
214 EOF
215
216 %{__sed} -i -e '1s,/usr/bin/python$,%{__python},' \
217       contrib/dg-extract-results.py \
218
219 %{__sed} -i -e '1s,/usr/bin/env python$,%{__python},' \
220       gdb/contrib/test_pubnames_and_indexes.py \
221       gdb/testsuite/print-ts.py
222
223 %{__sed} -i -e '1s,/usr/bin/env python3,%{__python3},' \
224       gdb/testsuite/analyze-racy-logs.py \
225       gdb/copyright.py
226
227 %{__sed} -i -e '1s,/usr/bin/env bash,/bin/bash,' \
228       gdb/contrib/cc-with-tweaks.sh \
229       gdb/gcore.in \
230       src-release.sh
231
232 sed -i -e 's/\[2\.69\]/[%{autoconf_ver}]/' config/override.m4
233
234 %build
235 # omit hand-written gdb/testsuite aclocal.m4
236 for dir in gdb gdbserver ; do
237         olddir=$(pwd)
238         cd $dir
239         %{__rm} aclocal.m4
240         %{__aclocal} $(grep '^ACLOCAL_AMFLAGS' Makefile.in | sed -e 's/.*=//')
241         cd $olddir
242 done
243 for dir in $(find gdb -name 'configure.in' -o -name 'configure.ac'); do
244         dir=$(dirname "$dir")
245         olddir=$(pwd)
246         cd $dir
247         %{__autoconf}
248         grep -q AC_CONFIG_HEADER configure.* && %{__autoheader}
249         cd $olddir
250 done
251 cp -f /usr/share/automake/config.* .
252 install -d build && cd build
253 # don't --enable-shared here, there would be libs version mismatch with binutils
254 ../%configure \
255         --disable-gdbtk \
256         --disable-shared \
257         --disable-silent-rules \
258         --enable-gdbcli \
259         --enable-gdbmi \
260         --enable-multi-ice \
261         --enable-netrom \
262         --enable-nls \
263         --enable-tui \
264         --with-cpu=%{_target_cpu} \
265         --with-gdb-datadir=%{_datadir}/gdb \
266         --with-guile%{!?with_guile:=no} \
267 %ifnarch alpha
268         --with-mmalloc \
269 %endif
270 %if %{with python}
271         --with-python="%{__python3}" \
272         --with-pythondir=%{py3_sitescriptdir} \
273 %else
274         --without-python \
275 %endif
276         --with-separate-debug-dir=/usr/lib/debug \
277         --with-system-readline \
278         --without-included-gettext \
279         --without-included-regex \
280         --without-x
281
282 # V=1 because only some subdirs honour --enable-silent-rules
283 %{__make} \
284         V=1
285
286 %{__make} -j1 info
287
288 # gdb/ChangeLog: Build gdb directly from *.o files not using libgdb.a.
289 %{__make} -C gdb libgdb.a \
290         V=1
291
292 %install
293 rm -rf $RPM_BUILD_ROOT
294 install -d $RPM_BUILD_ROOT%{_infodir}
295
296 %{__make} -C build -j1 install install-info \
297         DESTDIR=$RPM_BUILD_ROOT
298
299 cp -a build/gdb/libgdb.a $RPM_BUILD_ROOT%{_libdir}
300
301 # gdbtui seems all identical to gdb except when invoked as gdbtui, ncurses
302 # window is created too.
303 echo ".so gdb.1" > $RPM_BUILD_ROOT%{_mandir}/man1/gdbtui.1
304 ln -f $RPM_BUILD_ROOT%{_bindir}/{gdb,gdbtui}
305
306 bzip2 -dc %{SOURCE1} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
307 %{__rm} $RPM_BUILD_ROOT%{_mandir}/README.gdb-non-english-man-pages
308
309 rm -f $RPM_BUILD_ROOT%{_infodir}/dir
310
311 %if %{with python}
312 # Temporarily now:
313 for LIB in lib lib64 libx32; do
314         LIBPATH="$RPM_BUILD_ROOT%{_datadir}/gdb/auto-load%{_prefix}/$LIB"
315         install -d $LIBPATH
316 done
317
318 %py3_ocomp $RPM_BUILD_ROOT%{py3_sitescriptdir}
319 %py3_comp $RPM_BUILD_ROOT%{py3_sitescriptdir}
320 %endif
321
322 cp -a %{SOURCE3} $RPM_BUILD_ROOT%{_mandir}/man1/gstack.1
323
324 cp -p build/libdecnumber/libdecnumber.a $RPM_BUILD_ROOT%{_libdir}
325
326 # Remove the files that are part of a gdb build but that are owned and provided by other packages.
327 # These are part of binutils:
328 %{__rm} $RPM_BUILD_ROOT%{_localedir}/*/LC_MESSAGES/{bfd,opcodes}.mo
329 %{__rm} $RPM_BUILD_ROOT%{_infodir}/{bfd,ctf-spec}.info*
330 %{__rm} $RPM_BUILD_ROOT%{_includedir}/{ansidecl,bfd,bfdlink,ctf,ctf-api,diagnostics,dis-asm,symcat,plugin-api}.h
331 %{__rm} $RPM_BUILD_ROOT%{_libdir}/lib{bfd,ctf,ctf-nobfd,opcodes}.la
332 %{__rm} $RPM_BUILD_ROOT%{_libdir}/lib{bfd,ctf,ctf-nobfd,opcodes}.a
333
334 %clean
335 rm -rf $RPM_BUILD_ROOT
336
337 %post   -p /sbin/postshell
338 -/usr/sbin/fix-info-dir -c %{_infodir}
339
340 %postun -p /sbin/postshell
341 -/usr/sbin/fix-info-dir -c %{_infodir}
342
343 %files
344 %defattr(644,root,root,755)
345 %doc gdb/{NEWS,PROBLEMS,README}
346 %attr(755,root,root) %{_bindir}/gdb
347 %attr(755,root,root) %{_bindir}/gdbtui
348 %attr(755,root,root) %{_bindir}/gdb-add-index
349 %attr(755,root,root) %{_bindir}/gstack
350 %attr(755,root,root) %{_bindir}/gcore
351 %dir %{_datadir}/gdb
352 %dir %{_datadir}/gdb/auto-load
353 %dir %{_datadir}/gdb/auto-load%{_prefix}
354 %dir %{_datadir}/gdb/auto-load%{_prefix}/lib
355 %ifarch %{x8664} x32
356 %dir %{_datadir}/gdb/auto-load%{_prefix}/lib64
357 %dir %{_datadir}/gdb/auto-load%{_prefix}/libx32
358 %endif
359 %ifarch aarch64
360 %dir %{_datadir}/gdb/auto-load%{_prefix}/lib64
361 %endif
362 %{?with_guile:%{_datadir}/gdb/guile}
363 %{_datadir}/gdb/syscalls
364 %{_datadir}/gdb/system-gdbinit
365 %{_datadir}/gdb/python
366 %{_mandir}/man1/gdb.1*
367 %{_mandir}/man1/gdbtui.1*
368 %{_mandir}/man1/gdb-add-index.1*
369 %{_mandir}/man1/gstack.1*
370 %{_mandir}/man1/gcore.1*
371 %{_mandir}/man5/gdbinit.5*
372 %lang(es) %{_mandir}/es/man1/*
373 %lang(fr) %{_mandir}/fr/man1/*
374 %lang(hu) %{_mandir}/hu/man1/*
375 %lang(ja) %{_mandir}/ja/man1/*
376 %lang(pl) %{_mandir}/pl/man1/*
377 %{_infodir}/annotate.info*
378 %{_infodir}/gdb.info*
379 %{_infodir}/stabs.info*
380
381 %files gdbserver
382 %defattr(644,root,root,755)
383 %attr(755,root,root) %{_bindir}/gdbserver
384 %{_mandir}/man1/gdbserver.1*
385 %ifnarch %{arm}
386 %attr(755,root,root) %{_libdir}/libinproctrace.so
387 %endif
388
389 %files lib
390 %defattr(644,root,root,755)
391 %{_libdir}/libdecnumber.a
392 %{_libdir}/libgdb.a
393 %{_includedir}/gdb
This page took 0.063069 seconds and 4 git commands to generate.