]> git.pld-linux.org Git - packages/gdb.git/blob - gdb.spec
- drop libunwind BR, that library is not used anywhere in gdb
[packages/gdb.git] / gdb.spec
1 # NOTE: -lib package is used by fpc.spec
2
3 # TODO
4 # - change install msg to poldek in buildid-locate-rpm-pld.patch when poldek allows it. LP#493922
5 #
6 # Conditional build:
7 %bcond_without  guile           # Guile embedded scripting
8 %bcond_without  python          # build without python support
9
10 Summary:        A GNU source-level debugger for C, C++ and Fortran
11 Summary(de.UTF-8):      Symbolischer Debugger für C und andere Sprachen
12 Summary(es.UTF-8):      Depurador de programas C y otras lenguajes
13 Summary(fr.UTF-8):      Débugger symbolique pour C et d'autres langages
14 Summary(pl.UTF-8):      Symboliczny odpluskwiacz dla C i innych języków
15 Summary(pt_BR.UTF-8):   Depurador de programas C e outras linguagens
16 Summary(ru.UTF-8):      Символический отладчик для C и других языков
17 Summary(tr.UTF-8):      C ve diğer diller için sembolik hata ayıklayıcı
18 Summary(uk.UTF-8):      Символьний відладчик для С та інших мов
19 Summary(zh_CN.UTF-8):   [开发]C和其他语言的调试器
20 Summary(zh_TW.UTF-8):   [.-A開發]C和.$)B其.-A他語.$)B言的調試器
21 %define         snap    20120926
22 Name:           gdb
23 Version:        7.8.1
24 Release:        1
25 License:        GPL v3+
26 Group:          Development/Debuggers
27 Source0:        http://ftp.gnu.org/gnu/gdb/%{name}-%{version}.tar.xz
28 # Source0-md5:  8072be87a94be0936bc3b4b6941b0862
29 Source1:        http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-non-english-man-pages.tar.bz2
30 # Source1-md5:  2e8a48939ae282c12bbacdd54e398247
31 Source3:        %{name}-gstack.man
32 Patch100:       gdb-6.6-buildid-locate.patch
33 Patch101:       gdb-6.6-buildid-locate-solib-missing-ids.patch
34 Patch102:       gdb-6.6-buildid-locate-rpm.patch
35 Patch103:       gdb-6.6-buildid-locate-core-as-arg.patch
36 Patch104:       gdb-6.6-buildid-locate-rpm-librpm-workaround.patch
37 Patch105:       gdb-6.6-buildid-locate-misleading-warning-missing-debuginfo-rhbz981154.patch
38 Patch110:       gdb-6.3-gstack-20050411.patch
39 Patch111:       gdb-gdb-add-index-script.patch
40 Patch112:       gdb-archer-vla-tests.patch
41 Patch113:       gdb-vla-intel.patch
42 Patch114:       gdb-vla-intel-04of23-fix.patch
43 Patch115:       gdb-vla-intel-stringbt-fix.patch
44 Patch1000:      %{name}-readline.patch
45 Patch1001:      %{name}-info.patch
46 Patch1002:      %{name}-passflags.patch
47 Patch1005:      %{name}-pretty-print-by-default.patch
48 Patch1006:      buildid-locate-rpm-pld.patch
49 URL:            http://www.gnu.org/software/gdb/
50 BuildRequires:  autoconf >= 2.69
51 BuildRequires:  automake
52 BuildRequires:  bison
53 BuildRequires:  babeltrace-devel
54 BuildRequires:  expat-devel
55 BuildRequires:  flex
56 BuildRequires:  gettext-tools
57 %{?with_guile:BuildRequires:    guile-devel >= 2.0}
58 BuildRequires:  libselinux-devel
59 BuildRequires:  libtool
60 BuildRequires:  ncurses-devel >= 5.2
61 BuildRequires:  pkgconfig
62 BuildRequires:  readline-devel
63 BuildRequires:  rpmbuild(macros) >= 1.219
64 BuildRequires:  texinfo >= 4.4
65 BuildRequires:  zlib-devel
66 %if %{with python}
67 BuildRequires:  python-devel
68 BuildRequires:  rpm-pythonprov
69 Obsoletes:      python-gdb
70 # for traceback module
71 Requires:       python-modules
72 %endif
73 Requires:       libunwind >= 0.97
74 %{?with_guile:Requires: guile >= 2.0}
75 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
76
77 %description
78 Gdb is a full featured, command driven debugger. Gdb allows you to
79 trace the execution of programs and examine their internal state at
80 any time. Gdb works for C and C++ compiled with the GNU C compiler
81 gcc.
82
83 %description -l de.UTF-8
84 dem Sie die Ausführung von Programmen verfolgen und jederzeit den
85 inneren Zustand überprüfen können. Er funktioniert für C und mit GNU C
86 kompiliertes C++.
87
88 %description -l es.UTF-8
89 Este es un debugger orientado a comandos repleto de características.
90 Te permite rastrear la ejecución de programas y examinar su estado
91 interno a cualquier momento. Funciona para C y C++ compilado con el
92 compilador GNU C.
93
94 %description -l fr.UTF-8
95 Débugger complet, piloté par commandes. Permet de tracer l'exécution
96 des programmes et d'examiner à tout moment leur état interne.
97 Fonctionne avec les binaires C et C++ compilés avec le compilateur C
98 de GNU, gcc.
99
100 %description -l pl.UTF-8
101 Gdb jest rozbudowanym odpluskwiaczem (debuggerem), pozwalającym
102 śledzić wykonywanie programu i badać jego stan wewnętrzny. Gdb
103 umożliwia odpluskwianie programów napisanych w C/C++ i skompilowanych
104 przy pomocy kompilatora GNU (gcc).
105
106 %description -l pt_BR.UTF-8
107 Este é um debugger orientado a comandos repleto de características.
108 Ele permite à você rastrear a execução de programas e examinar o seu
109 estado interno a qualquer momento. Ele funciona para para C e C++
110 compilado com o compilador GNU C.
111
112 %description -l ru.UTF-8
113 Это полноценный отладчик, управляемый командами. Он позволяет
114 трассировать исполнение программ и изучать их внутреннее состояние в
115 любой момент времени. Работает с программами на C и C++,
116 скомпилированными GNU компилятором C (gcc, egcs, pgcc).
117
118 %description -l tr.UTF-8
119 Bir komut arayüzü üzerinden programcıya programını adım adım izleme
120 (trace) ve herhangi bir anda programın durumunu inceleme olanağı
121 verir.
122
123 %description -l uk.UTF-8
124 Це повноцінний відладчик, що керується командами. Він дозволяє
125 трасувати виконання програм та вивчати їх внутрішній стан в довільний
126 момент часу. Працює з програмами на C та C++, зкомпільованими
127 компіляторами GNU C (gcc, egcs, pgcc).
128
129 %package gdbserver
130 Summary:        A standalone server for GDB (the GNU source-level debugger)
131 Summary(pl.UTF-8):      Samodzielny serwer GDB (debuggera GNU)
132 Group:          Development/Debuggers
133
134 %description gdbserver
135 GDB, the GNU debugger, allows you to debug programs written in C, C++,
136 Java, and other languages, by executing them in a controlled fashion
137 and printing their data.
138
139 This package provides a program that allows you to run GDB on a
140 different machine than the one which is running the program being
141 debugged.
142
143 %description gdbserver -l pl.UTF-8
144 GDB (GNU debugger) pozwala śledzić programy napisane w C, C++, Javie i
145 innych językach programowania poprzez wykonywanie ich w sposób
146 kontrolowany oraz wypisywanie ich danych.
147
148 Ten pakiet zawiera program pozwalający uruchamiać GDB na innej
149 maszynie niż ta, na której działa śledzony program.
150
151 %package lib
152 Summary:        GDB in the form of a static library
153 Summary(pl.UTF-8):      GDB w postaci biblioteki statycznej
154 Group:          Development/Debuggers
155 # libraries that needs to be linked to fulfill libgdb.a symbol requirements
156 Requires:       binutils-devel >= 2.17.50
157 Requires:       expat-devel
158 Requires:       libselinux-devel
159 Requires:       libsepol-devel
160 Requires:       ncurses-devel
161 Requires:       python-devel
162 Requires:       readline-devel
163 Requires:       xz-devel
164 Requires:       zlib-devel
165
166 %description lib
167 GDB in the form of a static library.
168
169 %description lib -l pl.UTF-8
170 GDB w postaci biblioteki statycznej.
171
172 %prep
173 %setup -q
174
175 # Files have `# <number> <file>' statements breaking VPATH / find-debuginfo.sh .
176 rm -f gdb/ada-exp.c gdb/ada-lex.c gdb/c-exp.c gdb/cp-name-parser.c gdb/f-exp.c
177 rm -f gdb/jv-exp.c gdb/m2-exp.c gdb/objc-exp.c gdb/p-exp.c
178
179 %patch100 -p1
180 %patch101 -p1
181 %patch102 -p1
182 %patch103 -p1
183 %patch104 -p1
184 %patch105 -p1
185 %patch110 -p1
186 %patch111 -p1
187 %patch112 -p1
188 %patch113 -p1
189 %patch114 -p1
190 %patch115 -p1
191
192 %patch1000 -p1
193 %patch1001 -p1
194 %patch1002 -p1
195 %patch1005 -p1
196 %patch1006 -p1
197
198 # Change the version that gets printed at GDB startup, so it is PLD Linux specific.
199 cat > gdb/version.in << EOF
200 %{version}-%{release} (PLD Linux)
201 EOF
202
203 sed -i -e 's#_GCC_AUTOCONF_VERSION\], \[2\.64\]#_GCC_AUTOCONF_VERSION], [2.69]#g' config/override.m4
204
205 %build
206 # omit hand-written gdb/testsuite aclocal.m4
207 for dir in gdb gdb/gdbserver ; do
208         olddir=$(pwd)
209         cd $dir
210         %{__rm} aclocal.m4
211         %{__aclocal} $(grep '^ACLOCAL_AMFLAGS' Makefile.in | sed -e 's/.*=//')
212         cd $olddir
213 done
214 for dir in $(find gdb -name 'configure.in' -o -name 'configure.ac'); do
215         dir=$(dirname "$dir")
216         olddir=$(pwd)
217         cd $dir
218         %{__autoconf}
219         grep -q AC_CONFIG_HEADER configure.* && %{__autoheader}
220         cd $olddir
221 done
222 cp -f /usr/share/automake/config.* .
223 # don't --enable-shared here, there would be libs version mismatch with binutils
224 %configure \
225         --with-gdb-datadir=%{_datadir}/gdb \
226         --with-separate-debug-dir=/usr/lib/debug \
227 %if %{with python}
228         --with-python=yes \
229         --with-pythondir=%{py_sitescriptdir} \
230 %else
231         --without-python \
232 %endif
233 %if %{with guile}
234         --with-guile \
235 %else
236         --without-guile \
237 %endif
238         --disable-gdbtk \
239         --disable-shared \
240         --enable-gdbcli \
241         --enable-gdbmi \
242         --enable-multi-ice \
243         --enable-netrom \
244         --enable-nls \
245         --enable-tui \
246         --with-system-readline \
247         --with-cpu=%{_target_cpu} \
248 %ifnarch alpha
249         --with-mmalloc \
250 %endif
251         --without-included-gettext \
252         --without-included-regex \
253         --without-x
254
255 %{__make}
256 %{__make} -j1 info
257
258 # gdb/ChangeLog: Build gdb directly from *.o files not using libgdb.a.
259 %{__make} -C gdb libgdb.a
260
261 %install
262 rm -rf $RPM_BUILD_ROOT
263 install -d $RPM_BUILD_ROOT%{_infodir}
264
265 %{__make} -j1 install install-info \
266         DESTDIR=$RPM_BUILD_ROOT
267
268 # gdbtui seems all identical to gdb except when invoked as gdbtio, ncurses
269 # window is created too.
270 echo ".so gdb.1" > $RPM_BUILD_ROOT%{_mandir}/man1/gdbtui.1
271 ln -f $RPM_BUILD_ROOT%{_bindir}/{gdb,gdbtui}
272
273 bzip2 -dc %{SOURCE1} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
274 cp -a gdb/libgdb.a $RPM_BUILD_ROOT%{_libdir}
275
276 rm -f $RPM_BUILD_ROOT%{_infodir}/dir
277 rm -f $RPM_BUILD_ROOT%{_mandir}/README.gdb-non-english-man-pages
278
279 %if %{with python}
280 # Temporarily now:
281 for LIB in lib lib64; do
282         LIBPATH="$RPM_BUILD_ROOT%{_datadir}/gdb/auto-load%{_prefix}/$LIB"
283         install -d $LIBPATH
284 done
285
286 %py_ocomp $RPM_BUILD_ROOT%{py_sitescriptdir}
287 %py_comp $RPM_BUILD_ROOT%{py_sitescriptdir}
288 %py_postclean
289 %endif
290
291 cp -a %{SOURCE3} $RPM_BUILD_ROOT%{_mandir}/man1/gstack.1
292
293 install libdecnumber/libdecnumber.a $RPM_BUILD_ROOT%{_libdir}
294
295 # Remove the files that are part of a gdb build but that are owned and provided by other packages.
296 # These are part of binutils:
297 %{__rm} $RPM_BUILD_ROOT%{_localedir}/*/LC_MESSAGES/{bfd,opcodes}.mo
298 %{__rm} $RPM_BUILD_ROOT%{_infodir}/{bfd,configure,standards}.info*
299 %{__rm} $RPM_BUILD_ROOT%{_includedir}/{ansidecl,bfd,bfdlink,dis-asm,symcat}.h
300 %{__rm} $RPM_BUILD_ROOT%{_libdir}/lib{bfd,opcodes}.la
301 %{__rm} $RPM_BUILD_ROOT%{_libdir}/lib{bfd,opcodes}.a
302
303 %clean
304 rm -rf $RPM_BUILD_ROOT
305
306 %post   -p /sbin/postshell
307 -/usr/sbin/fix-info-dir -c %{_infodir}
308
309 %postun -p /sbin/postshell
310 -/usr/sbin/fix-info-dir -c %{_infodir}
311
312 %files
313 %defattr(644,root,root,755)
314 %doc gdb/{ChangeLog,NEWS,PROBLEMS,README}
315 %attr(755,root,root) %{_bindir}/gdb
316 %attr(755,root,root) %{_bindir}/gdbtui
317 %attr(755,root,root) %{_bindir}/gdb-add-index
318 %attr(755,root,root) %{_bindir}/gstack
319 %attr(755,root,root) %{_bindir}/gcore
320 %dir %{_datadir}/gdb
321 %dir %{_datadir}/gdb/auto-load
322 %dir %{_datadir}/gdb/auto-load%{_prefix}
323 %dir %{_datadir}/gdb/auto-load%{_prefix}/lib
324 %ifarch %{x8664}
325 %dir %{_datadir}/gdb/auto-load%{_prefix}/lib64
326 %endif
327 %{?with_guile:%{_datadir}/gdb/guile}
328 %{_datadir}/gdb/syscalls
329 %{_datadir}/gdb/system-gdbinit
330 %{_datadir}/gdb/python
331 %{_mandir}/man1/gdb.1*
332 %{_mandir}/man1/gdbtui.1*
333 %{_mandir}/man1/gdb-add-index.1*
334 %{_mandir}/man1/gstack.1*
335 %{_mandir}/man1/gcore.1*
336 %{_mandir}/man5/gdbinit.5*
337 %lang(es) %{_mandir}/es/man1/*
338 %lang(fr) %{_mandir}/fr/man1/*
339 %lang(hu) %{_mandir}/hu/man1/*
340 %lang(ja) %{_mandir}/ja/man1/*
341 %lang(pl) %{_mandir}/pl/man1/*
342 %{_infodir}/annotate.info*
343 %{_infodir}/gdb.info*
344 %{_infodir}/stabs.info*
345
346 %files gdbserver
347 %defattr(644,root,root,755)
348 %attr(755,root,root) %{_bindir}/gdbserver
349 %{_mandir}/man1/gdbserver.1*
350 %attr(755,root,root) %{_libdir}/libinproctrace.so
351
352 %files lib
353 %defattr(644,root,root,755)
354 %{_libdir}/libdecnumber.a
355 %{_libdir}/libgdb.a
356 %{_includedir}/gdb
This page took 0.146861 seconds and 4 git commands to generate.