]> git.pld-linux.org Git - packages/gdb.git/blob - gdb.spec
- make building with guile support deterministic
[packages/gdb.git] / gdb.spec
1 # NOTE: -lib package is used by fpc.spec
2
3 # TODO
4 # - change install msg to poldek in buildid-locate-rpm-pld.patch when poldek allows it. LP#493922
5 #
6 # Conditional build:
7 %bcond_without  guile           # Guile embedded scripting
8 %bcond_without  python          # build without python support
9
10 Summary:        A GNU source-level debugger for C, C++ and Fortran
11 Summary(de.UTF-8):      Symbolischer Debugger für C und andere Sprachen
12 Summary(es.UTF-8):      Depurador de programas C y otras lenguajes
13 Summary(fr.UTF-8):      Débugger symbolique pour C et d'autres langages
14 Summary(pl.UTF-8):      Symboliczny odpluskwiacz dla C i innych języków
15 Summary(pt_BR.UTF-8):   Depurador de programas C e outras linguagens
16 Summary(ru.UTF-8):      Символический отладчик для C и других языков
17 Summary(tr.UTF-8):      C ve diğer diller için sembolik hata ayıklayıcı
18 Summary(uk.UTF-8):      Символьний відладчик для С та інших мов
19 Summary(zh_CN.UTF-8):   [开发]C和其他语言的调试器
20 Summary(zh_TW.UTF-8):   [.-A開發]C和.$)B其.-A他語.$)B言的調試器
21 %define         snap    20120926
22 Name:           gdb
23 Version:        7.8
24 Release:        1
25 License:        GPL v3+
26 Group:          Development/Debuggers
27 Source0:        http://ftp.gnu.org/gnu/gdb/%{name}-%{version}.tar.xz
28 # Source0-md5:  bd958fe9019d7c7896f29f6724a764ed
29 Source1:        http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-non-english-man-pages.tar.bz2
30 # Source1-md5:  2e8a48939ae282c12bbacdd54e398247
31 Source3:        %{name}-gstack.man
32 Patch100:       gdb-6.6-buildid-locate.patch
33 Patch101:       gdb-6.6-buildid-locate-solib-missing-ids.patch
34 Patch102:       gdb-6.6-buildid-locate-rpm.patch
35 Patch103:       gdb-6.6-buildid-locate-core-as-arg.patch
36 Patch104:       gdb-6.6-buildid-locate-rpm-librpm-workaround.patch
37 Patch105:       gdb-6.6-buildid-locate-misleading-warning-missing-debuginfo-rhbz981154.patch
38 Patch110:       gdb-6.3-gstack-20050411.patch
39 Patch111:       gdb-gdb-add-index-script.patch
40 Patch112:       gdb-archer-vla-tests.patch
41 Patch113:       gdb-vla-intel.patch
42 Patch114:       gdb-vla-intel-04of23-fix.patch
43 Patch115:       gdb-vla-intel-stringbt-fix.patch
44 Patch1000:      %{name}-readline.patch
45 Patch1001:      %{name}-info.patch
46 Patch1002:      %{name}-passflags.patch
47 Patch1005:      %{name}-pretty-print-by-default.patch
48 Patch1006:      buildid-locate-rpm-pld.patch
49 URL:            http://www.gnu.org/software/gdb/
50 BuildRequires:  autoconf >= 2.69
51 BuildRequires:  automake
52 BuildRequires:  bison
53 BuildRequires:  expat-devel
54 BuildRequires:  flex
55 BuildRequires:  gettext-devel
56 %{?with_guile:BuildRequires:    guile-devel >= 2.0}
57 BuildRequires:  libselinux-devel
58 BuildRequires:  libtool
59 BuildRequires:  libunwind-devel >= 0.97
60 BuildRequires:  ncurses-devel >= 5.2
61 BuildRequires:  pkgconfig
62 BuildRequires:  readline-devel
63 BuildRequires:  rpmbuild(macros) >= 1.219
64 BuildRequires:  texinfo >= 4.4
65 BuildRequires:  zlib-devel
66 %if %{with python}
67 BuildRequires:  python-devel
68 BuildRequires:  rpm-pythonprov
69 Obsoletes:      python-gdb
70 # for traceback module
71 Requires:       python-modules
72 %endif
73 Requires:       libunwind >= 0.97
74 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
75
76 %description
77 Gdb is a full featured, command driven debugger. Gdb allows you to
78 trace the execution of programs and examine their internal state at
79 any time. Gdb works for C and C++ compiled with the GNU C compiler
80 gcc.
81
82 %description -l de.UTF-8
83 dem Sie die Ausführung von Programmen verfolgen und jederzeit den
84 inneren Zustand überprüfen können. Er funktioniert für C und mit GNU C
85 kompiliertes C++.
86
87 %description -l es.UTF-8
88 Este es un debugger orientado a comandos repleto de características.
89 Te permite rastrear la ejecución de programas y examinar su estado
90 interno a cualquier momento. Funciona para C y C++ compilado con el
91 compilador GNU C.
92
93 %description -l fr.UTF-8
94 Débugger complet, piloté par commandes. Permet de tracer l'exécution
95 des programmes et d'examiner à tout moment leur état interne.
96 Fonctionne avec les binaires C et C++ compilés avec le compilateur C
97 de GNU, gcc.
98
99 %description -l pl.UTF-8
100 Gdb jest rozbudowanym odpluskwiaczem (debuggerem), pozwalającym
101 śledzić wykonywanie programu i badać jego stan wewnętrzny. Gdb
102 umożliwia odpluskwianie programów napisanych w C/C++ i skompilowanych
103 przy pomocy kompilatora GNU (gcc).
104
105 %description -l pt_BR.UTF-8
106 Este é um debugger orientado a comandos repleto de características.
107 Ele permite à você rastrear a execução de programas e examinar o seu
108 estado interno a qualquer momento. Ele funciona para para C e C++
109 compilado com o compilador GNU C.
110
111 %description -l ru.UTF-8
112 Это полноценный отладчик, управляемый командами. Он позволяет
113 трассировать исполнение программ и изучать их внутреннее состояние в
114 любой момент времени. Работает с программами на C и C++,
115 скомпилированными GNU компилятором C (gcc, egcs, pgcc).
116
117 %description -l tr.UTF-8
118 Bir komut arayüzü üzerinden programcıya programını adım adım izleme
119 (trace) ve herhangi bir anda programın durumunu inceleme olanağı
120 verir.
121
122 %description -l uk.UTF-8
123 Це повноцінний відладчик, що керується командами. Він дозволяє
124 трасувати виконання програм та вивчати їх внутрішній стан в довільний
125 момент часу. Працює з програмами на C та C++, зкомпільованими
126 компіляторами GNU C (gcc, egcs, pgcc).
127
128 %package gdbserver
129 Summary:        A standalone server for GDB (the GNU source-level debugger)
130 Summary(pl.UTF-8):      Samodzielny serwer GDB (debuggera GNU)
131 Group:          Development/Debuggers
132
133 %description gdbserver
134 GDB, the GNU debugger, allows you to debug programs written in C, C++,
135 Java, and other languages, by executing them in a controlled fashion
136 and printing their data.
137
138 This package provides a program that allows you to run GDB on a
139 different machine than the one which is running the program being
140 debugged.
141
142 %description gdbserver -l pl.UTF-8
143 GDB (GNU debugger) pozwala śledzić programy napisane w C, C++, Javie i
144 innych językach programowania poprzez wykonywanie ich w sposób
145 kontrolowany oraz wypisywanie ich danych.
146
147 Ten pakiet zawiera program pozwalający uruchamiać GDB na innej
148 maszynie niż ta, na której działa śledzony program.
149
150 %package lib
151 Summary:        GDB in the form of a static library
152 Summary(pl.UTF-8):      GDB w postaci biblioteki statycznej
153 Group:          Development/Debuggers
154 # libraries that needs to be linked to fulfill libgdb.a symbol requirements
155 Requires:       binutils-devel >= 2.17.50
156 Requires:       expat-devel
157 Requires:       libselinux-devel
158 Requires:       libsepol-devel
159 Requires:       ncurses-devel
160 Requires:       python-devel
161 Requires:       readline-devel
162 Requires:       xz-devel
163 Requires:       zlib-devel
164
165 %description lib
166 GDB in the form of a static library.
167
168 %description lib -l pl.UTF-8
169 GDB w postaci biblioteki statycznej.
170
171 %prep
172 %setup -q
173
174 # Files have `# <number> <file>' statements breaking VPATH / find-debuginfo.sh .
175 rm -f gdb/ada-exp.c gdb/ada-lex.c gdb/c-exp.c gdb/cp-name-parser.c gdb/f-exp.c
176 rm -f gdb/jv-exp.c gdb/m2-exp.c gdb/objc-exp.c gdb/p-exp.c
177
178 %patch100 -p1
179 %patch101 -p1
180 %patch102 -p1
181 %patch103 -p1
182 %patch104 -p1
183 %patch105 -p1
184 %patch110 -p1
185 %patch111 -p1
186 %patch112 -p1
187 %patch113 -p1
188 %patch114 -p1
189 %patch115 -p1
190
191 %patch1000 -p1
192 %patch1001 -p1
193 %patch1002 -p1
194 %patch1005 -p1
195 %patch1006 -p1
196
197 # Change the version that gets printed at GDB startup, so it is PLD Linux specific.
198 cat > gdb/version.in << EOF
199 %{version}-%{release} (PLD Linux)
200 EOF
201
202 sed -i -e 's#_GCC_AUTOCONF_VERSION\], \[2\.64\]#_GCC_AUTOCONF_VERSION], [2.69]#g' config/override.m4
203
204 %build
205 # omit hand-written gdb/testsuite aclocal.m4
206 for dir in gdb gdb/gdbserver ; do
207         olddir=$(pwd)
208         cd $dir
209         %{__rm} aclocal.m4
210         %{__aclocal} $(grep '^ACLOCAL_AMFLAGS' Makefile.in | sed -e 's/.*=//')
211         cd $olddir
212 done
213 for dir in $(find gdb -name 'configure.in' -o -name 'configure.ac'); do
214         dir=$(dirname "$dir")
215         olddir=$(pwd)
216         cd $dir
217         %{__autoconf}
218         grep -q AC_CONFIG_HEADER configure.* && %{__autoheader}
219         cd $olddir
220 done
221 cp -f /usr/share/automake/config.* .
222 # don't --enable-shared here, there would be libs version mismatch with binutils
223 %configure \
224         --with-gdb-datadir=%{_datadir}/gdb \
225         --with-separate-debug-dir=/usr/lib/debug \
226 %if %{with python}
227         --with-python=yes \
228         --with-pythondir=%{py_sitescriptdir} \
229 %else
230         --without-python \
231 %endif
232 %if %{with guile}
233         --with-guile \
234 %else
235         --without-guile \
236 %endif
237         --disable-gdbtk \
238         --disable-shared \
239         --enable-gdbcli \
240         --enable-gdbmi \
241         --enable-multi-ice \
242         --enable-netrom \
243         --enable-nls \
244         --enable-tui \
245         --with-system-readline \
246         --with-cpu=%{_target_cpu} \
247 %ifnarch alpha
248         --with-mmalloc \
249 %endif
250         --without-included-gettext \
251         --without-included-regex \
252         --without-x
253
254 %{__make}
255 %{__make} -j1 info
256
257 # gdb/ChangeLog: Build gdb directly from *.o files not using libgdb.a.
258 %{__make} -C gdb libgdb.a
259
260 %install
261 rm -rf $RPM_BUILD_ROOT
262 install -d $RPM_BUILD_ROOT%{_infodir}
263
264 %{__make} -j1 install install-info \
265         DESTDIR=$RPM_BUILD_ROOT
266
267 # gdbtui seems all identical to gdb except when invoked as gdbtio, ncurses
268 # window is created too.
269 echo ".so gdb.1" > $RPM_BUILD_ROOT%{_mandir}/man1/gdbtui.1
270 ln -f $RPM_BUILD_ROOT%{_bindir}/{gdb,gdbtui}
271
272 bzip2 -dc %{SOURCE1} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
273 cp -a gdb/libgdb.a $RPM_BUILD_ROOT%{_libdir}
274
275 rm -f $RPM_BUILD_ROOT%{_infodir}/dir
276 rm -f $RPM_BUILD_ROOT%{_mandir}/README.gdb-non-english-man-pages
277
278 %if %{with python}
279 # Temporarily now:
280 for LIB in lib lib64; do
281         LIBPATH="$RPM_BUILD_ROOT%{_datadir}/gdb/auto-load%{_prefix}/$LIB"
282         install -d $LIBPATH
283 done
284
285 %py_ocomp $RPM_BUILD_ROOT%{py_sitescriptdir}
286 %py_comp $RPM_BUILD_ROOT%{py_sitescriptdir}
287 %py_postclean
288 %endif
289
290 cp -a %{SOURCE3} $RPM_BUILD_ROOT%{_mandir}/man1/gstack.1
291
292 install libdecnumber/libdecnumber.a $RPM_BUILD_ROOT%{_libdir}
293
294 # Remove the files that are part of a gdb build but that are owned and provided by other packages.
295 # These are part of binutils:
296 %{__rm} $RPM_BUILD_ROOT%{_localedir}/*/LC_MESSAGES/{bfd,opcodes}.mo
297 %{__rm} $RPM_BUILD_ROOT%{_infodir}/{bfd,configure,standards}.info*
298 %{__rm} $RPM_BUILD_ROOT%{_includedir}/{ansidecl,bfd,bfdlink,dis-asm,symcat}.h
299 %{__rm} $RPM_BUILD_ROOT%{_libdir}/lib{bfd,opcodes}.la
300 %{__rm} $RPM_BUILD_ROOT%{_libdir}/lib{bfd,opcodes}.a
301
302 %clean
303 rm -rf $RPM_BUILD_ROOT
304
305 %post   -p /sbin/postshell
306 -/usr/sbin/fix-info-dir -c %{_infodir}
307
308 %postun -p /sbin/postshell
309 -/usr/sbin/fix-info-dir -c %{_infodir}
310
311 %files
312 %defattr(644,root,root,755)
313 %doc gdb/{ChangeLog,NEWS,PROBLEMS,README}
314 %attr(755,root,root) %{_bindir}/gdb
315 %attr(755,root,root) %{_bindir}/gdbtui
316 %attr(755,root,root) %{_bindir}/gdb-add-index
317 %attr(755,root,root) %{_bindir}/gstack
318 %attr(755,root,root) %{_bindir}/gcore
319 %dir %{_datadir}/gdb
320 %dir %{_datadir}/gdb/auto-load
321 %dir %{_datadir}/gdb/auto-load%{_prefix}
322 %dir %{_datadir}/gdb/auto-load%{_prefix}/lib
323 %ifarch %{x8664}
324 %dir %{_datadir}/gdb/auto-load%{_prefix}/lib64
325 %endif
326 %{?with_guile:%{_datadir}/gdb/guile}
327 %{_datadir}/gdb/syscalls
328 %{_datadir}/gdb/system-gdbinit
329 %{_datadir}/gdb/python
330 %{_mandir}/man1/gdb.1*
331 %{_mandir}/man1/gdbtui.1*
332 %{_mandir}/man1/gdb-add-index.1*
333 %{_mandir}/man1/gstack.1*
334 %{_mandir}/man1/gcore.1*
335 %{_mandir}/man5/gdbinit.5*
336 %lang(es) %{_mandir}/es/man1/*
337 %lang(fr) %{_mandir}/fr/man1/*
338 %lang(hu) %{_mandir}/hu/man1/*
339 %lang(ja) %{_mandir}/ja/man1/*
340 %lang(pl) %{_mandir}/pl/man1/*
341 %{_infodir}/annotate.info*
342 %{_infodir}/gdb.info*
343 %{_infodir}/stabs.info*
344
345 %files gdbserver
346 %defattr(644,root,root,755)
347 %attr(755,root,root) %{_bindir}/gdbserver
348 %{_mandir}/man1/gdbserver.1*
349 %attr(755,root,root) %{_libdir}/libinproctrace.so
350
351 %files lib
352 %defattr(644,root,root,755)
353 %{_libdir}/libdecnumber.a
354 %{_libdir}/libgdb.a
355 %{_includedir}/gdb
This page took 0.059663 seconds and 4 git commands to generate.