]> git.pld-linux.org Git - packages/gdb.git/blob - gdb.spec
R: guile with scm_set_automatic_finalization_enabled
[packages/gdb.git] / gdb.spec
1 # NOTE: -lib package is used by fpc.spec
2
3 # TODO
4 # - rpm5 librpm support (gdb/configure.ac checks for 4.x or so)
5 # - change install msg to poldek in buildid-locate-rpm-pld.patch when poldek allows it. LP#493922
6 #
7 # Conditional build:
8 %bcond_without  guile           # Guile embedded scripting
9 %bcond_without  python          # build without python support
10
11 Summary:        A GNU source-level debugger for C, C++ and Fortran
12 Summary(de.UTF-8):      Symbolischer Debugger für C und andere Sprachen
13 Summary(es.UTF-8):      Depurador de programas C y otras lenguajes
14 Summary(fr.UTF-8):      Débugger symbolique pour C et d'autres langages
15 Summary(pl.UTF-8):      Symboliczny odpluskwiacz dla C i innych języków
16 Summary(pt_BR.UTF-8):   Depurador de programas C e outras linguagens
17 Summary(ru.UTF-8):      Символический отладчик для C и других языков
18 Summary(tr.UTF-8):      C ve diğer diller için sembolik hata ayıklayıcı
19 Summary(uk.UTF-8):      Символьний відладчик для С та інших мов
20 Summary(zh_CN.UTF-8):   [开发]C和其他语言的调试器
21 Summary(zh_TW.UTF-8):   [.-A開發]C和.$)B其.-A他語.$)B言的調試器
22 %define         snap    20120926
23 Name:           gdb
24 Version:        8.0
25 Release:        1
26 License:        GPL v3+
27 Group:          Development/Debuggers
28 Source0:        http://ftp.gnu.org/gnu/gdb/%{name}-%{version}.tar.xz
29 # Source0-md5:  c3d35cd949084be53b92cc1e03485f88
30 Source1:        http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-non-english-man-pages.tar.bz2
31 # Source1-md5:  2e8a48939ae282c12bbacdd54e398247
32 Source3:        %{name}-gstack.man
33 Patch0:         x32.patch
34 Patch100:       gdb-6.6-buildid-locate.patch
35 Patch101:       gdb-6.6-buildid-locate-solib-missing-ids.patch
36 Patch102:       gdb-6.6-buildid-locate-rpm.patch
37 Patch103:       gdb-6.6-buildid-locate-core-as-arg.patch
38 Patch104:       gdb-6.6-buildid-locate-rpm-librpm-workaround.patch
39 Patch105:       gdb-6.6-buildid-locate-misleading-warning-missing-debuginfo-rhbz981154.patch
40 Patch106:       gdb-6.6-buildid-locate-rpm-scl.patch
41 Patch110:       gdb-6.3-gstack-20050411.patch
42 Patch111:       gdb-gdb-add-index-script.patch
43 Patch112:       gdb-archer-vla-tests.patch
44 Patch113:       gdb-vla-intel-fortran-strides.patch
45 Patch114:       gdb-vla-intel-stringbt-fix.patch
46 Patch115:       gdb-vla-intel-fortran-vla-strings.patch
47 Patch116:       gdb-vla-intel-tests.patch
48 Patch1000:      %{name}-readline.patch
49 Patch1001:      %{name}-info.patch
50 Patch1002:      %{name}-passflags.patch
51 Patch1005:      %{name}-pretty-print-by-default.patch
52 Patch1006:      buildid-locate-rpm-pld.patch
53 URL:            http://www.gnu.org/software/gdb/
54 BuildRequires:  autoconf >= 2.69
55 BuildRequires:  automake
56 BuildRequires:  bison
57 BuildRequires:  babeltrace-devel >= 1.1.0
58 BuildRequires:  expat-devel
59 BuildRequires:  flex >= 2.6.4
60 BuildRequires:  gettext-tools >= 0.12.1
61 %{?with_guile:BuildRequires:    guile-devel >= 2.0}
62 BuildRequires:  libselinux-devel
63 BuildRequires:  libstdc++-devel >= 6:4.8
64 BuildRequires:  libtool
65 BuildRequires:  make >= 3.81
66 BuildRequires:  ncurses-devel >= 5.2
67 BuildRequires:  pkgconfig
68 BuildRequires:  readline-devel
69 BuildRequires:  rpmbuild(macros) >= 1.219
70 BuildRequires:  texinfo >= 4.4
71 BuildRequires:  xz-devel
72 BuildRequires:  zlib-devel
73 %if %{with python}
74 BuildRequires:  python-devel
75 BuildRequires:  rpm-pythonprov
76 Obsoletes:      python-gdb
77 # for traceback module
78 Requires:       python-modules
79 %endif
80 %{?with_guile:Requires: guile >= 2.0.12}
81 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
82
83 %description
84 Gdb is a full featured, command driven debugger. Gdb allows you to
85 trace the execution of programs and examine their internal state at
86 any time. Gdb works for C and C++ compiled with the GNU C compiler
87 gcc.
88
89 %description -l de.UTF-8
90 dem Sie die Ausführung von Programmen verfolgen und jederzeit den
91 inneren Zustand überprüfen können. Er funktioniert für C und mit GNU C
92 kompiliertes C++.
93
94 %description -l es.UTF-8
95 Este es un debugger orientado a comandos repleto de características.
96 Te permite rastrear la ejecución de programas y examinar su estado
97 interno a cualquier momento. Funciona para C y C++ compilado con el
98 compilador GNU C.
99
100 %description -l fr.UTF-8
101 Débugger complet, piloté par commandes. Permet de tracer l'exécution
102 des programmes et d'examiner à tout moment leur état interne.
103 Fonctionne avec les binaires C et C++ compilés avec le compilateur C
104 de GNU, gcc.
105
106 %description -l pl.UTF-8
107 Gdb jest rozbudowanym odpluskwiaczem (debuggerem), pozwalającym
108 śledzić wykonywanie programu i badać jego stan wewnętrzny. Gdb
109 umożliwia odpluskwianie programów napisanych w C/C++ i skompilowanych
110 przy pomocy kompilatora GNU (gcc).
111
112 %description -l pt_BR.UTF-8
113 Este é um debugger orientado a comandos repleto de características.
114 Ele permite à você rastrear a execução de programas e examinar o seu
115 estado interno a qualquer momento. Ele funciona para para C e C++
116 compilado com o compilador GNU C.
117
118 %description -l ru.UTF-8
119 Это полноценный отладчик, управляемый командами. Он позволяет
120 трассировать исполнение программ и изучать их внутреннее состояние в
121 любой момент времени. Работает с программами на C и C++,
122 скомпилированными GNU компилятором C (gcc, egcs, pgcc).
123
124 %description -l tr.UTF-8
125 Bir komut arayüzü üzerinden programcıya programını adım adım izleme
126 (trace) ve herhangi bir anda programın durumunu inceleme olanağı
127 verir.
128
129 %description -l uk.UTF-8
130 Це повноцінний відладчик, що керується командами. Він дозволяє
131 трасувати виконання програм та вивчати їх внутрішній стан в довільний
132 момент часу. Працює з програмами на C та C++, зкомпільованими
133 компіляторами GNU C (gcc, egcs, pgcc).
134
135 %package gdbserver
136 Summary:        A standalone server for GDB (the GNU source-level debugger)
137 Summary(pl.UTF-8):      Samodzielny serwer GDB (debuggera GNU)
138 Group:          Development/Debuggers
139
140 %description gdbserver
141 GDB, the GNU debugger, allows you to debug programs written in C, C++,
142 Java, and other languages, by executing them in a controlled fashion
143 and printing their data.
144
145 This package provides a program that allows you to run GDB on a
146 different machine than the one which is running the program being
147 debugged.
148
149 %description gdbserver -l pl.UTF-8
150 GDB (GNU debugger) pozwala śledzić programy napisane w C, C++, Javie i
151 innych językach programowania poprzez wykonywanie ich w sposób
152 kontrolowany oraz wypisywanie ich danych.
153
154 Ten pakiet zawiera program pozwalający uruchamiać GDB na innej
155 maszynie niż ta, na której działa śledzony program.
156
157 %package lib
158 Summary:        GDB in the form of a static library
159 Summary(pl.UTF-8):      GDB w postaci biblioteki statycznej
160 Group:          Development/Debuggers
161 # libraries that needs to be linked to fulfill libgdb.a symbol requirements
162 Requires:       binutils-devel >= 2.17.50
163 Requires:       expat-devel
164 Requires:       libselinux-devel
165 Requires:       libsepol-devel
166 Requires:       ncurses-devel
167 Requires:       python-devel
168 Requires:       readline-devel
169 Requires:       xz-devel
170 Requires:       zlib-devel
171
172 %description lib
173 GDB in the form of a static library.
174
175 %description lib -l pl.UTF-8
176 GDB w postaci biblioteki statycznej.
177
178 %prep
179 %setup -q
180
181 %patch0 -p1
182
183 # Files have `# <number> <file>' statements breaking VPATH / find-debuginfo.sh .
184 rm -f gdb/ada-exp.c gdb/ada-lex.c gdb/c-exp.c gdb/cp-name-parser.c gdb/f-exp.c
185 rm -f gdb/jv-exp.c gdb/m2-exp.c gdb/objc-exp.c gdb/p-exp.c
186
187 %patch100 -p1
188 %patch101 -p1
189 %patch102 -p1
190 %patch103 -p1
191 %patch104 -p1
192 %patch105 -p1
193 %patch106 -p1
194 %patch110 -p1
195 %patch111 -p1
196 %patch112 -p1
197 %patch113 -p1
198 %patch114 -p1
199 %patch115 -p1
200 %patch116 -p1
201
202 %patch1000 -p1
203 %patch1001 -p1
204 %patch1002 -p1
205 %patch1005 -p1
206 %patch1006 -p1
207
208 # Change the version that gets printed at GDB startup, so it is PLD Linux specific.
209 cat > gdb/version.in << EOF
210 %{version}-%{release} (PLD Linux)
211 EOF
212
213 sed -i -e 's#_GCC_AUTOCONF_VERSION\], \[2\.64\]#_GCC_AUTOCONF_VERSION], [2.69]#g' config/override.m4
214
215 %build
216 # omit hand-written gdb/testsuite aclocal.m4
217 for dir in gdb gdb/gdbserver ; do
218         olddir=$(pwd)
219         cd $dir
220         %{__rm} aclocal.m4
221         %{__aclocal} $(grep '^ACLOCAL_AMFLAGS' Makefile.in | sed -e 's/.*=//')
222         cd $olddir
223 done
224 for dir in $(find gdb -name 'configure.in' -o -name 'configure.ac'); do
225         dir=$(dirname "$dir")
226         olddir=$(pwd)
227         cd $dir
228         %{__autoconf}
229         grep -q AC_CONFIG_HEADER configure.* && %{__autoheader}
230         cd $olddir
231 done
232 cp -f /usr/share/automake/config.* .
233 # don't --enable-shared here, there would be libs version mismatch with binutils
234 %configure \
235         --with-gdb-datadir=%{_datadir}/gdb \
236         --with-separate-debug-dir=/usr/lib/debug \
237 %if %{with python}
238         --with-python=yes \
239         --with-pythondir=%{py_sitescriptdir} \
240 %else
241         --without-python \
242 %endif
243 %if %{with guile}
244         --with-guile \
245 %else
246         --without-guile \
247 %endif
248         --disable-gdbtk \
249         --disable-shared \
250         --enable-gdbcli \
251         --enable-gdbmi \
252         --enable-multi-ice \
253         --enable-netrom \
254         --enable-nls \
255         --enable-tui \
256         --with-system-readline \
257         --with-cpu=%{_target_cpu} \
258 %ifnarch alpha
259         --with-mmalloc \
260 %endif
261         --without-included-gettext \
262         --without-included-regex \
263         --without-x
264
265 %{__make}
266 %{__make} -j1 info
267
268 # gdb/ChangeLog: Build gdb directly from *.o files not using libgdb.a.
269 %{__make} -C gdb libgdb.a
270
271 %install
272 rm -rf $RPM_BUILD_ROOT
273 install -d $RPM_BUILD_ROOT%{_infodir}
274
275 %{__make} -j1 install install-info \
276         DESTDIR=$RPM_BUILD_ROOT
277
278 cp -a gdb/libgdb.a $RPM_BUILD_ROOT%{_libdir}
279
280 # gdbtui seems all identical to gdb except when invoked as gdbtui, ncurses
281 # window is created too.
282 echo ".so gdb.1" > $RPM_BUILD_ROOT%{_mandir}/man1/gdbtui.1
283 ln -f $RPM_BUILD_ROOT%{_bindir}/{gdb,gdbtui}
284
285 bzip2 -dc %{SOURCE1} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
286 %{__rm} $RPM_BUILD_ROOT%{_mandir}/README.gdb-non-english-man-pages
287
288 rm -f $RPM_BUILD_ROOT%{_infodir}/dir
289
290 %if %{with python}
291 # Temporarily now:
292 for LIB in lib lib64 libx32; do
293         LIBPATH="$RPM_BUILD_ROOT%{_datadir}/gdb/auto-load%{_prefix}/$LIB"
294         install -d $LIBPATH
295 done
296
297 %py_ocomp $RPM_BUILD_ROOT%{py_sitescriptdir}
298 %py_comp $RPM_BUILD_ROOT%{py_sitescriptdir}
299 %py_postclean
300 %endif
301
302 cp -a %{SOURCE3} $RPM_BUILD_ROOT%{_mandir}/man1/gstack.1
303
304 install libdecnumber/libdecnumber.a $RPM_BUILD_ROOT%{_libdir}
305
306 # Remove the files that are part of a gdb build but that are owned and provided by other packages.
307 # These are part of binutils:
308 %{__rm} $RPM_BUILD_ROOT%{_localedir}/*/LC_MESSAGES/{bfd,opcodes}.mo
309 %{__rm} $RPM_BUILD_ROOT%{_infodir}/bfd.info*
310 %{__rm} $RPM_BUILD_ROOT%{_includedir}/{ansidecl,bfd,bfdlink,dis-asm,symcat,plugin-api}.h
311 %{__rm} $RPM_BUILD_ROOT%{_libdir}/lib{bfd,opcodes}.la
312 %{__rm} $RPM_BUILD_ROOT%{_libdir}/lib{bfd,opcodes}.a
313
314 %clean
315 rm -rf $RPM_BUILD_ROOT
316
317 %post   -p /sbin/postshell
318 -/usr/sbin/fix-info-dir -c %{_infodir}
319
320 %postun -p /sbin/postshell
321 -/usr/sbin/fix-info-dir -c %{_infodir}
322
323 %files
324 %defattr(644,root,root,755)
325 %doc gdb/{ChangeLog,NEWS,PROBLEMS,README}
326 %attr(755,root,root) %{_bindir}/gdb
327 %attr(755,root,root) %{_bindir}/gdbtui
328 %attr(755,root,root) %{_bindir}/gdb-add-index
329 %attr(755,root,root) %{_bindir}/gstack
330 %attr(755,root,root) %{_bindir}/gcore
331 %dir %{_datadir}/gdb
332 %dir %{_datadir}/gdb/auto-load
333 %dir %{_datadir}/gdb/auto-load%{_prefix}
334 %dir %{_datadir}/gdb/auto-load%{_prefix}/lib
335 %ifarch %{x8664} x32
336 %dir %{_datadir}/gdb/auto-load%{_prefix}/lib64
337 %dir %{_datadir}/gdb/auto-load%{_prefix}/libx32
338 %endif
339 %{?with_guile:%{_datadir}/gdb/guile}
340 %{_datadir}/gdb/syscalls
341 %{_datadir}/gdb/system-gdbinit
342 %{_datadir}/gdb/python
343 %{_mandir}/man1/gdb.1*
344 %{_mandir}/man1/gdbtui.1*
345 %{_mandir}/man1/gdb-add-index.1*
346 %{_mandir}/man1/gstack.1*
347 %{_mandir}/man1/gcore.1*
348 %{_mandir}/man5/gdbinit.5*
349 %lang(es) %{_mandir}/es/man1/*
350 %lang(fr) %{_mandir}/fr/man1/*
351 %lang(hu) %{_mandir}/hu/man1/*
352 %lang(ja) %{_mandir}/ja/man1/*
353 %lang(pl) %{_mandir}/pl/man1/*
354 %{_infodir}/annotate.info*
355 %{_infodir}/gdb.info*
356 %{_infodir}/stabs.info*
357
358 %files gdbserver
359 %defattr(644,root,root,755)
360 %attr(755,root,root) %{_bindir}/gdbserver
361 %{_mandir}/man1/gdbserver.1*
362 %attr(755,root,root) %{_libdir}/libinproctrace.so
363
364 %files lib
365 %defattr(644,root,root,755)
366 %{_libdir}/libdecnumber.a
367 %{_libdir}/libgdb.a
368 %{_includedir}/gdb
This page took 1.071737 seconds and 4 git commands to generate.