]> git.pld-linux.org Git - packages/gdb.git/blob - gdb.spec
switch to python3
[packages/gdb.git] / gdb.spec
1 # NOTE: -lib package is used by fpc.spec
2
3 # TODO
4 # - rpm5 librpm support (gdb/configure.ac checks for 4.x or so)
5 # - change install msg to poldek in buildid-locate-rpm-pld.patch when poldek allows it. LP#493922
6 # - reenable guile after https://sourceware.org/bugzilla/show_bug.cgi?id=21104 is fixed
7 #
8 # Conditional build:
9 %bcond_with     guile           # Guile embedded scripting
10 %bcond_without  python          # build without python support
11
12 Summary:        A GNU source-level debugger for C, C++ and Fortran
13 Summary(de.UTF-8):      Symbolischer Debugger für C und andere Sprachen
14 Summary(es.UTF-8):      Depurador de programas C y otras lenguajes
15 Summary(fr.UTF-8):      Débugger symbolique pour C et d'autres langages
16 Summary(pl.UTF-8):      Symboliczny odpluskwiacz dla C i innych języków
17 Summary(pt_BR.UTF-8):   Depurador de programas C e outras linguagens
18 Summary(ru.UTF-8):      Символический отладчик для C и других языков
19 Summary(tr.UTF-8):      C ve diğer diller için sembolik hata ayıklayıcı
20 Summary(uk.UTF-8):      Символьний відладчик для С та інших мов
21 Summary(zh_CN.UTF-8):   [开发]C和其他语言的调试器
22 Summary(zh_TW.UTF-8):   [.-A開發]C和.$)B其.-A他語.$)B言的調試器
23 Name:           gdb
24 Version:        9.1
25 Release:        2
26 License:        GPL v3+
27 Group:          Development/Debuggers
28 Source0:        http://ftp.gnu.org/gnu/gdb/%{name}-%{version}.tar.xz
29 # Source0-md5:  f7e9f6236c425097d9e5f18a6ac40655
30 Source1:        http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-non-english-man-pages.tar.bz2
31 # Source1-md5:  2e8a48939ae282c12bbacdd54e398247
32 Source3:        %{name}-gstack.man
33 Patch100:       gdb-6.6-buildid-locate.patch
34 Patch101:       gdb-6.6-buildid-locate-solib-missing-ids.patch
35 Patch102:       gdb-6.6-buildid-locate-rpm.patch
36 Patch103:       gdb-6.6-buildid-locate-core-as-arg.patch
37 Patch104:       gdb-6.6-buildid-locate-rpm-librpm-workaround.patch
38 Patch105:       gdb-6.6-buildid-locate-misleading-warning-missing-debuginfo-rhbz981154.patch
39 Patch106:       gdb-6.6-buildid-locate-rpm-scl.patch
40 Patch110:       gdb-6.3-gstack-20050411.patch
41
42 Patch112:       gdb-archer-vla-tests.patch
43 Patch113:       gdb-vla-intel-fortran-strides.patch
44 Patch114:       gdb-vla-intel-stringbt-fix.patch
45 Patch115:       gdb-vla-intel-fortran-vla-strings.patch
46 Patch116:       gdb-vla-intel-tests.patch
47 Patch1000:      %{name}-readline.patch
48 Patch1001:      %{name}-info.patch
49 Patch1002:      %{name}-passflags.patch
50 Patch1005:      %{name}-pretty-print-by-default.patch
51 Patch1006:      buildid-locate-rpm-pld.patch
52 URL:            http://www.gnu.org/software/gdb/
53 BuildRequires:  autoconf >= 2.69
54 BuildRequires:  automake
55 BuildRequires:  bison
56 BuildRequires:  babeltrace-devel >= 1.1.0
57 BuildRequires:  expat-devel
58 BuildRequires:  flex >= 2.6.4
59 BuildRequires:  gettext-tools >= 0.12.1
60 %if %{with guile}
61 BuildRequires:  guile-devel >= 2.0
62 BuildRequires:  guile-devel < 2.2
63 %endif
64 %ifarch %{ix86} %{x8664}
65 BuildRequires:  libipt-devel
66 %endif
67 BuildRequires:  libselinux-devel
68 BuildRequires:  libstdc++-devel >= 6:4.8
69 BuildRequires:  libtool
70 BuildRequires:  make >= 3.81
71 BuildRequires:  mpfr-devel
72 BuildRequires:  ncurses-devel >= 5.2
73 BuildRequires:  pkgconfig
74 BuildRequires:  readline-devel
75 BuildRequires:  rpmbuild(macros) >= 1.219
76 BuildRequires:  source-highlight-devel >= 3.0
77 BuildRequires:  tar >= 1:1.22
78 BuildRequires:  texinfo >= 4.4
79 BuildRequires:  xxHash-devel
80 BuildRequires:  xz
81 BuildRequires:  xz-devel
82 BuildRequires:  zlib-devel
83 %if %{with python}
84 BuildRequires:  python3-devel
85 BuildRequires:  rpm-pythonprov
86 Obsoletes:      python-gdb
87 # for traceback module
88 Requires:       python3-modules
89 %endif
90 %{?with_guile:Requires: guile >= 2.0.12}
91 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
92
93 %description
94 Gdb is a full featured, command driven debugger. Gdb allows you to
95 trace the execution of programs and examine their internal state at
96 any time. Gdb works for C and C++ compiled with the GNU C compiler
97 gcc.
98
99 %description -l de.UTF-8
100 dem Sie die Ausführung von Programmen verfolgen und jederzeit den
101 inneren Zustand überprüfen können. Er funktioniert für C und mit GNU C
102 kompiliertes C++.
103
104 %description -l es.UTF-8
105 Este es un debugger orientado a comandos repleto de características.
106 Te permite rastrear la ejecución de programas y examinar su estado
107 interno a cualquier momento. Funciona para C y C++ compilado con el
108 compilador GNU C.
109
110 %description -l fr.UTF-8
111 Débugger complet, piloté par commandes. Permet de tracer l'exécution
112 des programmes et d'examiner à tout moment leur état interne.
113 Fonctionne avec les binaires C et C++ compilés avec le compilateur C
114 de GNU, gcc.
115
116 %description -l pl.UTF-8
117 Gdb jest rozbudowanym odpluskwiaczem (debuggerem), pozwalającym
118 śledzić wykonywanie programu i badać jego stan wewnętrzny. Gdb
119 umożliwia odpluskwianie programów napisanych w C/C++ i skompilowanych
120 przy pomocy kompilatora GNU (gcc).
121
122 %description -l pt_BR.UTF-8
123 Este é um debugger orientado a comandos repleto de características.
124 Ele permite à você rastrear a execução de programas e examinar o seu
125 estado interno a qualquer momento. Ele funciona para para C e C++
126 compilado com o compilador GNU C.
127
128 %description -l ru.UTF-8
129 Это полноценный отладчик, управляемый командами. Он позволяет
130 трассировать исполнение программ и изучать их внутреннее состояние в
131 любой момент времени. Работает с программами на C и C++,
132 скомпилированными GNU компилятором C (gcc, egcs, pgcc).
133
134 %description -l tr.UTF-8
135 Bir komut arayüzü üzerinden programcıya programını adım adım izleme
136 (trace) ve herhangi bir anda programın durumunu inceleme olanağı
137 verir.
138
139 %description -l uk.UTF-8
140 Це повноцінний відладчик, що керується командами. Він дозволяє
141 трасувати виконання програм та вивчати їх внутрішній стан в довільний
142 момент часу. Працює з програмами на C та C++, зкомпільованими
143 компіляторами GNU C (gcc, egcs, pgcc).
144
145 %package gdbserver
146 Summary:        A standalone server for GDB (the GNU source-level debugger)
147 Summary(pl.UTF-8):      Samodzielny serwer GDB (debuggera GNU)
148 Group:          Development/Debuggers
149
150 %description gdbserver
151 GDB, the GNU debugger, allows you to debug programs written in C, C++,
152 Java, and other languages, by executing them in a controlled fashion
153 and printing their data.
154
155 This package provides a program that allows you to run GDB on a
156 different machine than the one which is running the program being
157 debugged.
158
159 %description gdbserver -l pl.UTF-8
160 GDB (GNU debugger) pozwala śledzić programy napisane w C, C++, Javie i
161 innych językach programowania poprzez wykonywanie ich w sposób
162 kontrolowany oraz wypisywanie ich danych.
163
164 Ten pakiet zawiera program pozwalający uruchamiać GDB na innej
165 maszynie niż ta, na której działa śledzony program.
166
167 %package lib
168 Summary:        GDB in the form of a static library
169 Summary(pl.UTF-8):      GDB w postaci biblioteki statycznej
170 Group:          Development/Debuggers
171 # libraries that needs to be linked to fulfill libgdb.a symbol requirements
172 Requires:       binutils-devel >= 2.17.50
173 Requires:       expat-devel
174 Requires:       libselinux-devel
175 Requires:       libsepol-devel
176 Requires:       ncurses-devel
177 Requires:       python3-devel
178 Requires:       readline-devel
179 Requires:       xz-devel
180 Requires:       zlib-devel
181
182 %description lib
183 GDB in the form of a static library.
184
185 %description lib -l pl.UTF-8
186 GDB w postaci biblioteki statycznej.
187
188 %prep
189 %setup -q
190
191 # Files have `# <number> <file>' statements breaking VPATH / find-debuginfo.sh .
192 %{__rm} gdb/ada-exp.c gdb/ada-lex.c gdb/c-exp.c gdb/cp-name-parser.c gdb/f-exp.c
193 %{__rm} gdb/m2-exp.c gdb/p-exp.c
194
195 %patch100 -p1
196 %patch101 -p1
197 %patch102 -p1
198 %patch103 -p1
199 %patch104 -p1
200 %patch105 -p1
201 %patch106 -p1
202 %patch110 -p1
203
204 %patch112 -p1
205 %patch113 -p1
206 %patch114 -p1
207 %patch115 -p1
208 %patch116 -p1
209
210 %patch1000 -p1
211 %patch1001 -p1
212 %patch1002 -p1
213 %patch1005 -p1
214 %patch1006 -p1
215
216 # Change the version that gets printed at GDB startup, so it is PLD Linux specific.
217 cat > gdb/version.in << EOF
218 %{version}-%{release} (PLD Linux)
219 EOF
220
221 sed -E -i -e '1s,#!\s*/usr/bin/env\s+python2(\s|$),#!%{__python}\1,' -e '1s,#!\s*/usr/bin/env\s+python(\s|$),#!%{__python3}\1,' -e '1s,#!\s*/usr/bin/python(\s|$),#!%{__python3}\1,' \
222       contrib/dg-extract-results.py \
223       gdb/contrib/test_pubnames_and_indexes.py \
224       gdb/testsuite/analyze-racy-logs.py \
225       gdb/testsuite/print-ts.py
226
227 sed -E -i -e '1s,#!\s*/usr/bin/env\s+python3(\s|$),#!%{__python3}\1,' \
228       gdb/copyright.py
229
230 sed -E -i -e '1s,#!\s*/usr/bin/env\s+(.*),#!%{__bindir}\1,' \
231       gdb/contrib/cc-with-tweaks.sh \
232       gdb/gcore \
233       gdb/gcore.in \
234       src-release.sh
235
236 %build
237 # omit hand-written gdb/testsuite aclocal.m4
238 for dir in gdb gdb/gdbserver ; do
239         olddir=$(pwd)
240         cd $dir
241         %{__rm} aclocal.m4
242         %{__aclocal} $(grep '^ACLOCAL_AMFLAGS' Makefile.in | sed -e 's/.*=//')
243         cd $olddir
244 done
245 for dir in $(find gdb -name 'configure.in' -o -name 'configure.ac'); do
246         dir=$(dirname "$dir")
247         olddir=$(pwd)
248         cd $dir
249         %{__autoconf}
250         grep -q AC_CONFIG_HEADER configure.* && %{__autoheader}
251         cd $olddir
252 done
253 cp -f /usr/share/automake/config.* .
254 install -d build && cd build
255 # don't --enable-shared here, there would be libs version mismatch with binutils
256 ../%configure \
257         --disable-gdbtk \
258         --disable-shared \
259         --disable-silent-rules \
260         --enable-gdbcli \
261         --enable-gdbmi \
262         --enable-multi-ice \
263         --enable-netrom \
264         --enable-nls \
265         --enable-tui \
266         --with-cpu=%{_target_cpu} \
267         --with-gdb-datadir=%{_datadir}/gdb \
268         --with-guile%{!?with_guile:=no} \
269 %ifnarch alpha
270         --with-mmalloc \
271 %endif
272 %if %{with python}
273         --with-python="%{__python3}" \
274         --with-pythondir=%{py3_sitescriptdir} \
275 %else
276         --without-python \
277 %endif
278         --with-separate-debug-dir=/usr/lib/debug \
279         --with-system-readline \
280         --without-included-gettext \
281         --without-included-regex \
282         --without-x
283
284 # V=1 because only some subdirs honour --enable-silent-rules
285 %{__make} \
286         V=1
287
288 %{__make} -j1 info
289
290 # gdb/ChangeLog: Build gdb directly from *.o files not using libgdb.a.
291 %{__make} -C gdb libgdb.a \
292         V=1
293
294 %install
295 rm -rf $RPM_BUILD_ROOT
296 install -d $RPM_BUILD_ROOT%{_infodir}
297
298 %{__make} -C build -j1 install install-info \
299         DESTDIR=$RPM_BUILD_ROOT
300
301 cp -a build/gdb/libgdb.a $RPM_BUILD_ROOT%{_libdir}
302
303 # gdbtui seems all identical to gdb except when invoked as gdbtui, ncurses
304 # window is created too.
305 echo ".so gdb.1" > $RPM_BUILD_ROOT%{_mandir}/man1/gdbtui.1
306 ln -f $RPM_BUILD_ROOT%{_bindir}/{gdb,gdbtui}
307
308 bzip2 -dc %{SOURCE1} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
309 %{__rm} $RPM_BUILD_ROOT%{_mandir}/README.gdb-non-english-man-pages
310
311 rm -f $RPM_BUILD_ROOT%{_infodir}/dir
312
313 %if %{with python}
314 # Temporarily now:
315 for LIB in lib lib64 libx32; do
316         LIBPATH="$RPM_BUILD_ROOT%{_datadir}/gdb/auto-load%{_prefix}/$LIB"
317         install -d $LIBPATH
318 done
319
320 %py3_ocomp $RPM_BUILD_ROOT%{py3_sitescriptdir}
321 %py3_comp $RPM_BUILD_ROOT%{py3_sitescriptdir}
322 %endif
323
324 cp -a %{SOURCE3} $RPM_BUILD_ROOT%{_mandir}/man1/gstack.1
325
326 cp -p build/libdecnumber/libdecnumber.a $RPM_BUILD_ROOT%{_libdir}
327
328 # Remove the files that are part of a gdb build but that are owned and provided by other packages.
329 # These are part of binutils:
330 %{__rm} $RPM_BUILD_ROOT%{_localedir}/*/LC_MESSAGES/{bfd,opcodes}.mo
331 %{__rm} $RPM_BUILD_ROOT%{_infodir}/bfd.info*
332 %{__rm} $RPM_BUILD_ROOT%{_includedir}/{ansidecl,bfd,bfd_stdint,bfdlink,diagnostics,dis-asm,symcat,plugin-api}.h
333 %{__rm} $RPM_BUILD_ROOT%{_libdir}/lib{bfd,opcodes}.la
334 %{__rm} $RPM_BUILD_ROOT%{_libdir}/lib{bfd,opcodes}.a
335
336 %clean
337 rm -rf $RPM_BUILD_ROOT
338
339 %post   -p /sbin/postshell
340 -/usr/sbin/fix-info-dir -c %{_infodir}
341
342 %postun -p /sbin/postshell
343 -/usr/sbin/fix-info-dir -c %{_infodir}
344
345 %files
346 %defattr(644,root,root,755)
347 %doc gdb/{ChangeLog,NEWS,PROBLEMS,README}
348 %attr(755,root,root) %{_bindir}/gdb
349 %attr(755,root,root) %{_bindir}/gdbtui
350 %attr(755,root,root) %{_bindir}/gdb-add-index
351 %attr(755,root,root) %{_bindir}/gstack
352 %attr(755,root,root) %{_bindir}/gcore
353 %dir %{_datadir}/gdb
354 %dir %{_datadir}/gdb/auto-load
355 %dir %{_datadir}/gdb/auto-load%{_prefix}
356 %dir %{_datadir}/gdb/auto-load%{_prefix}/lib
357 %ifarch %{x8664} x32
358 %dir %{_datadir}/gdb/auto-load%{_prefix}/lib64
359 %dir %{_datadir}/gdb/auto-load%{_prefix}/libx32
360 %endif
361 %{?with_guile:%{_datadir}/gdb/guile}
362 %{_datadir}/gdb/syscalls
363 %{_datadir}/gdb/system-gdbinit
364 %{_datadir}/gdb/python
365 %{_mandir}/man1/gdb.1*
366 %{_mandir}/man1/gdbtui.1*
367 %{_mandir}/man1/gdb-add-index.1*
368 %{_mandir}/man1/gstack.1*
369 %{_mandir}/man1/gcore.1*
370 %{_mandir}/man5/gdbinit.5*
371 %lang(es) %{_mandir}/es/man1/*
372 %lang(fr) %{_mandir}/fr/man1/*
373 %lang(hu) %{_mandir}/hu/man1/*
374 %lang(ja) %{_mandir}/ja/man1/*
375 %lang(pl) %{_mandir}/pl/man1/*
376 %{_infodir}/annotate.info*
377 %{_infodir}/gdb.info*
378 %{_infodir}/stabs.info*
379
380 %files gdbserver
381 %defattr(644,root,root,755)
382 %attr(755,root,root) %{_bindir}/gdbserver
383 %{_mandir}/man1/gdbserver.1*
384 %ifnarch %{arm}
385 %attr(755,root,root) %{_libdir}/libinproctrace.so
386 %endif
387
388 %files lib
389 %defattr(644,root,root,755)
390 %{_libdir}/libdecnumber.a
391 %{_libdir}/libgdb.a
392 %{_includedir}/gdb
This page took 0.066846 seconds and 4 git commands to generate.