]> git.pld-linux.org Git - packages/gdb.git/blob - gdb.spec
- use macros in %{pre,post}{,un}
[packages/gdb.git] / gdb.spec
1 Summary:        A GNU source-level debugger for C, C++ and Fortran
2 Summary(de):    Symbolischer Debugger für C und andere Sprachen 
3 Summary(fr):    Débugger symbolique pour C et d'autres langages
4 Summary(pl):    Symboliczny odpluskwiacz dla C i innych jêzyków
5 Summary(tr):    C ve diðer diller için sembolik hata ayýklayýcý
6 Name:           gdb
7 Version:        5.0
8 Release:        6
9 License:        GPL
10 Group:          Development/Debuggers
11 Group(pl):      Programowanie/Odpluskwiacze
12 Group(de):      Entwicklung/Debugger
13 Source0:        ftp://ftp.gnu.org/pub/gnu/gdb/%{name}-%{version}.tar.bz2
14 Patch0:         %{name}-gettext.patch
15 Patch1:         %{name}-ncurses.patch
16 Patch2:         %{name}-readline.patch
17 Patch3:         %{name}-info.patch
18 Patch4:         %{name}-procfs.patch
19 BuildRequires:  ncurses-devel >= 5.2
20 BuildRequires:  readline-devel >= 4.2
21 BuildRequires:  XFree86-devel
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %description
25 Gdb is a full featured, command driven debugger. Gdb allows you to
26 trace the execution of programs and examine their internal state at
27 any time. Gdb works for C and C++ compiled with the GNU C compiler
28 gcc.
29
30 %description -l de
31 dem Sie die Ausführung von Programmen verfolgen und jederzeit den
32 inneren Zustand überprüfen können. Er funktioniert für C und mit GNU C
33 kompiliertes C++.
34
35 %description -l fr
36 Débugger complet, piloté par commandes. Permet de tracer l'exécution
37 des programmes et d'examiner à tout moment leur état interne.
38 Fonctionne avec les binaires C et C++ compilés avec le compilateur C
39 de GNU, gcc.
40
41 %description -l pl
42 Gdb jest rozbudowanym odpluskwiaczem (debuggerem), pozwalaj±cym
43 ¶ledziæ wykonywanie programu i badaæ jego stan wewnêtrzny. Gdb
44 umo¿liwia odpluskwianie programów napisanych w C/C++ i skompilowanych
45 przy pomocy kompilatora GNU (gcc).
46
47 %description -l tr
48 Bir komut arayüzü üzerinden programcýya programýný adým adým izleme
49 (trace) ve herhangi bir anda programýn durumunu inceleme olanaðý
50 verir.
51
52 %prep
53 %setup -q
54 %patch0 -p1
55 %patch1 -p1
56 %patch2 -p1
57 %patch3 -p1
58 %patch4 -p1
59
60 %build
61 (cd gdb; aclocal; autoconf; cd ..)
62 # !! Don't enable shared here !! 
63 # This will cause serious problems --misiek
64 %configure \
65         --disable-shared \
66         --enable-nls \
67         --without-included-gettext \
68         --enable-multi-ice \
69         --enable-gdbmi \
70         --enable-netrom \
71         --with-cpu=%{_target_cpu} \
72         --with-x \
73 %ifnarch alpha
74         --with-mmalloc \
75 %endif
76         --with-mmap
77 #       --enable-tui
78
79 # rebuild main Makefile again (due to some bug, Makefile is deleted)
80 %configure \
81         --norecursion
82                         
83 %{__make}
84 %{__make} info
85
86 %install
87 rm -rf $RPM_BUILD_ROOT
88 install -d $RPM_BUILD_ROOT%{_infodir}
89
90 %{__make} install install-info \
91         prefix=$RPM_BUILD_ROOT%{_prefix} \
92         bindir=$RPM_BUILD_ROOT%{_bindir} \
93         sbindir=$RPM_BUILD_ROOT%{_sbindir} \
94         infodir=$RPM_BUILD_ROOT%{_infodir} \
95         includedir=$RPM_BUILD_ROOT%{_includedir} \
96         libdir=$RPM_BUILD_ROOT%{_libdir} \
97         mandir=$RPM_BUILD_ROOT%{_mandir}
98
99 gzip -9nf $RPM_BUILD_ROOT{%{_infodir}/*info*,%{_mandir}/man?/*}
100
101 %post
102 %fix_info_dir
103
104 %postun
105 %fix_info_dir
106
107 %clean
108 rm -rf $RPM_BUILD_ROOT
109
110 %files
111 %defattr(644,root,root,755)
112 %attr(755,root,root) %{_bindir}/*
113
114 %{_mandir}/man1/*
115 %{_infodir}/gdb*.info*
116 %{_infodir}/stabs*.info*
This page took 0.045158 seconds and 4 git commands to generate.