]> git.pld-linux.org Git - packages/gdb.git/blob - gdb.spec
- updated to 8.0
[packages/gdb.git] / gdb.spec
1 # NOTE: -lib package is used by fpc.spec
2
3 # TODO
4 # - change install msg to poldek in buildid-locate-rpm-pld.patch when poldek allows it. LP#493922
5 #
6 # Conditional build:
7 %bcond_without  guile           # Guile embedded scripting
8 %bcond_without  python          # build without python support
9
10 Summary:        A GNU source-level debugger for C, C++ and Fortran
11 Summary(de.UTF-8):      Symbolischer Debugger für C und andere Sprachen
12 Summary(es.UTF-8):      Depurador de programas C y otras lenguajes
13 Summary(fr.UTF-8):      Débugger symbolique pour C et d'autres langages
14 Summary(pl.UTF-8):      Symboliczny odpluskwiacz dla C i innych języków
15 Summary(pt_BR.UTF-8):   Depurador de programas C e outras linguagens
16 Summary(ru.UTF-8):      Символический отладчик для C и других языков
17 Summary(tr.UTF-8):      C ve diğer diller için sembolik hata ayıklayıcı
18 Summary(uk.UTF-8):      Символьний відладчик для С та інших мов
19 Summary(zh_CN.UTF-8):   [开发]C和其他语言的调试器
20 Summary(zh_TW.UTF-8):   [.-A開發]C和.$)B其.-A他語.$)B言的調試器
21 %define         snap    20120926
22 Name:           gdb
23 Version:        8.0
24 Release:        1
25 License:        GPL v3+
26 Group:          Development/Debuggers
27 Source0:        http://ftp.gnu.org/gnu/gdb/%{name}-%{version}.tar.xz
28 # Source0-md5:  c3d35cd949084be53b92cc1e03485f88
29 Source1:        http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-non-english-man-pages.tar.bz2
30 # Source1-md5:  2e8a48939ae282c12bbacdd54e398247
31 Source3:        %{name}-gstack.man
32 # https://sourceware.org/bugzilla/show_bug.cgi?id=20287
33 Patch0:         gdb-bug-20287.patch
34 # https://sourceware.org/bugzilla/show_bug.cgi?id=20413
35 Patch1:         gdb-bug-20413.patch
36 Patch100:       gdb-6.6-buildid-locate.patch
37 Patch101:       gdb-6.6-buildid-locate-solib-missing-ids.patch
38 Patch102:       gdb-6.6-buildid-locate-rpm.patch
39 Patch103:       gdb-6.6-buildid-locate-core-as-arg.patch
40 Patch104:       gdb-6.6-buildid-locate-rpm-librpm-workaround.patch
41 Patch105:       gdb-6.6-buildid-locate-misleading-warning-missing-debuginfo-rhbz981154.patch
42 Patch106:       gdb-6.6-buildid-locate-rpm-scl.patch
43 Patch110:       gdb-6.3-gstack-20050411.patch
44 Patch111:       gdb-gdb-add-index-script.patch
45 Patch112:       gdb-archer-vla-tests.patch
46 Patch113:       gdb-vla-intel-fortran-strides.patch
47 Patch114:       gdb-vla-intel-stringbt-fix.patch
48 Patch115:       gdb-vla-intel-fortran-vla-strings.patch
49 Patch116:       gdb-vla-intel-tests.patch
50 Patch1000:      %{name}-readline.patch
51 Patch1001:      %{name}-info.patch
52 Patch1002:      %{name}-passflags.patch
53 Patch1005:      %{name}-pretty-print-by-default.patch
54 Patch1006:      buildid-locate-rpm-pld.patch
55 URL:            http://www.gnu.org/software/gdb/
56 BuildRequires:  autoconf >= 2.69
57 BuildRequires:  automake
58 BuildRequires:  bison
59 BuildRequires:  babeltrace-devel
60 BuildRequires:  expat-devel
61 BuildRequires:  flex >= 2.6.4
62 BuildRequires:  gettext-tools
63 %{?with_guile:BuildRequires:    guile-devel >= 2.0}
64 BuildRequires:  libselinux-devel
65 BuildRequires:  libtool
66 BuildRequires:  ncurses-devel >= 5.2
67 BuildRequires:  pkgconfig
68 BuildRequires:  readline-devel
69 BuildRequires:  rpmbuild(macros) >= 1.219
70 BuildRequires:  texinfo >= 4.4
71 BuildRequires:  zlib-devel
72 %if %{with python}
73 BuildRequires:  python-devel
74 BuildRequires:  rpm-pythonprov
75 Obsoletes:      python-gdb
76 # for traceback module
77 Requires:       python-modules
78 %endif
79 %{?with_guile:Requires: guile >= 2.0}
80 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
81
82 %description
83 Gdb is a full featured, command driven debugger. Gdb allows you to
84 trace the execution of programs and examine their internal state at
85 any time. Gdb works for C and C++ compiled with the GNU C compiler
86 gcc.
87
88 %description -l de.UTF-8
89 dem Sie die Ausführung von Programmen verfolgen und jederzeit den
90 inneren Zustand überprüfen können. Er funktioniert für C und mit GNU C
91 kompiliertes C++.
92
93 %description -l es.UTF-8
94 Este es un debugger orientado a comandos repleto de características.
95 Te permite rastrear la ejecución de programas y examinar su estado
96 interno a cualquier momento. Funciona para C y C++ compilado con el
97 compilador GNU C.
98
99 %description -l fr.UTF-8
100 Débugger complet, piloté par commandes. Permet de tracer l'exécution
101 des programmes et d'examiner à tout moment leur état interne.
102 Fonctionne avec les binaires C et C++ compilés avec le compilateur C
103 de GNU, gcc.
104
105 %description -l pl.UTF-8
106 Gdb jest rozbudowanym odpluskwiaczem (debuggerem), pozwalającym
107 śledzić wykonywanie programu i badać jego stan wewnętrzny. Gdb
108 umożliwia odpluskwianie programów napisanych w C/C++ i skompilowanych
109 przy pomocy kompilatora GNU (gcc).
110
111 %description -l pt_BR.UTF-8
112 Este é um debugger orientado a comandos repleto de características.
113 Ele permite à você rastrear a execução de programas e examinar o seu
114 estado interno a qualquer momento. Ele funciona para para C e C++
115 compilado com o compilador GNU C.
116
117 %description -l ru.UTF-8
118 Это полноценный отладчик, управляемый командами. Он позволяет
119 трассировать исполнение программ и изучать их внутреннее состояние в
120 любой момент времени. Работает с программами на C и C++,
121 скомпилированными GNU компилятором C (gcc, egcs, pgcc).
122
123 %description -l tr.UTF-8
124 Bir komut arayüzü üzerinden programcıya programını adım adım izleme
125 (trace) ve herhangi bir anda programın durumunu inceleme olanağı
126 verir.
127
128 %description -l uk.UTF-8
129 Це повноцінний відладчик, що керується командами. Він дозволяє
130 трасувати виконання програм та вивчати їх внутрішній стан в довільний
131 момент часу. Працює з програмами на C та C++, зкомпільованими
132 компіляторами GNU C (gcc, egcs, pgcc).
133
134 %package gdbserver
135 Summary:        A standalone server for GDB (the GNU source-level debugger)
136 Summary(pl.UTF-8):      Samodzielny serwer GDB (debuggera GNU)
137 Group:          Development/Debuggers
138
139 %description gdbserver
140 GDB, the GNU debugger, allows you to debug programs written in C, C++,
141 Java, and other languages, by executing them in a controlled fashion
142 and printing their data.
143
144 This package provides a program that allows you to run GDB on a
145 different machine than the one which is running the program being
146 debugged.
147
148 %description gdbserver -l pl.UTF-8
149 GDB (GNU debugger) pozwala śledzić programy napisane w C, C++, Javie i
150 innych językach programowania poprzez wykonywanie ich w sposób
151 kontrolowany oraz wypisywanie ich danych.
152
153 Ten pakiet zawiera program pozwalający uruchamiać GDB na innej
154 maszynie niż ta, na której działa śledzony program.
155
156 %package lib
157 Summary:        GDB in the form of a static library
158 Summary(pl.UTF-8):      GDB w postaci biblioteki statycznej
159 Group:          Development/Debuggers
160 # libraries that needs to be linked to fulfill libgdb.a symbol requirements
161 Requires:       binutils-devel >= 2.17.50
162 Requires:       expat-devel
163 Requires:       libselinux-devel
164 Requires:       libsepol-devel
165 Requires:       ncurses-devel
166 Requires:       python-devel
167 Requires:       readline-devel
168 Requires:       xz-devel
169 Requires:       zlib-devel
170
171 %description lib
172 GDB in the form of a static library.
173
174 %description lib -l pl.UTF-8
175 GDB w postaci biblioteki statycznej.
176
177 %prep
178 %setup -q
179
180 # Files have `# <number> <file>' statements breaking VPATH / find-debuginfo.sh .
181 rm -f gdb/ada-exp.c gdb/ada-lex.c gdb/c-exp.c gdb/cp-name-parser.c gdb/f-exp.c
182 rm -f gdb/jv-exp.c gdb/m2-exp.c gdb/objc-exp.c gdb/p-exp.c
183
184 %patch100 -p1
185 %patch101 -p1
186 %patch102 -p1
187 %patch103 -p1
188 %patch104 -p1
189 %patch105 -p1
190 %patch106 -p1
191 %patch110 -p1
192 %patch111 -p1
193 %patch112 -p1
194 %patch113 -p1
195 %patch114 -p1
196 %patch115 -p1
197 %patch116 -p1
198
199 %patch1000 -p1
200 %patch1001 -p1
201 %patch1002 -p1
202 %patch1005 -p1
203 %patch1006 -p1
204
205 # Change the version that gets printed at GDB startup, so it is PLD Linux specific.
206 cat > gdb/version.in << EOF
207 %{version}-%{release} (PLD Linux)
208 EOF
209
210 sed -i -e 's#_GCC_AUTOCONF_VERSION\], \[2\.64\]#_GCC_AUTOCONF_VERSION], [2.69]#g' config/override.m4
211
212 %build
213 # omit hand-written gdb/testsuite aclocal.m4
214 for dir in gdb gdb/gdbserver ; do
215         olddir=$(pwd)
216         cd $dir
217         %{__rm} aclocal.m4
218         %{__aclocal} $(grep '^ACLOCAL_AMFLAGS' Makefile.in | sed -e 's/.*=//')
219         cd $olddir
220 done
221 for dir in $(find gdb -name 'configure.in' -o -name 'configure.ac'); do
222         dir=$(dirname "$dir")
223         olddir=$(pwd)
224         cd $dir
225         %{__autoconf}
226         grep -q AC_CONFIG_HEADER configure.* && %{__autoheader}
227         cd $olddir
228 done
229 cp -f /usr/share/automake/config.* .
230 # don't --enable-shared here, there would be libs version mismatch with binutils
231 %configure \
232         --with-gdb-datadir=%{_datadir}/gdb \
233         --with-separate-debug-dir=/usr/lib/debug \
234 %if %{with python}
235         --with-python=yes \
236         --with-pythondir=%{py_sitescriptdir} \
237 %else
238         --without-python \
239 %endif
240 %if %{with guile}
241         --with-guile \
242 %else
243         --without-guile \
244 %endif
245         --disable-gdbtk \
246         --disable-shared \
247         --enable-gdbcli \
248         --enable-gdbmi \
249         --enable-multi-ice \
250         --enable-netrom \
251         --enable-nls \
252         --enable-tui \
253         --with-system-readline \
254         --with-cpu=%{_target_cpu} \
255 %ifnarch alpha
256         --with-mmalloc \
257 %endif
258         --without-included-gettext \
259         --without-included-regex \
260         --without-x
261
262 %{__make}
263 %{__make} -j1 info
264
265 # gdb/ChangeLog: Build gdb directly from *.o files not using libgdb.a.
266 %{__make} -C gdb libgdb.a
267
268 %install
269 rm -rf $RPM_BUILD_ROOT
270 install -d $RPM_BUILD_ROOT%{_infodir}
271
272 %{__make} -j1 install install-info \
273         DESTDIR=$RPM_BUILD_ROOT
274
275 # gdbtui seems all identical to gdb except when invoked as gdbtio, ncurses
276 # window is created too.
277 echo ".so gdb.1" > $RPM_BUILD_ROOT%{_mandir}/man1/gdbtui.1
278 ln -f $RPM_BUILD_ROOT%{_bindir}/{gdb,gdbtui}
279
280 bzip2 -dc %{SOURCE1} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
281 cp -a gdb/libgdb.a $RPM_BUILD_ROOT%{_libdir}
282
283 rm -f $RPM_BUILD_ROOT%{_infodir}/dir
284 rm -f $RPM_BUILD_ROOT%{_mandir}/README.gdb-non-english-man-pages
285
286 %if %{with python}
287 # Temporarily now:
288 for LIB in lib lib64 libx32; do
289         LIBPATH="$RPM_BUILD_ROOT%{_datadir}/gdb/auto-load%{_prefix}/$LIB"
290         install -d $LIBPATH
291 done
292
293 %py_ocomp $RPM_BUILD_ROOT%{py_sitescriptdir}
294 %py_comp $RPM_BUILD_ROOT%{py_sitescriptdir}
295 %py_postclean
296 %endif
297
298 cp -a %{SOURCE3} $RPM_BUILD_ROOT%{_mandir}/man1/gstack.1
299
300 install libdecnumber/libdecnumber.a $RPM_BUILD_ROOT%{_libdir}
301
302 # Remove the files that are part of a gdb build but that are owned and provided by other packages.
303 # These are part of binutils:
304 %{__rm} $RPM_BUILD_ROOT%{_localedir}/*/LC_MESSAGES/{bfd,opcodes}.mo
305 %{__rm} $RPM_BUILD_ROOT%{_infodir}/bfd.info*
306 %{__rm} $RPM_BUILD_ROOT%{_includedir}/{ansidecl,bfd,bfdlink,dis-asm,symcat,plugin-api}.h
307 %{__rm} $RPM_BUILD_ROOT%{_libdir}/lib{bfd,opcodes}.la
308 %{__rm} $RPM_BUILD_ROOT%{_libdir}/lib{bfd,opcodes}.a
309
310 %clean
311 rm -rf $RPM_BUILD_ROOT
312
313 %post   -p /sbin/postshell
314 -/usr/sbin/fix-info-dir -c %{_infodir}
315
316 %postun -p /sbin/postshell
317 -/usr/sbin/fix-info-dir -c %{_infodir}
318
319 %files
320 %defattr(644,root,root,755)
321 %doc gdb/{ChangeLog,NEWS,PROBLEMS,README}
322 %attr(755,root,root) %{_bindir}/gdb
323 %attr(755,root,root) %{_bindir}/gdbtui
324 %attr(755,root,root) %{_bindir}/gdb-add-index
325 %attr(755,root,root) %{_bindir}/gstack
326 %attr(755,root,root) %{_bindir}/gcore
327 %dir %{_datadir}/gdb
328 %dir %{_datadir}/gdb/auto-load
329 %dir %{_datadir}/gdb/auto-load%{_prefix}
330 %dir %{_datadir}/gdb/auto-load%{_prefix}/lib
331 %ifarch %{x8664} x32
332 %dir %{_datadir}/gdb/auto-load%{_prefix}/lib64
333 %dir %{_datadir}/gdb/auto-load%{_prefix}/libx32
334 %endif
335 %{?with_guile:%{_datadir}/gdb/guile}
336 %{_datadir}/gdb/syscalls
337 %{_datadir}/gdb/system-gdbinit
338 %{_datadir}/gdb/python
339 %{_mandir}/man1/gdb.1*
340 %{_mandir}/man1/gdbtui.1*
341 %{_mandir}/man1/gdb-add-index.1*
342 %{_mandir}/man1/gstack.1*
343 %{_mandir}/man1/gcore.1*
344 %{_mandir}/man5/gdbinit.5*
345 %lang(es) %{_mandir}/es/man1/*
346 %lang(fr) %{_mandir}/fr/man1/*
347 %lang(hu) %{_mandir}/hu/man1/*
348 %lang(ja) %{_mandir}/ja/man1/*
349 %lang(pl) %{_mandir}/pl/man1/*
350 %{_infodir}/annotate.info*
351 %{_infodir}/gdb.info*
352 %{_infodir}/stabs.info*
353
354 %files gdbserver
355 %defattr(644,root,root,755)
356 %attr(755,root,root) %{_bindir}/gdbserver
357 %{_mandir}/man1/gdbserver.1*
358 %attr(755,root,root) %{_libdir}/libinproctrace.so
359
360 %files lib
361 %defattr(644,root,root,755)
362 %{_libdir}/libdecnumber.a
363 %{_libdir}/libgdb.a
364 %{_includedir}/gdb
This page took 0.095091 seconds and 4 git commands to generate.