]> git.pld-linux.org Git - packages/gdb.git/blob - gdb.spec
- updated to 12.1
[packages/gdb.git] / gdb.spec
1 # NOTE: -lib package is used by fpc.spec
2
3 # TODO
4 # - debuginfod (BR: elfutils-debuginfod-devel >= 0.179)
5 # - rpm5 librpm support (gdb/configure.ac checks for 4.x or so)
6 # - change install msg to poldek in buildid-locate-rpm-pld.patch when poldek allows it. LP#493922
7 # - reenable guile after https://sourceware.org/bugzilla/show_bug.cgi?id=21104 is fixed
8 #
9 # Conditional build:
10 %bcond_with     guile           # Guile embedded scripting
11 %bcond_without  python          # build without python support
12
13 Summary:        A GNU source-level debugger for C, C++ and Fortran
14 Summary(de.UTF-8):      Symbolischer Debugger für C und andere Sprachen
15 Summary(es.UTF-8):      Depurador de programas C y otras lenguajes
16 Summary(fr.UTF-8):      Débugger symbolique pour C et d'autres langages
17 Summary(pl.UTF-8):      Symboliczny odpluskwiacz dla C i innych języków
18 Summary(pt_BR.UTF-8):   Depurador de programas C e outras linguagens
19 Summary(ru.UTF-8):      Символический отладчик для C и других языков
20 Summary(tr.UTF-8):      C ve diğer diller için sembolik hata ayıklayıcı
21 Summary(uk.UTF-8):      Символьний відладчик для С та інших мов
22 Summary(zh_CN.UTF-8):   [开发]C和其他语言的调试器
23 Summary(zh_TW.UTF-8):   [.-A開發]C和.$)B其.-A他語.$)B言的調試器
24 Name:           gdb
25 Version:        12.1
26 Release:        1
27 License:        GPL v3+
28 Group:          Development/Debuggers
29 Source0:        https://ftp.gnu.org/gnu/gdb/%{name}-%{version}.tar.xz
30 # Source0-md5:  759a1b8d2b4d403367dd0e14fa04643d
31 Source1:        http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-non-english-man-pages.tar.bz2
32 # Source1-md5:  2e8a48939ae282c12bbacdd54e398247
33 Source3:        %{name}-gstack.man
34 Patch100:       gdb-6.6-buildid-locate.patch
35 Patch101:       gdb-6.6-buildid-locate-solib-missing-ids.patch
36 Patch102:       gdb-6.6-buildid-locate-rpm.patch
37 Patch104:       gdb-6.6-buildid-locate-rpm-librpm-workaround.patch
38 Patch105:       gdb-6.6-buildid-locate-misleading-warning-missing-debuginfo-rhbz981154.patch
39 Patch106:       gdb-6.6-buildid-locate-rpm-scl.patch
40 Patch110:       gdb-6.3-gstack-20050411.patch
41 Patch1000:      %{name}-readline.patch
42 Patch1001:      %{name}-info.patch
43 Patch1002:      %{name}-passflags.patch
44 Patch1005:      %{name}-pretty-print-by-default.patch
45 Patch1006:      buildid-locate-rpm-pld.patch
46 URL:            http://www.gnu.org/software/gdb/
47 BuildRequires:  autoconf >= 2.69
48 BuildRequires:  automake
49 BuildRequires:  babeltrace-devel >= 1.1.0
50 BuildRequires:  bison
51 BuildRequires:  expat-devel
52 BuildRequires:  flex >= 2.6.4
53 BuildRequires:  gettext-tools >= 0.12.1
54 BuildRequires:  gmp-devel
55 %if %{with guile}
56 BuildRequires:  guile-devel >= 2.0
57 BuildRequires:  guile-devel < 3.2
58 %endif
59 %ifarch %{ix86} %{x8664}
60 BuildRequires:  libipt-devel
61 %endif
62 BuildRequires:  libmpc-devel
63 BuildRequires:  libselinux-devel
64 BuildRequires:  libstdc++-devel >= 6:4.8
65 BuildRequires:  libtool >= 2:2
66 BuildRequires:  make >= 3.81
67 BuildRequires:  mpfr-devel
68 BuildRequires:  ncurses-devel >= 5.2
69 BuildRequires:  pkgconfig
70 BuildRequires:  readline-devel
71 BuildRequires:  rpm-devel >= 4.6
72 BuildRequires:  rpmbuild(macros) >= 1.219
73 BuildRequires:  source-highlight-devel >= 3.0
74 BuildRequires:  tar >= 1:1.22
75 BuildRequires:  texinfo >= 4.4
76 BuildRequires:  xxHash-devel
77 BuildRequires:  xz
78 BuildRequires:  xz-devel
79 BuildRequires:  zlib-devel
80 %if %{with python}
81 BuildRequires:  python3-devel >= 1:3.2
82 BuildRequires:  rpm-pythonprov
83 Obsoletes:      python-gdb < 7.3
84 # for traceback module
85 Requires:       python3-modules >= 1:3.2
86 %endif
87 %{?with_guile:Requires: guile >= 2.0.12}
88 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
89
90 %define         autoconf_ver    %(rpm -q --qf='%%{VERSION}' autoconf)
91
92 %description
93 Gdb is a full featured, command driven debugger. Gdb allows you to
94 trace the execution of programs and examine their internal state at
95 any time. Gdb works for C and C++ compiled with the GNU C compiler
96 gcc.
97
98 %description -l de.UTF-8
99 dem Sie die Ausführung von Programmen verfolgen und jederzeit den
100 inneren Zustand überprüfen können. Er funktioniert für C und mit GNU C
101 kompiliertes C++.
102
103 %description -l es.UTF-8
104 Este es un debugger orientado a comandos repleto de características.
105 Te permite rastrear la ejecución de programas y examinar su estado
106 interno a cualquier momento. Funciona para C y C++ compilado con el
107 compilador GNU C.
108
109 %description -l fr.UTF-8
110 Débugger complet, piloté par commandes. Permet de tracer l'exécution
111 des programmes et d'examiner à tout moment leur état interne.
112 Fonctionne avec les binaires C et C++ compilés avec le compilateur C
113 de GNU, gcc.
114
115 %description -l pl.UTF-8
116 Gdb jest rozbudowanym odpluskwiaczem (debuggerem), pozwalającym
117 śledzić wykonywanie programu i badać jego stan wewnętrzny. Gdb
118 umożliwia odpluskwianie programów napisanych w C/C++ i skompilowanych
119 przy pomocy kompilatora GNU (gcc).
120
121 %description -l pt_BR.UTF-8
122 Este é um debugger orientado a comandos repleto de características.
123 Ele permite à você rastrear a execução de programas e examinar o seu
124 estado interno a qualquer momento. Ele funciona para para C e C++
125 compilado com o compilador GNU C.
126
127 %description -l ru.UTF-8
128 Это полноценный отладчик, управляемый командами. Он позволяет
129 трассировать исполнение программ и изучать их внутреннее состояние в
130 любой момент времени. Работает с программами на C и C++,
131 скомпилированными GNU компилятором C (gcc, egcs, pgcc).
132
133 %description -l tr.UTF-8
134 Bir komut arayüzü üzerinden programcıya programını adım adım izleme
135 (trace) ve herhangi bir anda programın durumunu inceleme olanağı
136 verir.
137
138 %description -l uk.UTF-8
139 Це повноцінний відладчик, що керується командами. Він дозволяє
140 трасувати виконання програм та вивчати їх внутрішній стан в довільний
141 момент часу. Працює з програмами на C та C++, зкомпільованими
142 компіляторами GNU C (gcc, egcs, pgcc).
143
144 %package gdbserver
145 Summary:        A standalone server for GDB (the GNU source-level debugger)
146 Summary(pl.UTF-8):      Samodzielny serwer GDB (debuggera GNU)
147 Group:          Development/Debuggers
148
149 %description gdbserver
150 GDB, the GNU debugger, allows you to debug programs written in C, C++,
151 Java, and other languages, by executing them in a controlled fashion
152 and printing their data.
153
154 This package provides a program that allows you to run GDB on a
155 different machine than the one which is running the program being
156 debugged.
157
158 %description gdbserver -l pl.UTF-8
159 GDB (GNU debugger) pozwala śledzić programy napisane w C, C++, Javie i
160 innych językach programowania poprzez wykonywanie ich w sposób
161 kontrolowany oraz wypisywanie ich danych.
162
163 Ten pakiet zawiera program pozwalający uruchamiać GDB na innej
164 maszynie niż ta, na której działa śledzony program.
165
166 %package lib
167 Summary:        GDB in the form of a static library
168 Summary(pl.UTF-8):      GDB w postaci biblioteki statycznej
169 Group:          Development/Debuggers
170 # libraries that needs to be linked to fulfill libgdb.a symbol requirements
171 Requires:       binutils-devel >= 2.17.50
172 Requires:       expat-devel
173 Requires:       libselinux-devel
174 Requires:       libsepol-devel
175 Requires:       ncurses-devel
176 Requires:       python3-devel
177 Requires:       readline-devel
178 Requires:       xz-devel
179 Requires:       zlib-devel
180
181 %description lib
182 GDB in the form of a static library.
183
184 %description lib -l pl.UTF-8
185 GDB w postaci biblioteki statycznej.
186
187 %prep
188 %setup -q
189
190 # Files have `# <number> <file>' statements breaking VPATH / find-debuginfo.sh .
191 %{__rm} gdb/ada-exp.c gdb/ada-lex.c gdb/c-exp.c gdb/cp-name-parser.c gdb/f-exp.c
192 %{__rm} gdb/m2-exp.c gdb/p-exp.c
193
194 %patch100 -p1
195 %patch101 -p1
196 %patch102 -p1
197 %patch104 -p1
198 %patch105 -p1
199 %patch106 -p1
200 %patch110 -p1
201
202 %patch1000 -p1
203 %patch1001 -p1
204 %patch1002 -p1
205 %patch1005 -p1
206 %patch1006 -p1
207
208 # Change the version that gets printed at GDB startup, so it is PLD Linux specific.
209 cat > gdb/version.in << EOF
210 %{version}-%{release} (PLD Linux)
211 EOF
212
213 %{__sed} -i -e '1s,/usr/bin/python$,%{__python},' \
214       contrib/dg-extract-results.py \
215
216 %{__sed} -i -e '1s,/usr/bin/env python$,%{__python},' \
217       gdb/contrib/test_pubnames_and_indexes.py \
218       gdb/testsuite/print-ts.py
219
220 %{__sed} -i -e '1s,/usr/bin/env python3,%{__python3},' \
221       gdb/testsuite/analyze-racy-logs.py \
222       gdb/copyright.py
223
224 %{__sed} -i -e '1s,/usr/bin/env bash,/bin/bash,' \
225       gdb/contrib/cc-with-tweaks.sh \
226       gdb/gcore.in \
227       src-release.sh
228
229 sed -i -e 's/\[2\.69\]/[%{autoconf_ver}]/' config/override.m4
230
231 %build
232 # omit hand-written gdb/testsuite aclocal.m4
233 for dir in gdb gdbserver ; do
234         olddir=$(pwd)
235         cd $dir
236         %{__rm} aclocal.m4
237         %{__aclocal} $(grep '^ACLOCAL_AMFLAGS' Makefile.in | sed -e 's/.*=//')
238         cd $olddir
239 done
240 for dir in $(find gdb -name 'configure.in' -o -name 'configure.ac'); do
241         dir=$(dirname "$dir")
242         olddir=$(pwd)
243         cd $dir
244         %{__autoconf}
245         grep -q AC_CONFIG_HEADER configure.* && %{__autoheader}
246         cd $olddir
247 done
248 cp -f /usr/share/automake/config.* .
249 install -d build && cd build
250 # don't --enable-shared here, there would be libs version mismatch with binutils
251 ../%configure \
252         --disable-gdbtk \
253         --disable-shared \
254         --disable-silent-rules \
255         --enable-gdbcli \
256         --enable-gdbmi \
257         --enable-multi-ice \
258         --enable-netrom \
259         --enable-nls \
260         --enable-tui \
261         --with-cpu=%{_target_cpu} \
262         --with-gdb-datadir=%{_datadir}/gdb \
263         --with-guile%{!?with_guile:=no} \
264 %ifnarch alpha
265         --with-mmalloc \
266 %endif
267 %if %{with python}
268         --with-python="%{__python3}" \
269         --with-pythondir=%{py3_sitescriptdir} \
270 %else
271         --without-python \
272 %endif
273         --with-separate-debug-dir=/usr/lib/debug \
274         --with-system-readline \
275         --without-included-gettext \
276         --without-included-regex \
277         --without-x
278
279 # V=1 because only some subdirs honour --enable-silent-rules
280 %{__make} \
281         V=1
282
283 %{__make} -j1 info
284
285 # gdb/ChangeLog: Build gdb directly from *.o files not using libgdb.a.
286 %{__make} -C gdb libgdb.a \
287         V=1
288
289 %install
290 rm -rf $RPM_BUILD_ROOT
291 install -d $RPM_BUILD_ROOT%{_infodir}
292
293 %{__make} -C build -j1 install install-info \
294         DESTDIR=$RPM_BUILD_ROOT
295
296 cp -a build/gdb/libgdb.a $RPM_BUILD_ROOT%{_libdir}
297
298 # gdbtui seems all identical to gdb except when invoked as gdbtui, ncurses
299 # window is created too.
300 echo ".so gdb.1" > $RPM_BUILD_ROOT%{_mandir}/man1/gdbtui.1
301 ln -f $RPM_BUILD_ROOT%{_bindir}/{gdb,gdbtui}
302
303 bzip2 -dc %{SOURCE1} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
304 %{__rm} $RPM_BUILD_ROOT%{_mandir}/README.gdb-non-english-man-pages
305
306 rm -f $RPM_BUILD_ROOT%{_infodir}/dir
307
308 %if %{with python}
309 # Temporarily now:
310 for LIB in lib lib64 libx32; do
311         LIBPATH="$RPM_BUILD_ROOT%{_datadir}/gdb/auto-load%{_prefix}/$LIB"
312         install -d $LIBPATH
313 done
314
315 %py3_ocomp $RPM_BUILD_ROOT%{py3_sitescriptdir}
316 %py3_comp $RPM_BUILD_ROOT%{py3_sitescriptdir}
317 %endif
318
319 cp -a %{SOURCE3} $RPM_BUILD_ROOT%{_mandir}/man1/gstack.1
320
321 cp -p build/libdecnumber/libdecnumber.a $RPM_BUILD_ROOT%{_libdir}
322
323 # Remove the files that are part of a gdb build but that are owned and provided by other packages.
324 # These are part of binutils:
325 %{__rm} $RPM_BUILD_ROOT%{_localedir}/*/LC_MESSAGES/{bfd,opcodes}.mo
326 %{__rm} $RPM_BUILD_ROOT%{_infodir}/{bfd,ctf-spec}.info*
327 %{__rm} $RPM_BUILD_ROOT%{_includedir}/{ansidecl,bfd,bfdlink,ctf,ctf-api,diagnostics,dis-asm,symcat,plugin-api}.h
328 %{__rm} $RPM_BUILD_ROOT%{_libdir}/lib{bfd,ctf,ctf-nobfd,opcodes}.la
329 %{__rm} $RPM_BUILD_ROOT%{_libdir}/lib{bfd,ctf,ctf-nobfd,opcodes}.a
330
331 %clean
332 rm -rf $RPM_BUILD_ROOT
333
334 %post   -p /sbin/postshell
335 -/usr/sbin/fix-info-dir -c %{_infodir}
336
337 %postun -p /sbin/postshell
338 -/usr/sbin/fix-info-dir -c %{_infodir}
339
340 %files
341 %defattr(644,root,root,755)
342 %doc gdb/{NEWS,PROBLEMS,README}
343 %attr(755,root,root) %{_bindir}/gdb
344 %attr(755,root,root) %{_bindir}/gdbtui
345 %attr(755,root,root) %{_bindir}/gdb-add-index
346 %attr(755,root,root) %{_bindir}/gstack
347 %attr(755,root,root) %{_bindir}/gcore
348 %dir %{_datadir}/gdb
349 %dir %{_datadir}/gdb/auto-load
350 %dir %{_datadir}/gdb/auto-load%{_prefix}
351 %dir %{_datadir}/gdb/auto-load%{_prefix}/lib
352 %ifarch %{x8664} x32
353 %dir %{_datadir}/gdb/auto-load%{_prefix}/lib64
354 %dir %{_datadir}/gdb/auto-load%{_prefix}/libx32
355 %endif
356 %ifarch aarch64
357 %dir %{_datadir}/gdb/auto-load%{_prefix}/lib64
358 %endif
359 %{?with_guile:%{_datadir}/gdb/guile}
360 %{_datadir}/gdb/syscalls
361 %{_datadir}/gdb/system-gdbinit
362 %{_datadir}/gdb/python
363 %{_mandir}/man1/gdb.1*
364 %{_mandir}/man1/gdbtui.1*
365 %{_mandir}/man1/gdb-add-index.1*
366 %{_mandir}/man1/gstack.1*
367 %{_mandir}/man1/gcore.1*
368 %{_mandir}/man5/gdbinit.5*
369 %lang(es) %{_mandir}/es/man1/*
370 %lang(fr) %{_mandir}/fr/man1/*
371 %lang(hu) %{_mandir}/hu/man1/*
372 %lang(ja) %{_mandir}/ja/man1/*
373 %lang(pl) %{_mandir}/pl/man1/*
374 %{_infodir}/annotate.info*
375 %{_infodir}/gdb.info*
376 %{_infodir}/stabs.info*
377
378 %files gdbserver
379 %defattr(644,root,root,755)
380 %attr(755,root,root) %{_bindir}/gdbserver
381 %{_mandir}/man1/gdbserver.1*
382 %ifnarch %{arm}
383 %attr(755,root,root) %{_libdir}/libinproctrace.so
384 %endif
385
386 %files lib
387 %defattr(644,root,root,755)
388 %{_libdir}/libdecnumber.a
389 %{_libdir}/libgdb.a
390 %{_includedir}/gdb
This page took 1.072543 seconds and 4 git commands to generate.