]> git.pld-linux.org Git - packages/gdb.git/blob - gdb.spec
- fix build on x32
[packages/gdb.git] / gdb.spec
1 # NOTE: -lib package is used by fpc.spec
2
3 # TODO
4 # - change install msg to poldek in buildid-locate-rpm-pld.patch when poldek allows it. LP#493922
5 #
6 # Conditional build:
7 %bcond_without  guile           # Guile embedded scripting
8 %bcond_without  python          # build without python support
9
10 Summary:        A GNU source-level debugger for C, C++ and Fortran
11 Summary(de.UTF-8):      Symbolischer Debugger für C und andere Sprachen
12 Summary(es.UTF-8):      Depurador de programas C y otras lenguajes
13 Summary(fr.UTF-8):      Débugger symbolique pour C et d'autres langages
14 Summary(pl.UTF-8):      Symboliczny odpluskwiacz dla C i innych języków
15 Summary(pt_BR.UTF-8):   Depurador de programas C e outras linguagens
16 Summary(ru.UTF-8):      Символический отладчик для C и других языков
17 Summary(tr.UTF-8):      C ve diğer diller için sembolik hata ayıklayıcı
18 Summary(uk.UTF-8):      Символьний відладчик для С та інших мов
19 Summary(zh_CN.UTF-8):   [开发]C和其他语言的调试器
20 Summary(zh_TW.UTF-8):   [.-A開發]C和.$)B其.-A他語.$)B言的調試器
21 %define         snap    20120926
22 Name:           gdb
23 Version:        8.0
24 Release:        1
25 License:        GPL v3+
26 Group:          Development/Debuggers
27 Source0:        http://ftp.gnu.org/gnu/gdb/%{name}-%{version}.tar.xz
28 # Source0-md5:  c3d35cd949084be53b92cc1e03485f88
29 Source1:        http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-non-english-man-pages.tar.bz2
30 # Source1-md5:  2e8a48939ae282c12bbacdd54e398247
31 Source3:        %{name}-gstack.man
32 Patch0:         x32.patch
33 Patch100:       gdb-6.6-buildid-locate.patch
34 Patch101:       gdb-6.6-buildid-locate-solib-missing-ids.patch
35 Patch102:       gdb-6.6-buildid-locate-rpm.patch
36 Patch103:       gdb-6.6-buildid-locate-core-as-arg.patch
37 Patch104:       gdb-6.6-buildid-locate-rpm-librpm-workaround.patch
38 Patch105:       gdb-6.6-buildid-locate-misleading-warning-missing-debuginfo-rhbz981154.patch
39 Patch106:       gdb-6.6-buildid-locate-rpm-scl.patch
40 Patch110:       gdb-6.3-gstack-20050411.patch
41 Patch111:       gdb-gdb-add-index-script.patch
42 Patch112:       gdb-archer-vla-tests.patch
43 Patch113:       gdb-vla-intel-fortran-strides.patch
44 Patch114:       gdb-vla-intel-stringbt-fix.patch
45 Patch115:       gdb-vla-intel-fortran-vla-strings.patch
46 Patch116:       gdb-vla-intel-tests.patch
47 Patch1000:      %{name}-readline.patch
48 Patch1001:      %{name}-info.patch
49 Patch1002:      %{name}-passflags.patch
50 Patch1005:      %{name}-pretty-print-by-default.patch
51 Patch1006:      buildid-locate-rpm-pld.patch
52 URL:            http://www.gnu.org/software/gdb/
53 BuildRequires:  autoconf >= 2.69
54 BuildRequires:  automake
55 BuildRequires:  bison
56 BuildRequires:  babeltrace-devel
57 BuildRequires:  expat-devel
58 BuildRequires:  flex >= 2.6.4
59 BuildRequires:  gettext-tools
60 %{?with_guile:BuildRequires:    guile-devel >= 2.0}
61 BuildRequires:  libselinux-devel
62 BuildRequires:  libtool
63 BuildRequires:  ncurses-devel >= 5.2
64 BuildRequires:  pkgconfig
65 BuildRequires:  readline-devel
66 BuildRequires:  rpmbuild(macros) >= 1.219
67 BuildRequires:  texinfo >= 4.4
68 BuildRequires:  zlib-devel
69 %if %{with python}
70 BuildRequires:  python-devel
71 BuildRequires:  rpm-pythonprov
72 Obsoletes:      python-gdb
73 # for traceback module
74 Requires:       python-modules
75 %endif
76 %{?with_guile:Requires: guile >= 2.0}
77 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
78
79 %description
80 Gdb is a full featured, command driven debugger. Gdb allows you to
81 trace the execution of programs and examine their internal state at
82 any time. Gdb works for C and C++ compiled with the GNU C compiler
83 gcc.
84
85 %description -l de.UTF-8
86 dem Sie die Ausführung von Programmen verfolgen und jederzeit den
87 inneren Zustand überprüfen können. Er funktioniert für C und mit GNU C
88 kompiliertes C++.
89
90 %description -l es.UTF-8
91 Este es un debugger orientado a comandos repleto de características.
92 Te permite rastrear la ejecución de programas y examinar su estado
93 interno a cualquier momento. Funciona para C y C++ compilado con el
94 compilador GNU C.
95
96 %description -l fr.UTF-8
97 Débugger complet, piloté par commandes. Permet de tracer l'exécution
98 des programmes et d'examiner à tout moment leur état interne.
99 Fonctionne avec les binaires C et C++ compilés avec le compilateur C
100 de GNU, gcc.
101
102 %description -l pl.UTF-8
103 Gdb jest rozbudowanym odpluskwiaczem (debuggerem), pozwalającym
104 śledzić wykonywanie programu i badać jego stan wewnętrzny. Gdb
105 umożliwia odpluskwianie programów napisanych w C/C++ i skompilowanych
106 przy pomocy kompilatora GNU (gcc).
107
108 %description -l pt_BR.UTF-8
109 Este é um debugger orientado a comandos repleto de características.
110 Ele permite à você rastrear a execução de programas e examinar o seu
111 estado interno a qualquer momento. Ele funciona para para C e C++
112 compilado com o compilador GNU C.
113
114 %description -l ru.UTF-8
115 Это полноценный отладчик, управляемый командами. Он позволяет
116 трассировать исполнение программ и изучать их внутреннее состояние в
117 любой момент времени. Работает с программами на C и C++,
118 скомпилированными GNU компилятором C (gcc, egcs, pgcc).
119
120 %description -l tr.UTF-8
121 Bir komut arayüzü üzerinden programcıya programını adım adım izleme
122 (trace) ve herhangi bir anda programın durumunu inceleme olanağı
123 verir.
124
125 %description -l uk.UTF-8
126 Це повноцінний відладчик, що керується командами. Він дозволяє
127 трасувати виконання програм та вивчати їх внутрішній стан в довільний
128 момент часу. Працює з програмами на C та C++, зкомпільованими
129 компіляторами GNU C (gcc, egcs, pgcc).
130
131 %package gdbserver
132 Summary:        A standalone server for GDB (the GNU source-level debugger)
133 Summary(pl.UTF-8):      Samodzielny serwer GDB (debuggera GNU)
134 Group:          Development/Debuggers
135
136 %description gdbserver
137 GDB, the GNU debugger, allows you to debug programs written in C, C++,
138 Java, and other languages, by executing them in a controlled fashion
139 and printing their data.
140
141 This package provides a program that allows you to run GDB on a
142 different machine than the one which is running the program being
143 debugged.
144
145 %description gdbserver -l pl.UTF-8
146 GDB (GNU debugger) pozwala śledzić programy napisane w C, C++, Javie i
147 innych językach programowania poprzez wykonywanie ich w sposób
148 kontrolowany oraz wypisywanie ich danych.
149
150 Ten pakiet zawiera program pozwalający uruchamiać GDB na innej
151 maszynie niż ta, na której działa śledzony program.
152
153 %package lib
154 Summary:        GDB in the form of a static library
155 Summary(pl.UTF-8):      GDB w postaci biblioteki statycznej
156 Group:          Development/Debuggers
157 # libraries that needs to be linked to fulfill libgdb.a symbol requirements
158 Requires:       binutils-devel >= 2.17.50
159 Requires:       expat-devel
160 Requires:       libselinux-devel
161 Requires:       libsepol-devel
162 Requires:       ncurses-devel
163 Requires:       python-devel
164 Requires:       readline-devel
165 Requires:       xz-devel
166 Requires:       zlib-devel
167
168 %description lib
169 GDB in the form of a static library.
170
171 %description lib -l pl.UTF-8
172 GDB w postaci biblioteki statycznej.
173
174 %prep
175 %setup -q
176
177 # Files have `# <number> <file>' statements breaking VPATH / find-debuginfo.sh .
178 rm -f gdb/ada-exp.c gdb/ada-lex.c gdb/c-exp.c gdb/cp-name-parser.c gdb/f-exp.c
179 rm -f gdb/jv-exp.c gdb/m2-exp.c gdb/objc-exp.c gdb/p-exp.c
180
181 %patch100 -p1
182 %patch101 -p1
183 %patch102 -p1
184 %patch103 -p1
185 %patch104 -p1
186 %patch105 -p1
187 %patch106 -p1
188 %patch110 -p1
189 %patch111 -p1
190 %patch112 -p1
191 %patch113 -p1
192 %patch114 -p1
193 %patch115 -p1
194 %patch116 -p1
195
196 %patch1000 -p1
197 %patch1001 -p1
198 %patch1002 -p1
199 %patch1005 -p1
200 %patch1006 -p1
201
202 # Change the version that gets printed at GDB startup, so it is PLD Linux specific.
203 cat > gdb/version.in << EOF
204 %{version}-%{release} (PLD Linux)
205 EOF
206
207 sed -i -e 's#_GCC_AUTOCONF_VERSION\], \[2\.64\]#_GCC_AUTOCONF_VERSION], [2.69]#g' config/override.m4
208
209 %build
210 # omit hand-written gdb/testsuite aclocal.m4
211 for dir in gdb gdb/gdbserver ; do
212         olddir=$(pwd)
213         cd $dir
214         %{__rm} aclocal.m4
215         %{__aclocal} $(grep '^ACLOCAL_AMFLAGS' Makefile.in | sed -e 's/.*=//')
216         cd $olddir
217 done
218 for dir in $(find gdb -name 'configure.in' -o -name 'configure.ac'); do
219         dir=$(dirname "$dir")
220         olddir=$(pwd)
221         cd $dir
222         %{__autoconf}
223         grep -q AC_CONFIG_HEADER configure.* && %{__autoheader}
224         cd $olddir
225 done
226 cp -f /usr/share/automake/config.* .
227 # don't --enable-shared here, there would be libs version mismatch with binutils
228 %configure \
229         --with-gdb-datadir=%{_datadir}/gdb \
230         --with-separate-debug-dir=/usr/lib/debug \
231 %if %{with python}
232         --with-python=yes \
233         --with-pythondir=%{py_sitescriptdir} \
234 %else
235         --without-python \
236 %endif
237 %if %{with guile}
238         --with-guile \
239 %else
240         --without-guile \
241 %endif
242         --disable-gdbtk \
243         --disable-shared \
244         --enable-gdbcli \
245         --enable-gdbmi \
246         --enable-multi-ice \
247         --enable-netrom \
248         --enable-nls \
249         --enable-tui \
250         --with-system-readline \
251         --with-cpu=%{_target_cpu} \
252 %ifnarch alpha
253         --with-mmalloc \
254 %endif
255         --without-included-gettext \
256         --without-included-regex \
257         --without-x
258
259 %{__make}
260 %{__make} -j1 info
261
262 # gdb/ChangeLog: Build gdb directly from *.o files not using libgdb.a.
263 %{__make} -C gdb libgdb.a
264
265 %install
266 rm -rf $RPM_BUILD_ROOT
267 install -d $RPM_BUILD_ROOT%{_infodir}
268
269 %{__make} -j1 install install-info \
270         DESTDIR=$RPM_BUILD_ROOT
271
272 # gdbtui seems all identical to gdb except when invoked as gdbtio, ncurses
273 # window is created too.
274 echo ".so gdb.1" > $RPM_BUILD_ROOT%{_mandir}/man1/gdbtui.1
275 ln -f $RPM_BUILD_ROOT%{_bindir}/{gdb,gdbtui}
276
277 bzip2 -dc %{SOURCE1} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
278 cp -a gdb/libgdb.a $RPM_BUILD_ROOT%{_libdir}
279
280 rm -f $RPM_BUILD_ROOT%{_infodir}/dir
281 rm -f $RPM_BUILD_ROOT%{_mandir}/README.gdb-non-english-man-pages
282
283 %if %{with python}
284 # Temporarily now:
285 for LIB in lib lib64 libx32; do
286         LIBPATH="$RPM_BUILD_ROOT%{_datadir}/gdb/auto-load%{_prefix}/$LIB"
287         install -d $LIBPATH
288 done
289
290 %py_ocomp $RPM_BUILD_ROOT%{py_sitescriptdir}
291 %py_comp $RPM_BUILD_ROOT%{py_sitescriptdir}
292 %py_postclean
293 %endif
294
295 cp -a %{SOURCE3} $RPM_BUILD_ROOT%{_mandir}/man1/gstack.1
296
297 install libdecnumber/libdecnumber.a $RPM_BUILD_ROOT%{_libdir}
298
299 # Remove the files that are part of a gdb build but that are owned and provided by other packages.
300 # These are part of binutils:
301 %{__rm} $RPM_BUILD_ROOT%{_localedir}/*/LC_MESSAGES/{bfd,opcodes}.mo
302 %{__rm} $RPM_BUILD_ROOT%{_infodir}/bfd.info*
303 %{__rm} $RPM_BUILD_ROOT%{_includedir}/{ansidecl,bfd,bfdlink,dis-asm,symcat,plugin-api}.h
304 %{__rm} $RPM_BUILD_ROOT%{_libdir}/lib{bfd,opcodes}.la
305 %{__rm} $RPM_BUILD_ROOT%{_libdir}/lib{bfd,opcodes}.a
306
307 %clean
308 rm -rf $RPM_BUILD_ROOT
309
310 %post   -p /sbin/postshell
311 -/usr/sbin/fix-info-dir -c %{_infodir}
312
313 %postun -p /sbin/postshell
314 -/usr/sbin/fix-info-dir -c %{_infodir}
315
316 %files
317 %defattr(644,root,root,755)
318 %doc gdb/{ChangeLog,NEWS,PROBLEMS,README}
319 %attr(755,root,root) %{_bindir}/gdb
320 %attr(755,root,root) %{_bindir}/gdbtui
321 %attr(755,root,root) %{_bindir}/gdb-add-index
322 %attr(755,root,root) %{_bindir}/gstack
323 %attr(755,root,root) %{_bindir}/gcore
324 %dir %{_datadir}/gdb
325 %dir %{_datadir}/gdb/auto-load
326 %dir %{_datadir}/gdb/auto-load%{_prefix}
327 %dir %{_datadir}/gdb/auto-load%{_prefix}/lib
328 %ifarch %{x8664} x32
329 %dir %{_datadir}/gdb/auto-load%{_prefix}/lib64
330 %dir %{_datadir}/gdb/auto-load%{_prefix}/libx32
331 %endif
332 %{?with_guile:%{_datadir}/gdb/guile}
333 %{_datadir}/gdb/syscalls
334 %{_datadir}/gdb/system-gdbinit
335 %{_datadir}/gdb/python
336 %{_mandir}/man1/gdb.1*
337 %{_mandir}/man1/gdbtui.1*
338 %{_mandir}/man1/gdb-add-index.1*
339 %{_mandir}/man1/gstack.1*
340 %{_mandir}/man1/gcore.1*
341 %{_mandir}/man5/gdbinit.5*
342 %lang(es) %{_mandir}/es/man1/*
343 %lang(fr) %{_mandir}/fr/man1/*
344 %lang(hu) %{_mandir}/hu/man1/*
345 %lang(ja) %{_mandir}/ja/man1/*
346 %lang(pl) %{_mandir}/pl/man1/*
347 %{_infodir}/annotate.info*
348 %{_infodir}/gdb.info*
349 %{_infodir}/stabs.info*
350
351 %files gdbserver
352 %defattr(644,root,root,755)
353 %attr(755,root,root) %{_bindir}/gdbserver
354 %{_mandir}/man1/gdbserver.1*
355 %attr(755,root,root) %{_libdir}/libinproctrace.so
356
357 %files lib
358 %defattr(644,root,root,755)
359 %{_libdir}/libdecnumber.a
360 %{_libdir}/libgdb.a
361 %{_includedir}/gdb
This page took 0.043638 seconds and 3 git commands to generate.