]> git.pld-linux.org Git - packages/gdb.git/blob - gdb.spec
- rebuild with readline 7.0
[packages/gdb.git] / gdb.spec
1 # NOTE: -lib package is used by fpc.spec
2
3 # TODO
4 # - change install msg to poldek in buildid-locate-rpm-pld.patch when poldek allows it. LP#493922
5 #
6 # Conditional build:
7 %bcond_without  guile           # Guile embedded scripting
8 %bcond_without  python          # build without python support
9
10 Summary:        A GNU source-level debugger for C, C++ and Fortran
11 Summary(de.UTF-8):      Symbolischer Debugger für C und andere Sprachen
12 Summary(es.UTF-8):      Depurador de programas C y otras lenguajes
13 Summary(fr.UTF-8):      Débugger symbolique pour C et d'autres langages
14 Summary(pl.UTF-8):      Symboliczny odpluskwiacz dla C i innych języków
15 Summary(pt_BR.UTF-8):   Depurador de programas C e outras linguagens
16 Summary(ru.UTF-8):      Символический отладчик для C и других языков
17 Summary(tr.UTF-8):      C ve diğer diller için sembolik hata ayıklayıcı
18 Summary(uk.UTF-8):      Символьний відладчик для С та інших мов
19 Summary(zh_CN.UTF-8):   [开发]C和其他语言的调试器
20 Summary(zh_TW.UTF-8):   [.-A開發]C和.$)B其.-A他語.$)B言的調試器
21 %define         snap    20120926
22 Name:           gdb
23 Version:        7.11.1
24 Release:        3
25 License:        GPL v3+
26 Group:          Development/Debuggers
27 Source0:        http://ftp.gnu.org/gnu/gdb/%{name}-%{version}.tar.xz
28 # Source0-md5:  5aa71522e488e358243917967db87476
29 Source1:        http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-non-english-man-pages.tar.bz2
30 # Source1-md5:  2e8a48939ae282c12bbacdd54e398247
31 Source3:        %{name}-gstack.man
32 # https://sourceware.org/bugzilla/show_bug.cgi?id=20287
33 Patch0:         gdb-bug-20287.patch
34 # https://sourceware.org/bugzilla/show_bug.cgi?id=20413
35 Patch1:         gdb-bug-20413.patch
36 Patch100:       gdb-6.6-buildid-locate.patch
37 Patch101:       gdb-6.6-buildid-locate-solib-missing-ids.patch
38 Patch102:       gdb-6.6-buildid-locate-rpm.patch
39 Patch103:       gdb-6.6-buildid-locate-core-as-arg.patch
40 Patch104:       gdb-6.6-buildid-locate-rpm-librpm-workaround.patch
41 Patch105:       gdb-6.6-buildid-locate-misleading-warning-missing-debuginfo-rhbz981154.patch
42 Patch110:       gdb-6.3-gstack-20050411.patch
43 Patch111:       gdb-gdb-add-index-script.patch
44 Patch112:       gdb-archer-vla-tests.patch
45 Patch113:       gdb-vla-intel.patch
46 Patch114:       gdb-vla-intel-04of23-fix.patch
47 Patch115:       gdb-vla-intel-stringbt-fix.patch
48 Patch116:       gdb-vla-intel-logical-not.patch
49 Patch1000:      %{name}-readline.patch
50 Patch1001:      %{name}-info.patch
51 Patch1002:      %{name}-passflags.patch
52 Patch1005:      %{name}-pretty-print-by-default.patch
53 Patch1006:      buildid-locate-rpm-pld.patch
54 URL:            http://www.gnu.org/software/gdb/
55 BuildRequires:  autoconf >= 2.69
56 BuildRequires:  automake
57 BuildRequires:  bison
58 BuildRequires:  babeltrace-devel
59 BuildRequires:  expat-devel
60 BuildRequires:  flex
61 BuildRequires:  gettext-tools
62 %{?with_guile:BuildRequires:    guile-devel >= 2.0}
63 BuildRequires:  libselinux-devel
64 BuildRequires:  libtool
65 BuildRequires:  ncurses-devel >= 5.2
66 BuildRequires:  pkgconfig
67 BuildRequires:  readline-devel
68 BuildRequires:  rpmbuild(macros) >= 1.219
69 BuildRequires:  texinfo >= 4.4
70 BuildRequires:  zlib-devel
71 %if %{with python}
72 BuildRequires:  python-devel
73 BuildRequires:  rpm-pythonprov
74 Obsoletes:      python-gdb
75 # for traceback module
76 Requires:       python-modules
77 %endif
78 %{?with_guile:Requires: guile >= 2.0}
79 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
80
81 %description
82 Gdb is a full featured, command driven debugger. Gdb allows you to
83 trace the execution of programs and examine their internal state at
84 any time. Gdb works for C and C++ compiled with the GNU C compiler
85 gcc.
86
87 %description -l de.UTF-8
88 dem Sie die Ausführung von Programmen verfolgen und jederzeit den
89 inneren Zustand überprüfen können. Er funktioniert für C und mit GNU C
90 kompiliertes C++.
91
92 %description -l es.UTF-8
93 Este es un debugger orientado a comandos repleto de características.
94 Te permite rastrear la ejecución de programas y examinar su estado
95 interno a cualquier momento. Funciona para C y C++ compilado con el
96 compilador GNU C.
97
98 %description -l fr.UTF-8
99 Débugger complet, piloté par commandes. Permet de tracer l'exécution
100 des programmes et d'examiner à tout moment leur état interne.
101 Fonctionne avec les binaires C et C++ compilés avec le compilateur C
102 de GNU, gcc.
103
104 %description -l pl.UTF-8
105 Gdb jest rozbudowanym odpluskwiaczem (debuggerem), pozwalającym
106 śledzić wykonywanie programu i badać jego stan wewnętrzny. Gdb
107 umożliwia odpluskwianie programów napisanych w C/C++ i skompilowanych
108 przy pomocy kompilatora GNU (gcc).
109
110 %description -l pt_BR.UTF-8
111 Este é um debugger orientado a comandos repleto de características.
112 Ele permite à você rastrear a execução de programas e examinar o seu
113 estado interno a qualquer momento. Ele funciona para para C e C++
114 compilado com o compilador GNU C.
115
116 %description -l ru.UTF-8
117 Это полноценный отладчик, управляемый командами. Он позволяет
118 трассировать исполнение программ и изучать их внутреннее состояние в
119 любой момент времени. Работает с программами на C и C++,
120 скомпилированными GNU компилятором C (gcc, egcs, pgcc).
121
122 %description -l tr.UTF-8
123 Bir komut arayüzü üzerinden programcıya programını adım adım izleme
124 (trace) ve herhangi bir anda programın durumunu inceleme olanağı
125 verir.
126
127 %description -l uk.UTF-8
128 Це повноцінний відладчик, що керується командами. Він дозволяє
129 трасувати виконання програм та вивчати їх внутрішній стан в довільний
130 момент часу. Працює з програмами на C та C++, зкомпільованими
131 компіляторами GNU C (gcc, egcs, pgcc).
132
133 %package gdbserver
134 Summary:        A standalone server for GDB (the GNU source-level debugger)
135 Summary(pl.UTF-8):      Samodzielny serwer GDB (debuggera GNU)
136 Group:          Development/Debuggers
137
138 %description gdbserver
139 GDB, the GNU debugger, allows you to debug programs written in C, C++,
140 Java, and other languages, by executing them in a controlled fashion
141 and printing their data.
142
143 This package provides a program that allows you to run GDB on a
144 different machine than the one which is running the program being
145 debugged.
146
147 %description gdbserver -l pl.UTF-8
148 GDB (GNU debugger) pozwala śledzić programy napisane w C, C++, Javie i
149 innych językach programowania poprzez wykonywanie ich w sposób
150 kontrolowany oraz wypisywanie ich danych.
151
152 Ten pakiet zawiera program pozwalający uruchamiać GDB na innej
153 maszynie niż ta, na której działa śledzony program.
154
155 %package lib
156 Summary:        GDB in the form of a static library
157 Summary(pl.UTF-8):      GDB w postaci biblioteki statycznej
158 Group:          Development/Debuggers
159 # libraries that needs to be linked to fulfill libgdb.a symbol requirements
160 Requires:       binutils-devel >= 2.17.50
161 Requires:       expat-devel
162 Requires:       libselinux-devel
163 Requires:       libsepol-devel
164 Requires:       ncurses-devel
165 Requires:       python-devel
166 Requires:       readline-devel
167 Requires:       xz-devel
168 Requires:       zlib-devel
169
170 %description lib
171 GDB in the form of a static library.
172
173 %description lib -l pl.UTF-8
174 GDB w postaci biblioteki statycznej.
175
176 %prep
177 %setup -q
178
179 %patch0 -p1
180 %patch1 -p1
181
182 # Files have `# <number> <file>' statements breaking VPATH / find-debuginfo.sh .
183 rm -f gdb/ada-exp.c gdb/ada-lex.c gdb/c-exp.c gdb/cp-name-parser.c gdb/f-exp.c
184 rm -f gdb/jv-exp.c gdb/m2-exp.c gdb/objc-exp.c gdb/p-exp.c
185
186 %patch100 -p1
187 %patch101 -p1
188 %patch102 -p1
189 %patch103 -p1
190 %patch104 -p1
191 %patch105 -p1
192 %patch110 -p1
193 %patch111 -p1
194 %patch112 -p1
195 %patch113 -p1
196 %patch114 -p1
197 %patch115 -p1
198 %patch116 -p1
199
200 %patch1000 -p1
201 %patch1001 -p1
202 %patch1002 -p1
203 %patch1005 -p1
204 %patch1006 -p1
205
206 # Change the version that gets printed at GDB startup, so it is PLD Linux specific.
207 cat > gdb/version.in << EOF
208 %{version}-%{release} (PLD Linux)
209 EOF
210
211 sed -i -e 's#_GCC_AUTOCONF_VERSION\], \[2\.64\]#_GCC_AUTOCONF_VERSION], [2.69]#g' config/override.m4
212
213 %build
214 # omit hand-written gdb/testsuite aclocal.m4
215 for dir in gdb gdb/gdbserver ; do
216         olddir=$(pwd)
217         cd $dir
218         %{__rm} aclocal.m4
219         %{__aclocal} $(grep '^ACLOCAL_AMFLAGS' Makefile.in | sed -e 's/.*=//')
220         cd $olddir
221 done
222 for dir in $(find gdb -name 'configure.in' -o -name 'configure.ac'); do
223         dir=$(dirname "$dir")
224         olddir=$(pwd)
225         cd $dir
226         %{__autoconf}
227         grep -q AC_CONFIG_HEADER configure.* && %{__autoheader}
228         cd $olddir
229 done
230 cp -f /usr/share/automake/config.* .
231 # don't --enable-shared here, there would be libs version mismatch with binutils
232 %configure \
233         --with-gdb-datadir=%{_datadir}/gdb \
234         --with-separate-debug-dir=/usr/lib/debug \
235 %if %{with python}
236         --with-python=yes \
237         --with-pythondir=%{py_sitescriptdir} \
238 %else
239         --without-python \
240 %endif
241 %if %{with guile}
242         --with-guile \
243 %else
244         --without-guile \
245 %endif
246         --disable-gdbtk \
247         --disable-shared \
248         --enable-gdbcli \
249         --enable-gdbmi \
250         --enable-multi-ice \
251         --enable-netrom \
252         --enable-nls \
253         --enable-tui \
254         --with-system-readline \
255         --with-cpu=%{_target_cpu} \
256 %ifnarch alpha
257         --with-mmalloc \
258 %endif
259         --without-included-gettext \
260         --without-included-regex \
261         --without-x
262
263 %{__make}
264 %{__make} -j1 info
265
266 # gdb/ChangeLog: Build gdb directly from *.o files not using libgdb.a.
267 %{__make} -C gdb libgdb.a
268
269 %install
270 rm -rf $RPM_BUILD_ROOT
271 install -d $RPM_BUILD_ROOT%{_infodir}
272
273 %{__make} -j1 install install-info \
274         DESTDIR=$RPM_BUILD_ROOT
275
276 # gdbtui seems all identical to gdb except when invoked as gdbtio, ncurses
277 # window is created too.
278 echo ".so gdb.1" > $RPM_BUILD_ROOT%{_mandir}/man1/gdbtui.1
279 ln -f $RPM_BUILD_ROOT%{_bindir}/{gdb,gdbtui}
280
281 bzip2 -dc %{SOURCE1} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
282 cp -a gdb/libgdb.a $RPM_BUILD_ROOT%{_libdir}
283
284 rm -f $RPM_BUILD_ROOT%{_infodir}/dir
285 rm -f $RPM_BUILD_ROOT%{_mandir}/README.gdb-non-english-man-pages
286
287 %if %{with python}
288 # Temporarily now:
289 for LIB in lib lib64 libx32; do
290         LIBPATH="$RPM_BUILD_ROOT%{_datadir}/gdb/auto-load%{_prefix}/$LIB"
291         install -d $LIBPATH
292 done
293
294 %py_ocomp $RPM_BUILD_ROOT%{py_sitescriptdir}
295 %py_comp $RPM_BUILD_ROOT%{py_sitescriptdir}
296 %py_postclean
297 %endif
298
299 cp -a %{SOURCE3} $RPM_BUILD_ROOT%{_mandir}/man1/gstack.1
300
301 install libdecnumber/libdecnumber.a $RPM_BUILD_ROOT%{_libdir}
302
303 # Remove the files that are part of a gdb build but that are owned and provided by other packages.
304 # These are part of binutils:
305 %{__rm} $RPM_BUILD_ROOT%{_localedir}/*/LC_MESSAGES/{bfd,opcodes}.mo
306 %{__rm} $RPM_BUILD_ROOT%{_infodir}/bfd.info*
307 %{__rm} $RPM_BUILD_ROOT%{_includedir}/{ansidecl,bfd,bfdlink,dis-asm,symcat,plugin-api}.h
308 %{__rm} $RPM_BUILD_ROOT%{_libdir}/lib{bfd,opcodes}.la
309 %{__rm} $RPM_BUILD_ROOT%{_libdir}/lib{bfd,opcodes}.a
310
311 %clean
312 rm -rf $RPM_BUILD_ROOT
313
314 %post   -p /sbin/postshell
315 -/usr/sbin/fix-info-dir -c %{_infodir}
316
317 %postun -p /sbin/postshell
318 -/usr/sbin/fix-info-dir -c %{_infodir}
319
320 %files
321 %defattr(644,root,root,755)
322 %doc gdb/{ChangeLog,NEWS,PROBLEMS,README}
323 %attr(755,root,root) %{_bindir}/gdb
324 %attr(755,root,root) %{_bindir}/gdbtui
325 %attr(755,root,root) %{_bindir}/gdb-add-index
326 %attr(755,root,root) %{_bindir}/gstack
327 %attr(755,root,root) %{_bindir}/gcore
328 %dir %{_datadir}/gdb
329 %dir %{_datadir}/gdb/auto-load
330 %dir %{_datadir}/gdb/auto-load%{_prefix}
331 %dir %{_datadir}/gdb/auto-load%{_prefix}/lib
332 %ifarch %{x8664} x32
333 %dir %{_datadir}/gdb/auto-load%{_prefix}/lib64
334 %dir %{_datadir}/gdb/auto-load%{_prefix}/libx32
335 %endif
336 %{?with_guile:%{_datadir}/gdb/guile}
337 %{_datadir}/gdb/syscalls
338 %{_datadir}/gdb/system-gdbinit
339 %{_datadir}/gdb/python
340 %{_mandir}/man1/gdb.1*
341 %{_mandir}/man1/gdbtui.1*
342 %{_mandir}/man1/gdb-add-index.1*
343 %{_mandir}/man1/gstack.1*
344 %{_mandir}/man1/gcore.1*
345 %{_mandir}/man5/gdbinit.5*
346 %lang(es) %{_mandir}/es/man1/*
347 %lang(fr) %{_mandir}/fr/man1/*
348 %lang(hu) %{_mandir}/hu/man1/*
349 %lang(ja) %{_mandir}/ja/man1/*
350 %lang(pl) %{_mandir}/pl/man1/*
351 %{_infodir}/annotate.info*
352 %{_infodir}/gdb.info*
353 %{_infodir}/stabs.info*
354
355 %files gdbserver
356 %defattr(644,root,root,755)
357 %attr(755,root,root) %{_bindir}/gdbserver
358 %{_mandir}/man1/gdbserver.1*
359 %attr(755,root,root) %{_libdir}/libinproctrace.so
360
361 %files lib
362 %defattr(644,root,root,755)
363 %{_libdir}/libdecnumber.a
364 %{_libdir}/libgdb.a
365 %{_includedir}/gdb
This page took 0.071411 seconds and 3 git commands to generate.