]> git.pld-linux.org Git - packages/gdb.git/blob - gdb.spec
- updated to 14.1 + rebased Fedora buildid patches set
[packages/gdb.git] / gdb.spec
1 # NOTE: -lib package is used by fpc.spec
2
3 # TODO
4 # - debuginfod (BR: elfutils-debuginfod-devel >= 0.179)
5 # - rpm5 librpm support (gdb/configure.ac checks for 4.x or so)
6 # - change install msg to poldek in buildid-locate-rpm-pld.patch when poldek allows it. LP#493922
7 # - reenable guile after https://sourceware.org/bugzilla/show_bug.cgi?id=21104 is fixed
8 #
9 # Conditional build:
10 %bcond_with     guile           # Guile embedded scripting
11 %bcond_without  python          # build without python support
12
13 Summary:        A GNU source-level debugger for C, C++ and Fortran
14 Summary(de.UTF-8):      Symbolischer Debugger für C und andere Sprachen
15 Summary(es.UTF-8):      Depurador de programas C y otras lenguajes
16 Summary(fr.UTF-8):      Débugger symbolique pour C et d'autres langages
17 Summary(pl.UTF-8):      Symboliczny odpluskwiacz dla C i innych języków
18 Summary(pt_BR.UTF-8):   Depurador de programas C e outras linguagens
19 Summary(ru.UTF-8):      Символический отладчик для C и других языков
20 Summary(tr.UTF-8):      C ve diğer diller için sembolik hata ayıklayıcı
21 Summary(uk.UTF-8):      Символьний відладчик для С та інших мов
22 Summary(zh_CN.UTF-8):   [开发]C和其他语言的调试器
23 Summary(zh_TW.UTF-8):   [.-A開發]C和.$)B其.-A他語.$)B言的調試器
24 Name:           gdb
25 Version:        12.1
26 Release:        1
27 License:        GPL v3+
28 Group:          Development/Debuggers
29 Source0:        https://ftp.gnu.org/gnu/gdb/%{name}-%{version}.tar.xz
30 # Source0-md5:  759a1b8d2b4d403367dd0e14fa04643d
31 Source1:        http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-non-english-man-pages.tar.bz2
32 # Source1-md5:  2e8a48939ae282c12bbacdd54e398247
33 Source3:        %{name}-gstack.man
34 Patch100:       gdb-6.6-buildid-locate.patch
35 Patch101:       gdb-6.6-buildid-locate-solib-missing-ids.patch
36 Patch102:       gdb-6.6-buildid-locate-rpm.patch
37 Patch104:       gdb-6.6-buildid-locate-rpm-librpm-workaround.patch
38 Patch105:       gdb-6.6-buildid-locate-misleading-warning-missing-debuginfo-rhbz981154.patch
39 Patch106:       gdb-6.6-buildid-locate-rpm-scl.patch
40 Patch110:       gdb-6.3-gstack-20050411.patch
41 Patch1000:      %{name}-readline.patch
42 Patch1001:      %{name}-info.patch
43 Patch1002:      %{name}-passflags.patch
44 Patch1003:      %{name}-readline8.2.patch
45 Patch1005:      %{name}-pretty-print-by-default.patch
46 Patch1006:      buildid-locate-rpm-pld.patch
47 URL:            http://www.gnu.org/software/gdb/
48 BuildRequires:  autoconf >= 2.69
49 BuildRequires:  automake
50 BuildRequires:  babeltrace-devel >= 1.1.0
51 BuildRequires:  bison
52 BuildRequires:  expat-devel
53 BuildRequires:  flex >= 2.6.4
54 BuildRequires:  gettext-tools >= 0.12.1
55 BuildRequires:  gmp-devel
56 %if %{with guile}
57 BuildRequires:  guile-devel >= 2.0
58 BuildRequires:  guile-devel < 3.2
59 %endif
60 %ifarch %{ix86} %{x8664}
61 BuildRequires:  libipt-devel
62 %endif
63 BuildRequires:  libmpc-devel
64 BuildRequires:  libselinux-devel
65 BuildRequires:  libstdc++-devel >= 6:4.8
66 BuildRequires:  libtool >= 2:2
67 BuildRequires:  make >= 3.81
68 BuildRequires:  mpfr-devel
69 BuildRequires:  ncurses-devel >= 5.2
70 BuildRequires:  pkgconfig
71 BuildRequires:  readline-devel
72 BuildRequires:  rpm-devel >= 4.6
73 BuildRequires:  rpmbuild(macros) >= 1.219
74 BuildRequires:  source-highlight-devel >= 3.0
75 BuildRequires:  tar >= 1:1.22
76 BuildRequires:  texinfo >= 4.4
77 BuildRequires:  xxHash-devel
78 BuildRequires:  xz
79 BuildRequires:  xz-devel
80 BuildRequires:  zlib-devel
81 %if %{with python}
82 BuildRequires:  python3-devel >= 1:3.2
83 BuildRequires:  rpm-pythonprov
84 Obsoletes:      python-gdb < 7.3
85 # for traceback module
86 Requires:       python3-modules >= 1:3.2
87 %endif
88 %{?with_guile:Requires: guile >= 2.0.12}
89 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
90
91 %define         autoconf_ver    %(rpm -q --qf='%%{VERSION}' autoconf)
92
93 %description
94 Gdb is a full featured, command driven debugger. Gdb allows you to
95 trace the execution of programs and examine their internal state at
96 any time. Gdb works for C and C++ compiled with the GNU C compiler
97 gcc.
98
99 %description -l de.UTF-8
100 dem Sie die Ausführung von Programmen verfolgen und jederzeit den
101 inneren Zustand überprüfen können. Er funktioniert für C und mit GNU C
102 kompiliertes C++.
103
104 %description -l es.UTF-8
105 Este es un debugger orientado a comandos repleto de características.
106 Te permite rastrear la ejecución de programas y examinar su estado
107 interno a cualquier momento. Funciona para C y C++ compilado con el
108 compilador GNU C.
109
110 %description -l fr.UTF-8
111 Débugger complet, piloté par commandes. Permet de tracer l'exécution
112 des programmes et d'examiner à tout moment leur état interne.
113 Fonctionne avec les binaires C et C++ compilés avec le compilateur C
114 de GNU, gcc.
115
116 %description -l pl.UTF-8
117 Gdb jest rozbudowanym odpluskwiaczem (debuggerem), pozwalającym
118 śledzić wykonywanie programu i badać jego stan wewnętrzny. Gdb
119 umożliwia odpluskwianie programów napisanych w C/C++ i skompilowanych
120 przy pomocy kompilatora GNU (gcc).
121
122 %description -l pt_BR.UTF-8
123 Este é um debugger orientado a comandos repleto de características.
124 Ele permite à você rastrear a execução de programas e examinar o seu
125 estado interno a qualquer momento. Ele funciona para para C e C++
126 compilado com o compilador GNU C.
127
128 %description -l ru.UTF-8
129 Это полноценный отладчик, управляемый командами. Он позволяет
130 трассировать исполнение программ и изучать их внутреннее состояние в
131 любой момент времени. Работает с программами на C и C++,
132 скомпилированными GNU компилятором C (gcc, egcs, pgcc).
133
134 %description -l tr.UTF-8
135 Bir komut arayüzü üzerinden programcıya programını adım adım izleme
136 (trace) ve herhangi bir anda programın durumunu inceleme olanağı
137 verir.
138
139 %description -l uk.UTF-8
140 Це повноцінний відладчик, що керується командами. Він дозволяє
141 трасувати виконання програм та вивчати їх внутрішній стан в довільний
142 момент часу. Працює з програмами на C та C++, зкомпільованими
143 компіляторами GNU C (gcc, egcs, pgcc).
144
145 %package gdbserver
146 Summary:        A standalone server for GDB (the GNU source-level debugger)
147 Summary(pl.UTF-8):      Samodzielny serwer GDB (debuggera GNU)
148 Group:          Development/Debuggers
149
150 %description gdbserver
151 GDB, the GNU debugger, allows you to debug programs written in C, C++,
152 Java, and other languages, by executing them in a controlled fashion
153 and printing their data.
154
155 This package provides a program that allows you to run GDB on a
156 different machine than the one which is running the program being
157 debugged.
158
159 %description gdbserver -l pl.UTF-8
160 GDB (GNU debugger) pozwala śledzić programy napisane w C, C++, Javie i
161 innych językach programowania poprzez wykonywanie ich w sposób
162 kontrolowany oraz wypisywanie ich danych.
163
164 Ten pakiet zawiera program pozwalający uruchamiać GDB na innej
165 maszynie niż ta, na której działa śledzony program.
166
167 %package lib
168 Summary:        GDB in the form of a static library
169 Summary(pl.UTF-8):      GDB w postaci biblioteki statycznej
170 Group:          Development/Debuggers
171 # libraries that needs to be linked to fulfill libgdb.a symbol requirements
172 Requires:       binutils-devel >= 2.17.50
173 Requires:       expat-devel
174 Requires:       libselinux-devel
175 Requires:       libsepol-devel
176 Requires:       ncurses-devel
177 Requires:       python3-devel
178 Requires:       readline-devel
179 Requires:       xz-devel
180 Requires:       zlib-devel
181
182 %description lib
183 GDB in the form of a static library.
184
185 %description lib -l pl.UTF-8
186 GDB w postaci biblioteki statycznej.
187
188 %prep
189 %setup -q
190
191 # Files have `# <number> <file>' statements breaking VPATH / find-debuginfo.sh .
192 %{__rm} gdb/ada-exp.c gdb/ada-lex.c gdb/c-exp.c gdb/cp-name-parser.c gdb/f-exp.c
193 %{__rm} gdb/m2-exp.c gdb/p-exp.c
194
195 %patch100 -p1
196 %patch101 -p1
197 %patch102 -p1
198 %patch104 -p1
199 %patch105 -p1
200 %patch106 -p1
201 %patch110 -p1
202
203 %patch1000 -p1
204 %patch1001 -p1
205 %patch1002 -p1
206 %patch1003 -p1
207 %patch1005 -p1
208 %patch1006 -p1
209
210 # Change the version that gets printed at GDB startup, so it is PLD Linux specific.
211 cat > gdb/version.in << EOF
212 %{version}-%{release} (PLD Linux)
213 EOF
214
215 %{__sed} -i -e '1s,/usr/bin/python$,%{__python},' \
216       contrib/dg-extract-results.py \
217
218 %{__sed} -i -e '1s,/usr/bin/env python$,%{__python},' \
219       gdb/contrib/test_pubnames_and_indexes.py \
220       gdb/testsuite/print-ts.py
221
222 %{__sed} -i -e '1s,/usr/bin/env python3,%{__python3},' \
223       gdb/testsuite/analyze-racy-logs.py \
224       gdb/copyright.py
225
226 %{__sed} -i -e '1s,/usr/bin/env bash,/bin/bash,' \
227       gdb/contrib/cc-with-tweaks.sh \
228       gdb/gcore.in \
229       src-release.sh
230
231 sed -i -e 's/\[2\.69\]/[%{autoconf_ver}]/' config/override.m4
232
233 %build
234 # omit hand-written gdb/testsuite aclocal.m4
235 for dir in gdb gdbserver ; do
236         olddir=$(pwd)
237         cd $dir
238         %{__rm} aclocal.m4
239         %{__aclocal} $(grep '^ACLOCAL_AMFLAGS' Makefile.in | sed -e 's/.*=//')
240         cd $olddir
241 done
242 for dir in $(find gdb -name 'configure.in' -o -name 'configure.ac'); do
243         dir=$(dirname "$dir")
244         olddir=$(pwd)
245         cd $dir
246         %{__autoconf}
247         grep -q AC_CONFIG_HEADER configure.* && %{__autoheader}
248         cd $olddir
249 done
250 cp -f /usr/share/automake/config.* .
251 install -d build && cd build
252 # don't --enable-shared here, there would be libs version mismatch with binutils
253 ../%configure \
254         --disable-gdbtk \
255         --disable-shared \
256         --disable-silent-rules \
257         --enable-gdbcli \
258         --enable-gdbmi \
259         --enable-multi-ice \
260         --enable-netrom \
261         --enable-nls \
262         --enable-tui \
263         --with-cpu=%{_target_cpu} \
264         --with-gdb-datadir=%{_datadir}/gdb \
265         --with-guile%{!?with_guile:=no} \
266 %ifnarch alpha
267         --with-mmalloc \
268 %endif
269 %if %{with python}
270         --with-python="%{__python3}" \
271         --with-pythondir=%{py3_sitescriptdir} \
272 %else
273         --without-python \
274 %endif
275         --with-separate-debug-dir=/usr/lib/debug \
276         --with-system-readline \
277         --without-included-gettext \
278         --without-included-regex \
279         --without-x
280
281 # V=1 because only some subdirs honour --enable-silent-rules
282 %{__make} \
283         V=1
284
285 %{__make} -j1 info
286
287 # gdb/ChangeLog: Build gdb directly from *.o files not using libgdb.a.
288 %{__make} -C gdb libgdb.a \
289         V=1
290
291 %install
292 rm -rf $RPM_BUILD_ROOT
293 install -d $RPM_BUILD_ROOT%{_infodir}
294
295 %{__make} -C build -j1 install install-info \
296         DESTDIR=$RPM_BUILD_ROOT
297
298 cp -a build/gdb/libgdb.a $RPM_BUILD_ROOT%{_libdir}
299
300 # gdbtui seems all identical to gdb except when invoked as gdbtui, ncurses
301 # window is created too.
302 echo ".so gdb.1" > $RPM_BUILD_ROOT%{_mandir}/man1/gdbtui.1
303 ln -f $RPM_BUILD_ROOT%{_bindir}/{gdb,gdbtui}
304
305 bzip2 -dc %{SOURCE1} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
306 %{__rm} $RPM_BUILD_ROOT%{_mandir}/README.gdb-non-english-man-pages
307
308 rm -f $RPM_BUILD_ROOT%{_infodir}/dir
309
310 %if %{with python}
311 # Temporarily now:
312 for LIB in lib lib64 libx32; do
313         LIBPATH="$RPM_BUILD_ROOT%{_datadir}/gdb/auto-load%{_prefix}/$LIB"
314         install -d $LIBPATH
315 done
316
317 %py3_ocomp $RPM_BUILD_ROOT%{py3_sitescriptdir}
318 %py3_comp $RPM_BUILD_ROOT%{py3_sitescriptdir}
319 %endif
320
321 cp -a %{SOURCE3} $RPM_BUILD_ROOT%{_mandir}/man1/gstack.1
322
323 cp -p build/libdecnumber/libdecnumber.a $RPM_BUILD_ROOT%{_libdir}
324
325 # Remove the files that are part of a gdb build but that are owned and provided by other packages.
326 # These are part of binutils:
327 %{__rm} $RPM_BUILD_ROOT%{_localedir}/*/LC_MESSAGES/{bfd,opcodes}.mo
328 %{__rm} $RPM_BUILD_ROOT%{_infodir}/{bfd,ctf-spec}.info*
329 %{__rm} $RPM_BUILD_ROOT%{_includedir}/{ansidecl,bfd,bfdlink,ctf,ctf-api,diagnostics,dis-asm,symcat,plugin-api}.h
330 %{__rm} $RPM_BUILD_ROOT%{_libdir}/lib{bfd,ctf,ctf-nobfd,opcodes}.la
331 %{__rm} $RPM_BUILD_ROOT%{_libdir}/lib{bfd,ctf,ctf-nobfd,opcodes}.a
332
333 %clean
334 rm -rf $RPM_BUILD_ROOT
335
336 %post   -p /sbin/postshell
337 -/usr/sbin/fix-info-dir -c %{_infodir}
338
339 %postun -p /sbin/postshell
340 -/usr/sbin/fix-info-dir -c %{_infodir}
341
342 %files
343 %defattr(644,root,root,755)
344 %doc gdb/{NEWS,PROBLEMS,README}
345 %attr(755,root,root) %{_bindir}/gdb
346 %attr(755,root,root) %{_bindir}/gdbtui
347 %attr(755,root,root) %{_bindir}/gdb-add-index
348 %attr(755,root,root) %{_bindir}/gstack
349 %attr(755,root,root) %{_bindir}/gcore
350 %dir %{_datadir}/gdb
351 %dir %{_datadir}/gdb/auto-load
352 %dir %{_datadir}/gdb/auto-load%{_prefix}
353 %dir %{_datadir}/gdb/auto-load%{_prefix}/lib
354 %ifarch %{x8664} x32
355 %dir %{_datadir}/gdb/auto-load%{_prefix}/lib64
356 %dir %{_datadir}/gdb/auto-load%{_prefix}/libx32
357 %endif
358 %ifarch aarch64
359 %dir %{_datadir}/gdb/auto-load%{_prefix}/lib64
360 %endif
361 %{?with_guile:%{_datadir}/gdb/guile}
362 %{_datadir}/gdb/syscalls
363 %{_datadir}/gdb/system-gdbinit
364 %{_datadir}/gdb/python
365 %{_mandir}/man1/gdb.1*
366 %{_mandir}/man1/gdbtui.1*
367 %{_mandir}/man1/gdb-add-index.1*
368 %{_mandir}/man1/gstack.1*
369 %{_mandir}/man1/gcore.1*
370 %{_mandir}/man5/gdbinit.5*
371 %lang(es) %{_mandir}/es/man1/*
372 %lang(fr) %{_mandir}/fr/man1/*
373 %lang(hu) %{_mandir}/hu/man1/*
374 %lang(ja) %{_mandir}/ja/man1/*
375 %lang(pl) %{_mandir}/pl/man1/*
376 %{_infodir}/annotate.info*
377 %{_infodir}/gdb.info*
378 %{_infodir}/stabs.info*
379
380 %files gdbserver
381 %defattr(644,root,root,755)
382 %attr(755,root,root) %{_bindir}/gdbserver
383 %{_mandir}/man1/gdbserver.1*
384 %ifnarch %{arm}
385 %attr(755,root,root) %{_libdir}/libinproctrace.so
386 %endif
387
388 %files lib
389 %defattr(644,root,root,755)
390 %{_libdir}/libdecnumber.a
391 %{_libdir}/libgdb.a
392 %{_includedir}/gdb
This page took 0.141086 seconds and 3 git commands to generate.