]> git.pld-linux.org Git - packages/evolution-data-server.git/blob - evolution-data-server.spec
- rebuild with howl 0.9.10, release 2
[packages/evolution-data-server.git] / evolution-data-server.spec
1 #
2 # todo:
3 # - system libical
4 #
5 %define         mver            1.2
6
7 Summary:        Evolution data server
8 Summary(pl):    Serwer danych Evolution
9 Name:           evolution-data-server
10 Version:        1.2.1
11 Release:        2
12 License:        GPL
13 Group:          Libraries
14 Source0:        http://ftp.gnome.org/pub/gnome/sources/evolution-data-server/1.2/%{name}-%{version}.tar.bz2
15 # Source0-md5:  c86cc41c1563f552015aebb563018936
16 Patch0:         %{name}-system_db.patch
17 Patch1:         %{name}-GG-IM.patch
18 Patch2:         %{name}-workaround-cal-backend-leak.patch
19 Patch3:         %{name}-bonobo.patch
20 URL:            http://www.ximian.com/products/ximian_evolution/
21 BuildRequires:  ORBit2-devel >= 1:2.12.1
22 BuildRequires:  autoconf >= 2.52
23 BuildRequires:  automake
24 BuildRequires:  db-devel
25 BuildRequires:  gnome-common >= 2.8.0
26 BuildRequires:  howl-devel >= 0.9.10
27 BuildRequires:  intltool
28 BuildRequires:  libglade2-devel >= 1:2.5.0
29 BuildRequires:  libgnomeui-devel >= 2.10.0
30 BuildRequires:  libsoup-devel >= 2.2.2
31 BuildRequires:  libstdc++-devel
32 BuildRequires:  libtool
33 BuildRequires:  nspr-devel
34 Buildrequires:  nss-devel
35 BuildRequires:  openldap-devel
36 BuildRequires:  pkgconfig
37 Requires(post,postun):  /sbin/ldconfig
38 Requires(post,postun):  /usr/bin/scrollkeeper-update
39 Requires(post):         GConf2
40 Requires:       libsoup >= 2.2.2
41 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
42
43 %description
44 The Evolution data server for the calendar and addressbook.
45
46 %description -l pl
47 Serwer danych Evolution dla kalendarza i ksi±¿ki adresowej.
48
49 %package devel
50 Summary:        Evolution data server development files
51 Summary(pl):    Pliki programistyczne serwera danych evolution
52 Group:          Development/Libraries
53 Requires:       %{name} = %{version}-%{release}
54 # for all but libegroupwise
55 Requires:       GConf2-devel >= 2.10.0
56 Requires:       ORBit2-devel >= 1:2.12.1
57 Requires:       glib2-devel >= 1:2.6.2
58 Requires:       libbonobo-devel >= 2.8.1
59 Requires:       libgnome-devel >= 2.10.0
60 Requires:       libxml2-devel
61 # for libegroupwise
62 Requires:       libsoup-devel >= 2.2.2
63
64 %description devel
65 This package contains the files necessary to develop applications
66 using Evolution's data server libraries.
67
68 %description devel -l pl
69 Ten pakiet zawiera pliki potrzebne do tworzenia aplikacji
70 korzystaj±cych z bibliotek serwera danych Evolution.
71
72 %package static
73 Summary:        Evolution data server static libraries
74 Summary(pl):    Statyczne biblioteki serwera danych Evolution
75 Group:          Development/Libraries
76 Requires:       %{name}-devel = %{version}-%{release}
77
78 %description static
79 Evolution data server static libraries.
80
81 %description static -l pl
82 Statyczne biblioteki serwera danych Evolution.
83
84 %prep
85 %setup -q 
86 %patch0 -p1
87 %patch1 -p1
88 %patch2 -p1
89 %patch3 -p1
90
91 rm -rf libdb
92
93 %build
94 glib-gettextize --copy --force
95 intltoolize --copy --force
96 %{__libtoolize}
97 %{__aclocal}
98 %{__autoheader}
99 %{__autoconf}
100 %{__automake}
101
102 cd calendar/libical
103 %{__libtoolize}
104 %{__aclocal}
105 %{__autoheader}
106 %{__autoconf}
107 %{__automake}
108 cd ../..
109
110 %configure \
111         --enable-gtk-doc \
112         --enable-static \
113         --with-openldap=yes \
114         --with-nspr-includes=%{_includedir}/nspr \
115         --with-nspr-libs=%{_libdir} \
116         --with-nss-includes=%{_includedir}/nss \
117         --with-nss-libs=%{_libdir}
118 %{__make} \
119         HTML_DIR=%{_gtkdocdir} \
120         GTKHTML_DATADIR=%{_datadir}/idl 
121
122 %install
123 rm -rf $RPM_BUILD_ROOT
124
125 %{__make} install \
126         DESTDIR=$RPM_BUILD_ROOT \
127         GTKHTML_DATADIR=%{_datadir}/idl \
128         HTML_DIR=%{_gtkdocdir} \
129         pkgconfigdir=%{_pkgconfigdir}
130
131 rm $RPM_BUILD_ROOT%{_libdir}/%{name}-%{mver}/{camel-providers,extensions}/*.{,l}a
132
133 rm -r $RPM_BUILD_ROOT%{_datadir}/locale/no
134
135 %find_lang %{name} --all-name
136
137 %clean
138 rm -rf $RPM_BUILD_ROOT
139
140 %post
141 /sbin/ldconfig
142 /usr/bin/scrollkeeper-update
143 %gconf_schema_install
144
145 %postun
146 /sbin/ldconfig
147 /usr/bin/scrollkeeper-update
148
149 %files -f %{name}.lang
150 %defattr(644,root,root,755)
151 %doc AUTHORS ChangeLog NEWS* README
152 %attr(755,root,root) %{_libdir}/camel-index-control-%{mver}
153 %attr(755,root,root) %{_libdir}/camel-lock-helper-%{mver}
154 %attr(755,root,root) %{_libdir}/*.so.*.*
155 %dir %{_libdir}/%{name}-%{mver}
156 %attr(755,root,root) %{_libdir}/%{name}-%{mver}/%{name}
157 %dir %{_libdir}/%{name}-%{mver}/camel-providers
158 %attr(755,root,root) %{_libdir}/%{name}-%{mver}/camel-providers/*.so
159 %{_libdir}/%{name}-%{mver}/camel-providers/*.urls
160 %dir %{_libdir}/%{name}-%{mver}/extensions
161 %attr(755,root,root) %{_libdir}/%{name}-%{mver}/extensions/*.so
162 %{_libdir}/bonobo/servers/*
163 %{_datadir}/idl/*
164 %dir %{_datadir}/%{name}-%{mver}
165 %{_datadir}/%{name}-%{mver}/glade
166 %{_datadir}/%{name}-%{mver}/weather
167 %{_datadir}/%{name}-%{mver}/zoneinfo
168 %{_datadir}/%{name}-%{mver}/*.schema
169 %{_pixmapsdir}/%{name}-%{mver}
170
171 %files devel
172 %defattr(644,root,root,755)
173 %attr(755,root,root) %{_libdir}/*.so
174 %{_libdir}/*.la
175 %{_includedir}/*
176 %{_pkgconfigdir}/*
177 %{_gtkdocdir}/*
178
179 %files static
180 %defattr(644,root,root,755)
181 %{_libdir}/*.a
This page took 0.076924 seconds and 4 git commands to generate.