]> git.pld-linux.org Git - packages/dpkg.git/blob - dpkg.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/dpkg.git] / dpkg.spec
1 #
2 # Conditional build:
3 %bcond_with     alternatives    # build alternatives package
4
5 Summary:        Package maintenance system for Debian Linux
6 Summary(pl.UTF-8):      Program do obsługi pakietów Debiana
7 Name:           dpkg
8 Version:        1.18.10
9 Release:        1
10 License:        GPL v2+
11 Group:          Applications/File
12 Source0:        ftp://ftp.debian.org/debian/pool/main/d/dpkg/%{name}_%{version}.tar.xz
13 # Source0-md5:  ccff17730c0964428fc186ded2f2f401
14 Patch0:         %{name}-md5.patch
15 URL:            http://packages.debian.org/search?keywords=dpkg
16 BuildRequires:  bzip2-devel
17 BuildRequires:  gettext-tools >= 0.19
18 BuildRequires:  libselinux-devel
19 BuildRequires:  perl-tools-pod
20 BuildRequires:  pkgconfig
21 BuildRequires:  rpm-perlprov
22 BuildRequires:  rpmbuild(macros) >= 1.654
23 BuildRequires:  tar >= 1:1.22
24 BuildRequires:  xz
25 BuildRequires:  xz-devel
26 BuildRequires:  zlib-devel
27 Requires:       perl-base
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 # blacklist false positives
31 %define         _noautoreq_perl         extra file in Tie::ExtraHash
32
33 %description
34 This package contains the programs to handle deb packages known from
35 Debian.
36
37 %description -l pl.UTF-8
38 Ten pakiet zawiera narzędzia do obsługi pakietów deb znanych z
39 Debiana.
40
41 %package -n libdpkg-devel
42 Summary:        dpkg library and header files
43 Summary(pl.UTF-8):      Biblioteka i pliki nagłówkowe dpkg
44 Group:          Development/Libraries
45 Requires:       bzip2-devel
46 Requires:       xz-devel
47 Requires:       zlib-devel
48
49 %description -n libdpkg-devel
50 dpkg library and header files.
51
52 %description -n libdpkg-devel -l pl.UTF-8
53 Biblioteka i pliki nagłówkowe dpkg.
54
55 %package alternatives
56 Summary:        Maintain symbolic links determining default commands
57 Summary(pl.UTF-8):      Utrzymywanie dowiązań symbolicznych określających domyślne polecenia
58 Group:          Applications/System
59 Requires:       %{name} = %{version}-%{release}
60
61 %description alternatives
62 alternatives creates, removes, maintains and displays information
63 about the symbolic links comprising the alternatives system. The
64 alternatives system is a reimplementation of the Debian alternatives
65 system.
66
67 %description alternatives -l pl.UTF-8
68 alternatives tworzy, usuwa, utrzymuje i wyświetla informacje o
69 dowiązaniach symbolicznych obejmujących system alternatyw. System
70 alternatyw to reimplementacja systemu alternatyw ("alternatives") z
71 Debiana.
72
73 %prep
74 %setup -q
75 %patch0 -p1
76
77 %build
78 # "ac_cv_header_md5_h=no" to disable error on md5.h from libmd5
79 # (dpkg expects this header from FreeBSD-compatible libmd, having different API)
80 %configure \
81         ac_cv_header_md5_h=no \
82         PO4A="true" \
83         --disable-dselect \
84         %{!?with_alternatives:--disable-update-alternatives} \
85         --disable-silent-rules \
86         --disable-start-stop-daemon \
87         --with-admindir=/var/lib/%{name}
88
89 %{__make}
90
91 %install
92 rm -rf $RPM_BUILD_ROOT
93 %{__make} install \
94         DESTDIR=$RPM_BUILD_ROOT
95
96 %if %{with alternatives}
97 %{__rm} $RPM_BUILD_ROOT%{_sysconfdir}/alternatives/README
98 %endif
99
100 # obsoleted by pkg-config
101 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libdpkg.la
102
103 # dpkg for main part, dpkg-dev for perl-based build script
104 # don't use --all-name to avoid e.g. dselect inclusion
105 %find_lang dpkg
106 %find_lang dpkg-dev
107 cat dpkg-dev.lang >>dpkg.lang
108
109 %clean
110 rm -rf $RPM_BUILD_ROOT
111
112 %files -f dpkg.lang
113 %defattr(644,root,root,755)
114 %doc AUTHORS ChangeLog README THANKS TODO
115 %attr(755,root,root) %{_bindir}/dpkg*
116 %dir %{_sysconfdir}/dpkg
117 %dir %{_sysconfdir}/dpkg/dpkg.cfg.d
118
119 %dir %{_datadir}/dpkg
120 %{_datadir}/dpkg/abitable
121 %{_datadir}/dpkg/cputable
122 %{_datadir}/dpkg/ostable
123 %{_datadir}/dpkg/triplettable
124 %{_datadir}/dpkg/*.mk
125
126 %{perl_vendorlib}/Dpkg.pm
127 %{perl_vendorlib}/Dpkg
128
129 %dir /var/lib/dpkg
130 %dir /var/lib/dpkg/info
131 %dir /var/lib/dpkg/parts
132 %dir /var/lib/dpkg/updates
133
134 %{_mandir}/man1/dpkg*.1*
135 %{_mandir}/man3/Dpkg.3*
136 %{_mandir}/man3/Dpkg::*.3*
137 %{_mandir}/man5/deb*.5*
138 %{_mandir}/man5/dpkg.cfg.5*
139 %{_mandir}/man5/dsc.5*
140 %lang(de) %{_mandir}/de/man1/dpkg*.1*
141 %lang(de) %{_mandir}/de/man5/deb*.5*
142 %lang(de) %{_mandir}/de/man5/dpkg.cfg.5*
143 %lang(de) %{_mandir}/de/man5/dsc.5*
144 %lang(es) %{_mandir}/es/man1/dpkg*.1*
145 %lang(es) %{_mandir}/es/man5/deb*.5*
146 %lang(es) %{_mandir}/es/man5/dpkg.cfg.5*
147 %lang(fr) %{_mandir}/fr/man1/dpkg*.1*
148 %lang(fr) %{_mandir}/fr/man5/deb*.5*
149 %lang(fr) %{_mandir}/fr/man5/dpkg.cfg.5*
150 %lang(it) %{_mandir}/it/man1/dpkg*.1*
151 %lang(it) %{_mandir}/it/man5/deb*.5*
152 %lang(it) %{_mandir}/it/man5/dpkg.cfg.5*
153 %lang(ja) %{_mandir}/ja/man1/dpkg*.1*
154 %lang(ja) %{_mandir}/ja/man5/deb*.5*
155 %lang(ja) %{_mandir}/ja/man5/dpkg.cfg.5*
156 %lang(nl) %{_mandir}/nl/man1/dpkg*.1*
157 %lang(nl) %{_mandir}/nl/man5/deb*.5*
158 %lang(nl) %{_mandir}/nl/man5/dpkg.cfg.5*
159 %lang(pl) %{_mandir}/pl/man1/dpkg*.1*
160 %lang(pl) %{_mandir}/pl/man5/deb*.5*
161 %lang(pl) %{_mandir}/pl/man5/dpkg.cfg.5*
162 %lang(sv) %{_mandir}/sv/man1/dpkg*.1*
163 %lang(sv) %{_mandir}/sv/man5/deb*.5*
164 %lang(sv) %{_mandir}/sv/man5/dpkg.cfg.5*
165
166 %files -n libdpkg-devel
167 %defattr(644,root,root,755)
168 %{_libdir}/libdpkg.a
169 %{_includedir}/dpkg
170 %{_pkgconfigdir}/libdpkg.pc
171
172 %if %{with alternatives}
173 %files alternatives
174 %defattr(644,root,root,755)
175 %dir %{_sysconfdir}/alternatives
176 %attr(755,root,root) %{_bindir}/update-alternatives
177 %{_mandir}/man1/update-alternatives.1*
178 %lang(de) %{_mandir}/de/man1/update-alternatives.1*
179 %lang(es) %{_mandir}/es/man1/update-alternatives.1*
180 %lang(fr) %{_mandir}/fr/man1/update-alternatives.1*
181 %lang(it) %{_mandir}/it/man1/update-alternatives.1*
182 %lang(ja) %{_mandir}/ja/man1/update-alternatives.1*
183 %lang(pl) %{_mandir}/pl/man1/update-alternatives.1*
184 %lang(sv) %{_mandir}/sv/man1/update-alternatives.1*
185 %dir /var/lib/dpkg/alternatives
186 %endif
This page took 0.087778 seconds and 3 git commands to generate.