]> git.pld-linux.org Git - packages/dpkg.git/blob - dpkg.spec
- updated _noautoreq_perl; release 2
[packages/dpkg.git] / dpkg.spec
1 #
2 # Conditional build:
3 %bcond_with     alternatives    # build alternatives package
4
5 Summary:        Package maintenance system for Debian Linux
6 Summary(pl.UTF-8):      Program do obsługi pakietów Debiana
7 Name:           dpkg
8 Version:        1.22.2
9 Release:        2
10 License:        GPL v2+
11 Group:          Applications/File
12 Source0:        http://ftp.debian.org/debian/pool/main/d/dpkg/%{name}_%{version}.tar.xz
13 # Source0-md5:  591fe669ae36c1c93a8658bd650e38a6
14 URL:            https://packages.debian.org/search?keywords=dpkg
15 BuildRequires:  automake
16 BuildRequires:  bzip2-devel
17 BuildRequires:  gettext-tools >= 0.19.8
18 BuildRequires:  libmd-devel
19 BuildRequires:  libselinux-devel >= 2.3
20 BuildRequires:  libstdc++-devel >= 6:4.7
21 BuildRequires:  ncurses-devel >= 5
22 BuildRequires:  perl-base >= 1:5.32.1
23 BuildRequires:  perl-tools-pod >= 1:5.32.1
24 BuildRequires:  pkgconfig
25 BuildRequires:  po4a >= 0.59
26 BuildRequires:  rpm-build >= 4.6
27 BuildRequires:  rpm-perlprov
28 BuildRequires:  rpmbuild(macros) >= 1.754
29 BuildRequires:  tar >= 1:1.22
30 BuildRequires:  xz
31 BuildRequires:  xz-devel
32 BuildRequires:  zlib-devel
33 BuildRequires:  zstd-devel
34 Requires:       perl-base
35 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
36
37 # blacklist false positives
38 %define         _noautoreq_perl         at extra file
39
40 %description
41 This package contains the programs to handle deb packages known from
42 Debian.
43
44 %description -l pl.UTF-8
45 Ten pakiet zawiera narzędzia do obsługi pakietów deb znanych z
46 Debiana.
47
48 %package -n libdpkg-devel
49 Summary:        dpkg library and header files
50 Summary(pl.UTF-8):      Biblioteka i pliki nagłówkowe dpkg
51 Group:          Development/Libraries
52 Requires:       bzip2-devel
53 Requires:       xz-devel
54 Requires:       zlib-devel
55
56 %description -n libdpkg-devel
57 dpkg library and header files.
58
59 %description -n libdpkg-devel -l pl.UTF-8
60 Biblioteka i pliki nagłówkowe dpkg.
61
62 %package alternatives
63 Summary:        Maintain symbolic links determining default commands
64 Summary(pl.UTF-8):      Utrzymywanie dowiązań symbolicznych określających domyślne polecenia
65 Group:          Applications/System
66 Requires:       %{name} = %{version}-%{release}
67
68 %description alternatives
69 alternatives creates, removes, maintains and displays information
70 about the symbolic links comprising the alternatives system. The
71 alternatives system is a reimplementation of the Debian alternatives
72 system.
73
74 %description alternatives -l pl.UTF-8
75 alternatives tworzy, usuwa, utrzymuje i wyświetla informacje o
76 dowiązaniach symbolicznych obejmujących system alternatyw. System
77 alternatyw to reimplementacja systemu alternatyw ("alternatives") z
78 Debiana.
79
80 %package -n zsh-completion-dpkg
81 Summary:        ZSH completion for dpkg command
82 Summary(pl.UTF-8):      Dopełnianianie parametrów w ZSH dla polecenia dpkg
83 Group:          Applications/Shells
84 Requires:       %{name} = %{version}-%{release}
85 Requires:       zsh
86 BuildArch:      noarch
87
88 %description -n zsh-completion-dpkg
89 ZSH completion for dpkg command.
90
91 %description -n zsh-completion-dpkg -l pl.UTF-8
92 Dopełnianianie parametrów w ZSH dla polecenia dpkg.
93
94 %prep
95 %setup -q
96
97 %build
98 # dpkg expects <md5.h> from FreeBSD-compatible libmd (not libmd5)
99 CPPFLAGS="%{rpmcppflags} -I/usr/include/libmd"
100 %configure \
101         PO4A="true" \
102         --disable-devel-docs \
103         --disable-dselect \
104         --disable-silent-rules \
105         --disable-start-stop-daemon \
106         %{!?with_alternatives:--disable-update-alternatives} \
107         --with-admindir=/var/lib/%{name} \
108         --with-zshcompletionsdir=%{zsh_compdir}
109
110 %{__make}
111
112 %install
113 rm -rf $RPM_BUILD_ROOT
114 %{__make} install \
115         DESTDIR=$RPM_BUILD_ROOT
116
117 %if %{with alternatives}
118 %{__rm} $RPM_BUILD_ROOT%{_sysconfdir}/alternatives/README
119 %endif
120
121 # packaged as doc
122 %{__rm} -r $RPM_BUILD_ROOT%{_datadir}/doc/dpkg
123
124 # obsoleted by pkg-config
125 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libdpkg.la
126
127 # dpkg for main part, dpkg-dev for perl-based build script
128 # don't use --all-name to avoid e.g. dselect inclusion
129 %find_lang dpkg
130 %find_lang dpkg-dev
131 cat dpkg-dev.lang >>dpkg.lang
132
133 %clean
134 rm -rf $RPM_BUILD_ROOT
135
136 %files -f dpkg.lang
137 %defattr(644,root,root,755)
138 %doc AUTHORS ChangeLog README THANKS TODO
139 %attr(755,root,root) %{_bindir}/dpkg*
140 %attr(755,root,root) %{_sbindir}/dpkg-fsys-usrunmess
141 %dir %{_sysconfdir}/dpkg
142 %dir %{_sysconfdir}/dpkg/dpkg.cfg.d
143
144 %dir %{_datadir}/dpkg
145 %{_datadir}/dpkg/abitable
146 %{_datadir}/dpkg/cputable
147 %{_datadir}/dpkg/ostable
148 %{_datadir}/dpkg/tupletable
149 %{_datadir}/dpkg/*.mk
150 %{_datadir}/dpkg/*.specs
151
152 %dir %{_datadir}/dpkg/sh
153 %{_datadir}/dpkg/sh/dpkg-error.sh
154
155 %dir %{_libexecdir}/dpkg
156 %attr(755,root,root) %{_libexecdir}/dpkg/dpkg-db-backup
157 %attr(755,root,root) %{_libexecdir}/dpkg/dpkg-db-keeper
158
159 %{perl_vendorlib}/Dpkg.pm
160 %{perl_vendorlib}/Dpkg
161
162 %dir /var/lib/dpkg
163 %dir /var/lib/dpkg/info
164 %dir /var/lib/dpkg/parts
165 %dir /var/lib/dpkg/updates
166
167 %{_mandir}/man1/dpkg*.1*
168 %{_mandir}/man3/Dpkg.3*
169 %{_mandir}/man3/Dpkg::*.3*
170 %{_mandir}/man5/deb*.5*
171 %{_mandir}/man5/dpkg.cfg.5*
172 %{_mandir}/man5/dsc.5*
173 %{_mandir}/man7/deb-version.7*
174 %{_mandir}/man7/dpkg-build-api.7*
175 %{_mandir}/man8/dpkg-fsys-usrunmess.8.*
176 %lang(de) %{_mandir}/de/man1/dpkg*.1*
177 %lang(de) %{_mandir}/de/man5/deb*.5*
178 %lang(de) %{_mandir}/de/man5/dpkg.cfg.5*
179 %lang(de) %{_mandir}/de/man5/dsc.5*
180 %lang(de) %{_mandir}/de/man7/deb-version.7*
181 %lang(de) %{_mandir}/de/man7/dpkg-build-api.7*
182 %lang(de) %{_mandir}/de/man8/dpkg-fsys-usrunmess.8.*
183 %lang(es) %{_mandir}/es/man1/dpkg*.1*
184 %lang(es) %{_mandir}/es/man5/deb*.5*
185 %lang(es) %{_mandir}/es/man5/dpkg.cfg.5*
186 %lang(fr) %{_mandir}/fr/man1/dpkg*.1*
187 %lang(fr) %{_mandir}/fr/man5/deb*.5*
188 %lang(fr) %{_mandir}/fr/man5/dpkg.cfg.5*
189 %lang(fr) %{_mandir}/fr/man5/dsc.5*
190 %lang(fr) %{_mandir}/fr/man7/deb-version.7*
191 %lang(fr) %{_mandir}/fr/man8/dpkg-fsys-usrunmess.8.*
192 %lang(it) %{_mandir}/it/man1/dpkg*.1*
193 %lang(it) %{_mandir}/it/man5/deb*.5*
194 %lang(it) %{_mandir}/it/man5/dpkg.cfg.5*
195 %lang(ja) %{_mandir}/ja/man1/dpkg*.1*
196 %lang(ja) %{_mandir}/ja/man5/deb*.5*
197 %lang(ja) %{_mandir}/ja/man5/dpkg.cfg.5*
198 %lang(nl) %{_mandir}/nl/man1/dpkg*.1*
199 %lang(nl) %{_mandir}/nl/man5/deb*.5*
200 %lang(nl) %{_mandir}/nl/man5/dpkg.cfg.5*
201 %lang(nl) %{_mandir}/nl/man5/dsc.5*
202 %lang(nl) %{_mandir}/nl/man7/deb-version.7*
203 %lang(nl) %{_mandir}/nl/man7/dpkg-build-api.7*
204 %lang(nl) %{_mandir}/nl/man8/dpkg-fsys-usrunmess.8.*
205 %lang(pl) %{_mandir}/pl/man1/dpkg*.1*
206 %lang(pl) %{_mandir}/pl/man5/deb*.5*
207 %lang(pl) %{_mandir}/pl/man5/dpkg.cfg.5*
208 %lang(pt) %{_mandir}/pt/man1/dpkg*.1*
209 %lang(pt) %{_mandir}/pt/man5/deb*.5*
210 %lang(pt) %{_mandir}/pt/man5/dpkg.cfg.5*
211 %lang(pt) %{_mandir}/pt/man5/dsc.5*
212 %lang(pt) %{_mandir}/pt/man7/deb-version.7*
213 %lang(pt) %{_mandir}/pt/man7/dpkg-build-api.7*
214 %lang(pt) %{_mandir}/pt/man8/dpkg-fsys-usrunmess.8.*
215 %lang(sv) %{_mandir}/sv/man1/dpkg*.1*
216 %lang(sv) %{_mandir}/sv/man5/deb*.5*
217 %lang(sv) %{_mandir}/sv/man5/dpkg.cfg.5*
218 %lang(sv) %{_mandir}/sv/man5/dsc.5*
219 %lang(sv) %{_mandir}/sv/man7/deb-version.7*
220 %lang(sv) %{_mandir}/sv/man7/dpkg-build-api.7*
221 %lang(sv) %{_mandir}/sv/man8/dpkg-fsys-usrunmess.8.*
222
223 %files -n libdpkg-devel
224 %defattr(644,root,root,755)
225 %doc doc/README.* doc/*.txt
226 %{_libdir}/libdpkg.a
227 %{_includedir}/dpkg
228 %{_aclocaldir}/dpkg*.m4
229 %{_pkgconfigdir}/libdpkg.pc
230
231 %if %{with alternatives}
232 %files alternatives
233 %defattr(644,root,root,755)
234 %dir %{_sysconfdir}/alternatives
235 %attr(755,root,root) %{_bindir}/update-alternatives
236 %{_mandir}/man1/update-alternatives.1*
237 %lang(de) %{_mandir}/de/man1/update-alternatives.1*
238 %lang(es) %{_mandir}/es/man1/update-alternatives.1*
239 %lang(fr) %{_mandir}/fr/man1/update-alternatives.1*
240 %lang(it) %{_mandir}/it/man1/update-alternatives.1*
241 %lang(ja) %{_mandir}/ja/man1/update-alternatives.1*
242 %lang(pl) %{_mandir}/pl/man1/update-alternatives.1*
243 %lang(sv) %{_mandir}/sv/man1/update-alternatives.1*
244 %dir /var/lib/dpkg/alternatives
245 %endif
246
247 %files -n zsh-completion-dpkg
248 %defattr(644,root,root,755)
249 %{zsh_compdir}/_dpkg-parsechangelog
This page took 0.133861 seconds and 4 git commands to generate.