]> git.pld-linux.org Git - packages/dpkg.git/blob - dpkg.spec
- point configure at the correct zsh completions dir
[packages/dpkg.git] / dpkg.spec
1 #
2 # Conditional build:
3 %bcond_with     alternatives    # build alternatives package
4
5 Summary:        Package maintenance system for Debian Linux
6 Summary(pl.UTF-8):      Program do obsługi pakietów Debiana
7 Name:           dpkg
8 Version:        1.21.7
9 Release:        1
10 License:        GPL v2+
11 Group:          Applications/File
12 Source0:        http://ftp.debian.org/debian/pool/main/d/dpkg/%{name}_%{version}.tar.xz
13 # Source0-md5:  2c6686bd991810ce8a87469a7f20b415
14 Patch0:         %{name}-md5.patch
15 URL:            http://packages.debian.org/search?keywords=dpkg
16 BuildRequires:  bzip2-devel
17 BuildRequires:  gettext-tools >= 0.19
18 BuildRequires:  libselinux-devel
19 BuildRequires:  perl-tools-pod
20 BuildRequires:  pkgconfig
21 BuildRequires:  rpm-perlprov
22 BuildRequires:  rpmbuild(macros) >= 1.754
23 BuildRequires:  tar >= 1:1.22
24 BuildRequires:  xz
25 BuildRequires:  xz-devel
26 BuildRequires:  zlib-devel
27 Requires:       perl-base
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 # blacklist false positives
31 %define         _noautoreq_perl         extra file in Tie::ExtraHash
32
33 %description
34 This package contains the programs to handle deb packages known from
35 Debian.
36
37 %description -l pl.UTF-8
38 Ten pakiet zawiera narzędzia do obsługi pakietów deb znanych z
39 Debiana.
40
41 %package -n libdpkg-devel
42 Summary:        dpkg library and header files
43 Summary(pl.UTF-8):      Biblioteka i pliki nagłówkowe dpkg
44 Group:          Development/Libraries
45 Requires:       bzip2-devel
46 Requires:       xz-devel
47 Requires:       zlib-devel
48
49 %description -n libdpkg-devel
50 dpkg library and header files.
51
52 %description -n libdpkg-devel -l pl.UTF-8
53 Biblioteka i pliki nagłówkowe dpkg.
54
55 %package alternatives
56 Summary:        Maintain symbolic links determining default commands
57 Summary(pl.UTF-8):      Utrzymywanie dowiązań symbolicznych określających domyślne polecenia
58 Group:          Applications/System
59 Requires:       %{name} = %{version}-%{release}
60
61 %description alternatives
62 alternatives creates, removes, maintains and displays information
63 about the symbolic links comprising the alternatives system. The
64 alternatives system is a reimplementation of the Debian alternatives
65 system.
66
67 %description alternatives -l pl.UTF-8
68 alternatives tworzy, usuwa, utrzymuje i wyświetla informacje o
69 dowiązaniach symbolicznych obejmujących system alternatyw. System
70 alternatyw to reimplementacja systemu alternatyw ("alternatives") z
71 Debiana.
72
73 %package -n zsh-completion-dpkg
74 Summary:        ZSH completion for dpkg command
75 Summary(pl.UTF-8):      Dopełnianianie parametrów w ZSH dla polecenia dpkg
76 Group:          Applications/Shells
77 Requires:       %{name} = %{version}-%{release}
78 Requires:       zsh
79 BuildArch:      noarch
80
81 %description -n zsh-completion-dpkg
82 ZSH completion for dpkg command.
83
84 %description -n zsh-completion-dpkg -l pl.UTF-8
85 Dopełnianianie parametrów w ZSH dla polecenia dpkg.
86
87 %prep
88 %setup -q
89 %patch0 -p1
90
91 %build
92 # "ac_cv_header_md5_h=no" to disable error on md5.h from libmd5
93 # (dpkg expects this header from FreeBSD-compatible libmd, having different API)
94 %configure \
95         ac_cv_header_md5_h=no \
96         PO4A="true" \
97         --disable-devel-docs \
98         --disable-dselect \
99         %{!?with_alternatives:--disable-update-alternatives} \
100         --with-zshcompletionsdir=%{zsh_compdir} \
101         --disable-silent-rules \
102         --disable-start-stop-daemon \
103         --with-admindir=/var/lib/%{name}
104
105 %{__make}
106
107 %install
108 rm -rf $RPM_BUILD_ROOT
109 %{__make} install \
110         DESTDIR=$RPM_BUILD_ROOT
111
112 %if %{with alternatives}
113 %{__rm} $RPM_BUILD_ROOT%{_sysconfdir}/alternatives/README
114 %endif
115
116 # packaged as doc
117 %{__rm} -r $RPM_BUILD_ROOT%{_datadir}/doc/dpkg
118
119 # obsoleted by pkg-config
120 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libdpkg.la
121
122 # dpkg for main part, dpkg-dev for perl-based build script
123 # don't use --all-name to avoid e.g. dselect inclusion
124 %find_lang dpkg
125 %find_lang dpkg-dev
126 cat dpkg-dev.lang >>dpkg.lang
127
128 %clean
129 rm -rf $RPM_BUILD_ROOT
130
131 %files -f dpkg.lang
132 %defattr(644,root,root,755)
133 %doc AUTHORS ChangeLog README THANKS TODO
134 %attr(755,root,root) %{_bindir}/dpkg*
135 %attr(755,root,root) %{_sbindir}/dpkg-fsys-usrunmess
136 %dir %{_sysconfdir}/dpkg
137 %dir %{_sysconfdir}/dpkg/dpkg.cfg.d
138
139 %dir %{_datadir}/dpkg
140 %{_datadir}/dpkg/abitable
141 %{_datadir}/dpkg/cputable
142 %{_datadir}/dpkg/ostable
143 %{_datadir}/dpkg/tupletable
144 %{_datadir}/dpkg/*.mk
145 %{_datadir}/dpkg/*.specs
146
147 %dir %{_datadir}/dpkg/sh
148 %{_datadir}/dpkg/sh/dpkg-error.sh
149
150 %dir %{_libexecdir}/dpkg
151 %attr(755,root,root) %{_libexecdir}/dpkg/dpkg-db-backup
152
153 %{perl_vendorlib}/Dpkg.pm
154 %{perl_vendorlib}/Dpkg
155
156 %dir /var/lib/dpkg
157 %dir /var/lib/dpkg/info
158 %dir /var/lib/dpkg/parts
159 %dir /var/lib/dpkg/updates
160
161 %{_mandir}/man1/dpkg*.1*
162 %{_mandir}/man3/Dpkg.3*
163 %{_mandir}/man3/Dpkg::*.3*
164 %{_mandir}/man5/deb*.5*
165 %{_mandir}/man5/dpkg.cfg.5*
166 %{_mandir}/man5/dsc.5*
167 %{_mandir}/man7/deb-version.7*
168 %{_mandir}/man8/dpkg-fsys-usrunmess.8.*
169 %lang(de) %{_mandir}/de/man1/dpkg*.1*
170 %lang(de) %{_mandir}/de/man5/deb*.5*
171 %lang(de) %{_mandir}/de/man5/dpkg.cfg.5*
172 %lang(de) %{_mandir}/de/man5/dsc.5*
173 %lang(de) %{_mandir}/de/man7/deb-version.7*
174 %lang(de) %{_mandir}/de/man8/dpkg-fsys-usrunmess.8.*
175 %lang(es) %{_mandir}/es/man1/dpkg*.1*
176 %lang(es) %{_mandir}/es/man5/deb*.5*
177 %lang(es) %{_mandir}/es/man5/dpkg.cfg.5*
178 %lang(fr) %{_mandir}/fr/man1/dpkg*.1*
179 %lang(fr) %{_mandir}/fr/man5/deb*.5*
180 %lang(fr) %{_mandir}/fr/man5/dpkg.cfg.5*
181 %lang(fr) %{_mandir}/fr/man5/dsc.5*
182 %lang(fr) %{_mandir}/fr/man7/deb-version.7*
183 %lang(hu) %{_mandir}/hu/man5/dpkg.cfg.5*
184 %lang(it) %{_mandir}/it/man1/dpkg*.1*
185 %lang(it) %{_mandir}/it/man5/deb*.5*
186 %lang(it) %{_mandir}/it/man5/dpkg.cfg.5*
187 %lang(ja) %{_mandir}/ja/man1/dpkg*.1*
188 %lang(ja) %{_mandir}/ja/man5/deb*.5*
189 %lang(ja) %{_mandir}/ja/man5/dpkg.cfg.5*
190 %lang(nl) %{_mandir}/nl/man1/dpkg*.1*
191 %lang(nl) %{_mandir}/nl/man5/deb*.5*
192 %lang(nl) %{_mandir}/nl/man5/dpkg.cfg.5*
193 %lang(nl) %{_mandir}/nl/man5/dsc.5*
194 %lang(nl) %{_mandir}/nl/man7/deb-version.7*
195 %lang(nl) %{_mandir}/nl/man8/dpkg-fsys-usrunmess.8.*
196 %lang(pl) %{_mandir}/pl/man1/dpkg*.1*
197 %lang(pl) %{_mandir}/pl/man5/deb*.5*
198 %lang(pl) %{_mandir}/pl/man5/dpkg.cfg.5*
199 %lang(pt) %{_mandir}/pt/man1/dpkg*.1*
200 %lang(pt) %{_mandir}/pt/man5/deb*.5*
201 %lang(pt) %{_mandir}/pt/man5/dpkg.cfg.5*
202 %lang(pt) %{_mandir}/pt/man5/dsc.5*
203 %lang(pt) %{_mandir}/pt/man7/deb-version.7*
204 %lang(pt) %{_mandir}/pt/man8/dpkg-fsys-usrunmess.8.*
205 %lang(sv) %{_mandir}/sv/man1/dpkg*.1*
206 %lang(sv) %{_mandir}/sv/man5/deb*.5*
207 %lang(sv) %{_mandir}/sv/man5/dpkg.cfg.5*
208 %lang(sv) %{_mandir}/sv/man5/dsc.5*
209 %lang(sv) %{_mandir}/sv/man7/deb-version.7*
210 %lang(sv) %{_mandir}/sv/man8/dpkg-fsys-usrunmess.8.*
211
212 %files -n libdpkg-devel
213 %defattr(644,root,root,755)
214 %doc doc/README.* doc/*.txt
215 %{_libdir}/libdpkg.a
216 %{_includedir}/dpkg
217 %{_aclocaldir}/dpkg*.m4
218 %{_pkgconfigdir}/libdpkg.pc
219
220 %if %{with alternatives}
221 %files alternatives
222 %defattr(644,root,root,755)
223 %dir %{_sysconfdir}/alternatives
224 %attr(755,root,root) %{_bindir}/update-alternatives
225 %{_mandir}/man1/update-alternatives.1*
226 %lang(de) %{_mandir}/de/man1/update-alternatives.1*
227 %lang(es) %{_mandir}/es/man1/update-alternatives.1*
228 %lang(fr) %{_mandir}/fr/man1/update-alternatives.1*
229 %lang(it) %{_mandir}/it/man1/update-alternatives.1*
230 %lang(ja) %{_mandir}/ja/man1/update-alternatives.1*
231 %lang(pl) %{_mandir}/pl/man1/update-alternatives.1*
232 %lang(sv) %{_mandir}/sv/man1/update-alternatives.1*
233 %dir /var/lib/dpkg/alternatives
234 %endif
235
236 %files -n zsh-completion-dpkg
237 %defattr(644,root,root,755)
238 %{zsh_compdir}/_dpkg-parsechangelog
This page took 0.108848 seconds and 3 git commands to generate.