]> git.pld-linux.org Git - packages/dante.git/blob - dante.spec
- Initial PLD version based on mandrake spec
[packages/dante.git] / dante.spec
1 Summary:        A free Socks v4/v5 client implementation
2 Name:           dante
3 Version:        1.1.9
4 Release:        1
5 License:        BSD-type
6 Group:          Networking/Daemons
7 URL:            http://www.inet.no/dante/
8 Source0:        ftp://ftp.inet.no/pub/socks/%{name}-%{version}.tar.gz
9 Source1:        sockd.init
10 Buildroot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
11
12 %define prefix %{_prefix}
13
14 %description
15 Dante is a free implementation of the proxy protocols socks version 4,
16 socks version 5 (rfc1928) and msproxy. It can be used as a firewall
17 between networks. It is being developed by Inferno Nettverk A/S, a
18 Norwegian consulting company. Commercial support is available.
19
20 This package contains the dynamic libraries required to "socksify"
21 existing applications to become socks clients.
22
23 %package server
24 Summary:        A free Socks v4/v5 server implementation
25 Group:          Networking/Daemons
26 Requires:       dante = %{version}
27
28 %description server
29 This package contains the socks proxy daemon and its documentation.
30 The sockd is the server part of the Dante socks proxy package and
31 allows socks clients to connect through it to the network.
32
33 %package devel
34 Summary:        development libraries for socks
35 Group:          Networking/Daemons
36 Requires:       dante = %{version}
37
38 %description devel
39 Additional libraries required to compile programs that use socks.
40
41 %prep
42 rm -rf $RPM_BUILD_ROOT
43
44 %setup -q
45
46 %build
47
48 CFLAGS="${RPM_OPT_FLAGS}" 
49 %configure --prefix=%{_prefix}
50 %{__make}
51
52 %install
53 rm -rf $RPM_BUILD_ROOT
54
55 %{__make} install DESTDIR=${RPM_BUILD_ROOT}
56
57 #set library as executable - prevent ldd from complaining
58 chmod +x ${RPM_BUILD_ROOT}%{_libdir}/*.so.*.*
59
60 install -d ${RPM_BUILD_ROOT}%{_sysconfdir}/rc.d/init.d ${RPM_BUILD_ROOT}%{_bindir}
61
62 install example/socks.conf ${RPM_BUILD_ROOT}%{_sysconfdir}
63 install example/sockd.conf ${RPM_BUILD_ROOT}%{_sysconfdir}
64
65 install -m 755 %{SOURCE1} ${RPM_BUILD_ROOT}/etc/rc.d/init.d/sockd
66
67 ln -sf %{_libdir}/libdsocks.so $RPM_BUILD_ROOT/%{_libdir}/libdsocks.so.0
68
69 %clean
70 rm -rf $RPM_BUILD_ROOT
71
72 %post -p /sbin/ldconfig
73
74 %postun -p /sbin/ldconfig
75
76 %post server
77 /sbin/chkconfig --add sockd
78
79 %postun server
80 if [ $1 = 0 ]; then
81    /sbin/chkconfig --del sockd
82 fi
83
84 %files
85 %defattr(644,root,root,755)
86 #files beginning with two capital letters are docs: BUGS, README.foo etc.
87 %doc [A-Z][A-Z]*
88 %{_libdir}/libsocks.so.0.1.0
89 %{_libdir}/libsocks.so.0
90 %{_libdir}/libdsocks.so.0.1.0
91 %{_libdir}/libdsocks.so.0
92 %attr(755,root,root) %{_bindir}/socksify
93 %{_mandir}/man5/socks.conf.5*
94 %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/socks.conf
95
96 %files server
97 %defattr(644,root,root,755)
98 %attr(755,root,root) %{_sbindir}/sockd
99 %{_mandir}/man8/sockd.8*
100 %{_mandir}/man5/sockd.conf.5*
101
102
103 %config(noreplace) %verify(not size mtime md5)  %{_sysconfdir}/sockd.conf
104 %config /etc/rc.d/init.d/sockd
105
106 %files devel
107 %defattr(644,root,root,755)
108 %{_libdir}/libsocks.la
109 %{_libdir}/libsocks.a
110 %{_libdir}/libdsocks.la
111 %{_libdir}/libsocks.so
112 %{_libdir}/libdsocks.so
This page took 0.160447 seconds and 4 git commands to generate.