]> git.pld-linux.org Git - packages/dante.git/blob - dante.spec
Release 6 (by relup.sh)
[packages/dante.git] / dante.spec
1 # NOTE: ldap and sasl seems stub in this (free only?) version
2 #
3 # Conditional build:
4 %bcond_without  upnp    # UPnP support (via miniupnp)
5 #
6 Summary:        A free Socks v4/v5 client implementation
7 Summary(pl.UTF-8):      Darmowa implementacja klienta Socks v4/5
8 Name:           dante
9 Version:        1.4.2
10 Release:        6
11 License:        BSD-like
12 Group:          Networking/Daemons
13 #Source0Download: http://www.inet.no/dante/download.html
14 Source0:        http://www.inet.no/dante/files/%{name}-%{version}.tar.gz
15 # Source0-md5:  29c2931339655da51576c4d2b7bf16f3
16 Source1:        sockd.init
17 Patch0:         %{name}-am.patch
18 Patch1:         %{name}-build.patch
19 Patch2:         %{name}-cpp.patch
20 URL:            http://www.inet.no/dante/
21 BuildRequires:  autoconf >= 2.61
22 BuildRequires:  automake
23 BuildRequires:  cyrus-sasl-devel
24 BuildRequires:  heimdal-devel
25 BuildRequires:  libtool >= 2:2
26 BuildRequires:  libwrap-devel
27 %{?with_upnp:BuildRequires:     miniupnpc-devel >= 1.6}
28 BuildRequires:  openldap-devel
29 BuildRequires:  pam-devel
30 %{?with_upnp:Requires:  miniupnpc >= 1.6}
31 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
33 %description
34 Dante is a free implementation of the proxy protocols socks version 4,
35 socks version 5 (rfc1928) and msproxy. It can be used as a firewall
36 between networks. It is being developed by Inferno Nettverk A/S, a
37 Norwegian consulting company. Commercial support is available.
38
39 This package contains the dynamic libraries required to "socksify"
40 existing applications to become socks clients.
41
42 %description -l pl.UTF-8
43 Dante jest darmową implementacją protokołów proxy: socks w wersji 4,
44 socks w wersji 5 (rfc1928) oraz msproxy. Może być używany jako zapora
45 pomiędzy sieciami. Implementacja jest rozwijana przez Inferno Nettverk
46 A/S - Norweską firmę konsultingową. Komercyjne wsparcie jest dostępne.
47
48 Ten pakiet zawiera dynamiczne biblioteki wymagane do "usocksowiania"
49 istniejących aplikacji tak by działały one jako klienci socks.
50
51 %package server
52 Summary:        A free Socks v4/v5 server implementation
53 Summary(pl.UTF-8):      Darmowa implementacja serwera Socks v4/5
54 Group:          Networking/Daemons
55 Requires(post,preun):   /sbin/chkconfig
56 Requires:       %{name} = %{version}-%{release}
57 Requires:       rc-scripts
58
59 %description server
60 This package contains the socks proxy daemon and its documentation.
61 The sockd is the server part of the Dante socks proxy package and
62 allows socks clients to connect through it to the network.
63
64 %description server -l pl.UTF-8
65 Ten pakiet zawiera serwer proxy socks oraz jego dokumentację. Serwer
66 sockd jest częścią pakietu proxy Dante. Za pośrednictwem serwera
67 klienci mogą łączyć się z serwerami w sieci.
68
69 %package devel
70 Summary:        Development files for socks library
71 Summary(pl.UTF-8):      Pliki programistyczne biblioteki socks
72 Group:          Networking/Daemons
73 Requires:       %{name} = %{version}-%{release}
74 Requires:       heimdal-devel
75 %{?with_upnp:Requires:  miniupnpc-devel >= 1.6}
76 Requires:       pam-devel
77
78 %description devel
79 Development files required to compile programs that use socks.
80
81 %description devel -l pl.UTF-8
82 Pliki programistyczne wymagane do rozwoju programów korzystających z
83 socks.
84
85 %package static
86 Summary:        Static socks library
87 Summary(pl.UTF-8):      Statyczna biblioteka socks
88 Group:          Networking/Daemons
89 Requires:       %{name}-devel = %{version}-%{release}
90
91 %description static
92 Static socks library.
93
94 %description static -l pl.UTF-8
95 Statyczna biblioteka socks.
96
97 %prep
98 %setup -q
99 %patch0 -p1
100 %patch1 -p1
101 %patch2 -p1
102
103 %build
104 %{__libtoolize}
105 %{__aclocal}
106 %{__autoconf}
107 %{__autoheader}
108 %{__automake}
109 # configure expects ldconfig in $PATH
110 PATH="$PATH:/sbin"
111 %configure \
112         --disable-silent-rules \
113         --without-glibc-secure \
114         %{!?with_upnp:--without-upnp}
115
116 %{__make}
117
118 %install
119 rm -rf $RPM_BUILD_ROOT
120 install -d $RPM_BUILD_ROOT{%{_sysconfdir},/etc/rc.d/init.d}
121
122 %{__make} install \
123         DESTDIR=$RPM_BUILD_ROOT
124
125 install example/sock{s,d}.conf $RPM_BUILD_ROOT%{_sysconfdir}
126
127 install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/sockd
128
129 %clean
130 rm -rf $RPM_BUILD_ROOT
131
132 %post   -p /sbin/ldconfig
133 %postun -p /sbin/ldconfig
134
135 %post server
136 /sbin/chkconfig --add sockd
137 if [ -f /var/lock/subsys/sockd ]; then
138         /etc/rc.d/init.d/sockd restart 1>&2
139 else
140         echo "Run \"/etc/rc.d/init.d/sockd start\" to start dante sockd daemon."
141 fi
142
143 %postun server
144 if [ "$1" = "0" ]; then
145         if [ -f /var/lock/subsys/sockd ]; then
146                 /etc/rc.d/init.d/sockd stop 1>&2
147         fi
148         /sbin/chkconfig --del sockd
149 fi
150
151 %files
152 %defattr(644,root,root,755)
153 %doc BUGS CREDITS LICENSE NEWS README SUPPORT UPGRADE
154 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/socks.conf
155 %attr(755,root,root) %{_libdir}/libsocks.so.*.*.*
156 %attr(755,root,root) %ghost %{_libdir}/libsocks.so.0
157 %attr(755,root,root) %{_libdir}/libdsocks.so
158 %attr(755,root,root) %{_bindir}/socksify
159 %{_mandir}/man5/socks.conf.5*
160 %{_mandir}/man1/socksify.1*
161
162 %files server
163 %defattr(644,root,root,755)
164 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/sockd.conf
165 %attr(754,root,root) /etc/rc.d/init.d/sockd
166 %attr(755,root,root) %{_sbindir}/sockd
167 %{_mandir}/man8/sockd.8*
168 %{_mandir}/man5/sockd.conf.5*
169
170 %files devel
171 %defattr(644,root,root,755)
172 %attr(755,root,root) %{_libdir}/libsocks.so
173 %{_libdir}/libsocks.la
174 %{_libdir}/libdsocks.la
175 %{_includedir}/socks.h
176
177 %files static
178 %defattr(644,root,root,755)
179 %{_libdir}/libsocks.a
This page took 0.198285 seconds and 4 git commands to generate.