]> git.pld-linux.org Git - packages/crun.git/blob - crun.spec
up to 0.18
[packages/crun.git] / crun.spec
1 %ifarch %{x8664} %{arm} aarch64 ppc64
2 %define         with_criu       1
3 %endif
4
5 %ifarch %{ix86} %{x8664} %{arm} aarch64 mips64 mips64le ppc64 ppc64le s390x
6 %define         with_man        1
7 %endif
8
9 Summary:        OCI runtime written in C
10 Name:           crun
11 Version:        0.18
12 Release:        1
13 License:        GPL v3+
14 Group:          Applications/System
15 Source0:        https://github.com/containers/crun/releases/download/%{version}/%{name}-%{version}.tar.xz
16 # Source0-md5:  27afa25604e16e5b5a2d9287dfe52e4e
17 URL:            https://github.com/containers/crun
18 BuildRequires:  autoconf >= 2.69
19 BuildRequires:  automake >= 1:1.11.2
20 %{?with_criu:BuildRequires:     criu-devel >= 3.15}
21 %{?with_man:BuildRequires:      go-md2man}
22 BuildRequires:  libcap-devel
23 BuildRequires:  libseccomp-devel
24 BuildRequires:  libselinux-devel
25 BuildRequires:  libtool
26 BuildRequires:  pkgconfig
27 BuildRequires:  python3
28 BuildRequires:  python3-devel
29 BuildRequires:  systemd-devel
30 BuildRequires:  tar >= 1:1.22
31 BuildRequires:  xz
32 BuildRequires:  yajl-devel >= 2.0.0
33 Requires:       criu-libs >= 3.15
34 Requires:       yajl >= 2.0.0
35 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
36
37 %description
38 crun is a runtime for running OCI containers.
39
40 %prep
41 %setup -q
42
43 %build
44 %{__libtoolize}
45 %{__aclocal}
46 %{__autoconf}
47 %{__autoheader}
48 %{__automake}
49 %configure \
50         --disable-silent-rules
51
52 %{__make}
53
54 %install
55 rm -rf $RPM_BUILD_ROOT
56
57 %{__make} install \
58         DESTDIR=$RPM_BUILD_ROOT
59
60 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libcrun.{a,la}
61
62 %clean
63 rm -rf $RPM_BUILD_ROOT
64
65 %files
66 %defattr(644,root,root,755)
67 %doc README.md
68 %attr(755,root,root) %{_bindir}/crun
69 %{?with_man:%{_mandir}/man1/crun.1*}
This page took 0.036909 seconds and 3 git commands to generate.