]> git.pld-linux.org Git - packages/crun.git/blob - crun.spec
up to 1.14.4
[packages/crun.git] / crun.spec
1 %ifarch %{x8664} %{armv7} %{armv8} aarch64 ppc64
2 %define         with_criu       1
3 %endif
4
5 %ifarch %{ix86} %{x8664} %{arm} aarch64 mips64 mips64le ppc64 ppc64le s390x
6 %define         with_man        1
7 %endif
8
9 Summary:        OCI runtime written in C
10 Name:           crun
11 Version:        1.14.4
12 Release:        1
13 License:        GPL v3+
14 Group:          Applications/System
15 Source0:        https://github.com/containers/crun/releases/download/%{version}/%{name}-%{version}.tar.xz
16 # Source0-md5:  f1f2ac412d8122c00f1a0ff24a2e7ad7
17 URL:            https://github.com/containers/crun
18 BuildRequires:  autoconf >= 2.69
19 BuildRequires:  automake >= 1:1.11.2
20 %{?with_criu:BuildRequires:     criu-devel >= 3.16.1}
21 %{?with_man:BuildRequires:      go-md2man}
22 BuildRequires:  libcap-devel
23 BuildRequires:  libseccomp-devel
24 BuildRequires:  libselinux-devel
25 BuildRequires:  libtool
26 BuildRequires:  linux-libc-headers >= 7:3.18
27 BuildRequires:  pkgconfig
28 BuildRequires:  python3
29 BuildRequires:  python3-modules
30 BuildRequires:  rpmbuild(macros) >= 2.007
31 BuildRequires:  systemd-devel
32 BuildRequires:  tar >= 1:1.22
33 BuildRequires:  xz
34 BuildRequires:  yajl-devel >= 2.0.0
35 Requires:       yajl >= 2.0.0
36 %{?with_criu:Suggests:  criu-libs >= 3.16.1}
37 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
38
39 %description
40 crun is a runtime for running OCI containers.
41
42 %prep
43 %setup -q
44
45 %build
46 %{__libtoolize}
47 %{__aclocal}
48 %{__autoconf}
49 %{__autoheader}
50 %{__automake}
51 %configure \
52         --disable-silent-rules
53
54 %{__make}
55
56 %install
57 rm -rf $RPM_BUILD_ROOT
58
59 %{__make} install \
60         DESTDIR=$RPM_BUILD_ROOT
61
62 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libcrun.{a,la}
63
64 %clean
65 rm -rf $RPM_BUILD_ROOT
66
67 %files
68 %defattr(644,root,root,755)
69 %doc README.md
70 %attr(755,root,root) %{_bindir}/crun
71 %{?with_man:%{_mandir}/man1/crun.1*}
This page took 0.117541 seconds and 4 git commands to generate.