]> git.pld-linux.org Git - packages/crun.git/blob - crun.spec
up to 1.8
[packages/crun.git] / crun.spec
1 %ifarch %{x8664} %{armv7} %{armv8} aarch64 ppc64
2 %define         with_criu       1
3 %endif
4
5 %ifarch %{ix86} %{x8664} %{arm} aarch64 mips64 mips64le ppc64 ppc64le s390x
6 %define         with_man        1
7 %endif
8
9 Summary:        OCI runtime written in C
10 Name:           crun
11 Version:        1.8
12 Release:        1
13 License:        GPL v3+
14 Group:          Applications/System
15 Source0:        https://github.com/containers/crun/releases/download/%{version}/%{name}-%{version}.tar.xz
16 # Source0-md5:  50207b4781c3081bd0d3286735494302
17 URL:            https://github.com/containers/crun
18 BuildRequires:  autoconf >= 2.69
19 BuildRequires:  automake >= 1:1.11.2
20 %{?with_criu:BuildRequires:     criu-devel >= 3.16.1}
21 %{?with_man:BuildRequires:      go-md2man}
22 BuildRequires:  libcap-devel
23 BuildRequires:  libgcrypt-devel
24 BuildRequires:  libseccomp-devel
25 BuildRequires:  libselinux-devel
26 BuildRequires:  libtool
27 BuildRequires:  linux-libc-headers >= 7:3.18
28 BuildRequires:  pkgconfig
29 BuildRequires:  python3
30 BuildRequires:  python3-devel
31 BuildRequires:  rpmbuild(macros) >= 2.007
32 BuildRequires:  systemd-devel
33 BuildRequires:  tar >= 1:1.22
34 BuildRequires:  xz
35 BuildRequires:  yajl-devel >= 2.0.0
36 Requires:       yajl >= 2.0.0
37 %{?with_criu:Suggests:  criu-libs >= 3.16.1}
38 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
39
40 %description
41 crun is a runtime for running OCI containers.
42
43 %prep
44 %setup -q
45
46 %build
47 %{__libtoolize}
48 %{__aclocal}
49 %{__autoconf}
50 %{__autoheader}
51 %{__automake}
52 %configure \
53         --disable-silent-rules
54
55 %{__make}
56
57 %install
58 rm -rf $RPM_BUILD_ROOT
59
60 %{__make} install \
61         DESTDIR=$RPM_BUILD_ROOT
62
63 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libcrun.{a,la}
64
65 %clean
66 rm -rf $RPM_BUILD_ROOT
67
68 %files
69 %defattr(644,root,root,755)
70 %doc README.md
71 %attr(755,root,root) %{_bindir}/crun
72 %{?with_man:%{_mandir}/man1/crun.1*}
This page took 0.580527 seconds and 3 git commands to generate.