]> git.pld-linux.org Git - packages/cloog-isl.git/blob - cloog-isl.spec
- drop .la file
[packages/cloog-isl.git] / cloog-isl.spec
1 #
2 # Conditional build:
3 %bcond_without  osl     # OpenScop support
4 #
5 %define isl_ver 0.19
6 Summary:        The Chunky Loop Generator
7 Summary(pl.UTF-8):      Chunky Loop Generator - generator pętli cząstkowych
8 Name:           cloog-isl
9 Version:        0.18.5
10 Release:        1
11 License:        LGPL v2.1+
12 Group:          Development/Tools
13 # older?
14 #Source0:       http://www.bastoul.net/cloog/pages/download/cloog-%{version}.tar.gz
15 #Source0Download: https://github.com/periscop/cloog/releases
16 Source0:        https://github.com/periscop/cloog/releases/download/cloog-%{version}/cloog-%{version}.tar.gz
17 # Source0-md5:  7e9058076193d8f53aae40cab94ad017
18 # git diff HEAD..origin/update-isl
19 Patch0:         cloog-isl-update.patch
20 URL:            http://www.cloog.org/
21 BuildRequires:  autoconf >= 2.53
22 BuildRequires:  automake
23 BuildRequires:  gmp-devel >= 5.0.2
24 BuildRequires:  gmp-c++-devel >= 5.0.2
25 BuildRequires:  isl-devel >= %{isl_ver}
26 BuildRequires:  libtool
27 %{?with_osl:BuildRequires:      osl-devel >= 0.9.2}
28 BuildRequires:  texinfo-texi2dvi
29 Requires:       %{name}-libs = %{version}-%{release}
30 Provides:       cloog = %{version}
31 Obsoletes:      cloog
32 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
33
34 %description
35 CLooG is a software which generates loops for scanning Z-polyhedra.
36 That is, CLooG finds the code or pseudo-code where each integral point
37 of one or more parametrized polyhedron or parametrized polyhedra union
38 is reached. CLooG is designed to avoid control overhead and to produce
39 a very efficient code.
40
41 This version is based on isl.
42
43 %description -l pl.UTF-8
44 CLooG to oprogramowanie generujące pętle do przeszukiwania
45 Z-wielościanów (Z-polyhedra). Oznacza to, że CLooG znajduje kod lub
46 pseudokod osiągający każdy punkt całkowity jednego lub większej liczby
47 sparametryzowanych wielościanów lub sum sparametryzowanych
48 wielościanów. CLooG jest zaprojektowany z myślą o zapobieganiu
49 narzutowi na sterowaniu oraz generowaniu bardzo wydajnego kodu.
50
51 Ta wersja jest oparta na bibliotece isl.
52
53 %package libs
54 Summary:        Chunky Loop Generator shared library - isl based version
55 Summary(pl.UTF-8):      Biblioteka współdzielona Chunky Loop Generatora - wersja oparta na isl
56 Group:          Libraries
57 Requires:       isl >= %{isl_ver}
58 %{?with_osl:Requires:   osl >= 0.9.2}
59
60 %description libs
61 Chunky Loop Generator shared library - isl based version.
62
63 %description libs -l pl.UTF-8
64 Biblioteka współdzielona Chunky Loop Generatora - wersja oparta na
65 isl.
66
67 %package devel
68 Summary:        Header files for the isl based version of Chunky Loop Generator
69 Summary(pl.UTF-8):      Pliki nagłówkowe opartej na isl wersji Chunky Loop Generatora
70 Group:          Development/Libraries
71 Requires:       %{name}-libs = %{version}-%{release}
72 Requires:       gmp-devel >= 5.0.2
73 Requires:       gmp-c++-devel >= 5.0.2
74 Requires:       isl-devel >= %{isl_ver}
75 %{?with_osl:Requires:   osl-devel >= 0.9.2}
76 Provides:       cloog-devel = %{version}
77
78 %description devel
79 The header files for Chunky Loop Generator library.
80
81 %description devel -l pl.UTF-8
82 Pliki nagłówkowe biblioteki Chunky Loop Generatora.
83
84 %package static
85 Summary:        Static library of isl based version of Chunky Loop Generator
86 Summary(pl.UTF-8):      Statyczna biblioteka opartej na isl wersji Chunky Loop Generatora
87 Group:          Development/Libraries
88 Requires:       %{name}-devel = %{version}-%{release}
89
90 %description static
91 Static library of isl based version of Chunky Loop Generator.
92
93 %description static -l pl.UTF-8
94 Statyczna biblioteka opartej na isl wersji Chunky Loop Generatora.
95
96 %prep
97 %setup -q -n cloog-%{version}
98 %patch0 -p1
99
100 %build
101 %{__libtoolize}
102 %{__aclocal} -I m4
103 %{__autoconf}
104 %{__automake}
105 # with_gmp_exec_prefix=yes avoids adding -L/lib to LDFLAGS
106 %configure \
107         --disable-silent-rules \
108         --with-gmp-exec-prefix \
109         --with-isl=system \
110         %{?with_osl:--with-osl=system}
111
112 %{__make}
113
114 %{__make} -C doc cloog.pdf
115
116 %install
117 rm -rf $RPM_BUILD_ROOT
118
119 %{__make} install \
120         DESTDIR=$RPM_BUILD_ROOT
121
122 # obsoleted by pkg-config
123 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libcloog-isl.la
124
125 %clean
126 rm -rf $RPM_BUILD_ROOT
127
128 %post   libs -p /sbin/ldconfig
129 %postun libs -p /sbin/ldconfig
130
131 %files
132 %defattr(644,root,root,755)
133 %attr(755,root,root) %{_bindir}/cloog
134
135 %files libs
136 %defattr(644,root,root,755)
137 %doc ChangeLog README
138 %attr(755,root,root) %{_libdir}/libcloog-isl.so.*.*.*
139 %attr(755,root,root) %ghost %{_libdir}/libcloog-isl.so.4
140
141 %files devel
142 %defattr(644,root,root,755)
143 %doc doc/cloog.pdf
144 %attr(755,root,root) %{_libdir}/libcloog-isl.so
145 %dir %{_includedir}/cloog
146 %{_includedir}/cloog/*.h
147 %{_includedir}/cloog/isl
148 %{_includedir}/cloog/matrix
149 %dir %{_libdir}/cloog-isl
150 %{_libdir}/cloog-isl/cloog-isl-config.cmake
151 %dir %{_libdir}/isl
152 %{_libdir}/isl/isl-config.cmake
153 %{_pkgconfigdir}/cloog-isl.pc
154
155 %files static
156 %defattr(644,root,root,755)
157 %{_libdir}/libcloog-isl.a
This page took 0.097943 seconds and 4 git commands to generate.