]> git.pld-linux.org Git - packages/cloog-isl.git/blob - cloog-isl.spec
- updated to 0.21.1; isl 0.26, osl 0.9.7
[packages/cloog-isl.git] / cloog-isl.spec
1 #
2 # Conditional build:
3 %bcond_without  osl     # OpenScop support
4 #
5 %define isl_ver 0.26
6 Summary:        The Chunky Loop Generator
7 Summary(pl.UTF-8):      Chunky Loop Generator - generator pętli cząstkowych
8 Name:           cloog-isl
9 Version:        0.21.1
10 Release:        1
11 License:        LGPL v2.1+
12 Group:          Development/Tools
13 # older?
14 #Source0:       http://www.bastoul.net/cloog/pages/download/cloog-%{version}.tar.gz
15 #Source0Download: https://github.com/periscop/cloog/releases
16 Source0:        https://github.com/periscop/cloog/releases/download/cloog-%{version}/cloog-%{version}.tar.gz
17 # Source0-md5:  cbd2fd43b3421ce466bd638bf90b326d
18 Patch0:         cflags.patch
19 URL:            http://www.cloog.org/
20 BuildRequires:  autoconf >= 2.53
21 BuildRequires:  automake
22 BuildRequires:  gmp-devel >= 5.0.2
23 BuildRequires:  gmp-c++-devel >= 5.0.2
24 BuildRequires:  isl-devel >= %{isl_ver}
25 BuildRequires:  libtool >= 2:2
26 %{?with_osl:BuildRequires:      osl-devel >= 0.9.7}
27 BuildRequires:  texinfo-texi2dvi
28 Requires:       %{name}-libs = %{version}-%{release}
29 Provides:       cloog = %{version}
30 Obsoletes:      cloog < 0.16
31 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
33 %description
34 CLooG is a software which generates loops for scanning Z-polyhedra.
35 That is, CLooG finds the code or pseudo-code where each integral point
36 of one or more parametrized polyhedron or parametrized polyhedra union
37 is reached. CLooG is designed to avoid control overhead and to produce
38 a very efficient code.
39
40 This version is based on isl.
41
42 %description -l pl.UTF-8
43 CLooG to oprogramowanie generujące pętle do przeszukiwania
44 Z-wielościanów (Z-polyhedra). Oznacza to, że CLooG znajduje kod lub
45 pseudokod osiągający każdy punkt całkowity jednego lub większej liczby
46 sparametryzowanych wielościanów lub sum sparametryzowanych
47 wielościanów. CLooG jest zaprojektowany z myślą o zapobieganiu
48 narzutowi na sterowaniu oraz generowaniu bardzo wydajnego kodu.
49
50 Ta wersja jest oparta na bibliotece isl.
51
52 %package libs
53 Summary:        Chunky Loop Generator shared library - isl based version
54 Summary(pl.UTF-8):      Biblioteka współdzielona Chunky Loop Generatora - wersja oparta na isl
55 Group:          Libraries
56 Requires:       isl >= %{isl_ver}
57 %{?with_osl:Requires:   osl >= 0.9.7}
58
59 %description libs
60 Chunky Loop Generator shared library - isl based version.
61
62 %description libs -l pl.UTF-8
63 Biblioteka współdzielona Chunky Loop Generatora - wersja oparta na
64 isl.
65
66 %package devel
67 Summary:        Header files for the isl based version of Chunky Loop Generator
68 Summary(pl.UTF-8):      Pliki nagłówkowe opartej na isl wersji Chunky Loop Generatora
69 Group:          Development/Libraries
70 Requires:       %{name}-libs = %{version}-%{release}
71 Requires:       gmp-devel >= 5.0.2
72 Requires:       gmp-c++-devel >= 5.0.2
73 Requires:       isl-devel >= %{isl_ver}
74 %{?with_osl:Requires:   osl-devel >= 0.9.7}
75 Provides:       cloog-devel = %{version}
76 Conflicts:      cloog-polylib-devel
77 Conflicts:      cloog-ppl-devel
78
79 %description devel
80 The header files for Chunky Loop Generator library.
81
82 %description devel -l pl.UTF-8
83 Pliki nagłówkowe biblioteki Chunky Loop Generatora.
84
85 %package static
86 Summary:        Static library of isl based version of Chunky Loop Generator
87 Summary(pl.UTF-8):      Statyczna biblioteka opartej na isl wersji Chunky Loop Generatora
88 Group:          Development/Libraries
89 Requires:       %{name}-devel = %{version}-%{release}
90
91 %description static
92 Static library of isl based version of Chunky Loop Generator.
93
94 %description static -l pl.UTF-8
95 Statyczna biblioteka opartej na isl wersji Chunky Loop Generatora.
96
97 %prep
98 %setup -q -n cloog-%{version}
99 %patch0 -p1
100
101 %build
102 %{__libtoolize}
103 %{__aclocal} -I m4
104 %{__autoconf}
105 %{__automake}
106 # with_gmp_exec_prefix=yes avoids adding -L/lib to LDFLAGS
107 %configure \
108         --disable-silent-rules \
109         --with-gmp-exec-prefix \
110         --with-isl=system \
111         %{?with_osl:--with-osl=system}
112
113 %{__make}
114
115 %{__make} -C doc cloog.pdf
116
117 %install
118 rm -rf $RPM_BUILD_ROOT
119
120 %{__make} install \
121         DESTDIR=$RPM_BUILD_ROOT
122
123 # obsoleted by pkg-config
124 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libcloog-isl.la
125
126 %clean
127 rm -rf $RPM_BUILD_ROOT
128
129 %post   libs -p /sbin/ldconfig
130 %postun libs -p /sbin/ldconfig
131
132 %files
133 %defattr(644,root,root,755)
134 %attr(755,root,root) %{_bindir}/cloog
135
136 %files libs
137 %defattr(644,root,root,755)
138 %doc ChangeLog README
139 %attr(755,root,root) %{_libdir}/libcloog-isl.so.*.*.*
140 %attr(755,root,root) %ghost %{_libdir}/libcloog-isl.so.4
141
142 %files devel
143 %defattr(644,root,root,755)
144 %doc doc/cloog.pdf
145 %attr(755,root,root) %{_libdir}/libcloog-isl.so
146 %dir %{_includedir}/cloog
147 %{_includedir}/cloog/*.h
148 %{_includedir}/cloog/isl
149 %{_includedir}/cloog/matrix
150 %dir %{_libdir}/cloog-isl
151 %{_libdir}/cloog-isl/cloog-isl-config.cmake
152 %dir %{_libdir}/isl
153 %{_libdir}/isl/isl-config.cmake
154 %{_pkgconfigdir}/cloog-isl.pc
155
156 %files static
157 %defattr(644,root,root,755)
158 %{_libdir}/libcloog-isl.a
This page took 0.107349 seconds and 4 git commands to generate.