]> git.pld-linux.org Git - packages/botan2.git/blob - botan2.spec
BR: xz-devel
[packages/botan2.git] / botan2.spec
1 # TODO: fix sphinx docs build (sphinx-build hangs?)
2 #
3 # Conditional build:
4 %bcond_without  tests           # unit tests
5 %bcond_with     apidocs         # Sphinx based HTML documentation [hangs, FIXME]
6 %bcond_without  static_libs     # static library
7 %bcond_without  python          # Python bindings
8 %bcond_without  python2         # CPython 2.x binding
9 %bcond_without  python3         # CPython 3.x binding
10 %bcond_with     openssl         # OpenSSL provider
11
12 %if %{without python}
13 %undefine       with_python2
14 %undefine       with_python3
15 %endif
16 Summary:        Crypto library written in C++
17 Summary(pl.UTF-8):      Biblioteka kryptograficzna napisana w C++
18 Name:           botan2
19 Version:        2.19.3
20 Release:        1
21 License:        BSD
22 Group:          Libraries
23 Source0:        https://botan.randombit.net/releases/Botan-%{version}.tar.xz
24 # Source0-md5:  6875d4a802db81646d80ed43ebcf9b27
25 URL:            https://botan.randombit.net/
26 BuildRequires:  bzip2-devel
27 BuildRequires:  docutils
28 BuildRequires:  libstdc++-devel
29 %{?with_openssl:BuildRequires:  openssl-devel}
30 BuildRequires:  python >= 1:2.7
31 BuildRequires:  rpm-build >= 4.6
32 BuildRequires:  rpm-pythonprov
33 BuildRequires:  rpmbuild(macros) >= 1.714
34 %{?with_apidocs:BuildRequires:  sphinx-pdg}
35 BuildRequires:  tar >= 1:1.22
36 BuildRequires:  xz
37 BuildRequires:  xz-devel
38 BuildRequires:  zlib-devel
39 %if %{with python2}
40 BuildRequires:  python-devel >= 1:2.7
41 %endif
42 %if %{with python3}
43 BuildRequires:  python3-devel >= 1:3.4
44 %endif
45 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
46
47 %description
48 Botan is a BSD-licensed crypto library written in C++. It provides a
49 wide variety of basic cryptographic algorithms, X.509 certificates and
50 CRLs, PKCS#10 certificate requests, a filter/pipe message processing
51 system, and a wide variety of other features, all written in portable
52 C++. The API reference, tutorial, and examples may help impart the
53 flavor of the library.
54
55 %description -l pl.UTF-8
56 Botan to biblioteka kryptograficzna na licencji BSD, napisana w C++.
57 Zapewnia szeroki zakres algorytmów kryptograficznych, certyfikaty
58 X.509 oraz CRL, żądania certyfikatów PKCS#10, system przetwarzania
59 komunikatów z filtrowaniem/potokami i wiele innych funkcji, wszystko
60 napisane w przenośnym C++. Dodatkowe udogodnienia to dokumentacja API,
61 wprowadzenie oraz przykłady.
62
63 %package devel
64 Summary:        Header files for Botan library
65 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki Botan
66 Group:          Development/Libraries
67 Requires:       %{name} = %{version}-%{release}
68 Requires:       bzip2-devel
69 Requires:       gmp-devel
70 %{?with_openssl:Requires:       openssl-devel}
71 Requires:       zlib-devel
72
73 %description devel
74 This package contains the header files for developing applications
75 that use Botan.
76
77 %description devel -l pl.UTF-8
78 Ten pakiet zawiera pliki nagłówkowe do tworzenia aplikacji
79 wykorzystujących bibliotekę Botan.
80
81 %package static
82 Summary:        Static Botan library
83 Summary(pl.UTF-8):      Statyczna biblioteka Botan
84 Group:          Development/Libraries
85 Requires:       %{name}-devel = %{version}-%{release}
86
87 %description static
88 Static Botan library.
89
90 %description static -l pl.UTF-8
91 Statyczna biblioteka Botan.
92
93 %package apidocs
94 Summary:        Botan API documentation
95 Summary(pl.UTF-8):      Dokumentacja API biblioteki Botan
96 Group:          Documentation
97 BuildArch:      noarch
98
99 %description apidocs
100 API and internal documentation for Botan library.
101
102 %description apidocs -l pl.UTF-8
103 Dokumentacja API biblioteki Botan.
104
105 %package -n python-botan
106 Summary:        Python 2.x binding for Botan library
107 Summary(pl.UTF-8):      Wiązanie Pythona 2.x do biblioteki Botan
108 Group:          Libraries/Python
109 Requires:       %{name} = %{version}-%{release}
110
111 %description -n python-botan
112 Python 2.x binding for Botan library.
113
114 %description -n python-botan -l pl.UTF-8
115 Wiązanie Pythona 2.x do biblioteki Botan.
116
117 %package -n python3-botan
118 Summary:        Python 3.x binding for Botan library
119 Summary(pl.UTF-8):      Wiązanie Pythona 3.x do biblioteki Botan
120 Group:          Libraries/Python
121 Requires:       %{name} = %{version}-%{release}
122
123 %description -n python3-botan
124 Python 3.x binding for Botan library.
125
126 %description -n python3-botan -l pl.UTF-8
127 Wiązanie Pythona 3.x do biblioteki Botan.
128
129 %prep
130 %setup -q -n Botan-%{version}
131
132 # kill shebang, nothing to execute directly
133 %{__sed} -i -e '1d' src/python/botan2.py
134
135 %build
136 # we have the necessary prerequisites, so enable optional modules
137 %define enable_modules bzip2,lzma,zlib,%{?with_openssl:openssl},sqlite3,tpm,pkcs11
138
139 # fixme: maybe disable unix_procs, very slow.
140 %define disable_modules %{nil}
141
142 ./configure.py \
143         --prefix=%{_prefix} \
144         --libdir=%{_lib} \
145         --cc=gcc \
146         --os=linux \
147         --cpu=%{_arch} \
148         --enable-modules=%{enable_modules} \
149         --disable-modules=%{disable_modules} \
150 %if %{with python2}
151         --with-python-version=%{py_ver} \
152 %endif
153         %{!?with_apidocs:--without-sphinx}
154
155 # (ab)using CXX as an easy way to inject our CXXFLAGS
156 %{__make} \
157         CXX="%{__cxx} -pthread" \
158         CXXFLAGS="%{rpmcxxflags}"
159
160 %if %{with apidocs}
161 %{__make} docs
162 %endif
163
164 %if %{with tests}
165 # certstor_system test is trying tp look up expired certs
166 # os_utils fail on builders
167 LD_LIBRARY_PATH=. ./botan-test --skip-tests=certstor_system,os_utils
168 %endif
169
170 %install
171 rm -rf $RPM_BUILD_ROOT
172
173 %{__make} install \
174         INSTALL_CMD_EXEC="install -p -m 755" \
175         INSTALL_CMD_DATA="install -p -m 644" \
176         DESTDIR=$RPM_BUILD_ROOT
177
178 %if %{with python2}
179 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
180 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
181 %py_postclean
182 %endif
183
184 %if %{with python3}
185 install -d $RPM_BUILD_ROOT%{py3_sitedir}
186 cp -p src/python/botan2.py $RPM_BUILD_ROOT%{py3_sitedir}
187 %py3_comp $RPM_BUILD_ROOT%{py3_sitedir}
188 %py3_ocomp $RPM_BUILD_ROOT%{py3_sitedir}
189 %endif
190
191 # packaged as %doc
192 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/botan-%{version}
193
194 %if %{with apidocs}
195 install -d $RPM_BUILD_ROOT%{_examplesdir}
196 cp -pr doc/examples $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
197 %endif
198
199 %clean
200 rm -rf $RPM_BUILD_ROOT
201
202 %post   -p /sbin/ldconfig
203 %postun -p /sbin/ldconfig
204
205 %files
206 %defattr(644,root,root,755)
207 %doc license.txt news.rst readme.rst doc/{authors.txt,credits.rst,security.rst}
208 %attr(755,root,root) %{_bindir}/botan
209 %attr(755,root,root) %{_libdir}/libbotan-2.so.*.*
210 %attr(755,root,root) %ghost %{_libdir}/libbotan-2.so.19
211 %{_mandir}/man1/botan.1*
212
213 %files devel
214 %defattr(644,root,root,755)
215 %attr(755,root,root) %{_libdir}/libbotan-2.so
216 %{_includedir}/botan-2
217 %{_pkgconfigdir}/botan-2.pc
218
219 %if %{with static_libs}
220 %files static
221 %defattr(644,root,root,755)
222 %{_libdir}/libbotan-2.a
223 %endif
224
225 %if %{with apidocs}
226 %files apidocs
227 %defattr(644,root,root,755)
228 # FIXME: update path after fixing sphinx build
229 %doc _doc/manual/{_static,*.html,*.js}
230 %{_examplesdir}/%{name}-%{version}
231 %endif
232
233 %if %{with python2}
234 %files -n python-botan
235 %defattr(644,root,root,755)
236 %{py_sitedir}/botan2.py[co]
237 %endif
238
239 %if %{with python3}
240 %files -n python3-botan
241 %defattr(644,root,root,755)
242 %{py3_sitedir}/botan2.py
243 %{py3_sitedir}/__pycache__/botan2.cpython-*.py[co]
244 %endif
This page took 0.117962 seconds and 4 git commands to generate.