]> git.pld-linux.org Git - packages/botan2.git/blob - botan2.spec
BR: python*-modules for %py*_*comp
[packages/botan2.git] / botan2.spec
1 # TODO: fix sphinx docs build (sphinx-build hangs?)
2 #
3 # Conditional build:
4 %bcond_without  tests           # unit tests
5 %bcond_with     apidocs         # Sphinx based HTML documentation [hangs, FIXME]
6 %bcond_without  static_libs     # static library
7 %bcond_without  python          # Python bindings
8 %bcond_without  python2         # CPython 2.x binding
9 %bcond_without  python3         # CPython 3.x binding
10 %bcond_with     openssl         # OpenSSL provider
11
12 %if %{without python}
13 %undefine       with_python2
14 %undefine       with_python3
15 %endif
16 Summary:        Crypto library written in C++
17 Summary(pl.UTF-8):      Biblioteka kryptograficzna napisana w C++
18 Name:           botan2
19 Version:        2.19.3
20 Release:        1
21 License:        BSD
22 Group:          Libraries
23 Source0:        https://botan.randombit.net/releases/Botan-%{version}.tar.xz
24 # Source0-md5:  6875d4a802db81646d80ed43ebcf9b27
25 URL:            https://botan.randombit.net/
26 BuildRequires:  bzip2-devel
27 BuildRequires:  docutils
28 BuildRequires:  libstdc++-devel
29 %{?with_openssl:BuildRequires:  openssl-devel}
30 BuildRequires:  python >= 1:2.7
31 BuildRequires:  rpm-build >= 4.6
32 BuildRequires:  rpm-pythonprov
33 BuildRequires:  rpmbuild(macros) >= 1.714
34 %{?with_apidocs:BuildRequires:  sphinx-pdg}
35 BuildRequires:  tar >= 1:1.22
36 BuildRequires:  xz
37 BuildRequires:  xz-devel
38 BuildRequires:  zlib-devel
39 %if %{with python2}
40 BuildRequires:  python-devel >= 1:2.7
41 BuildRequires:  python-modules
42 %endif
43 %if %{with python3}
44 BuildRequires:  python3-devel >= 1:3.4
45 BuildRequires:  python3-modules
46 %endif
47 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
48
49 %description
50 Botan is a BSD-licensed crypto library written in C++. It provides a
51 wide variety of basic cryptographic algorithms, X.509 certificates and
52 CRLs, PKCS#10 certificate requests, a filter/pipe message processing
53 system, and a wide variety of other features, all written in portable
54 C++. The API reference, tutorial, and examples may help impart the
55 flavor of the library.
56
57 %description -l pl.UTF-8
58 Botan to biblioteka kryptograficzna na licencji BSD, napisana w C++.
59 Zapewnia szeroki zakres algorytmów kryptograficznych, certyfikaty
60 X.509 oraz CRL, żądania certyfikatów PKCS#10, system przetwarzania
61 komunikatów z filtrowaniem/potokami i wiele innych funkcji, wszystko
62 napisane w przenośnym C++. Dodatkowe udogodnienia to dokumentacja API,
63 wprowadzenie oraz przykłady.
64
65 %package devel
66 Summary:        Header files for Botan library
67 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki Botan
68 Group:          Development/Libraries
69 Requires:       %{name} = %{version}-%{release}
70 Requires:       bzip2-devel
71 Requires:       gmp-devel
72 %{?with_openssl:Requires:       openssl-devel}
73 Requires:       zlib-devel
74
75 %description devel
76 This package contains the header files for developing applications
77 that use Botan.
78
79 %description devel -l pl.UTF-8
80 Ten pakiet zawiera pliki nagłówkowe do tworzenia aplikacji
81 wykorzystujących bibliotekę Botan.
82
83 %package static
84 Summary:        Static Botan library
85 Summary(pl.UTF-8):      Statyczna biblioteka Botan
86 Group:          Development/Libraries
87 Requires:       %{name}-devel = %{version}-%{release}
88
89 %description static
90 Static Botan library.
91
92 %description static -l pl.UTF-8
93 Statyczna biblioteka Botan.
94
95 %package apidocs
96 Summary:        Botan API documentation
97 Summary(pl.UTF-8):      Dokumentacja API biblioteki Botan
98 Group:          Documentation
99 BuildArch:      noarch
100
101 %description apidocs
102 API and internal documentation for Botan library.
103
104 %description apidocs -l pl.UTF-8
105 Dokumentacja API biblioteki Botan.
106
107 %package -n python-botan
108 Summary:        Python 2.x binding for Botan library
109 Summary(pl.UTF-8):      Wiązanie Pythona 2.x do biblioteki Botan
110 Group:          Libraries/Python
111 Requires:       %{name} = %{version}-%{release}
112
113 %description -n python-botan
114 Python 2.x binding for Botan library.
115
116 %description -n python-botan -l pl.UTF-8
117 Wiązanie Pythona 2.x do biblioteki Botan.
118
119 %package -n python3-botan
120 Summary:        Python 3.x binding for Botan library
121 Summary(pl.UTF-8):      Wiązanie Pythona 3.x do biblioteki Botan
122 Group:          Libraries/Python
123 Requires:       %{name} = %{version}-%{release}
124
125 %description -n python3-botan
126 Python 3.x binding for Botan library.
127
128 %description -n python3-botan -l pl.UTF-8
129 Wiązanie Pythona 3.x do biblioteki Botan.
130
131 %prep
132 %setup -q -n Botan-%{version}
133
134 # kill shebang, nothing to execute directly
135 %{__sed} -i -e '1d' src/python/botan2.py
136
137 %build
138 # we have the necessary prerequisites, so enable optional modules
139 %define enable_modules bzip2,lzma,zlib,%{?with_openssl:openssl},sqlite3,tpm,pkcs11
140
141 # fixme: maybe disable unix_procs, very slow.
142 %define disable_modules %{nil}
143
144 ./configure.py \
145         --prefix=%{_prefix} \
146         --libdir=%{_lib} \
147         --cc=gcc \
148         --os=linux \
149         --cpu=%{_arch} \
150         --enable-modules=%{enable_modules} \
151         --disable-modules=%{disable_modules} \
152 %if %{with python2}
153         --with-python-version=%{py_ver} \
154 %endif
155         %{!?with_apidocs:--without-sphinx}
156
157 # (ab)using CXX as an easy way to inject our CXXFLAGS
158 %{__make} \
159         CXX="%{__cxx} -pthread" \
160         CXXFLAGS="%{rpmcxxflags}"
161
162 %if %{with apidocs}
163 %{__make} docs
164 %endif
165
166 %if %{with tests}
167 # certstor_system test is trying tp look up expired certs
168 # os_utils fail on builders
169 LD_LIBRARY_PATH=. ./botan-test --skip-tests=certstor_system,os_utils
170 %endif
171
172 %install
173 rm -rf $RPM_BUILD_ROOT
174
175 %{__make} install \
176         INSTALL_CMD_EXEC="install -p -m 755" \
177         INSTALL_CMD_DATA="install -p -m 644" \
178         DESTDIR=$RPM_BUILD_ROOT
179
180 %if %{with python2}
181 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
182 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
183 %py_postclean
184 %endif
185
186 %if %{with python3}
187 install -d $RPM_BUILD_ROOT%{py3_sitedir}
188 cp -p src/python/botan2.py $RPM_BUILD_ROOT%{py3_sitedir}
189 %py3_comp $RPM_BUILD_ROOT%{py3_sitedir}
190 %py3_ocomp $RPM_BUILD_ROOT%{py3_sitedir}
191 %endif
192
193 # packaged as %doc
194 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/botan-%{version}
195
196 %if %{with apidocs}
197 install -d $RPM_BUILD_ROOT%{_examplesdir}
198 cp -pr doc/examples $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
199 %endif
200
201 %clean
202 rm -rf $RPM_BUILD_ROOT
203
204 %post   -p /sbin/ldconfig
205 %postun -p /sbin/ldconfig
206
207 %files
208 %defattr(644,root,root,755)
209 %doc license.txt news.rst readme.rst doc/{authors.txt,credits.rst,security.rst}
210 %attr(755,root,root) %{_bindir}/botan
211 %attr(755,root,root) %{_libdir}/libbotan-2.so.*.*
212 %attr(755,root,root) %ghost %{_libdir}/libbotan-2.so.19
213 %{_mandir}/man1/botan.1*
214
215 %files devel
216 %defattr(644,root,root,755)
217 %attr(755,root,root) %{_libdir}/libbotan-2.so
218 %{_includedir}/botan-2
219 %{_pkgconfigdir}/botan-2.pc
220
221 %if %{with static_libs}
222 %files static
223 %defattr(644,root,root,755)
224 %{_libdir}/libbotan-2.a
225 %endif
226
227 %if %{with apidocs}
228 %files apidocs
229 %defattr(644,root,root,755)
230 # FIXME: update path after fixing sphinx build
231 %doc _doc/manual/{_static,*.html,*.js}
232 %{_examplesdir}/%{name}-%{version}
233 %endif
234
235 %if %{with python2}
236 %files -n python-botan
237 %defattr(644,root,root,755)
238 %{py_sitedir}/botan2.py[co]
239 %endif
240
241 %if %{with python3}
242 %files -n python3-botan
243 %defattr(644,root,root,755)
244 %{py3_sitedir}/botan2.py
245 %{py3_sitedir}/__pycache__/botan2.cpython-*.py[co]
246 %endif
This page took 0.093427 seconds and 4 git commands to generate.